Ubuntu

Upgrade to Maverick breaks KVM

Reported by Harald Hannelius on 2010-10-19
38
This bug affects 6 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

After an upgrade from 10.04 LTS to 10.10 KVM-guests hang on boot. WinXP SP3 shows the XP-logo and the blue bar rolls back and forth, the ubuntu guest stops after printing "starting up . . . ".

Both guests consume a steady 50% CPU as shown by virt-managar. This goes on forever without changing (days).

The kernel supplied with Maverick was linux-image-2.6.35-22-generic-pae, I then booted the previous 2.6.32-24-generic-pae and now the guests boot up normally.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: linux-image-2.6.35-22-generic-pae 2.6.35-22.34
Regression: Yes
Reproducible: Yes
ProcVersionSignature: Ubuntu 2.6.32-24.43-generic-pae 2.6.32.15+drm33.5
Uname: Linux 2.6.32-24-generic-pae i686
NonfreeKernelModules: nvidia
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: harald 2787 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'SB'/'HDA ATI SB at 0xfe020000 irq 16'
   Mixer name : 'Realtek ALC883'
   Components : 'HDA:10ec0883,10438232,00100002'
   Controls : 38
   Simple ctrls : 21
Date: Tue Oct 19 13:27:44 2010
HibernationDevice: RESUME=UUID=d16415aa-874a-d994-9dc4-0ef5dc4d9f9f
MachineType: System manufacturer System Product Name
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-24-generic-pae root=UUID=7899d2f7-30de-4300-8662-b93a88520a57 ro noquiet nosplash
RelatedPackageVersions: linux-firmware 1.38
RfKill:

SourcePackage: linux
WpaSupplicantLog:

dmi.bios.date: 10/09/2007
dmi.bios.vendor: Phoenix Technologies, LTD
dmi.bios.version: ASUS M2A-VM ACPI BIOS Revision 1404
dmi.board.name: M2A-VM
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: 1.XX
dmi.chassis.asset.tag: 123456789000
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnPhoenixTechnologies,LTD:bvrASUSM2A-VMACPIBIOSRevision1404:bd10/09/2007:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnM2A-VM:rvr1.XX:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer

I reproduced this bug on my home computer, in the sense that my guests didn't boot (XP). I haven't booted the old kernel though.

Oh, and I'm using a VMDK-image and it's stated as such in the machine's XML-file.

According to the Release Notes;

https://wiki.ubuntu.com/MaverickMeerkat/ReleaseNotes#Linux%20kernel%202.6.35

"With 10.10 we have also dropped support for i586 and lower processors, as well as i686 processors without cmov support. "

Could this be the culprit for us running virtual guests?

No change by updating to 2.6.35-23-generic-pae. The WinXP-guest doesn't boot. It just sits there with a black screen saying "Booting from Hard Disk..." and chewing 50% CPU constantly.

My Ubuntu 9.10 guest did boot up though. I'm upgrading the guest now, let's see if that breaks it or not.

I had a dormant guest Debian with kernel 2.6.26-2, this doesn't boot. CPU pegged on 50% all the time and the only thing visible on the console is "Booting the kernel".

Still trying to resolve this I installed the following packages manually;

kvm_84+dfsg-0ubuntu16+0.13.0+noroms+0ubuntu1_i386.deb
qemu-common_0.13.0+noroms-0ubuntu1_all.deb
qemu-kvm-extras_0.13.0+noroms-0ubuntu1_i386.deb
qemu-kvm_0.13.0+noroms-0ubuntu1_i386.deb
qemu_0.13.0+noroms-0ubuntu1_i386.deb

No change actually. My Ubuntu 10.10 and Windows XP guests boots from the disk and then just sits there eating CPU. Interestingly, my Windows 7 and ReactOS images did boot up. I even tried creating a new virtual guest, importing the ubuntu qcow2 existing disk-image to no avail. It just doesn't get past the "starting up.." message just after grub.

Booting the ubuntu-10.10 desktop ISO worked, and installing it too. The newly created ubuntu 10 install booted fine. Hmm, makes me wonder.

seabios pre-0.6.1

Converting the qcow2 image into a raw-image didn't help either.

Windows XP boots into safe mode, and safe mode with networking.

I tried installing the same kernel on my ubuntu-guest as in ubuntu 10.10, namely the linux-image-generic-pae. This didn't help either. I am unable to boot these guests.

I now re-installed the host with 10.10 64-bit, and now the guests boot OK.

My host was 64 bit to start with, and I still have similar problems..

MNLipp (mnl) wrote :

I can confirm this bug. The only (minor) difference is that Windows XP hangs before the XP logo.

Trying to boot from the Windows XP SP2 CD gives me a BSOD ("Process1_Initialization_Failed" "STOP: 0x000006B"). I tried both linux-generic and linux-generic-pae (it's a 32-bit PC with 4G RAM).

When I transfer the disk image to my 64-bit server (also running up-to-date ubuntu 10.10) it works.

Does your WinXP kvm-guest boot if you boot up the previous kernel on the kvm-host? Mine did, and that's why i filed the bug as a kernel (config?) bug.

MNLipp (mnl) wrote :

I cannot really test the older kernel. I had problems with hibernate/resume, gave uswsusp a try and that has completely screwed up my file system. So I have a fresh install of Maverick since Wednesday (and therefore no older kernels). The kvm problem appeared with the fresh install. I had successfully booted my Windows XP on the Maverick that I still had on Monday (which was a Maverick by updates, starting with 9.04 -- if I remember correctly). That's why I tested the linux-generic first (see above), because updating from 9.04 to Maverick never updated the kernel from linux-generic to linux-generic-pae.

Good news (for me): 10 minutes ago I succeeded in booting Windows XP again. I changed the <emulator> stanza in the libvirt configuration from "/usr/bin/kvm" to "/usr/bin/qemu-system-i386".

This bug report (LP 663191) was filed before 666180 but that duplicate (666180) is receiving more attention than this bug report (663191) so I'm not sure which one should be marked as a duplicate.

https://bugs.launchpad.net/ubuntu/+source/qemu-kvm/+bug/666180

Brad Figg (brad-figg) on 2011-04-07
Changed in linux (Ubuntu):
status: New → Confirmed

Harald Hannelius, thank you for reporting this and helping make Ubuntu better. Maverick reached EOL on April 10, 2012.
Please see this document for currently supported Ubuntu releases:
https://wiki.ubuntu.com/Releases

We were wondering if this is still an issue in a supported release? If so, can you try with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you run the following command in a supported release from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux <replace-with-bug-number>

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.

Please let us know your results. Thanks in advance.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete

This is no longer an issue.

Changed in linux (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers