2.6.36rc8 rt2800pci ad hoc WEP "could not get IP configuration for connection"

Bug #662389 reported by Wolfgang Kufner on 2010-10-17
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

On a current installed maverick 64 bit with a current mainline rc kernel. The self compiled rt2860sta driver from ralink (not the stock maverick one) is available as can be seen from the lspci -k below, but the rt2800pci is in use (as is standard on maverick) after boot up. The rt2800pci gets as far as actually connecting but then fails to get an IP via dhcp. See the attached syslog part.

I then change to the ralink rt2860sta with:
sudo modprobe -rv rt2800pci
sudo modprobe -rv rt2860sta
sudo modprobe -v rt2860sta
The self compiled rt2860sta works.

03:00.0 Network controller: RaLink RT2860
 Subsystem: Foxconn International, Inc. Device e002
 Kernel driver in use: rt2800pci
 Kernel modules: rt2860sta, rt2800pci

tags: added: kj-triage

I think this is an interaction between a broken (bug 659143) rt2800pci driver and the also available rt2860sta. I speculate that the rt2860sta loads the firmware, because the firmware load error is not present in the log. Anyway I strongly suspect that this bug will go away once bug 659143 is fixed.

I have indeed never seen this bug again since I have fixed bug 659143. I'll set this as duplicate.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers