System (notebook) freze after electric cable is detached in Maverick

Bug #660746 reported by markush1986 on 2010-10-14
64
This bug affects 11 people
Affects Status Importance Assigned to Milestone
Linux
Incomplete
Undecided
Unassigned
linux (Ubuntu)
Medium
Unassigned

Bug Description

This bug appears in two cases:

1. electric cable is turned off and I start my notebook. After login in, it take a while an my system freezes.

2. I run the system with plugged power kable and i remove the cable => System freezes
-------------------
Ubuntu 10.10
---
Architecture: amd64
DistroRelease: Ubuntu 10.10
GConfNonDefault:
 /apps/gnome-power-manager/lock/blank_screen=false
 /apps/gnome-power-manager/lock/use_screensaver_settings=false
 /apps/gnome-power-manager/notify/sleep_failed_uri=
 /apps/gnome-power-manager/ui/icon_policy=charge
GnomeSessionIdleInhibited: No
GnomeSessionInhibitors: None
GnomeSessionSuspendInhibited: No
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release Candidate amd64 (20100928)
Lsusb:
 Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 001 Device 002: ID 04f2:b071 Chicony Electronics Co., Ltd 2.0M UVC Webcam / CNF7129
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: ASUSTeK Computer Inc. K70IO
NonfreeKernelModules: nvidia
Package: gnome-power-manager 2.32.0-0ubuntu1
PackageArchitecture: amd64
ProcCmdLine: BOOT_IMAGE=/vmlinuz-2.6.35-22-generic root=UUID=7de8f7bc-4cf2-47e3-9258-af5531ddf06c ro quiet splash
ProcEnviron:
 LANG=de_DE.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.35-22.34-generic 2.6.35.4
Tags: maverick ubuntu-une
Uname: Linux 2.6.35-22-generic x86_64
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 06/04/2009
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 205
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: K70IO
dmi.board.vendor: ASUSTeK Computer Inc.
dmi.board.version: 1.0
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK Computer Inc.
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr205:bd06/04/2009:svnASUSTeKComputerInc.:pnK70IO:pvr1.0:rvnASUSTeKComputerInc.:rnK70IO:rvr1.0:cvnASUSTeKComputerInc.:ct10:cvr:
dmi.product.name: K70IO
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK Computer Inc.

Fabio Marconi (fabiomarconi) wrote :

hello
can you reproduce the bug, thren run in a terminal
apport-collect -p gnome-power-manager 660746
Thanks
Fabio

affects: ubuntu → gnome-power-manager (Ubuntu)
Changed in gnome-power-manager (Ubuntu):
status: New → Incomplete
summary: - System (notebook) feeze after electric kabel is turn off
+ System (notebook) freze after electric cable is detached

apport information

tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

hello markush1986
Thanks for support
Fabio

Changed in gnome-power-manager (Ubuntu):
status: Incomplete → New
kkk (kknull0) wrote :

same problem...
happens only in ubuntu 10.10, not 10.04

Changed in gnome-power-manager (Ubuntu):
status: New → Confirmed
Gursimran singh (simar) on 2010-10-31
Changed in gnome-power-manager (Ubuntu):
importance: Undecided → High
importance: High → Undecided

The same problem:

I upgraded my Ubuntu 64-bit from 10.04 to 10.10 (by upgrade process) yesterday, everything seemed to work perfectly until I removed the AC power lead. Shortly after I noticed that wifi disconnected and after 5 seconds or so laptop totally crashed with the white screen. Nothing helped but hard power off... I repeated the same few times more - always the same result - wifi disconnects and then hard lockup with white/black/purple/colorfull pattern on LCD.

Then I made the clean install of 10.10 but finished with the same problem...

I tried to start OS while only on battery, it managed to get the login screen and then crashed...

I've assumed that 10.10 is unusable for me at the moment and installed back the 10.04 from the backup - everything is OK. So the problem is definitely with 10.10.

My basic HW info: Dell Vostro 1000, AMD TurionX2 2000MHz, 6GB DDR2, ATi Xpress 1150 Chipset (= RS485 NB + SB600 NB), Intel Wireless WiFi Link 4965AGN

I do suspect the problem is in 10.10 kernel or intel wifi driver or ubuntu power-management software.

10.04 works fine on my laptop which is almost nonstop on (running BOINC).

tags: added: maverick regression-release
Snowman (snowmanhv) wrote :

Having the similar problem

When running on battery and connecting to wifi hotspot (no encryption) system halts and
Num lock, Scroll lock start blinking. I have a fresh ubuntu 10.10 32-bit edition, didn't have
any problems on ubuntu 10.04 32-bit.

Hardware is MSI M670 : AMD Sempron 3600+, 4GB DDR2, nforce MCP51,
geforce go 6100 and ralink RT2561/RT61 wifi card

Galois Ghost (galoisghost) wrote :

I'm having the exact same problem on Kubuntu 10.10 32bit clean install. Did not have it in 10.04.

Hardware: Asus K50IE, Intel dual core T4400 2.2Ghz, 4GB DDR3, wi-fi: Integrated 802.11 b/g/n Built-in Bluetooth™ V2.1+EDR

Power management backend: HAL-Power
Network management backend: NetworkManager 0.7

n3m3s1s4u (n3m3s1s4u) wrote :

Hi,
I too am sadly having the same problem:
Asus K50ID.... Thought I was going mad, as I was using Mint 9 with no hassles on this notebook. I first tried Mint 10 RC, which is based on Ubuntu 10.10 and got the freezing. Then I decided it must be because of it being a RC.... so thought I would try a full release, clean install of 10.10 32bit, and am now getting the same problem.... so there is something in 10.10 that has been changed from 10.04 LTS that is making our notebooks freeze up when we switch over to battery from mains.....
Anyone got a fix, or an idea on getting around this?
In the interim I am going to switch back to a LTS version where there are no problems....

thanks

Unfortunately,

the bug is still present in 10.10 to this day (24.11.2010).

I have the Ubuntu installed on separate hardrive only for the purpose of testing whether the bug is still present.
I installed all the current updates today and checked the bug, but no change in the behaviour.

I unplugged the power cable, system disconnects the wifi and then crashes
few seconds later.

Ubuntu still unusable for me in 10.10 version...

summary: - System (notebook) freze after electric cable is detached
+ System (notebook) freze after electric cable is detached in Maverick
Changed in gnome-power:
importance: Unknown → Medium
status: Unknown → New
Download full text (4.5 KiB)

Some updates today:

I put the hardrive with Maverick into my laptop and installed new updates.
Then I removed the power lead and the system crashed. Again. So no progress in solving this bug yet.

I started to dig in my system little bit:

1.) I removed the internal WiFi card (based on Intel 4965AGN), then I booted the Maverick, removed
the power lead and NOTHING! No crash! But without wifi my laptop is quite useless, so:

2.) I plugged the USB WiFi stick (based on RaLink chipset RT2500USB), removed the power lead and
NOTHING! No crash! I have spare internal WiFi card, so I removed the USB WiFi stick and:

3.) I plugged another internal WiFi card (based on Broadcom BCM4315 chipset), booted Maverick,
installed restricted kernel drivers, restarted the system and removed the power lead - NOTHING! No crash!

Now I started to suspect the Intel 4965AGN WiFi card to be the cause of all the problems. So I removed the
Broadcom card and plugged the Intel back. Restarted, removed the power lead and CRASH!

So we are closer now, at least in my case.

I started to study the logs, I did this before but because of crashes there was nothing. But today I found two
pieces of information:

The last rows in the kern.log are suspicious:

kernel: [ 119.059334] atkbd serio0: Unknown key pressed (translated set 2, code 0xee on isa0060/serio0).
kernel: [ 119.059344] atkbd serio0: Use 'setkeycodes e06e <keycode>' to make it known.
kernel: [ 119.069352] atkbd serio0: Unknown key released (translated set 2, code 0xee on isa0060/serio0).
kernel: [ 119.069360] atkbd serio0: Use 'setkeycodes e06e <keycode>' to make it known.
...(my comment - these 4 messages are harmless, they always appear when I remove the power lead)...
kernel: [ 121.272191] EXT4-fs (sda1): re-mounted. Opts: errors=remount-ro,commit=600
...(my comment - following messages are the latest before crash)...
kernel: [ 126.610093] No probe response from AP 00:16:01:af:aa:7c after 500ms, disconnecting.
kernel: [ 127.110065] iwlagn 0000:05:00.0: Error sending REPLY_RXON: time out after 500ms.
kernel: [ 127.110079] iwlagn 0000:05:00.0: Error setting new RXON (-110)
kernel: [ 127.610087] iwlagn 0000:05:00.0: Error sending REPLY_REMOVE_STA: time out after 500ms.
kernel: [ 127.610103] iwlagn 0000:05:00.0: Error removing station 00:16:01:af:aa:7c
kernel: [ 127.662743] cfg80211: All devices are disconnected, going to restore regulatory settings
kernel: [ 127.662763] cfg80211: Restoring regulatory settings
kernel: [ 127.662773] cfg80211: Calling CRDA to update world regulatory domain
kernel: [ 127.675943] cfg80211: World regulatory domain updated:
kernel: [ 127.675953] (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
kernel: [ 127.675961] (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
kernel: [ 127.675968] (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
kernel: [ 127.675975] (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
kernel: [ 127.675983] (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
kernel: [ 127.675989] (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
kernel: [ 127.873202] iwlagn 00...

Read more...

Hi Miroslav,

your post gave me the idea to try to just disable the wireless powersaving for now:
sudo mv /usr/lib/pm-utils/power.d/wireless ~
(Just moving it to somewhere save.)

This works for me. Now wireless works fine on battery.

This is of course just a workaround. We need to find out what powersave attempts cause which cards to fail and why...

Hi Wolfgang,

I've been trying to find what's the problem whole day and I think
I found the solution/workaround.

You are pretty close, but
/usr/lib/pm-utils/power.d/wireless does nothing in my case,
I only get the message in pm-powersave.log:

--------------------------------------------------------------------
Running hook /usr/lib/pm-utils/power.d/wireless true:
Turning powersave for wlan0 on...Error for wireless request "Set Power Management" (8B2C) :
    SET failed on device wlan0 ; Operation not supported.
Failed.
/usr/lib/pm-utils/power.d/wireless true: success.
--------------------------------------------------------------------

But I found the script causing problem is:
/usr/lib/pm-utils/power.d/pcie_aspm

Very simple workaround is to create empty file "pcie_aspm" in
/etc/pm/power.d folder with execute bit disabled. What this does it
prevents /usr/lib/pm-utils/power.d/pcie_aspm from running.
It's better way than to delete /usr/lib/pm-utils/power.d/pcie_aspm,
because that can be recreated in future updates.

I wish you people give a try and check whether this help.

I forgot - I didn't study what pcie_aspm does but I guess it
tries to enable some power-saving on PCIE lanes.

I'm not sure we find what is the real cause of the problem,
it might be the poor hardware implementation in (my) Intel WiFi
card. With Broadcom WiFi card everything was just fine...

Michael Mercier (mickours) wrote :

Same problem on ASUS K50IE with ubuntu 10.10 64 bits
I have found a bypass and maybe a lead for debugging :
I have install the package "laptop-mode-tools" :
It remove the packages "acpi-support" and "pm-utils" and then it works on battery ( I'm currently on battery ;-) )

I hope it helps!

christine (christinewhenman) wrote :

i want to remove maverick from my notebook.how do i do this

markush1986, thank you for reporting this and helping make Ubuntu better. Maverick reached EOL on April 10, 2012.
Please see this document for currently supported Ubuntu releases:
https://wiki.ubuntu.com/Releases

We were wondering if this is still an issue in a supported release? If so, could you please capture the oops following https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies#Capturing_OOPs ? As well, could you please test for this with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

Also, could you please test the latest upstream kernel available? It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please do not test the kernel in the daily folder, but the one all the way at the bottom. Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. As well, please comment on which kernel version specifically you tested.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream', and comment as to why specifically you were unable to test it.

Please let us know your results. Thanks in advance.

Helpful Bug Reporting Links:
https://help.ubuntu.com/community/ReportingBugs#Bug_Reporting_Etiquette
https://help.ubuntu.com/community/ReportingBugs#A3._Make_sure_the_bug_hasn.27t_already_been_reported
https://help.ubuntu.com/community/ReportingBugs#Adding_Apport_Debug_Information_to_an_Existing_Launchpad_Bug
https://help.ubuntu.com/community/ReportingBugs#Adding_Additional_Attachments_to_an_Existing_Launchpad_Bug

tags: added: needs-upstream-testing
tags: removed: regression-release
affects: gnome-power-manager (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
affects: gnome-power → linux
Changed in linux:
importance: Medium → Undecided
status: New → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.