module lirc_atiusb does not load/build with kernel 2.6.35-22

Bug #660601 reported by Matt Rice on 2010-10-14
This bug affects 4 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)

Bug Description

Trying to connect a remote that uses lirc_atiusb module and that module is not available in the latest release.

Can reproduce by installing lirc: sudo apt-get install lirc
and trying to insert the module
sudo modprobe lirc_atiusb

get this error:
WARNING: All config files need .conf: /etc/modprobe.d/lirc-blacklist, it will be ignored in a future release
FATAL: Module lirc_atiusb not found

Tried with and without lirc-modules-source and no change

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: linux-headers-generic
Regression: Yes
Reproducible: Yes
ProcVersionSignature: Ubuntu 2.6.35-22.34-generic
Uname: Linux 2.6.35-22-generic i686
NonfreeKernelModules: nvidia
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
Architecture: i386
AudioDevicesInUse: Error: command ['fuser', '-v', '/dev/snd/controlC0', '/dev/snd/hwC0D0', '/dev/snd/pcmC0D0c', '/dev/snd/pcmC0D0p', '/dev/snd/pcmC0D1p', '/dev/snd/by-path', '/dev/snd/controlC1', '/dev/snd/pcmC1D0c', '/dev/snd/seq', '/dev/snd/timer'] failed with exit code 1:
CRDA: Error: [Errno 2] No such file or directory
 Card hw:0 'NVidia'/'HDA NVidia at 0xdbff8000 irq 22'
   Mixer name : 'Analog Devices AD1986A'
   Components : 'HDA:11d41986,1043818f,00100500'
   Controls : 37
   Simple ctrls : 21
 Card hw:1 'CX8801'/'Conexant CX8801 at 0xde000000'
   Mixer name : 'CX88'
   Components : ''
   Controls : 3
   Simple ctrls : 2
Date: Thu Oct 14 10:23:32 2010
HibernationDevice: RESUME=UUID=5fc2a4e3-36fa-4dbc-844b-27ee4f0d8f99
InstallationMedia: Mythbuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
 lo no wireless extensions.

 eth0 no wireless extensions.
MachineType: System manufacturer System Product Name
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.35-22-generic root=UUID=e5a2c961-8a23-47f6-a35e-2c4beb28e9ac ro quiet splash
RelatedPackageVersions: linux-firmware 1.38

SourcePackage: linux 04/30/2007
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 0701
dmi.board.asset.tag: To Be Filled By O.E.M. M2N-MX
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr0701:bd04/30/2007:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnM2N-MX:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer

Matt Rice (junk-mattrice) wrote :
kilmarnock (kilmarnock-gmx) wrote :

Same result here.
FATAL: Module lirc_atiusb not found.

Matt Rice (junk-mattrice) wrote :

please post some info about your install

kilmarnock (kilmarnock-gmx) wrote :

Ubuntu 10.10.
The module is not there, so no logs required? lirc_dev works fine.

kilmarnock (kilmarnock-gmx) wrote :

root@zonbu:/lib/modules/2.6.35-22-generic# find -name "lirc_dev*"

root@zonbu:/lib/modules/2.6.35-22-generic# find -name "lirc_atiusb*"

--> missing

uname -r

Brad Figg (brad-figg) on 2010-12-04
tags: added: acpi-table-checksum
tags: added: bios-amd-powernow
tags: added: acpi-apic
Brad Figg (brad-figg) on 2011-04-07
Changed in linux (Ubuntu):
status: New → Confirmed
Joe Littlejohn (joelittlejohn) wrote :

Does anyone have a workaround for this? Is there a way to build this module manually?

Joe Littlejohn (joelittlejohn) wrote :

In 10.10, after installing lirc-modules-source, I get the following:

$ uname -r
$sudo modprobe lirc_atiusb
FATAL: Error inserting lirc_atiusb (/lib/modules/2.6.35-28-generic/updates/dkms/lirc_atiusb.ko): Invalid argument

Joe Littlejohn (joelittlejohn) wrote :

Please ignore the two comments above, this was caused by invalid hardware/lircd config.

Matt Rice, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

Also, could you please test the latest upstream kernel available following ? It will allow additional upstream developers to examine the issue. Please do not test the daily folder, but the one all the way at the bottom. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:

where VERSION-NUMBER is the version number of the kernel you tested. For example:

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:

If the mainline kernel does not fix this bug, please add the following tags:

As well, please remove the tag:

If you are unable to test the mainline kernel, please comment as to why specifically you were unable to test it and add the following tags:

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

tags: added: bios-outdated-1004
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers