Ubuntu

linux-virtual depends on wireless-crda and contains wireless modules

Reported by Gioele Barabucci on 2010-10-10
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Wishlist
Stefan Bader

Bug Description

The linux-virtual image, tailored towards KVM and Xen vitual machines, depends on wireless-crda, a package that is useful only when used with real wireless cards.

Could that dependency be dropped?

Jeremy Foshee (jeremyfoshee) wrote :

Hi Gioele,

Please be sure to confirm this issue exists with the latest development release of Ubuntu. ISO CD images are available from http://cdimage.ubuntu.com/daily/current/ . If the issue remains, please run the following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux 657901

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

    [This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-kernel-logs
tags: added: needs-upstream-testing
tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete
Gioele Barabucci (gioele) wrote :

Yes, I can confirm that this problem is present in the latest linux-image-virtual package found in Maverick (linux-image-2.6.35-22-virtual).

Please note that this is only a compilation and packaging problem, not a problem in the kernel itself.

Gioele Barabucci (gioele) wrote :

Moving to Confirmed as I provided the requested info.

(This is to prevent this valid bug to expire because of a stale Incomplete status.)

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
tags: removed: needs-kernel-logs needs-upstream-testing
Jordon Bedwell (envygeeks) wrote :

I have requested that this bug have an importance set since it is a confirmed bug, I experienced it today while configuring several of our new VM's on a new Xen server with PV-Grub. I was pretty surprised and intrigued it required it at all. It should really be a recommend not a requirement.

Jeremy Foshee (jeremyfoshee) wrote :

setting initial importance to Medium pending a review of the image and the possible needs of this dependency.

~JFo

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
Stefan Bader (smb) wrote :

I would say this is rather lower on priority. The package is only 15k in size. Yes, it is probably confusing and potentially not needed (there might only be a strange case of using kvm with usb passthru). So nothing that would really be done for anything released previously. We can look at it for Natty, probably together with tailoring the kernel image at the same time (ie. remove all the wireless drivers from the configuration of the virtual kernel).

Changed in linux (Ubuntu):
assignee: nobody → Stefan Bader (stefan-bader-canonical)
importance: Medium → Wishlist
Jordon Bedwell (envygeeks) wrote :

Just updating to say this is still a problem in Natty.

Gioele Barabucci (gioele) wrote :

Another update: this is still a problem in Precise.

Gioele Barabucci (gioele) wrote :

This problem is still present Precise and current Quantal kernel.

The additional problem in Quantal is that -virtual kernel image is just an empty package requiring linux-image-generic.

summary: - linux-virtual depends on wireless-crda
+ linux-virtual depends on wireless-crda and contains wireless modules
Stefan Bader (smb) wrote :

In Quantal there are no binary packages for virtual. Instead the generic package is split into linux-image and linux-image-extra. There is a virtual meta-package which will pull in only the linux-image part while the meta-package for generic pull in both binary package.

Trying to approach this now by moving the dependency on crda into the extra package and also move all wireless related modules there. This has been queued up for Quantal now. If this change does not cause problems it might get proposed as a stable update for Precise.

Changed in linux (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 3.5.0-1.1

---------------
linux (3.5.0-1.1) quantal-proposed; urgency=low

  [ Andy Whitcroft ]

  * [Config] highbank -- enable CONFIG_RFKILL=y and CONFIG_CAN=m

  [ Leann Ogasawara ]

  * Rebase to v3.5-rc1
  * [Config] Remove USB_DEVICEFS from the config enforcer
  * [Config] Updateconfigs after rebase to v3.5-rc1
  * [Config] Temporarily disable CONFIG_MACH_NOKIA_RX51 on arm
  * [Config] Temporarily disable CONFIG_TOUCHSCREEN_EETI on arm
  * [Config] Temporarily disable CONFIG_TOUCHSCREEN_EGALAX on arm
  * [Config] Temporarily disable CONFIG_EZX_PCAP on arm
  * [Config] Temporarily disable CONFIG_LIS3L02DQ on arm
  * [Config] Temporarily disable CONFIG_TI_CPSW on arm
  * [Config] Temporarily disable CONFIG_GPIO_EM on arm
  * [Config] Temporarily disable CONFIG_SERIAL_8250_EM on armhf
  * [Config] Temporarily disable CONFIG_STMMAC_ETH on armhf
  * [Config] Temporarily disable CONFIG_HW_RANDOM_ATMEL on armhf
  * Rebase to v3.5-rc2
  * [Config] Updateconfigs after rebase to v3.5-rc2
  * [Config] Temporarily disable CONFIG_MV643XX_ETH on powerpc
  * Rebase to v3.5-rc3
  * [Config] Updateconfigs after rebase to v3.5-rc3

  [ Paul Mundt ]

  * SAUCE: fix bug.h's inclusion of kernel.h

  [ Stefan Bader ]

  * SAUCE: Fix compile failures of dm-raid45
  * [Config] Enable dm-raid45
  * Move dependency on crda to extra package
    - LP: #657901
  * SAUCE: Mask CR4 writes on older Xen hypervisors

  [ Upstream Kernel Changes ]

  * rebase to v3.5-rc3
    - LP: #993162
    - LP: #925577
  * rebase to v3.5-rc2
  * rebase to v3.5-rc1
    - LP: #955892
    - LP: #978038
    - LP: #987371
    - LP: #929545
    - LP: #942316
    - LP: #903853
 -- Leann Ogasawara <email address hidden> Fri, 08 Jun 2012 14:28:46 -0700

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers