Ubuntu

buitin speakers hp dv6 laptop jack sense non functional

Reported by Ian Paterson on 2010-10-02
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Luke Yelavich

Bug Description

Release; Maverick RC 10.10

The speakers on laptop model HP Pavilion dv6-2005tx Entertainment Notebook PC do not mute when headphones are plugged in as they should. (jack sense)
This was present in lucid and karmic, but a workaround was to add the following 2 lines to the end of /etc/modprobe.d/alsa-base.conf

options snd-hda-intel model=dell-m4 enable_msi=1
options snd_hda_Intel's model=hp-dv5

this no longer works in maverick

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: alsa-base 1.0.23+dfsg-1ubuntu4
ProcVersionSignature: Ubuntu 2.6.35-22.33-generic-pae 2.6.35.4
Uname: Linux 2.6.35-22-generic-pae i686
NonfreeKernelModules: nvidia
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ian 2151 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xdd100000 irq 54'
   Mixer name : 'IDT 92HD75B3X5'
   Components : 'HDA:111d7603,103c363e,00100202 HDA:11c11040,103c137e,00100200'
   Controls : 20
   Simple ctrls : 12
Card1.Amixer.info:
 Card hw:1 'NVidia'/'HDA NVidia at 0xd3000000 irq 55'
   Mixer name : 'Nvidia GT220 HDMI'
   Components : 'HDA:10de000a,10de0101,00100100'
   Controls : 16
   Simple ctrls : 4
Date: Sat Oct 2 17:27:19 2010
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Release Candidate i386 (20100419.1)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_NZ:en_AU:en_GB:en
 LANG=en_NZ.utf8
 SHELL=/bin/bash
SourcePackage: alsa-driver
dmi.bios.date: 09/10/2009
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: F.04
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 363E
dmi.board.vendor: Quanta
dmi.board.version: 32.16
dmi.chassis.type: 10
dmi.chassis.vendor: Quanta
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnHewlett-Packard:bvrF.04:bd09/10/2009:svnHewlett-Packard:pnHPPaviliondv6NotebookPC:pvr039F200000241210000020000:rvnQuanta:rn363E:rvr32.16:cvnQuanta:ct10:cvrN/A:
dmi.product.name: HP Pavilion dv6 Notebook PC
dmi.product.version: 039F200000241210000020000
dmi.sys.vendor: Hewlett-Packard

Ian Paterson (ipat500) wrote :
summary: - buitin speakers hp dv6 laptop jack senseis non functional
+ buitin speakers hp dv6 laptop jack sense non functional
Ian Paterson (ipat500) wrote :

Update:
appending the following to /etc/modprobe.d/alsa-base.conf is a workaround for this issue

alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
options snd-hda-intel model=dell-m4-1 enable_msi=1

Daniel T Chen (crimsun) wrote :

Please remove /all/ options snd-hda-intel lines from /etc/modprobe.d/*.conf and reboot, then reproduce this symptom. We'll need to add model quirks incrementally.

Changed in alsa-driver (Ubuntu):
status: New → Incomplete
Ian Paterson (ipat500) wrote :

Yes this is reproducible with a clean (unmodified) /etc/modprobe.d/alsa-base.conf

I also noticed that only this line is really needed for the hack:
options snd-hda-intel model=dell-m4-1 enable_msi=1

If that helps narrow it down a bit, apparently its because my sound card is very similar to the dell one.

Daniel T Chen (crimsun) wrote :

Are both model and enable_msi parameters necessary? Can you verify so?

Ian Paterson (ipat500) wrote :

Just the model parameter is needed
so the only extra bit in /etc/modprobe.d/alsa-base.conf at the moment is
options snd-hda-intel model=dell-m4-1

What about changing the model from dell to hp-dv5? Does that work?

Ian Paterson (ipat500) wrote :

Yes, using just hp-dv5 as the model works.

Something else I noticed is that on the output tab of gnome-volume-control (System>Preferences>Sound) the options in the connector combo-box changes:
using hp-dv5 as the model gives Analog Speakers and Analog Output as the options. Choosing Analog Speakers makes it work as it should. Choosing Analog Output turns off the speakers (both with headphones plugged and not) but the headphones are on (when they are plugged in). -so its name is wrong, it should say Analog Headphones.
I can't remember which is the default option, will have to look into that, that may be a problem otherwise for fresh installs.
(I had to change this to make it work so Analog Output is probably the default i.e. the wrong one)

using dell gives Analog Headphones and Analog Output as the options. Choosing Analog Output makes it work how it should, however choosing Analog Headphones results in no sound at all, no matter what, and also breaks the little light on the mute button (next to the speakers).

So basically hp-dv5 is a better match than dell. (as you would expect)

Luke Yelavich (themuso) wrote :

My thoughts as well. Could you possibly test both model options for microphone input/capturing? Whatever one gives better resluts will then be used to make a perminent fix for your hardware, i.e model options will not be neeed in future updates.

Thanks.

Ian Paterson (ipat500) wrote :

Both work fine in terms of inputs on the webcam. I am not sure about the mic jack next to the headphone jack however, since I don't have a mic to test this with so we will have to make do and assume it is all fine there.
I also cannot test the HDMI output on the NVIDIA graphics card which ALSA seems to have picked up, since I do not have an HDMI cable.
All up I believe that using the dv5 config would be better.
Thankyou, both of you for your help in this.

Luke Yelavich (themuso) wrote :

In that case, I'll follow through and send a patch upstream to make this fix perminent, to use the dv-5 model quirk.

affects: alsa-driver (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
assignee: nobody → Luke Yelavich (themuso)
status: Incomplete → In Progress
Gary M (garym) on 2010-10-29
tags: added: hda-jack-sense
Andy Whitcroft (apw) on 2011-02-10
Changed in linux (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers