[RV515] Guest session causes screen to flicker violently and session is unusable

Bug #652934 reported by Vish on 2010-10-01
22
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Andy Whitcroft
Lucid
Medium
Andy Whitcroft
Maverick
Medium
Andy Whitcroft
Natty
Medium
Andy Whitcroft

Bug Description

Binary package hint: xserver-xorg-video-ati

This has been happening in this system ever since the drm changes landed in the lucid kernel. it seems to be related to new_pll .

Initially the problem with the guest session would occur if i start it immediately itself.
But when i used new_pll=0 , it just causes the problem to occur hours later.

Problem also exists with the latest maverick kernel from leann's ppa
~$ uname -a
Linux Aspire-5670 2.6.35-23-generic #34~pre201009220900-Ubuntu SMP Wed Sep 22 23:22:58 UTC 2010 i686 GNU/Linux
Which is supposed to have a solution for this problem : <http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=0d9958b18e10d7426d94cc3dd024920a40db3ee2>

Because of this problem i had been using the mainline kernel for a very long time[.33, .34 and .35], but i have never had this problem with the mainline kernels.
Only with the Ubuntu stock kernel i get this issue.

Attaching a video clip of the error

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: xserver-xorg-video-ati 1:6.13.1-1ubuntu5
ProcVersionSignature: Ubuntu 2.6.35-23.34~pre201009220900-generic 2.6.35.5
Uname: Linux 2.6.35-23-generic i686
Architecture: i386
DRM.card0.LVDS.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1280x800 1280x720 1152x768 1024x768 800x600 848x480 720x480 640x480
 edid-base64: AP///////wBEk0EAAAAAAAAPAQOAIRV4Ck3Ak1xRiCchUFQAAAABAQEBAQEBAQEBAQEBAQEB6hoAgFAgEDAVIEQAS88QAAAYAAAADwAIACoAAQAEADJKBBkBAAAA/gBRVUFOVEFESVNQTEFZAAAA/gBRRDE1VEwwNzIKICAgAIk=
DRM.card0.VGA.1:
 status: disconnected
 enabled: disabled
 dpms: On
 modes:
 edid-base64:
Date: Fri Oct 1 16:43:31 2010
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Alpha i386 (20100924)
MachineType: Acer, inc. Aspire 5670
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.35-23-generic root=UUID=d0b3b834-dc68-4ad5-95e1-afefebd792ea ro quiet splash
ProcEnviron:
 LANG=en_IN
 SHELL=/bin/bash
SourcePackage: xserver-xorg-video-ati
dmi.bios.date: 01/12/07
dmi.bios.vendor: Acer
dmi.bios.version: v1.3239
dmi.board.name: Bodensee
dmi.board.vendor: Acer, Inc.
dmi.board.version: Not Applicable
dmi.chassis.type: 1
dmi.chassis.vendor: Acer, Inc.
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnAcer:bvrv1.3239:bd01/12/07:svnAcer,inc.:pnAspire5670:pvrNotApplicable:rvnAcer,Inc.:rnBodensee:rvrNotApplicable:cvnAcer,Inc.:ct1:cvrN/A:
dmi.product.name: Aspire 5670
dmi.product.version: Not Applicable
dmi.sys.vendor: Acer, inc.
system:
 distro: Ubuntu
 codename: maverick
 architecture: i686
 kernel: 2.6.35-23-generic

Vish (vish) wrote :
summary: [RV515] Guest session causes screen to flicker violently and makes
- session is unusable
+ session unusable
summary: - [RV515] Guest session causes screen to flicker violently and makes
- session unusable
+ [RV515] Guest session causes screen to flicker violently and session is
+ unusable
Vish (vish) wrote :
Vish (vish) wrote :

OK finally narrowed it down :
~$ uname -a
Linux Aspire-5670 2.6.32-19-generic #28-Ubuntu SMP Wed Mar 31 17:46:20 UTC 2010 i686 GNU/Linux

In kernel 32-18 the problem starts

***************************
Last good kernel is
~$ uname -a
Linux Aspire-5670 2.6.32-18-generic #27-Ubuntu SMP Fri Mar 26 19:51:10 UTC 2010 i686 GNU/Linux

The fix for Bug #507148 caused this problem

Vish (vish) wrote :

Err, i meant kernel 32-19 the problem starts:

~$ uname -a
Linux Aspire-5670 2.6.32-19-generic #28-Ubuntu SMP Wed Mar 31 17:46:20 UTC 2010 i686 GNU/Linux
In 12hrs the problem starts

~$ uname -a
Linux Aspire-5670 2.6.32-18-generic #27-Ubuntu SMP Fri Mar 26 19:51:10 UTC 2010 i686 GNU/Linux
Running it even for 4days, had no problem .

And running the mainline kernels did not ever give a problem, But it now seems it has been merged in mainline kernel too. :(

Robert Hooker (sarvatt) on 2010-10-22
affects: xserver-xorg-video-ati (Ubuntu) → linux (Ubuntu)
Robert Hooker (sarvatt) wrote :
Robert Hooker (sarvatt) on 2010-10-23
Changed in linux (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
Vish (vish) wrote :

The patch that was cherry-picked for Bug #507148 " [lucid] desktop runs out of video memory on ATI Radeon Mobility 7500 " , needs to be reverted.

The upstream patch that was cherry-picked from https://bugs.freedesktop.org/show_bug.cgi?id=26302 , was updated and merged in kernel .36 , which does not seem to cause this problem.

The fix that was merged in kernel .36 is commit e376573f7267390f4e1bdc552564b6fb913bce76 ('drm/radeon: fallback to GTT if bo creation/validation in VRAM fails.'), and commit 2b66b50b12cabc05f05543e792d4c9c2465d5702 ('drm/radeon/kms: Fix retrying ttm_bo_init() after it failed once.') fixes up a problem of the fix in the BO creation path.

Vish (vish) on 2010-11-26
tags: added: regression-release regression-update
tags: removed: regression-update
Andy Whitcroft (apw) wrote :

@vish -- could you test the kernels at the URL below, these contains the original fix reverted and brings up to the latest apparent fixes you indicate above. Please report any testing back here. We will also have to obtain testing for the original issue to confirm that they remain fixed with this new combination. The kernels are here:

    http://people.canonical.com/~apw/lp652934-maverick/

Thanks.

AttilaN (attila123456) wrote :

Just tried the above kernel on maverick. Guest session looks okay, but when I log out of it, the system hangs (only hard reset helps).

Vish (vish) wrote :

@apw: I'm running the kernel now, since the bug takes a while to manifest ;) , will report back after a couple of days of running the kernel.

@AttilaN: I dont see the system hang problem here, I'm able to switch back from a guest session. Are you sure your card is a RV515 as reported here? Was the hang only once or does it occur everytime you logout of the guest session? Did Alt+SysRq+K not work? If its not the same hardware, its better if a new bug is reported.

AttilaN (attila123456) wrote :

On 2nd thought... it does seem to work fine, that freeze must have been a one time thing. (Card is RV515.)

Vish (vish) wrote :

@AttilaN : Actually there is a problem recently in my system too where it freezes at seemingly random times, but it's not related to the kernel. [it has occurred in several kernels]

Only recently i noticed the following was the last message in ~/.xsession-errors when the system froze:

NOTE: child process received `Goodbye', closing down

I'm not sure if its related, Might be. So if it freezes for you could you check you xsession-errors. ?
If the same, we can probably file a separate bug and track that issue.

Vish (vish) wrote :

Tested [for 45hrs] with apw's kernel and i havent had any problems, Guest session is fine and no flickering.
~$ uname -a
Linux Aspire-5670 2.6.35-24-generic #41~lp652934v201011261013 SMP Fri Nov 26 10:15:57 UTC 2010 i686 GNU/Linux

Andy Whitcroft (apw) on 2011-03-02
Changed in linux (Ubuntu):
status: Confirmed → Fix Released
assignee: nobody → Andy Whitcroft (apw)
Changed in linux (Ubuntu Lucid):
status: New → In Progress
assignee: nobody → Andy Whitcroft (apw)
importance: Undecided → Medium
Changed in linux (Ubuntu Maverick):
importance: Undecided → Medium
status: New → In Progress
assignee: nobody → Andy Whitcroft (apw)
Tim Gardner (timg-tpi) on 2011-03-02
Changed in linux (Ubuntu Lucid):
status: In Progress → Fix Committed
Changed in linux (Ubuntu Maverick):
status: In Progress → Fix Committed
Jamie Strandboge (jdstrand) wrote :

I tested this on Lucid and the Guest session is no worse. Ie, switching to Guest Session from a compiz session results in an unusable guest session (black screen with some artificats) in both 2.6.32-27.49-generic and 2.6.32-30.59-generic.

Jamie Strandboge (jdstrand) wrote :

I forgot to mention, compiz works fine with 2.6.32-30.59-generic. There appear to be no regressions with the update. So while the guest session is still unusable for me, this update seems fine.

$ lspci|grep -i radeon
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility M7 LW [Radeon Mobility 7500]

Accepted linux into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Martin Pitt (pitti) wrote :

Accepted linux-ec2 into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed' to 'verification-done'.

If verification is not done by one week from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-lucid
Brad Figg (brad-figg) on 2011-03-21
tags: added: verification-needed-maverick
AttilaN (attila123456) wrote :

Still seeing the error on maverick 2.6.35-28...is there a different version in -proposed that I should test?

Steve Conklin (sconklin) wrote :

No, that's the version in -proposed for Maverick.

We still need verification of whether or not the issue is resolved for Lucid.

tags: added: verification-failed-maverick
removed: verification-needed-maverick
Vish (vish) wrote :

Yes, Kernel (2.6.35-28.49)-maverick , still has the issue.
But, apw's kernel dint have the problem, I wonder if the old patch was *dropped* when adding the new patch.
Or, was the change even uploaded? I dont see any mention of this bug in the changelog? (or I'm just being blind)

Vish (vish) wrote :

Gah! I had apt pinning! I see that there is linux (2.6.35-28.50) available.
Testing that now.

Vish (vish) wrote :

Maverick kernel linux (2.6.35-28.50) fixes the problem, tested it for 40hrs and dint have any problem, while 2.6.35-28.49 causes the issue in under 12-15hrs.

Testing Lucid kernel now...

tags: added: verification-done-maverick
removed: verification-failed-maverick
Steve Conklin (sconklin) wrote :

Vish,

Thanks for the testing. We'll need an answer today if you can, because of the time required to drop the patch respin the package if it doesn't fix the problem in Lucid.

Vish (vish) wrote :

Yup, Lucid one doesnt show any problems either.

tags: added: verification-done-lucid
removed: verification-needed-lucid
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.35-28.50

---------------
linux (2.6.35-28.50) maverick-proposed; urgency=low

  [ Brad Figg ]

  * Release Tracking Bug
    - LP: #734399

  [ Corentin Chary ]

  * SAUCE: (drop after 2.6.38) eeepc-wmi: reorder keymap
    - LP: #689393
  * SAUCE: (drop after 2.6.38) eeepc-wmi: add wlan key found on 1015P
    - LP: #689393

  [ Keng-Yu Lin ]

  * SAUCE: eeepc-wmi: set the touchpad toggle key code to F22
    - LP: #689393

  [ Tim Gardner ]

  * [Config] CONFIG_BOOT_PRINTK_DELAY=y
    - LP: #733191

  [ Upstream Kernel Changes ]

  * Revert "drm/radeon/bo: add some fallback placements for VRAM only
    objects."
    - LP: #652934
  * eeepc-wmi: add additional hotkeys
    - LP: #689393
  * xen: don't bother to stop other cpus on shutdown/reboot
    - LP: #727814
  * Yama: use thread group leader when creating match
    - LP: #729839
  * mmc: sdhci-pci: add ricoh e822 pci id with device specific quirks
    - LP: #730820
 -- Brad Figg <email address hidden> Sun, 13 Mar 2011 07:01:39 -0700

Changed in linux (Ubuntu Maverick):
status: Fix Committed → Fix Released

Accepted linux-ec2 into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Launchpad Janitor (janitor) wrote :
Download full text (7.2 KiB)

This bug was fixed in the package linux - 2.6.32-31.61

---------------
linux (2.6.32-31.61) lucid-proposed; urgency=low

  [ Brad Figg ]

  * Release Tracking Bug
    - LP: #754842

  [ Upstream Kernel Changes ]

  * x86, quirk: Fix SB600 revision check
    - LP: #742056

linux (2.6.32-31.60) lucid-proposed; urgency=low

  [ Brad Figg ]

  * Release Tracking Bug
    - LP: #734950

  [ Paolo Pisati ]

  * SAUCE: Clear new_profile in error path
    - LP: #732700

  [ Tim Gardner ]

  * [Config] CONFIG_BOOT_PRINTK_DELAY=y
    - LP: #733191

  [ Upstream Kernel Changes ]

  * Revert "drm/radeon/bo: add some fallback placements for VRAM only
    objects."
    - LP: #652934
  * drm/radeon: fall back to GTT if bo creation/validation in VRAM fails.
    - LP: #652934
  * drm/radeon/kms: Fix retrying ttm_bo_init() after it failed once.
    - LP: #652934
  * xfs: always use iget in bulkstat
    - LP: #692848
  * drm/radeon/kms: make the mac rv630 quirk generic
    - LP: #728687
  * drm/radeon/kms: add pll debugging output
    - LP: #728687
  * drm/radeon: remove 0x4243 pci id
    - LP: #728687
  * drm/radeon/kms: fix s/r issues with bios scratch regs
    - LP: #728687
  * drm/i915/lvds: Add AOpen i915GMm-HFS to the list of false-positive LVDS
    - LP: #728687
  * drm/i915: Add dependency on CONFIG_TMPFS
    - LP: #728687
  * Linux 2.6.32.29+drm33.14
    - LP: #728687
  * NFSD: memory corruption due to writing beyond the stat array
    - LP: #728687
  * mptfusion: mptctl_release is required in mptctl.c
    - LP: #728687
  * mptfusion: Fix Incorrect return value in mptscsih_dev_reset
    - LP: #728687
  * ocfs2_connection_find() returns pointer to bad structure
    - LP: #728687
  * x25: decrement netdev reference counts on unload
    - LP: #728687
  * x86, hpet: Disable per-cpu hpet timer if ARAT is supported
    - LP: #728687
  * OHCI: work around for nVidia shutdown problem
    - LP: #728687
  * x86/pvclock: Zero last_value on resume
    - LP: #728687
  * av7110: check for negative array offset
    - LP: #728687
  * CRED: Fix get_task_cred() and task_state() to not resurrect dead
    credentials
    - LP: #728687
  * bonding/vlan: Avoid mangled NAs on slaves without VLAN tag insertion
    - LP: #728687
  * CRED: Fix kernel panic upon security_file_alloc() failure.
    - LP: #728687
  * CRED: Fix BUG() upon security_cred_alloc_blank() failure
    - LP: #728687
  * CRED: Fix memory and refcount leaks upon security_prepare_creds()
    failure
    - LP: #728687
  * sendfile(): check f_op.splice_write() rather than f_op.sendpage()
    - LP: #728687
  * isdn: hisax: Replace the bogus access to irq stats
    - LP: #728687
  * ixgbe: add support for 82599 based Express Module X520-P2
    - LP: #728687
  * ixgbe: prevent speculative processing of descriptors before ready
    - LP: #728687
  * scsi_dh_alua: add netapp to dev list
    - LP: #728687
  * scsi_dh_alua: Add IBM Power Virtual SCSI ALUA device to dev list
    - LP: #728687
  * dm raid1: fail writes if errors are not handled and log fails
    - LP: #728687
  * GFS2: Fix bmap allocation corner-case bug
    - LP: #728687
  * dm raid1: fix null pointer dereference in suspend
    - LP: #728687
  * sunrpc/...

Read more...

Changed in linux (Ubuntu Lucid):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Accepted linux into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.