linux-omap cant bring up eth0 on igepv2 board, no network

Bug #645689 reported by Ricardo Lameiro on 2010-09-23
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
Maverick
Undecided
Unassigned

Bug Description

Using this kernel, i can't have access to the network interface on the IGEPv2.
Also, if you look at the crash report, lspci brings an error.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: linux-omap 2.6.35.22.23
Regression: No
Reproducible: Yes
ProcVersionSignature: Ubuntu 2.6.35-22.33-omap 2.6.35.4
Uname: Linux 2.6.35-22-omap armv7l
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: igep2 [igep2], device 0: TWL4030 twl4030-0 []
   Subdevices: 1/1
   Subdevice #0: subdevice #0
Architecture: armel
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: igep2 [igep2], device 0: TWL4030 twl4030-0 []
   Subdevices: 1/1
   Subdevice #0: subdevice #0
CurrentDmesg:

Date: Thu Sep 23 02:16:35 2010
Lspci:
 Error: command ['lspci', '-vvnn'] failed with exit code 1: pcilib: Cannot open /proc/bus/pci
 lspci: Cannot find any working access method.
Lsusb: Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
ProcCmdLine: mem=512M console=tty0 console=ttyS2,115200n8 root=/dev/mmcblk0p2 rw rootwait vram=12M omapfb.mode=dvi:1280x720MR-16@60
ProcEnviron:
 SHELL=/bin/bash
 LANG=pt_PT.UTF-8
SourcePackage: linux

Ricardo Lameiro (rlameiro) wrote :
Ricardo Lameiro (rlameiro) wrote :

this issues was solved on the linux-linaro kernel. LP: #618734

Ricardo Salveti (rsalveti) wrote :

Proposed fix:
http://kernel.ubuntu.com/git?p=rsalveti/ubuntu-maverick.git;a=commit;h=3f6271b62c886975faea5cc57f55f870a947eb13

Sent to the kernel-team, with following SRU:

SRU Justification:

Impact: When booting current omap 3 kernel at an IGEPv2 board the ethernet driver
is not loaded by default, and even when loaded by hand, it doesn't work because
current kernel defines CONFIG_FIXED_PHY, conflicting with SMSC911X driver.

Fix: The problem is fixed by disabling CONFIG_FIXED_PHY and changing
CONFIG_SMSC911X from module to built-in, for Omap. This is the same solution
provided by bug 618734, fixed at Linaro's kernel (91d9d3).

Testcase: Boot current omap 3 kernel and then call ifconfig -a, you shouldn't
be able to see eth0.

Jeremy Foshee (jeremyfoshee) wrote :

Hi Ricardo,

If you could also please test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

    [This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete
tags: removed: needs-upstream-testing
tags: added: igep

Accepted linux into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in linux (Ubuntu Maverick):
status: New → Fix Committed
tags: added: verification-needed
Steve Conklin (sconklin) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed' to 'verification-done'.

If verification is not done by Thursday, November 11, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

Ricardo Lameiro (rlameiro) wrote :

I cant test it before !! November. Can someone else test it?

Hi,

I can test. Exactly which package should I test ?

With latest kernel build from maverick repository I can have access to
the network interface on my IGEP v2 board.

Cheers,

  Enric

2010/11/5 Ricardo Lameiro <email address hidden>:
> I cant test it before !! November. Can someone else test it?
>
> --
> linux-omap cant bring up eth0 on igepv2 board, no network
> https://bugs.launchpad.net/bugs/645689
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “linux” package in Ubuntu: Incomplete
> Status in “linux” source package in Maverick: Fix Committed
>
> Bug description:
> Using this kernel, i can't have access to the network interface on the IGEPv2.
> Also, if you look at the crash report, lspci brings an error.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 10.10
> Package: linux-omap 2.6.35.22.23
> Regression: No
> Reproducible: Yes
> ProcVersionSignature: Ubuntu 2.6.35-22.33-omap 2.6.35.4
> Uname: Linux 2.6.35-22-omap armv7l
> AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
> AplayDevices:
>  **** List of PLAYBACK Hardware Devices ****
>  card 0: igep2 [igep2], device 0: TWL4030 twl4030-0 []
>   Subdevices: 1/1
>   Subdevice #0: subdevice #0
> Architecture: armel
> ArecordDevices:
>  **** List of CAPTURE Hardware Devices ****
>  card 0: igep2 [igep2], device 0: TWL4030 twl4030-0 []
>   Subdevices: 1/1
>   Subdevice #0: subdevice #0
> CurrentDmesg:
>
> Date: Thu Sep 23 02:16:35 2010
> Lspci:
>  Error: command ['lspci', '-vvnn'] failed with exit code 1: pcilib: Cannot open /proc/bus/pci
>  lspci: Cannot find any working access method.
> Lsusb: Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
> ProcCmdLine: mem=512M console=tty0 console=ttyS2,115200n8 root=/dev/mmcblk0p2 rw rootwait vram=12M omapfb.mode=dvi:1280x720MR-16@60
> ProcEnviron:
>  SHELL=/bin/bash
>  LANG=pt_PT.UTF-8
> SourcePackage: linux
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/645689/+subscribe
>

Download full text (3.2 KiB)

Tested on linux-linaro-2.6.35-1008.

ubuntu@ubuntu:~$ uname -a
Linux ubuntu 2.6.35-1008-linaro-omap #15-Ubuntu Fri Oct 22 11:56:29
UTC 2010 armv7l GNU/Linux
ubuntu@ubuntu:~$ ifconfig -a
eth0 Link encap:Ethernet HWaddr 4e:82:aa:8e:d2:0b
          inet addr:192.168.2.165 Bcast:192.168.2.255 Mask:255.255.255.0
          inet6 addr: fe80::4c82:aaff:fe8e:d20b/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
          RX packets:30 errors:0 dropped:0 overruns:0 frame:0
          TX packets:39 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:4284 (4.2 KB) TX bytes:7347 (7.3 KB)
          Interrupt:80

lo Link encap:Local Loopback
          inet addr:127.0.0.1 Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING MTU:16436 Metric:1
          RX packets:4 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:240 (240.0 B) TX bytes:240 (240.0 B)

Ethernet works.

Cheers,
   Enric

2010/11/7 Enric Balletbò i Serra <email address hidden>:
> Hi,
>
> I can test. Exactly which package should I test ?
>
> With latest kernel build from maverick repository I can have access to
> the network interface on my IGEP v2 board.
>
> Cheers,
>
>  Enric
>
> 2010/11/5 Ricardo Lameiro <email address hidden>:
>> I cant test it before !! November. Can someone else test it?
>>
>> --
>> linux-omap cant bring up eth0 on igepv2 board, no network
>> https://bugs.launchpad.net/bugs/645689
>> You received this bug notification because you are a direct subscriber
>> of the bug.
>>
>> Status in “linux” package in Ubuntu: Incomplete
>> Status in “linux” source package in Maverick: Fix Committed
>>
>> Bug description:
>> Using this kernel, i can't have access to the network interface on the IGEPv2.
>> Also, if you look at the crash report, lspci brings an error.
>>
>> ProblemType: Bug
>> DistroRelease: Ubuntu 10.10
>> Package: linux-omap 2.6.35.22.23
>> Regression: No
>> Reproducible: Yes
>> ProcVersionSignature: Ubuntu 2.6.35-22.33-omap 2.6.35.4
>> Uname: Linux 2.6.35-22-omap armv7l
>> AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
>> AplayDevices:
>>  **** List of PLAYBACK Hardware Devices ****
>>  card 0: igep2 [igep2], device 0: TWL4030 twl4030-0 []
>>   Subdevices: 1/1
>>   Subdevice #0: subdevice #0
>> Architecture: armel
>> ArecordDevices:
>>  **** List of CAPTURE Hardware Devices ****
>>  card 0: igep2 [igep2], device 0: TWL4030 twl4030-0 []
>>   Subdevices: 1/1
>>   Subdevice #0: subdevice #0
>> CurrentDmesg:
>>
>> Date: Thu Sep 23 02:16:35 2010
>> Lspci:
>>  Error: command ['lspci', '-vvnn'] failed with exit code 1: pcilib: Cannot open /proc/bus/pci
>>  lspci: Cannot find any working access method.
>> Lsusb: Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
>> ProcCmdLine: mem=512M console=tty0 console=ttyS2,115200n8 root=/dev/mmcblk0p2 rw rootwait vram=12M omapfb.mode=dvi:1280x720MR-16@60
>> ProcEnviron:
>>  SHELL=/bin/bash
>>  LANG=pt_PT.UTF-8
>> SourcePackage: linux
>>
>> To unsubscribe from this ...

Read more...

tags: added: verification-done
removed: verification-needed
Changed in linux (Ubuntu):
status: Incomplete → Fix Released
Changed in linux (Ubuntu Maverick):
assignee: nobody → Ricardo Salveti (rsalveti)
status: Fix Committed → Fix Released
Ricardo Salveti (rsalveti) wrote :

Actually this fix is not yet released. It was included at 23.36 but the one at main is still 22.33. The one at -proposed is 23.40 and include this fix. Just can't change the bug status anymore because of the new launchpad feature.

Oliver Grawert (ogra) on 2010-11-18
Changed in linux (Ubuntu Maverick):
status: Fix Released → Fix Committed
Changed in linux (Ubuntu):
status: Fix Released → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (16.2 KiB)

This bug was fixed in the package linux - 2.6.35-23.40

---------------
linux (2.6.35-23.40) maverick-proposed; urgency=low

  [ Brad Figg ]

  * No change rebuild.

linux (2.6.35-23.39) maverick-proposed; urgency=low

  [ Brad Figg ]
    - LP: #676214

  [ Ricardo Salveti de Araujo ]

  * SAUCE: ARM: OMAP3: beagle: use GPIO2 on the xM A3 to turn DVI on
    - LP: #663642

linux (2.6.35-23.38) maverick-proposed; urgency=low

  [ Brad Figg ]

  * Revert "SAUCE: ARM: OMAP3: beagle: use GPIO2 on the xM A3 to turn DVI
    on"

  [ Upstream Kernel Changes ]

  * Revert "(upstream) ALSA: hda - Apply ALC269 VAIO fix-up to all Sony
    laptops with ALC269"
  * Revert "ALSA: HDA: Correctly apply position_fix quirks for ATI and VIA
    controllers"
  * Buglink Fixup for reverted unverified fixes

linux (2.6.35-23.37) maverick-proposed; urgency=low

  [ Brad Figg ]

  * ARM: Temporarily disable module check for armel

linux (2.6.35-23.36) maverick-proposed; urgency=low

  [ Andy Whitcroft ]

  * reduce disk usage during buildd builds
    - LP: #645653

  [ Brad Figg ]

  * ARM: Temporarily disable module check for armel

  [ Enric Balletbo i Serra ]

  * ARM: igepv2: Adding support for VBUS and overcurrent
    - LP: #651589
  * ARM: igepv2: Fix and improve LED handling
    - LP: #654582
  * ARM: igepv2: Introduce function to dectect HW version
    - LP: #654586
  * ARM: igepv2: Fix handling of GPIOs for WLAN-BT combo
    - LP: #654590
  * ARM: igepv2: Add i2c eeprom driver to read EDID
    - LP: #654594
  * ARM: igepv2: Remove VMMC2 regulator
    - LP: #654595

  [ Leann Ogasawara ]

  * ARM: Temporarily disable module check for armel

  [ Mathieu Poirier ]

  * SAUCE: ARM: Add DSS2 support for Overo board
    - LP: #660811

  [ Maurus Cuelenaere ]

  * SAUCE: ARM: OMAP3: Add S-Video output to IGEPv2 board
    - LP: #607250

  [ Ricardo Salveti de Araujo ]

  * [Config] Remove CONFIG_FIXED_PHY and move CONFIG_SMSC911X from m to y
    for omap
    - LP: #645689
  * SAUCE: ARM: OMAP3: Adding vdd_sdi regulator supply to IGEPv2 board
    - LP: #607250
  * SAUCE: ARM: OMAP3: beagle: use GPIO2 on the xM A3 to turn DVI on
    - See: #663642

  [ Upstream Kernel Changes ]

  * Revert "(pre-stable) ALSA: HDA: Use model=auto for LG R510"
  * Revert "(pre-stable) ALSA: hda - Rename iMic to Int Mic on Lenovo
    NB0763"
  * Revert "Input: appletouch - fix integer overflow issue"
  * Revert "ALSA: hda - Handle pin NID 0x1a on ALC259/269"
  * Revert "ALSA: hda - Handle missing NID 0x1b on ALC259 codec"
  * Revert "(pre-stable) ALSA: hda - Add a new hp-laptop model for Conexant
    5066, tested on HP G60"
  * Revert "mmc: build fix: mmc_pm_notify is only available with
    CONFIG_PM=y"
  * Revert "mmc: fix all hangs related to mmc/sd card insert/removal during
    suspend/resume"
  * Revert "(pre-stable) bounce: call flush_dcache_page() after
    bounce_copy_vec()"
  * Revert "Input: i8042 - reset keyboard controller wehen resuming from
    S2R"
  * Revert "ALSA: HDA: Enable internal speaker on Dell M101z"
  * Revert "(pre-stable) drm/i915: don't enable self-refresh on Ironlake"
  * Revert "drm/i915: Allow LVDS on pipe A on gen4+"
  * (pre-stable) ACPI: enable repeated...

Changed in linux (Ubuntu Maverick):
status: Fix Committed → Fix Released
Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Changed in linux (Ubuntu Maverick):
assignee: Ricardo Salveti (rsalveti) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers