linux-headers-2.6.32.24 package configuration errors on postinst script

Bug #645150 reported by JW
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Confirmed
Undecided
Unassigned

Bug Description

Here is the message I receive after every package update now:

Examining /etc/kernel/postinst.d.
run-parts: executing /etc/kernel/postinst.d/dkms 2.6.32-24-generic /boot/vmlinuz-2.6.32-24-generic
run-parts: executing /etc/kernel/postinst.d/nvidia-common 2.6.32-24-generic /boot/vmlinuz-2.6.32-24-generic
run-parts: /etc/kernel/postinst.d/nvidia-common exited with return code 10
Failed to process /etc/kernel/postinst.d at /var/lib/dpkg/info/linux-image-2.6.32-24-generic.postinst line 1003.
dpkg: error processing linux-image-2.6.32-24-generic (--configure):
 subprocess installed post-installation script returned error exit status 2
Setting up linux-headers-2.6.32-24-generic (2.6.32-24.43) ...
Examining /etc/kernel/header_postinst.d.
run-parts: executing /etc/kernel/header_postinst.d/dkms 2.6.32-24-generic /boot/vmlinuz-2.6.32-24-generic
run-parts: executing /etc/kernel/header_postinst.d/nvidia-common 2.6.32-24-generic /boot/vmlinuz-2.6.32-24-generic
run-parts: /etc/kernel/header_postinst.d/nvidia-common exited with return code 10
Failed to process /etc/kernel/header_postinst.d at /var/lib/dpkg/info/linux-headers-2.6.32-24-generic.postinst line 110.
dpkg: error processing linux-headers-2.6.32-24-generic (--configure):
 subprocess installed post-installation script returned error exit status 2
Setting up amarok-common (2:2.3.2-0ubuntu1~lucid1~ppa1) ...
Setting up amarok-utils (2:2.3.2-0ubuntu1~lucid1~ppa1) ...
Setting up amarok (2:2.3.2-0ubuntu1~lucid1~ppa1) ...

Setting up amarok-dbg (2:2.3.2-0ubuntu1~lucid1~ppa1) ...
Setting up fglrx-modaliases (2:8.723.1-0ubuntu5) ...
Processing triggers for menu ...
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
Errors were encountered while processing:
 linux-image-2.6.32-24-generic
 linux-headers-2.6.32-24-generic
E: Sub-process /usr/bin/dpkg returned an error code (1)

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: linux-image-2.6.32-24-generic 2.6.32-24.43
Regression: Yes
Reproducible: Yes
ProcVersionSignature: Ubuntu 2.6.32-24.43-generic 2.6.32.15+drm33.5
Uname: Linux 2.6.32-24-generic x86_64
NonfreeKernelModules: nvidia
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: jwheaton 2257 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Audigy'/'SB Audigy 1 [SB0090] (rev.3, serial:0x511102) at 0x8880, irq 23'
   Mixer name : 'TriTech TR28602'
   Components : 'AC97a:54524123'
   Controls : 194
   Simple ctrls : 30
Date: Wed Sep 22 08:09:46 2010
HibernationDevice: RESUME=UUID=52cbc8a5-90a8-4815-87d5-7c62ca7b124e
MachineType: ASUSTEK COMPUTER INC P5W DH Deluxe
ProcCmdLine: root=UUID=01069596-6957-446e-b595-dd433fd72ba4 ro quiet splash
ProcEnviron:
 LANGUAGE=
 LANG=en_US.UTF-8
 SHELL=/bin/bash
RelatedPackageVersions: linux-firmware 1.34.1
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
SourcePackage: linux
WifiSyslog:
 Sep 22 07:54:45 archon NetworkManager: <info> Unmanaged Device found; state CONNECTED forced. (see http://bugs.launchpad.net/bugs/191889)
 Sep 22 08:06:34 archon kernel: [ 2768.391477] lo: Disabled Privacy Extensions
WpaSupplicantLog:

dmi.bios.date: 07/10/2008
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 2801
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: P5W DH Deluxe
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr2801:bd07/10/2008:svnASUSTEKCOMPUTERINC:pnP5WDHDeluxe:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5WDHDeluxe:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: P5W DH Deluxe
dmi.product.version: System Version
dmi.sys.vendor: ASUSTEK COMPUTER INC

Revision history for this message
JW (arch0njw) wrote :
Revision history for this message
JW (arch0njw) wrote :

Resolved this by removing and then installing the nvidia-common package. That appears to be where the problem was.

--- --- ---
Examining /etc/kernel/header_postinst.d.
run-parts: executing /etc/kernel/header_postinst.d/dkms 2.6.32-24-generic /boot/vmlinuz-2.6.32-24-generic
run-parts: executing /etc/kernel/header_postinst.d/nvidia-common 2.6.32-24-generic /boot/vmlinuz-2.6.32-24-generic
run-parts: /etc/kernel/header_postinst.d/nvidia-common exited with return code 10
Failed to process /etc/kernel/header_postinst.d at /var/lib/dpkg/info/linux-headers-2.6.32-24-generic.postinst line 110.
--- --- ---

Curiously, when I uninstalled nvidia-common this error message was issued again. If that package was uninstalled, shouldn't the header_postinst.d file be removed?

Upon installing nvidia-common again, the error messages went away.

Brad Figg (brad-figg)
tags: added: acpi-table-checksum
Brad Figg (brad-figg)
Changed in linux (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers