Touchpad is not working since last kernel update in maverick

Bug #641320 reported by Serge Hallyn on 2010-09-17
102
This bug affects 15 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Critical
Unassigned

Bug Description

Binary package hint: xorg

I called it an xorg bug, but it's probably purely a kernel bug. When I boot the previous
kernel, touchpad works. When I boot the one which was installed with last night's
maverick update, I can't move the mouse or click with the touchpad.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: xorg 1:7.5+6ubuntu3
ProcVersionSignature: Ubuntu 2.6.35-22.32-generic 2.6.35.4
Uname: Linux 2.6.35-22-generic x86_64
NonfreeKernelModules: nvidia
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 256.53 Fri Aug 27 20:27:48 PDT 2010
 GCC version: gcc version 4.4.5 (Ubuntu/Linaro 4.4.4-14ubuntu4)
Architecture: amd64
Date: Fri Sep 17 08:47:41 2010
DkmsStatus:
 nvidia-current, 256.53, 2.6.35-19-generic, x86_64: installed
 nvidia-current, 256.53, 2.6.35-20-generic, x86_64: installed
 nvidia-current, 256.53, 2.6.35-22-generic, x86_64: installed
 virtualbox-ose, 3.2.8, 2.6.35-20-generic, x86_64: installed
 virtualbox-ose, 3.2.8, 2.6.35-22-generic, x86_64: installed
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Alpha amd64 (20100820)
MachineType: Sony Corporation VPCF11KFX
ProcCmdLine: BOOT_IMAGE=/vmlinuz-2.6.35-22-generic root=UUID=39014c73-b7b6-48d9-9ae6-62eec39544eb ro
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: xorg
Symptom: display
dmi.bios.date: 12/07/2009
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: R0250Y6
dmi.board.asset.tag: N/A
dmi.board.name: VAIO
dmi.board.vendor: Sony Corporation
dmi.board.version: N/A
dmi.chassis.asset.tag: N/A
dmi.chassis.type: 10
dmi.chassis.vendor: Sony Corporation
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrR0250Y6:bd12/07/2009:svnSonyCorporation:pnVPCF11KFX:pvrR5840006:rvnSonyCorporation:rnVAIO:rvrN/A:cvnSonyCorporation:ct10:cvrN/A:
dmi.product.name: VPCF11KFX
dmi.product.version: R5840006
dmi.sys.vendor: Sony Corporation
glxinfo: Error: [Errno 2] No such file or directory
system:
 distro: Ubuntu
 codename: maverick
 architecture: x86_64
 kernel: 2.6.35-22-generic

Serge Hallyn (serge-hallyn) wrote :
Serge Hallyn (serge-hallyn) wrote :

This is an Xorg.log from the working kernel which I'm booted in now.

Chase Douglas (chasedouglas) wrote :

I was notified of this bug since the uTouch framework is now used for some input handling in X in Maverick. I am 99% sure this is not a uTouch induced issue since:

1. A kernel reversion fixes the issue.
2. The X Synaptics input module is used, which is not uTouch enabled.

This is likely due to the following commit, which enables ALPS support for the trackpad instead of the bare IMPS/2 protocol. This is confirmed by the Xorg logs from the different kernels:

http://kernel.ubuntu.com/git?p=ubuntu/ubuntu-maverick.git;a=commit;h=bd79df42218fe1db5e683b567791d4bb97b60685

affects: xorg (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
importance: Undecided → Critical
milestone: none → ubuntu-10.10
status: New → Triaged
Andy Whitcroft (apw) wrote :

I've reverted that patch and produced some test kernels. If those of you affected could test the kernels at the URL below and report back that would be helpful:

    http://people.canonical.com/~apw/lp641320-maverick/

Please report testing results here. Thanks.

David Mandala (davidm) wrote :

I installed the kernel on my Sony Vaio VPC-F1290X, rebooted with no change, mousepad still dead. I never used the prior kernels as I just purchased this machine, so I don't know if a prior kernel would have done anything anyway.

David Mandala (davidm) wrote :

dmesg dump art apw's request

Serge Hallyn (serge-hallyn) wrote :

Problem is fixed with the kernel from
http://people.canonical.com/~apw/lp641320-maverick/

Serge Hallyn (serge-hallyn) wrote :

(Mine is sony VPCF1 fwiw)

Joel Guthrie (joelguthrie) wrote :

The lp641220-maverick kernel restores the touchpad to a functional state, but it is now functions as a ImPS/2 Generic Wheel Mouse ( as per Chase Douglas above). The touchpad tab no longer appears under Pointing Devices. But as least it's working, somewhat.

$ xinput -list
⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ ImPS/2 Generic Wheel Mouse id=11 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
    ↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
    ↳ Sony Vaio Keys id=6 [slave keyboard (3)]
    ↳ Video Bus id=7 [slave keyboard (3)]
    ↳ Power Button id=8 [slave keyboard (3)]
    ↳ USB 2.0 Camera id=9 [slave keyboard (3)]
    ↳ AT Translated Set 2 keyboard id=10 [slave keyboard (3)]

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.35-22.33

---------------
linux (2.6.35-22.33) maverick; urgency=low

  [ Andy Whitcroft ]

  * Revert "SAUCE: Add support for Intellimouse Mode in ALPS touchpad on
    Dell E2 series Laptops"
    - LP: #641320

  [ Brian Rogers ]

  * SAUCE: ir-core: Fix null dereferences in the protocols sysfs interface
    - LP: #624701

  [ Christopher James Halse Rogers ]

  * SAUCE: Nouveau: Add quirk framework to disable acceleration
    - LP: #544088, #546393
  * SAUCE: Nouveau: Disable acceleration on MacBook Pros
    - LP: #546393

  [ John Johansen ]

  * Revert "SAUCE: AppArmor: allow newer tools to load policy on older
    kernels"
  * SAUCE: AppArmor: allow newer tools to load policy on older kernels
    - LP: #639758

  [ Mathieu J. Poirier ]

  * SAUCE: Adding vdd_sdi regulator supply to OMAP3EVM

  [ Upstream Kernel Changes ]

  * ALSA: HDA: Enable internal speaker on Dell M101z
    - LP: #640254
 -- Leann Ogasawara <email address hidden> Fri, 17 Sep 2010 13:21:28 -0700

Changed in linux (Ubuntu):
status: Triaged → Fix Released
Vladimir Prus (vladimir.prus) wrote :

This patch appears to have broken touchpad scrolling in my E6410, which was working fine before. Is this intended?

Kim Nguyễn (kim.nguyen) wrote :

I second Vladimir's comment. This patch breaks touchpad scrolling on my sony vaio:
Input device is an AlpsPS/2 ALPS GlidePoint
shows up correctly with xinput list with kernel 2.6.35-20-generic:
⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ PS/2 Mouse id=1
⎜ ↳ AlpsPS/2 ALPS GlidePoint id=12 [slave pointer (2)]
1 [slave pointer (2)]

With the current patch and 2.6.35-22 only the generic ps/2 mouse shows up.

tosh96 (tosh96-gmail) wrote :

I have the same problem where my touchpad is not working. This is after a fresh install of Maverick on a Sony Vaio VPCEE2S1E. The touchpad is not detected. As I am running 2.6.35.22, the patch provided here does not work for me. I have tested booting to several flavours of live CD with the same results.

$ uname -a
Linux lbj-lx 2.6.35-22-generic #34-Ubuntu SMP Sun Oct 10 09:26:05 UTC 2010 x86_64 GNU/Linux

$ xinput -list
⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ Microsoft Microsoft® 2.4GHz Transceiver v5.0 id=10 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
    ↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
    ↳ Power Button id=6 [slave keyboard (3)]
    ↳ Video Bus id=7 [slave keyboard (3)]
    ↳ Sony Vaio Keys id=8 [slave keyboard (3)]
    ↳ Power Button id=9 [slave keyboard (3)]
    ↳ Sony Visual Communication Camer id=11 [slave keyboard (3)]
    ↳ AT Translated Set 2 keyboard id=12 [slave keyboard (3)]

I have a new sony vaio F12M1E and had the same problem, right from the first boot of 10.10 from the installation cd.
Neither was working my display after I installed the nvidia driver, but that is another story (finally solved it by reverting to driver 256.53 instead of the newest one).

I got the touchpad recognized by following the instructions from this website:
http://www.thibautwdowiak.com/blog/index.php/77-install-of-ubuntu-1004-lucid-lynx-on-a-sony-vaio-vpcs12v5e.html

I'm *not sure what the solution does*, but here it is:

gksudo gedit /etc/default/grub

set the grub default to the following instead of "quiet splash"
GRUB_CMDLINE_LINUX_DEFAULT="nomodeset i8042.nopnp"

Then again in the terminal
sudo update-grub

and reboot

tosh96 (tosh96-gmail) wrote :

Perfect...

$ xinput -list
⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ AlpsPS/2 ALPS GlidePoint id=13 [slave pointer (2)]
⎜ ↳ PS/2 Mouse id=14 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
    ↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
    ↳ Power Button id=6 [slave keyboard (3)]
    ↳ Video Bus id=7 [slave keyboard (3)]
    ↳ Sony Vaio Keys id=8 [slave keyboard (3)]
    ↳ Power Button id=9 [slave keyboard (3)]
    ↳ Sony Visual Communication Camer id=11 [slave keyboard (3)]
    ↳ AT Translated Set 2 keyboard id=12 [slave keyboard (3)]

Thanks for pointing me in the right direction...I love Ubuntu & would have used an external mouse for as long as it took...but it's always nicer to have the touchpad working ;-)

bastianr (reich) wrote :

RE #14

It's not working for me.

⎜ ↳ ImPS/2 Generic Wheel Mouse id=14 [slave pointer (2)]

[ 0.000000] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-2.6.35-22-generic root=UUID=694f2eeb-d9c8-433a-8fd7-cfc4672a5aa5 ro nomodeset i8042.nopnp

Linux xyz 2.6.35-22-generic #35-Ubuntu SMP Sat Oct 16 20:45:36 UTC 2010 x86_64 GNU/Linux

Sony Vaio VPCEB1Z1E

To post a comment you must log in.