Screen flickers after 2.6.32-24.42 update (drm/i915 changes)

Bug #641027 reported by Michael Opdenacker on 2010-09-17
58
This bug affects 10 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

The display flickers several times per minute after the 2.6.32-24.42 kernel update. This is extremely tirying for the user.

linux (2.6.32-24.42) lucid-proposed; urgency=low

  [ Upstream Kernel Changes ]

  * (pre-stable) drm/i915: add PANEL_UNLOCK_REGS definition
    - LP: #561802, #578673
  * (pre-stable) drm/i915: make sure eDP panel is turned on
    - LP: #578673
  * (pre-stable) drm/i915: make sure we shut off the panel in eDP configs
    - LP: #578673

These package changes correspond to our hardware, an Intel graphics chipset.

00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02)
 Subsystem: Dell Device 0410
 Flags: bus master, fast devsel, latency 0, IRQ 35
 Memory at f0000000 (64-bit, non-prefetchable) [size=4M]
 Memory at e0000000 (64-bit, prefetchable) [size=256M]
 I/O ports at 60b0 [size=8]
 Capabilities: [90] Message Signalled Interrupts: Mask- 64bit- Queue=0/0 Enable+
 Capabilities: [d0] Power Management version 2
 Capabilities: [a4] PCIe advanced features <?>
 Kernel driver in use: i915
 Kernel modules: i915

I'll try to test with the latest mainline kernel as soon as I get time.

Booting on 2.6.32-23 (still installed) instead makes the problem go away.

Cheers,

Michael.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: linux-image-2.6.32-24-generic 2.6.32-24.42
Regression: Yes
Reproducible: Yes
ProcVersionSignature: Ubuntu 2.6.32-24.42-generic 2.6.32.15+drm33.5
Uname: Linux 2.6.32-24-generic i686
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 2/2
   Subdevice #0: subdevice #0
   Subdevice #1: subdevice #1
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: maria 1645 F.... xfce4-mixer-plu
                      maria 1653 F.... pulseaudio
                      maria 1691 F.... xfce4-volumed
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf5460000 irq 22'
   Mixer name : 'Intel G45 DEVIBX'
   Components : 'HDA:111d7605,10280410,00100104 HDA:80862804,80860101,00100000'
   Controls : 22
   Simple ctrls : 13
Date: Fri Sep 17 06:25:56 2010
EcryptfsInUse: Yes
HibernationDevice: RESUME=UUID=4a94078b-e73f-4688-a8ab-849aef1171c9
InstallationMedia: Xubuntu 10.04 "Lucid Lynx" - Release i386 (20100429)
MachineType: Dell Inc. Latitude E4310
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-24-generic root=UUID=0174c8f4-9dd1-4825-be0d-497de72aba62 ro quiet splash
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
RelatedPackageVersions: linux-firmware 1.34.1
SourcePackage: linux
dmi.bios.date: 05/28/2010
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A02
dmi.board.name: 0T6M8G
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.type: 9
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA02:bd05/28/2010:svnDellInc.:pnLatitudeE4310:pvr0001:rvnDellInc.:rn0T6M8G:rvrA00:cvnDellInc.:ct9:cvr:
dmi.product.name: Latitude E4310
dmi.product.version: 0001
dmi.sys.vendor: Dell Inc.

feffemannen (fredrik-ellborg) wrote :

I would like to add that this also happens on a fully updated maverick system with linux-image-2.6.35-22-generic. I've got a HP Elitebook 2540p and I've tried all different kind of kernels (also from the mainline) with only one success (i.e., without the flashing issue) so far: linux-image-2.6.35-020635rc6-generic.

Please tell me how I could help resolve this bug.

David B (d-bannon) wrote :

Now, this just could be the same or related to bug #585651. It was marked as resolved a couple of weeks ago but I dropped a note there suggesting, "maybe not". Steve Conklin kindly pointed out that was not enough to reopen, better to create a new bug report. Looking around I found this one.

In summary, all newish kernels have this problem with a laptop that uses the eDP display. Not a problem with external screen.

I am using a beta Maverick and Ubuntu's mainline (2.6.26) kernel dated 201009281108.

To save people the effort, while the flickering or flashing is not present in an earlier kernel (such as what you will find in U9.04) the hardware is so unfamiliar to that old kernel other things like external displays don't work. I mostly go from my desk at work to my desk at home and use an external display at both so the occasional flickering (when using laptop screen) is acceptable.

Other observations that might be interesting -

1. xrandr has problems understanding the internal screen but it does get setting right.
Screen 0: minimum 320 x 200, current 1280 x 960, maximum 8192 x 8192
(null)1 connected 1280x800+0+0 (normal left inverted right x axis y axis) 260mm x 160mm
   1280x800 60.0*+ 40.3
Note the (null)1 name.

2. xrandr has problems setting preferred mode on my HP Compaq LA2405wg screen, notes that 1920x1200 is preferred mode but still selects 1280x960. Switches over when asked to do so. On the other hand, works fine on my Acer screen at home.

3. xrandr, with any screen, blanks the screen momentarily as usual but surprisingly does so again about six seconds later. I have not seen that before...

I have been watching progress of this bug on http://bugs.freedesktop.org/show_bug.cgi?id=29821

A good history at https://bugs.launchpad.net/opensuse/+source/linux/+bug/585651

David

David B (d-bannon) wrote :

OK, flickering problem seems to be fixed in rc6 kernel. I am using the mainline 2.6.36 dated 201010021408 from Ubuntu and it no longer flickers !

(still fails to give the internal screen a name, calls it (null)1 and still fails to set, automaticly, the correct screen resolution for my external HP LA2405wg screen but thats easy to deal with !)

Thanks folks !

David

David B (d-bannon) wrote :

No, sorry, the flashing problem has "come back again". Pretty strange, I must have used it for at least two hours the other day with no sign of the problem. Then, today, at a meeting, its flashing or flickering away for all its worth again. Don't think there were even any non kernel updates provided in that time span. About the only difference I can think of is I was connected to a different wireless network, cannot imagine that could be a factor ! Will play ...

David

Same conclusion here with kernel 2.6.36-020636rc6-generic.

2010/10/6 David B <email address hidden>

> No, sorry, the flashing problem has "come back again". Pretty strange, I
> must have used it for at least two hours the other day with no sign of
> the problem. Then, today, at a meeting, its flashing or flickering away
> for all its worth again. Don't think there were even any non kernel
> updates provided in that time span. About the only difference I can
> think of is I was connected to a different wireless network, cannot
> imagine that could be a factor ! Will play ...
>
> David
>
> --
> Screen flickers after 2.6.32-24.42 update (drm/i915 changes)
> https://bugs.launchpad.net/bugs/641027
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Jg-freedesktop (jg-freedesktop) wrote :

Note that there is upstream EDP work going on that may be resolving this issue as of the instant of this writing; it fixed the several times a second flicker I was experiencing on my HP 2540p.

see: https://bugs.freedesktop.org/show_bug.cgi?id=29821

Please come help test, if you are up to building kernels from upstream's git...

According to my tests the bug is fixed in the intel-drm-next mainline 2.6.36-997-generic #201010040905.

Ray Frush (ray-frush) wrote :

My tests of linux-image-2.6.36-997-generic_2.6.36-997.201011120905_i386 on a Dell E4310 suggest new problems have been introduced. This kernel causes the display (all virtual terminal) to display blank. From what I can tell, keyboard input works fine, but there's no display, but the backlight does come on.

So, in a way, it does fix the flickering problem, but in a way that is unhelpful ;-)

David B (d-bannon) wrote :

Ray, I found that all releases of the Ubuntu mainline kernel after linux-image-2.6.36-999-generic_2.6.36-999.201010211341_amd64.deb broke quite a lot of things and I stopped looking after that. I think that after 20101021 we may have been looking at 2.6.37 prototype ...

But I have found, and feel guilty for not telling anyone, that suspending (and resuming) always stops the flickering. Hmm....

David

Brad Figg (brad-figg) on 2010-12-04
tags: added: acpi
tags: added: acpi-bad-address
tags: added: acpi-parse-exec-fail
tags: added: embedded-controller
Emil Gitman (ediulia) wrote :

I even tried to run fedora 14 live cd on my 2540p. the same issue with screen flicking....

Emil Gitman (ediulia) wrote :

thanks to david B.
really... i tried the fedora 14 live cd without any update. and suspend then resume really stops flicking
this is important information and may help to developers to solve this problem
going try on my favorite UBUNTU 10.10....
fedora bye bye..

Emil Gitman (ediulia) wrote :

small update about workaround.
after resume from screensaver the flicking come back and you must suspend and resume again.

Emil Gitman (ediulia) wrote :

one more update.
suspend and resume doesn't solve flicking in dual monitor mode
original laptop monitor flicking while there is no problem with second monitor.
i using Samsung SyncMaster 943b

Emil Gitman (ediulia) wrote :

good news. 2-6-38-7 kernel of natty fixed this bug..

Changed in linux (Fedora):
status: New → Fix Committed
Changed in linux (Ubuntu):
status: New → Fix Committed

Michael Opdenacker, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

Also, could you please test the latest upstream kernel available (not the daily folder) following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-v3.13-rc5

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

tags: added: bios-outdated-a11
no longer affects: linux (Ubuntu)
affects: linux (Fedora) → linux (Ubuntu)
Changed in linux (Ubuntu):
status: Fix Committed → Incomplete
importance: Undecided → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.