X failed on Intel B43 machine

Bug #640214 reported by Ike Panhc on 2010-09-16
24
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Ike Panhc
Nominated for Lucid by Robert Hooker
Karmic
Undecided
Ike Panhc
Maverick
Medium
Ike Panhc
mesa (Ubuntu)
Medium
Robert Hooker
Nominated for Lucid by Robert Hooker
Karmic
Medium
Robert Hooker
Maverick
Medium
Timo Aaltonen
xserver-xorg-video-intel (Ubuntu)
Medium
Robert Hooker
Nominated for Lucid by Robert Hooker
Karmic
Medium
Robert Hooker
Maverick
Medium
Robert Hooker

Bug Description

I have a machine with Intel B43 chipset but can not using X, looks like intel-agp and i915 module is not loaded.

--- SRU JUSTIFICATION NOTES ---

IMPACT: A new revision of the B43 chipset has been released and the corresponding drivers were not updated to recognize them until recently due to the rarity, but machines are now in the wild that contain them. Without this change the drivers will not recognize these devices at all and fail to load.

RESOLUTION: Adding the pci id's to the corresponding drivers, letting them know they are B43 chipset devices that it already knows how to work with.

TEST CASE:
1) Boot any ubuntu release on a device containing this chipset, which can be verified with lspci -v and seeing if 8086:2E90 or 8086:2E92 is listed.
2) Verify that i915/intel-agp are not listed in lsmod, and xserver-xorg-video-intel is the driver in use in /var/log/Xorg.0.log
3) Update packages
4) Reboot and verify i915 and intel-agp are listed in lsmod, and intel is the driver in use in /var/log/Xorg.0.log

REGRESSION POTENTIAL: Extremely low, no new code paths are added for these specific devices. The changes only add the new device to the corresponding drivers and they are functionally no different than the previous B43 devices supported already. No new code paths are added or changed to make these work.

SRU PATCH PROPOSALS:
xserver-xorg-video-intel (karmic):
https://bugs.edge.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/640214/+attachment/1595848/+files/xserver-xorg-video-intel_2.9.0-1ubuntu2.2.debdiff

mesa (karmic):
https://bugs.edge.launchpad.net/ubuntu/+source/mesa/+bug/640214/+attachment/1703217/+files/mesa_7.6.0-1ubuntu4.1.debdiff

Ike Panhc (ikepanhc) wrote :

"lspci -n" gives me 8086:2E90 and 8086:2E92 ids, and in kernel its 2E40 and 2E42.

I tried to modify the device id from 2E4x to 2E9x in kernel and xserver-xorg-video-intel, looks like everything works fine.

Changed in linux (Ubuntu):
assignee: nobody → Ike Panhc (ikepanhc)
status: New → In Progress
importance: Undecided → Medium

This is the patch for Xorg videio driver

tags: added: patch
Robert Hooker (sarvatt) wrote :

Cleaned up xserver-xorg-video-intel patch to more closely match what actually went upstream in this commit

http://cgit.freedesktop.org/xorg/driver/xf86-video-intel/commit/?id=55b5fe888002258dd863d41977bfbfcf1a922179

description: updated
Robert Hooker (sarvatt) wrote :

Debdiff against xserver-xorg-video-intel xserver-xorg-video-intel_2.9.0-1ubuntu2.1 containing the fix. Also available in this PPA if you could please test it out and post your /var/log/Xorg.0.log (note that it requires the kernel patches as well first)

https://edge.launchpad.net/~sarvatt/+archive/sru1

Robert Hooker (sarvatt) wrote :

Sorry, the patch/packages in the previous 2 posts were malformed. Attaching the correct ones now.

Robert Hooker (sarvatt) wrote :

Fixed debdiff for xserver-xorg-video-intel 2.9.0-1ubuntu2.2. Package has been uploaded to this PPA instead as well

https://edge.launchpad.net/~sarvatt/+archive/sru2

description: updated
Robert Hooker (sarvatt) on 2010-09-16
Changed in xserver-xorg-video-intel (Ubuntu):
assignee: nobody → Robert Hooker (sarvatt)
importance: Undecided → Medium
status: New → In Progress
description: updated
Ike Panhc (ikepanhc) wrote :

drivers/char/agp/intel-gtt.c also need to be updated. I have tested on maverick kernel and posted the patch on LKML.

http://lkml.org/lkml/2010/9/16/520
http://lkml.org/lkml/2010/9/16/521
http://lkml.org/lkml/2010/9/16/522

Tested xserver-xorg-video-intel 2.9.0-1ubuntu2.2 in PPA with linux-image-2.6.31-22-generic-pae (included patch), and it works.

Robert Hooker (sarvatt) wrote :

Thank you for testing! Before the xserver-xorg-video-intel side goes in, can you please try booting the stock kernel without the B43 patches here with that xserver-xorg-video-intel 2.9.0-1ubuntu2.2 to be sure it does not regress the working vesa it has now?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-video-intel - 2:2.12.0-1ubuntu5

---------------
xserver-xorg-video-intel (2:2.12.0-1ubuntu5) maverick; urgency=low

  [ Robert Hooker ]
  * Disable DRI on Sandybridge chipsets. Support for them will not be released
    until the Q42010 Intel releases, which will not be pulled into maverick.
    Without this change, all 3D apps on these devices cause hangs.
    (LP: #639667)
  * Add 102_b43_pciid_update.patch. Fixes detection of a new b43
    chipset revision that is being shipped. Without this the drivers
    will not attempt to load even though this chipset is the same as
    the previous b43 ones. Backport of upstream commit 55b5fe8880.
    (LP: #640214)

  [ Christopher James Halse Rogers ]
  * debian/patches/101_copy-fb.patch: Move scratch pixmap creation to the
    drmmode_copy_fb function, and clean up after we've used it. Fixes the
    SIGSEGV in FreeClientResources when logging out of KDE (LP: #628077)
  * debian/patches/106_backport_vblank_on_server_regenerate_fix.patch:
    Backport fix for SwapBuffers hang after server regenerate. LP 628077
    was hiding this by crashing the server. Fixes kwin desktop effects hanging
    on second and subsequent logins.
  * Cherry-pick e30f0338 to free the Screen pixmap on close. Fixes a memory
    leak on server regeneration, and another crash on KDE log out hidden by
    LP 628077.
 -- Christopher James Halse Rogers <email address hidden> Mon, 27 Sep 2010 14:34:27 +1000

Changed in xserver-xorg-video-intel (Ubuntu Maverick):
status: In Progress → Fix Released
Robert Hooker (sarvatt) wrote :

The kernel side of this change is now in 2.6.35.6 which will be brought into maverick.

Robert Hooker (sarvatt) on 2010-10-12
Changed in xserver-xorg-video-intel (Ubuntu):
status: Fix Released → Fix Committed
Ike Panhc (ikepanhc) wrote :
Changed in linux (Ubuntu Maverick):
status: In Progress → Fix Committed
Changed in linux (Ubuntu):
status: In Progress → Fix Committed
Bryce Harrington (bryce) wrote :

Upload of xserver-xorg-video-intel patch sponsored for karmic.

Changed in xserver-xorg-video-intel (Ubuntu Karmic):
status: New → Fix Committed
Ike Panhc (ikepanhc) on 2010-10-15
Changed in linux (Ubuntu Karmic):
status: New → Fix Committed
assignee: nobody → Ike Panhc (ikepanhc)
Robert Hooker (sarvatt) on 2010-10-20
Changed in xserver-xorg-video-intel (Ubuntu Karmic):
assignee: nobody → Robert Hooker (sarvatt)
importance: Undecided → Medium
Robert Hooker (sarvatt) wrote :

debdiff against mesa_7.6.0-1ubuntu4 targetting karmic-proposed containing the required mesa side of this fix for 3D support. It is currently building in this PPA:

https://edge.launchpad.net/~sarvatt/+archive/sru2

description: updated
Changed in mesa (Ubuntu):
assignee: nobody → Robert Hooker (sarvatt)
importance: Undecided → Medium
status: New → Fix Committed
Changed in mesa (Ubuntu Karmic):
assignee: nobody → Robert Hooker (sarvatt)
importance: Undecided → Medium
status: New → Fix Committed

Accepted xserver-xorg-video-intel into karmic-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Martin Pitt (pitti) wrote :

Accepted linux into karmic-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Martin Pitt (pitti) wrote :

Accepted linux into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Any tester for this package in Karmic ?

After enable propsed in Karmic, the X works well

mesa driver does not have new pci id for B43, so the 3D still does not work after proposed enable

Thanks for testing, that's much appreciated. I'm marking as verification-done since it's an improvement in the X server.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-video-intel - 2:2.9.0-1ubuntu2.2

---------------
xserver-xorg-video-intel (2:2.9.0-1ubuntu2.2) karmic-proposed; urgency=low

  * Add 102_b43_pciid_update.patch. Fixes detection of a new b43
    chipset revision that is being shipped. Without this the drivers
    will not attempt to load even though this chipset is the same as
    the previous b43 ones. Backport of upstream commit 55b5fe8880.
    (LP: #640214)
 -- Robert Hooker <email address hidden> Thu, 16 Sep 2010 18:52:24 -0400

Changed in xserver-xorg-video-intel (Ubuntu Karmic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.31-22.68

---------------
linux (2.6.31-22.68) karmic-proposed; urgency=low

  [ Andy Whitcroft ]

  * SAUCE: docs -- fix doc strings for fc_event_seq

  [ Brad Figg ]

  * SAUCE: (no-up) Modularize vesafb -- fix initialization
    - LP: #611471

  [ Chase Douglas ]

  * SAUCE: sched: update load count only once per cpu in 10 tick update
    window
    - LP: #513848

  [ Ike Panhc ]

  * SAUCE: agp/intel: Add second set of PCI-IDs for B43
    - LP: #640214
  * SAUCE: drm/i915: Add second set of PCI-IDs for B43
    - LP: #640214

  [ Steve Conklin ]

  * SAUCE: Fix compile error on ia64, powerpc, and sparc

  [ Upstream Kernel Changes ]

  * (pre-stable) x86-32, resume: do a global tlb flush in S4 resume
    - LP: #531309
  * PCI: Ensure we re-enable devices on resume
    - LP: #566149
 -- Steve Conklin <email address hidden> Fri, 22 Oct 2010 09:05:13 -0500

Changed in linux (Ubuntu Karmic):
status: Fix Committed → Fix Released
Jonathan Riddell (jr) wrote :

Accepted mesa into karmic-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: removed: verification-done
tags: added: verification-needed
Chris Van Hoof (vanhoof) wrote :

@hychen can you verify this mesa update for karmic on b43 hardware?

Regards,
Chris

Ike Panhc (ikepanhc) wrote :

Verification done on Karmic but partial on Lucid

Tested and have the result on Intel B43 machine with following procedure:

1. Install Ubuntu with Karmic CD
2. use gnome-display-properties and find out X can not have monitor EDID information
    The best resolution for the monitor is 1440x900, but system choose to use 1280x1024
3. Enable -propose archive, select for main server and upgrade the system, reboot.
4. Use 'uname -a' to have the running kernel version: 2.6.31-22 #68
5. use gnome-display-properties and find out X have monitor EDID information
    and using the correct resolution for the monitor: 1440x900

1. Install Ubuntu with Lucid LTS 10.04.1 CD
2. use gnome-display-properties and find out X can not have monitor EDID information
    The best resolution for the monitor is 1440x900, but system choose to use 1280x1024
3. Enable -propose archive, select for main server and upgrade the system, reboot.
4. Use 'uname -a' to have the running kernel version: 2.6.32-26 #46
5. use gnome-display-properties and find out X do *not* have monitor EDID information
    and using the correct resolution for the monitor: 1440x900

Ike Panhc (ikepanhc) wrote :
Ike Panhc (ikepanhc) wrote :
Ike Panhc (ikepanhc) wrote :

for verification on lucid.

KMS works and kernel change the resolution to the correct one. But seems xorg-xserver-video-intel can not recognized the graphic chip so that X uses fbdevhw driver.

Steve Conklin (sconklin) wrote :

I chatted with Ike - This is a pass for both Karmic and Lucid. Lucid requires an additional change for full functionality, but this change causes no ill effects and is necessary.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mesa - 7.6.0-1ubuntu4.1

---------------
mesa (7.6.0-1ubuntu4.1) karmic-proposed; urgency=low

  * Add 111_b43_id_update.patch: Fixes detection of a new b43
    chipset revision that is being shipped. Without this the drivers
    will not attempt to load even though this chipset is the same as
    the previous b43 ones. (LP: #640214)
 -- Robert Hooker <email address hidden> Wed, 20 Oct 2010 09:38:12 -0400

Changed in mesa (Ubuntu Karmic):
status: Fix Committed → Fix Released
Bryce Harrington (bryce) on 2010-11-22
tags: added: lucid
Launchpad Janitor (janitor) wrote :
Download full text (18.8 KiB)

This bug was fixed in the package linux - 2.6.32-26.47

---------------
linux (2.6.32-26.47) lucid-proposed; urgency=low

  [ Steve Conklin ]

  * Revert "SAUCE: ALSA: HDA: Enable internal mic on Dell E6410 and Dell
    E6510"
  * Revert "[Config] Added be2net, be2scsi to udebs"

  [ Upstream Kernel Changes ]

  * Revert "(ore-stable) ALSA: hda - Apply ALC269 VAIO fix-up to all Sony
    laptops with ALC269"
  * Revert "(pre-stable) ALSA: HDA: Correctly apply position_fix quirks for
    ATI and VIA controllers"
  * Revert "ALSA: hda: Use LPIB for another mainboard"
  * Revert "ALSA: hda: Use LPIB for ASUS M2V"
  * Revert "ALSA: hda: Use LPIB for an ASUS device"
  * Buglink Fixup for reverted unverified fixes

linux (2.6.32-26.46) lucid-proposed; urgency=low

  [ Brad Figg ]

  * SAUCE: ALSA: HDA: Enable internal mic on Dell E6410 and Dell E6510
    - See: #605047, #628961

  [ Tim Gardner ]

  * [Config] Added be2net, be2scsi to udebs
    - See: #628776

  [ Upstream Kernel Changes ]

  * Revert "(pre-stable) drm/i915: add PANEL_UNLOCK_REGS definition"
    - LP: #645444
  * Revert "(pre-stable) drm/i915: make sure we shut off the panel in eDP
    configs"
    - LP: #645444
  * Revert "(pre-stable) drm/i915: make sure eDP panel is turned on"
    - LP: #645444
  * Revert "(pre-stable) drm/radeon/kms: initialize set_surface_reg reg for
    rs600 asic"
    - LP: #645371
  * Revert "drm/nouveau: Fix fbcon corruption with font width not divisible
    by 8"
    - LP: #663176
  * mmc: fix all hangs related to mmc/sd card insert/removal during
    suspend/resume
    - LP: #477106
  * mmc: build fix: mmc_pm_notify is only available with CONFIG_PM=y
    - LP: #477106
  * hwmon: (k8temp) Differentiate between AM2 and ASB1
    - LP: #644694
  * xen: handle events as edge-triggered
    - LP: #644694
  * xen: use percpu interrupts for IPIs and VIRQs
    - LP: #644694
  * ALSA: hda - Rename iMic to Int Mic on Lenovo NB0763
    - LP: #605101, #644694
  * sata_mv: fix broken DSM/TRIM support (v2)
    - LP: #644694
  * x86, tsc, sched: Recompute cyc2ns_offset's during resume from sleep
    states
    - LP: #644694
  * PCI: MSI: Remove unsafe and unnecessary hardware access
    - LP: #644694
  * PCI: MSI: Restore read_msi_msg_desc(); add get_cached_msi_msg_desc()
    - LP: #644694
  * sched: kill migration thread in CPU_POST_DEAD instead of CPU_DEAD
    - LP: #644694
  * sched: revert stable c6fc81a sched: Fix a race between ttwu() and
    migrate_task()
    - LP: #644694
  * staging: hv: Fix missing functions for net_device_ops
    - LP: #644694
  * staging: hv: Fixed bounce kmap problem by using correct index
    - LP: #644694
  * staging: hv: Fixed the value of the 64bit-hole inside ring buffer
    - LP: #644694
  * staging: hv: Increased storvsc ringbuffer and max_io_requests
    - LP: #644694
  * staging: hv: Fixed lockup problem with bounce_buffer scatter list
    - LP: #644694
  * fuse: flush background queue on connection close
    - LP: #644694
  * ath9k_hw: fix parsing of HT40 5 GHz CTLs
    - LP: #644694
  * ocfs2: Fix incorrect checksum validation error
    - LP: #644694
  * USB: ehci-ppc-of: problems in unwind
    - LP: #644694
  * USB: Fix kernel oo...

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Robert Hooker (sarvatt) on 2010-12-16
Changed in xserver-xorg-video-intel (Ubuntu):
status: Fix Committed → Fix Released
Changed in mesa (Ubuntu):
status: Fix Committed → Fix Released
Chris Van Hoof (vanhoof) on 2011-02-18
tags: added: hwe-blocker
Julian Wiedmann (jwiedmann) wrote :

The kernel patch mentioned in comment #16 was released for Maverick a long time ago - mesa still seems to need the new ID though.

Changed in linux (Ubuntu Maverick):
status: Fix Committed → Fix Released
Chris Van Hoof (vanhoof) on 2011-03-16
Changed in mesa (Ubuntu Maverick):
assignee: nobody → Robert Hooker (sarvatt)
importance: Undecided → Medium
assignee: Robert Hooker (sarvatt) → Timo Aaltonen (tjaalton)
Chris Van Hoof (vanhoof) wrote :

Closing the remaining maverick mesa task out. We can revisit this should an update for maverick be required.

Changed in mesa (Ubuntu Maverick):
status: New → Won't Fix
tags: added: testcase
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.