Kernel Oops - BUG: unable to handle kernel NULL pointer dereference at (null); RIP: 0010:[<0000000000000000>] [<(null)>] (null)

Bug #640154 reported by Derek on 2010-09-16
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

Oops occurs on every boot. Boot continues normally after this, although sound does not function, despite the device seeming to have been detected normally.

ProblemType: KernelOops
DistroRelease: Ubuntu 10.10
Package: linux-image-2.6.35-21-generic 2.6.35-21.31
Regression: No
Reproducible: Yes
ProcVersionSignature: Ubuntu 2.6.35-21.31-generic 2.6.35.4
Uname: Linux 2.6.35-21-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
Annotation: Your system might become unstable now and might need to be restarted.
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC269 Analog [ALC269 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: nemo 1525 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xdd400000 irq 47'
   Mixer name : 'Intel IbexPeak HDMI'
   Components : 'HDA:10ec0269,104d4300,00100004 HDA:80862804,104d4300,00100000'
   Controls : 20
   Simple ctrls : 9
Date: Wed Sep 15 23:03:02 2010
Failure: oops
HibernationDevice: RESUME=UUID=367676ab-abb4-4acd-842e-768d168666ad
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Beta amd64 (20100901.1)
MachineType: Sony Corporation VPCB11KGX
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.35-21-generic root=UUID=954d6713-921d-45aa-91f5-a0d5192e2eef ro quiet splash
RelatedPackageVersions: linux-firmware 1.38
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
SourcePackage: linux
Title: BUG: unable to handle kernel NULL pointer dereference at (null)
dmi.bios.date: 01/07/2009
dmi.bios.vendor: INSYDE
dmi.bios.version: R0250Q4
dmi.board.asset.tag: N/A
dmi.board.name: VAIO
dmi.board.vendor: Sony Corporation
dmi.board.version: N/A
dmi.chassis.asset.tag: N/A
dmi.chassis.type: 10
dmi.chassis.vendor: Sony Corporation
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnINSYDE:bvrR0250Q4:bd01/07/2009:svnSonyCorporation:pnVPCB11KGX:pvrR5911351:rvnSonyCorporation:rnVAIO:rvrN/A:cvnSonyCorporation:ct10:cvrN/A:
dmi.product.name: VPCB11KGX
dmi.product.version: R5911351
dmi.sys.vendor: Sony Corporation

Derek (bugs-m8y) wrote :
tags: added: kj-triage
Derek (bugs-m8y) wrote :

https://bugzilla.kernel.org/show_bug.cgi?id=18742

Miiiiight be related. It is in the same function at any rate, and also AMD64.

The output is a little different, he's in do_disable_cpu_turbo which isn't hit in mine, but then he's on 2.6.36 too...

Presumably given different version and build, the offset differences don't mean much either.

Derek (bugs-m8y) wrote :

No shock, but blacklisting intel_ips avoids the oops.
No sound still, so that's presumably unrelated.

I'm skeptical the IPS was doing anything useful due to:
[ 6.873860] intel ips 0000:00:1f.6: Warning: CPU TDP doesn't match expected value (found 25, expected 35)
and
[ 6.874061] intel ips 0000:00:1f.6: failed to get i915 symbols, graphics turbo disabled

Derek (bugs-m8y) wrote :

The sound issue was completely unrelated and fixed by the very helpful comment by Pistolpete in:
https://launchpad.net/bugs/546769

He also included a patch, although clearly the issue still exists.

I am also affected from the Oops, blacklisting intel_ips avoids it for me, too.

Derek (bugs-m8y) wrote :

I filed this at the request of ubuntu folks due to having sliiightly different hardware than bug #632430
However comment #6 in that bug which appears to be doing a little investigation suggests that this bug is, in fact, a dupe.

Just letting y'all know.

Derek (bugs-m8y) wrote :

Fixed by bug #632430, comment #7

I've removed the blacklist.

Although I doubt it is doing anything useful anyway. Probably just using up a (small) amount of memory and cpu.

Brad Figg (brad-figg) on 2011-05-04
Changed in linux (Ubuntu):
status: New → Confirmed

Derek, thank you for reporting this and helping make Ubuntu better. Maverick reached EOL on April 2012.
Please see this document for currently supported Ubuntu releases:
https://wiki.ubuntu.com/Releases

We were wondering if this is still an issue in a supported release? If so, can you try with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you run the following command in a supported release from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux <replace-with-bug-number>

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

description: updated
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
summary: - BUG: unable to handle kernel NULL pointer dereference in ips_adjust in
- intel_ips on Sony VPC-B11KGX
+ Kernel Oops - BUG: unable to handle kernel NULL pointer dereference at
+ (null); RIP: 0010:[<0000000000000000>] [<(null)>] (null)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.