10.10 -> many times logs out instead of shutting down

Bug #637942 reported by Xavier Lucas on 2010-09-14
This bug affects 5 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)

Bug Description

UBUNTU 10.10:
When I click on the main menu to shut down my laptop, it logs me out instead and shows me the logging in window. I have to select shut down on this window to actually shut down the computer. I'm sorry, I dunno how to tell you which packages are affected, but I'll do whatever you need if you don't observe the same problem, in order to reproduce it.


PS: I didn't notice that I posted it 2 times, my apologies :-(
Architecture: i386
DistroRelease: Ubuntu 10.10
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
Package: gnome-panel 1:2.30.2-1ubuntu3
PackageArchitecture: i386
 PATH=(custom, user)
ProcVersionSignature: Ubuntu 2.6.35-22.34-generic
Tags: maverick
Uname: Linux 2.6.35-22-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Xavier Lucas (xlc1986) on 2010-09-14
description: updated
description: updated
Book 'em Dano (heymrdjd) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please execute the following command, as it will automatically gather debugging information, in a terminal:

apport-collect 637942

This will help us to find and resolve the problem. Bear in mind that you may need to install the python-launchpadlib package from the universe repository. Additionally, when prompted to give apport-collect permissions for Launchpad you will need to give it at least the ability to "Change Non-Private" data as it will be adding information to your bug report. Thanks in advance!

When reporting bugs in the future please use apport, either via the appropriate application's "Help -> Report a Problem" menu or using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at https://wiki.ubuntu.com/ReportingBugs.

affects: ubuntu → gnome-panel (Ubuntu)
Changed in gnome-panel (Ubuntu):
status: New → Incomplete

apport information

tags: added: apport-collected
description: updated
Book 'em Dano (heymrdjd) on 2010-10-14
tags: added: i386 maverick
Changed in gnome-panel (Ubuntu):
importance: Undecided → Medium
status: Incomplete → Triaged
Jamie Royer (jamie-royer) wrote :

What does it mean "Triaged"? Does that mean I can modify my system to get it to shutdown properly?

I click shutdown and it logs out. From the login screen I click shutdown and it restarts. I have to turn it off manually when I see it starting to reboot.

I upgraded from 10.04 to 10.10. I'm running on a Dell Studio XPS 16. I think this bug affects me too.


Jamie Royer (jamie-royer) wrote :

I found a work-around. Create a new user and carefully move files from one account to the other.

I only moved the directories that I was fairly certain weren't Gnome related.

Shutting down from the user account now works. I didn't test shutting down from the login page. Probably still not working.


Jamie Royer (jamie-royer) wrote :

It appears to have something to do with Skype and/or Empathy. Creating a new user worked until I installed Skype and setup Empathy. If I exit Skype and use the "Me" menu to set my status to "Offline", then shutdown works.

The login screen "Shutdown" still just reboots or hangs (twice now).


Book 'em Dano (heymrdjd) wrote :

Thanks for taking the time to report this bug and helping to make Ubuntu better. Could you please attach the resulting log file of: gnome-power-bugreport.sh & > gpm.log to the report? You might also want to take a look at the debugging instructions located at https://wiki.ubuntu.com/DebuggingGNOMEPowerManager and submit any other logs related to your problem. Thanks in advance.

affects: gnome-panel (Ubuntu) → pm-utils (Ubuntu)
Changed in pm-utils (Ubuntu):
status: Triaged → Incomplete
Eric (weisscoder) wrote :

Output of "/usr/share/gnome-power-manager/gnome-power-bugreport > ~/Desktop/gpm.log". Let me know if you need any further logs.

Eric (weisscoder) wrote :

It may also be relevant to note that I have only experienced this bug when using the "indicator applet session", not when using the physical power button on my computer. Have others found this to be the case?

Xavier Lucas (xlc1986) wrote :

Find attached the log requested.
Eric it could be possible, I'm not sure because I don't use the power button much often. In any case I think that the laptop also switches down correctly when I close the lap.

Jamie Royer (jamie-royer) wrote :

Attaching gpm.log - hope this helps.

Eric (weisscoder) wrote :

Changed status to "new" as requested logs have been attached.

Also, I wonder if this might actually be a bug in indicator session (https://launchpad.net/ubuntu/+source/indicator-session)? It looks like it may be related to, or the same as, https://bugs.launchpad.net/ubuntu/+source/indicator-session/+bug/704139, but some of the details of that bug report differ.

Changed in pm-utils (Ubuntu):
status: Incomplete → New
Xavier Lucas (xlc1986) wrote :

I have checked the bug in indicator-sessions, bug 704139.
I experience the "log out" window not only when selecting "Reboot..." but most often when trying to "Switch down" my laptop.

kz (z-kvn) wrote :

Hello I have met exact the same issue. After I click Restart or Shutdown from indicator, it will just log me off. I have attached gpm.log for your reference.

Changed in pm-utils (Ubuntu):
status: New → Confirmed

Xavier Lucas, thank you for reporting this bug to Ubuntu. Maverick reached EOL on April 10, 2012.
See this document for currently supported Ubuntu releases: https://wiki.ubuntu.com/Releases

Is this reproducible in the latest release of Ubuntu via http://cdimage.ubuntu.com/daily-live/current/ ?

If so, please execute the following via a terminal in order for the necessary debugging information to be attached:
apport-collect 637942

affects: pm-utils (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
importance: Medium → Low
status: Confirmed → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers