Add support for Intellimouse Mode in ALPS touchpad on Dell Latitude series Laptops

Bug #632884 reported by Jerone Young on 2010-09-08
34
This bug affects 3 people
Affects Status Importance Assigned to Milestone
OEM Priority Project
High
Chris Van Hoof
linux (Ubuntu)
High
Unassigned
Maverick
High
Unassigned
Natty
High
Unassigned

Bug Description

Currently many Dell Latitude systems have a ALPS touchpad and are missing scroll support. Dell will still be shipping this touchpad with upcoming Latitudes.

Though the issue now is upstream does not want to take the patch, as they want access to the mulitouch capabilities of the ALPS touchpad. ALPS has stated they will not give out specs for these capabilities and everyone should use the patch below, developed by Dell:

The final patch can be found here:
https://patchwork.kernel.org/patch/118834/

First submission can be found here..has more of a thread:
https://patchwork.kernel.org/patch/118447/

Jerone Young (jerone) on 2010-09-08
Changed in oem-priority:
status: New → Confirmed
importance: Undecided → High
Chris Van Hoof (vanhoof) on 2010-09-08
Changed in oem-priority:
assignee: nobody → Chris Van Hoof (vanhoof)
description: updated
Manoj Iyer (manjo) wrote :

can you pls test the kernel in http://kernel.ubuntu.com/~manjo/maveric/lp632884/ and report back here ?

Jerone Young (jerone) wrote :

@Manoj
           Tried the kernel you pointed to. It only supports the vertical scrolling. But not horizontal.

Chris Van Hoof (vanhoof) wrote :

@manoj -- Jerone is going to do some more testing w/ the kernel you built, as well as the original patch to see if horizontal scrolling was a feature that did work with the first patch.

Changed in oem-priority:
assignee: Chris Van Hoof (vanhoof) → Manoj Iyer (manjo)
status: Confirmed → Incomplete
Jerone Young (jerone) wrote :

Hey guys,
               Talked this over with Dell. Apparently vertical scrolling is all that is enabled by the patch. Which is fine. The ALPS actually does not have horizontal scrolling in this mode.

Changed in oem-priority:
status: Incomplete → Confirmed
Manoj Iyer (manjo) wrote :

Submitted sauce patch to ukml. Thanks for your help Jerone.

Chris Van Hoof (vanhoof) wrote :

Thanks for the update Jerone

Changed in linux (Ubuntu):
status: New → Fix Committed
Jerone Young (jerone) on 2010-09-13
Changed in oem-priority:
status: Confirmed → Fix Released

This should be resolved as of 2.6.35-21.30. Marking Fix Released for Maverick.

linux (2.6.35-21.30) maverick; urgency=low

  [ Andy Whitcroft ]

  * SAUCE: fbcon -- fix OOPs triggered by race prevention fixes
    - LP: #614008

  [ Daniel Lezcano ]

  * SAUCE: fix compilation warning when CONFIG_SECURITY is not set

  [ Henrik Rydberg ]

  * SAUCE: Input: wacom - add fuzz parameters to features
  * SAUCE: Input: wacom - collect device quirks into single function
  * SAUCE: Input: wacom - add support for the Bamboo Touch trackpad
  * SAUCE: Input: wacom - add a quirk for low resolution Bamboo devices
  * SAUCE: hid: ntrig: Remove unused device ids
  * SAUCE: hid: ntrig: remove sysfs nodes
  * SAUCE: hid: ntrig: Correct logic for quirks
  * SAUCE: hid: ntrig: zero-initialize ntrig struct
  * SAUCE: hid: ntrig: Setup input filtering manually
  * SAUCE: hid: ntrig: New ghost-filtering event logic

  [ Leann Ogasawara ]

  * SAUCE: ndiswrapper: Initialize buffer index and check its value
    - LP: #613796

  [ Manoj Iyer ]

  * SAUCE: Add support for Intellimouse Mode in ALPS touchpad on Dell E2
    series Laptops
    - LP: #632884

  [ Ping Cheng ]

  * SAUCE: Input: wacom - parse the Bamboo device family

  [ Rafi Rubin ]

  * SAUCE: hid: ntrig: identify firmware version (wiggled)

  [ Tim Gardner ]

  * [Config] CONFIG_NL80211_TESTMODE=n

  [ Upstream Kernel Changes ]

  * Revert "input: mt: Add support for the Bamboo Touch trackpad"
  * e1000e: initial support for 82579 LOMs
  * e1000e: correct MAC-PHY interconnect register offset for 82579
  * (pre-stable) ALSA: hda - Add a new hp-laptop model for Conexant 5066,
    tested on HP G60
    - LP: #587388
  * DSS2: Don't power off a panel twice
    - LP: #588243
  * mmc: build fix: mmc_pm_notify is only available with CONFIG_PM=y
  * Input: i8042 - reset keyboard controller wehen resuming from S2R
    - LP: #86820
  * ALSA: hda - Fix beep frequency on IDT 92HD73xx and 92HD71Bxx codecs
    - LP: #414795
  * agp/intel: Support the extended physical addressing bits on
    Sandybridge.
    - LP: #632488
  * drm/i915,intel_agp: Add support for Sandybridge D0
    - LP: #632488
  * (pre-stable) intel_agp,i915: Add more sandybridge graphics device ids
    - LP: #632488
  * mmc: omap: fix for bus width which improves SD card's peformance.
 -- Leann Ogasawara <email address hidden> Tue, 07 Sep 2010 09:58:52 -0700

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Chris Van Hoof (vanhoof) on 2010-09-15
Changed in linux (Ubuntu):
assignee: nobody → Manoj Iyer (manjo)
Changed in oem-priority:
assignee: Manoj Iyer (manjo) → Jerone Young (jerone)

The patch to resolve this bug has been reverted as it's causes regressions. See bug 641320. Please submit a revised patch for Maverick SRU. Thanks.

Changed in linux (Ubuntu):
status: Fix Released → Triaged
Jerone Young (jerone) on 2010-09-18
Changed in oem-priority:
status: Fix Released → Triaged
Jerone Young (jerone) wrote :

Working with Rez (the author) to redo patch. Dell is now aware it caused regression with other vendors.

Looking like this patch will now not make initial 10.10 release at this point.

Jerone Young (jerone) wrote :

Rez has refactored patch. But it does not have a lot of what is in bug 550625

rez (rezwanul-kabir) wrote :

I am preparing to resubmit this patch upstream. This patch resolves the suspend/resume issues seen on previous patch and restricts the
the quirks to Dell portables only. Testing feedback will be greatly appreciated. BTW, ALPS is also testing this patch at this time.
Thanks..
    --rez

Chris Van Hoof (vanhoof) wrote :

Thanks Rez -- Can you send me a pointer to the patch upstream once you submit it? We'll follow-up here with a SRU for Maverick afterwards.

--chris

Chris

Okay, I am waiting for feedback from ALPS on their testing results.
Thanks..
   --rez

Rezwanul Kabir
Dell Linux Development
512-725-0766

>-----Original Message-----
>From: <email address hidden> [mailto:<email address hidden>] On
>Behalf Of Chris Van Hoof
>Sent: Wednesday, September 22, 2010 3:11 PM
>To: Kabir, Rezwanul
>Subject: [Bug 632884] Re: Add support for Intellimouse Mode in
>ALPS touchpad on Dell Latitude series Laptops
>
>Thanks Rez -- Can you send me a pointer to the patch upstream
>once you submit it? We'll follow-up here with a SRU for
>Maverick afterwards.
>
>--chris
>
>--
> Add support for Intellimouse Mode in ALPS touchpad on Dell
>Latitude series Laptops
>https://bugs.launchpad.net/bugs/632884
>You received this bug notification because you are a direct
>subscriber of the bug.
>

rez (rezwanul-kabir) wrote :
rez (rezwanul-kabir) wrote :

Attached the patch ready for upstream with minor cleanups. However, ALPS hasn't yet completed their test efforts. So, I will post it upstream once I get back from vacation ( in about 2 weeks)

Chris Van Hoof (vanhoof) wrote :

Thanks Rez!

Changed in oem-priority:
assignee: Jerone Young (jerone) → Chris Van Hoof (vanhoof)
Chris Van Hoof (vanhoof) wrote :

Hi Rez -- Any feedback from Alps?

Mario Limonciello (superm1) wrote :

Chris, just FYI rez is on vac currently. I think he's set to return end of this week.

tags: added: patch
Chris Van Hoof (vanhoof) wrote :

Hi Rez -- Just checking back in on this one. Any news?

rez (rezwanul-kabir) wrote :

Hi Chris

  Sorry, ALPS has been very slow so far in completing the tests. They have so far tested
  both Mercury (earlier Dell platforms to ensure they don't break) and Pinnacle based
  systems (the later ones that we are testing now). They have confirmed functionality
  and suspend/resume success. However, they are still waiting to confirm that the
  patch doesn't break systems from other vendors.

  I have talked to them about this today and they committed to respond back to me ASAP.

   Thanks..
      --rez

Rezwanul Kabir
Dell Linux Development
512-725-0766

>-----Original Message-----
>From: <email address hidden> [mailto:<email address hidden>] On
>Behalf Of Chris Van Hoof
>Sent: Monday, November 08, 2010 2:42 PM
>To: Kabir, Rezwanul
>Subject: [Bug 632884] Re: Add support for Intellimouse Mode in
>ALPS touchpad on Dell Latitude series Laptops
>
>Hi Rez -- Just checking back in on this one. Any news?
>
>--
> Add support for Intellimouse Mode in ALPS touchpad on Dell
>Latitude series Laptops
>https://bugs.launchpad.net/bugs/632884
>You received this bug notification because you are a direct
>subscriber of the bug.
>

Chris Van Hoof (vanhoof) wrote :

Thanks Rez -- Please keep me posted!

Changed in linux (Ubuntu):
importance: Undecided → High
Chris Van Hoof (vanhoof) on 2010-11-29
tags: added: hwe-blocker
Chris Van Hoof (vanhoof) on 2010-12-16
Changed in linux (Ubuntu):
assignee: Manoj Iyer (manjo) → Kent Baxley (kentb)
Chris Van Hoof (vanhoof) wrote :

Hi Rez -- Is this the correct patch?

https://patchwork.kernel.org/patch/350841/

Changed in linux (Ubuntu):
assignee: Kent Baxley (kentb) → rez (rezwanul-kabir)
Andy Whitcroft (apw) wrote :

As patchworks seems to be unavailable currently I have pulled this copy from the google cache. This is the patch referred to in the previous comment.

Andy Whitcroft (apw) on 2010-12-30
Changed in linux (Ubuntu Maverick):
status: New → Triaged
importance: Undecided → High
Andy Whitcroft (apw) wrote :

Pulled the patch in comment #24 into Natty and built a test kernel. Could those of you affected by this issue confirm that the test kernels fix things for you. Also any testing results with similar but non-affected hardware appreciated. Kernels are at the URL below:

    http://people.canonical.com/~apw/lp632884-natty/

Thanks.

Andy Whitcroft (apw) wrote :

Screenshot showing Chromium doubled in the launcher.

Andy Whitcroft (apw) wrote :

/me notes that comment #26 is for another bug, please ignore.

Robert Hooker (sarvatt) wrote :

Andy's kernel linked in comment #25 is working great here, enables scroll support on my latitude E65x0

Andy Whitcroft (apw) wrote :

Ok pulling this into Natty for further wider testing.

Changed in linux (Ubuntu):
status: Triaged → Fix Committed
Andy Whitcroft (apw) wrote :

Once we have good feedback in Natty and feedback from rez on their testing, we can consider this for SRU to maverick.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.37-12.26

---------------
linux (2.6.37-12.26) natty; urgency=low

  [ Andy Whitcroft ]

  * rebase to v2.6.37-rc8
  * [Config] armel -- reenable omap flavour
  * [Config] disable CONFIG_MACH_OMAP3517EVM to fix FTBS on armel omap
  * [Config] disable CONFIG_GPIO_VX855 to fix FTBS on omap armel
  * [Config] disable CONFIG_WESTBRIDGE_ASTORIA to fix FTBS on omap armel
  * [Config] disable CONFIG_TI_DAVINCI_EMAC to fix FTBS on omap armel
  * rebase to mainline 989d873fc5b6a96695b97738dea8d9f02a60f8ab
  * [Config] track missing modules
  * rebase to v2.6.37 final

  [ Chase Douglas ]

  * SAUCE: (drop after 2.6.37) HID: magicmouse: Don't report REL_{X, Y} for
    Magic Trackpad

  [ Stefan Bader ]

  * Revert "SAUCE: blkfront: default to sd devices"
    - LP: #684875

  [ Tim Gardner ]

  * Revert "SAUCE: (no-up) libata: Ignore HPA by default."
    - LP: #380138
  * [Config] Added autofs4.ko to -virtual flavour
    - LP: #692917

  [ Upstream Kernel Changes ]

  * Add support for Intellimouse Mode in ALPS touchpad on Dell E2 series
    Laptops
    - LP: #632884

  [ Upstream Kernel Changes ]

  * rebase to v2.6.37-rc8
  * rebase to mainline 989d873fc5b6a96695b97738dea8d9f02a60f8ab
  * rebase to v2.6.37 final
 -- Andy Whitcroft <email address hidden> Thu, 23 Dec 2010 18:34:13 +0000

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Alex Moldovan (alexmoldovan) wrote :

Here is the dmesg from a Dell Latitude E4310 using the 2.6.37-12 kernel as stated in the bug report (#31). Mousing, clicking and scrolling do work on the touchpad. However, the Touchpad settings tab in "Mouse Preferences" are missing. This machine model has the "nipple" and the Touchpad.

Andy Whitcroft (apw) wrote :

From what I can see the machine is being recognised as expected and the quirk is kicking in, switching the touchpad from over to '4-byte "Intellimouse Mode"'. This is evidenced by the following in dmesg:

  [ 3.667423] alps.c: Enabled hardware quirk, falling back to psmouse-core

This is emmited by a later version of the patch attached above to this bug, the one recommended by ALPS for this hardware. This is expected to fix the scrolling issues, but in this mode it will not be seen as a touchpad (it is behaving as a clever mouse) and so userspace will not offer touchpad options for it.

Changed in linux (Ubuntu Natty):
assignee: rez (rezwanul-kabir) → nobody
Chris Van Hoof (vanhoof) wrote :

Closing the remaining bug tasks here, we can revisit this for Maverick if needed in the future

Changed in linux (Ubuntu Maverick):
status: Triaged → Won't Fix
Changed in oem-priority:
status: Triaged → Fix Released
Herton R. Krzesinski (herton) wrote :

This bug is being referenced in current sru-report for natty update, because one of the commits in the update is "pointing" to the old commit which originally fixed this bug. Just marking verification-done-natty to keep sru-report page happy.

tags: added: verification-done-natty
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers