Lucid update to 2.6.32.19 stable

Bug #622877 reported by Brad Figg on 2010-08-23
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Brad Figg
Lucid
Undecided
Unassigned

Bug Description

SRU Justification

Impact:
  The upstream process for stable tree updates is quite similar
  in scope to the Ubuntu SRU process, e.g., each patch has to
  demonstrably fix a bug, and each patch is vetted by upstream
  by originating either directly from Linus' tree or in a minimally
  backported form of that patch. The 2.6.32.19 upstream stable
  patch set is now available. It should be included in the Ubuntu
  kernel as well.

  http://kernel.org/pub/linux/kernel/v2.6/ChangeLog-2.6.32.19
  http://kernel.org/pub/linux/kernel/v2.6/patch-2.6.32.19.bz2

TEST CASE: TBD

  The following 115 patches are in the 2.6.32.19 stable release:

  * Linux 2.6.32.19
  * x86: don't send SIGBUS for kernel page faults
  * mm: fix missing page table unmap for stack guard page failure case
  * mm: keep a guard page below a grow-down stack segment
  * mm: fix corruption of hibernation caused by reusing swap during image saving
  * md/raid1: delay reads that could overtake behind-writes.
  * ibmvfc: Reduce error recovery timeout
  * ibmvfc: Fix command completion handling
  * aic79xx: check for non-NULL scb in ahd_handle_nonpkt_busfree
  * loop: Update mtime when writing using aops
  * Skip check for mandatory locks when unlocking
  * ocfs2: Set MS_POSIXACL on remount
  * ocfs2: Find proper end cpos for a leaf refcount block.
  * dlm: send reply before bast
  * dlm: fix ordering of bast and cast
  * dlm: always use GFP_NOFS
  * reiserfs: fix oops while creating privroot with selinux enabled
  * reiserfs: properly honor read-only devices
  * ext4: Fix optional-arg mount options
  * ext4: Make sure the MOVE_EXT ioctl can't overwrite append-only files
  * ACPI: Fix regression where _PPC is not read at boot even when ignore_ppc=0
  * powerpc/eeh: Fix a bug when pci structure is null
  * HWPOISON: abort on failed unmap
  * HWPOISON: remove the anonymous entry
  * x86: Fix out of order of gsi
  * memory hotplug: fix a bug on /dev/mem for 64-bit kernels
  * crypto: testmgr - Fix complain about lack test for internal used algorithm
  * fix SBA IOMMU to handle allocation failure properly
  * mutex: Don't spin when the owner CPU is offline or other weird cases
  * sched, cputime: Introduce thread_group_times()
  * sched: Fix granularity of task_u/stime()
  * timekeeping: Fix clock_gettime vsyscall time warp
  * nohz: Reuse ktime in sub-functions of tick_check_idle.
  * nohz: Introduce arch_needs_cpu
  * Btrfs: kfree correct pointer during mount option parsing
  * Btrfs: btrfs_mark_extent_written uses the wrong slot
  * Btrfs: apply updated fallocate i_size fix
  * Btrfs: do not try and lookup the file extent when finishing ordered io
  * Btrfs: Fix oopsen when dropping empty tree.
  * Btrfs: remove BUG_ON() due to mounting bad filesystem
  * Btrfs: make error return negative in btrfs_sync_file()
  * Btrfs: fix race between allocate and release extent buffer.
  * Btrfs: check total number of devices when removing missing
  * Btrfs: check return value of open_bdev_exclusive properly
  * Btrfs: do not mark the chunk as readonly if in degraded mode
  * Btrfs: run orphan cleanup on default fs root
  * Btrfs: fix a memory leak in btrfs_init_acl
  * Btrfs: Use correct values when updating inode i_size on fallocate
  * Btrfs: fix possible panic on unmount
  * Btrfs: deal with NULL acl sent to btrfs_set_acl
  * Btrfs: fix regression in orphan cleanup
  * Btrfs: Fix race in btrfs_mark_extent_written
  * Btrfs, fix memory leaks in error paths
  * Btrfs: align offsets for btrfs_ordered_update_i_size
  * btrfs: fix missing last-entry in readdir(3)
  * Btrfs: make sure fallocate properly starts a transaction
  * Btrfs: make metadata chunks smaller
  * Btrfs: Show discard option in /proc/mounts
  * Btrfs: deny sys_link across subvolumes.
  * Btrfs: fail mount on bad mount options
  * Btrfs: don't add extent 0 to the free space cache v2
  * Btrfs: Fix per root used space accounting
  * Btrfs: Fix btrfs_drop_extent_cache for skip pinned case
  * Btrfs: Add delayed iput
  * Btrfs: Pass transaction handle to security and ACL initialization functions
  * Btrfs: Make truncate(2) more ENOSPC friendly
  * Btrfs: Make fallocate(2) more ENOSPC friendly
  * Btrfs: Avoid orphan inodes cleanup during committing transaction
  * Btrfs: Avoid orphan inodes cleanup while replaying log
  * Btrfs: Fix disk_i_size update corner case
  * Btrfs: Rewrite btrfs_drop_extents
  * Btrfs: Add btrfs_duplicate_item
  * Btrfs: Avoid superfluous tree-log writeout
  * drm/i915: Use RSEN instead of HTPLG for tfp410 monitor detection.
  * ext4: fix freeze deadlock under IO
  * xen: Do not suspend IPI IRQs.
  * irq: Add new IRQ flag IRQF_NO_SUSPEND
  * net: Fix NETDEV_NOTIFY_PEERS to not conflict with NETDEV_BONDING_DESLAVE.
  * xen: netfront: explicitly generate arp_notify event after migration.
  * arp_notify: allow drivers to explicitly request a notification event.
  * jfs: don't allow os2 xattr namespace overlap with others
  * Bluetooth: Added support for controller shipped with iMac i5
  * drm/edid: Fix the HDTV hack sync adjustment
  * USB: fix thread-unsafe anchor utiliy routines
  * USB: usbtest: avoid to free coherent buffer in atomic context
  * USB: cp210x: Add four new device IDs
  * USB: ftdi_sio: device id for Navitator
  * USB: option: add huawei k3765 k4505 devices to work properly
  * USB: option: Huawei ETS 1220 support added
  * USB: serial: enabling support for Segway RMP in ftdi_sio
  * USB delay init quirk for logitech Harmony 700-series devices
  * USB: resizing usbmon binary interface buffer causes protection faults
  * ARM: 6280/1: imx: Fix build failure when including <mach/gpio.h> without <linux/spinlock.h>
  * ARM: 6299/1: errata: TLBIASIDIS and TLBIMVAIS operations can broadcast a faulty ASID
  * smsc911x: Add spinlocks around registers access
  * signalfd: fill in ssi_int for posix timers and message queues
  * bio, fs: update RWA_MASK, READA and SWRITE to match the corresponding BIO_RW_* bits
  * fs/ecryptfs/file.c: introduce missing free
  * ecryptfs: release reference to lower mount if interpose fails
  * eCryptfs: Handle ioctl calls with unlocked and compat functions
  * blkdev: cgroup whitelist permission fix
  * md/raid10: fix deadlock with unaligned read during resync
  * ide-cd: Do not access completed requests in the irq handler
  * drivers/video/w100fb.c: ignore void return value / fix build failure
  * splice: fix misuse of SPLICE_F_NONBLOCK
  * solos-pci: Fix race condition in tasklet RX handling
  * PCI: disable MSI on VIA K8M800
  * PCI: Do not run NVidia quirks related to MSI with MSI disabled
  * Staging: panel: Prevent double-calling of parport_release - fix oops.
  * Staging: line6: needs to select SND_PCM
  * x86, vmware: Preset lpj values when on VMware.
  * x86: Add memory modify constraints to xchg() and cmpxchg()
  * nvram: Fix write beyond end condition; prove to gcc copy is safe
  * powerpc: fix build with make 3.82
  * ata_piix: fix locking around SIDPR access

Brad Figg (brad-figg) on 2010-08-23
Changed in linux (Ubuntu):
assignee: nobody → Brad Figg (brad-figg)
status: New → In Progress
description: updated
Brad Figg (brad-figg) wrote :

The following upstream stable patches were skipped due to having been previously applied as a CVE:

  * x86: don't send SIGBUS for kernel page faults
  * mm: fix missing page table unmap for stack guard page failure case
  * mm: keep a guard page below a grow-down stack segment

The following upstream stable patches were skipped due to non trivial revert issues:

  * ext4: fix freeze deadlock under IO

Steve Conklin (sconklin) wrote :

SRU Justification

Impact: The upstream process for stable tree updates is quite similar in scope to the Ubuntu SRU process, e.g., each patch has to demonstrably fix a bug, and each patch is vetted by upstream by originating either directly from Linus' tree or in a minimally backported form of that patch.

The 2.6.32.19 upstream stable patch set is now available. It should be included in the Ubuntu kernel as well.

Changed in linux (Ubuntu):
milestone: none → lucid-updates
status: In Progress → Fix Committed
Martin Pitt (pitti) on 2010-09-01
Changed in linux (Ubuntu Lucid):
milestone: none → lucid-updates
Changed in linux (Ubuntu):
milestone: lucid-updates → none
Changed in linux (Ubuntu Lucid):
status: New → Fix Committed
Changed in linux (Ubuntu):
status: Fix Committed → Invalid

Accepted linux into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Brad Figg (brad-figg) on 2010-09-22
tags: added: verification-done
removed: verification-needed
Brad Figg (brad-figg) on 2010-09-22
tags: added: verification-needed
removed: verification-done
Launchpad Janitor (janitor) wrote :
Download full text (43.7 KiB)

This bug was fixed in the package linux - 2.6.32-25.44

---------------
linux (2.6.32-25.44) lucid-proposed; urgency=low

  [ Brad Figg ]

  * SAUCE: (no-up) Modularize vesafb -- fix initialization
    - LP: #611471

  [ Stefan Bader ]

  * Revert "SAUCE: sync before umount to reduce time taken by ext4 umount"
    - LP: #543617, #585092

  [ Steve Conklin ]

  * Revert "SAUCE: tulip: Let dmfe handle davicom on non-sparc"
    - LP: #607824

  [ Tim Gardner ]

  * [Config] Added ums-cypress to udeb
    - LP: #576066

  [ Upstream Kernel Changes ]

  * Revert "PCI quirk: Disable MSI on VIA K8T890 systems"
    - LP: #607824
  * Revert "PCI quirks: disable msi on AMD rs4xx internal gfx bridges"
    - LP: #607824
  * Revert "(pre-stable) Input: psmouse - reset all types of mice before
    reconnecting"
    - LP: #607824
  * Revert "jbd: jbd-debug and jbd2-debug should be writable"
    - LP: #607824
  * Revert "ext4: Make fsync sync new parent directories in no-journal
    mode"
    - LP: #615548
  * Revert "ext4: Fix compat EXT4_IOC_ADD_GROUP"
    - LP: #615548
  * Revert "ext4: Conditionally define compat ioctl numbers"
    - LP: #615548
  * Revert "ext4: restart ext4_ext_remove_space() after transaction
    restart"
    - LP: #615548
  * Revert "ext4: Clear the EXT4_EOFBLOCKS_FL flag only when warranted"
    - LP: #615548
  * Revert "ext4: Avoid crashing on NULL ptr dereference on a filesystem
    error"
    - LP: #615548
  * Revert "ext4: Use bitops to read/modify i_flags in struct
    ext4_inode_info"
    - LP: #615548
  * Revert "ext4: Show journal_checksum option"
    - LP: #615548
  * Revert "ext4: check for a good block group before loading buddy pages"
    - LP: #615548
  * Revert "ext4: Prevent creation of files larger than RLIMIT_FSIZE using
    fallocate"
    - LP: #615548
  * Revert "ext4: Remove extraneous newlines in ext4_msg() calls"
    - LP: #615548
  * Revert "ext4: init statistics after journal recovery"
    - LP: #615548
  * Revert "ext4: clean up inode bitmaps manipulation in ext4_free_inode"
    - LP: #615548
  * Revert "ext4: Do not zero out uninitialized extents beyond i_size"
    - LP: #615548
  * Revert "ext4: don't scan/accumulate more pages than mballoc will
    allocate"
    - LP: #615548
  * Revert "ext4: stop issuing discards if not supported by device"
    - LP: #615548
  * Revert "ext4: check s_log_groups_per_flex in online resize code"
    - LP: #615548
  * Revert "ext4: fix quota accounting in case of fallocate"
    - LP: #615548
  * Revert "ext4: allow defrag (EXT4_IOC_MOVE_EXT) in 32bit compat mode"
    - LP: #615548
  * Revert "ext4: rename ext4_mb_release_desc() to ext4_mb_unload_buddy()"
    - LP: #615548
  * Revert "ext4: Remove unnecessary call to ext4_get_group_desc() in
    mballoc"
    - LP: #615548
  * Revert "ext4: fix memory leaks in error path handling of
    ext4_ext_zeroout()"
    - LP: #615548
  * Revert "ext4: check missed return value in ext4_sync_file()"
    - LP: #615548
  * Revert "ext4: Issue the discard operation *before* releasing the blocks
    to be reused"
    - LP: #615548
  * Revert "ext4: Fix buffer head leaks after calls to
    ext4_get_inode_loc()"
    - LP: #615548
  * Revert "ex...

Changed in linux (Ubuntu Lucid):
status: Fix Committed → Fix Released
tags: added: testcase
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers