BUG: scheduling while atomic: patch/2747/0x10000001

Bug #619335 reported by Bryan Hundven
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Leann Ogasawara

Bug Description

Applying a large patch and downloading a file.
cpufreq was set to the maximum frequency.

ProblemType: KernelOops
DistroRelease: Ubuntu 10.10
Package: linux-image-2.6.35-16-generic-pae 2.6.35-16.22
Regression: No
Reproducible: No
ProcVersionSignature: Ubuntu 2.6.35-16.22-generic-pae 2.6.35.2
Uname: Linux 2.6.35-16-generic-pae i686
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
Annotation: Your system might become unstable now and might need to be restarted.
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: AD198x Analog [AD198x Analog]
   Subdevices: 2/2
   Subdevice #0: subdevice #0
   Subdevice #1: subdevice #1
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: bryan 1857 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xfe6dc000 irq 50'
   Mixer name : 'Analog Devices AD1984A'
   Components : 'HDA:11d4194a,10280420,00100400'
   Controls : 34
   Simple ctrls : 20
Date: Tue Aug 17 09:25:21 2010
Failure: oops
Frequency: This has only happened once.
HibernationDevice: RESUME=UUID=069c9ef4-6636-42fb-8fae-5dd477d9bd38
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Alpha i386 (20100803.1)
IwConfig:
 lo no wireless extensions.

 eth0 no wireless extensions.
MachineType: Dell Inc. OptiPlex 780
ProcCmdLine: BOOT_IMAGE=/vmlinuz-2.6.35-16-generic-pae root=/dev/sda3 ro quiet splash
RelatedPackageVersions: linux-firmware 1.38
RfKill:
 0: hci0: Bluetooth
  Soft blocked: no
  Hard blocked: no
SourcePackage: linux
Title: BUG: scheduling while atomic: patch/2747/0x10000001
dmi.bios.date: 02/13/2010
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A03
dmi.board.name: 03NVJ6
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.type: 15
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA03:bd02/13/2010:svnDellInc.:pnOptiPlex780:pvr:rvnDellInc.:rn03NVJ6:rvrA00:cvnDellInc.:ct15:cvr:
dmi.product.name: OptiPlex 780
dmi.sys.vendor: Dell Inc.

Revision history for this message
Bryan Hundven (bryanhundven) wrote :
Revision history for this message
Leann Ogasawara (leannogasawara) wrote :

Hi Bryan,

I have a feeling this is the same issue being seen in bug 618846. I've applied a patch to the latest Maverick kernel which should hopefully resolve this. I've placed test kernels (both i386 and amd64) at the following location. If you could please test and let me know your results that would be great. Thanks in advance.

http://people.canonical.com/~ogasawara/lp618846/

Changed in linux (Ubuntu):
assignee: nobody → Leann Ogasawara (leannogasawara)
importance: Undecided → Medium
status: New → In Progress
Revision history for this message
Bryan Hundven (bryanhundven) wrote :

Leann,

I will test and report back.

Thank you.

Revision history for this message
Bryan Hundven (bryanhundven) wrote :

Oh, I am running the i386-generic-pae, Just to keep everything as close to the same as possbile, do you have a build that is pae?

Revision history for this message
Leann Ogasawara (leannogasawara) wrote :

Hi Bryan,

I've posed i386-generic-pae kernels to http://people.canonical.com/~ogasawara/lp618846/ . However, I'm about to upload a new kernel which will contain the patch in question anyways, so you may just want to wait and update to this newer kernel when it's available (probably about a day to build and propagate through the archive). Either way, please let me know your results. Thanks.

Revision history for this message
Leann Ogasawara (leannogasawara) wrote :

I believe this to be fixed with the recent linux-2.6.35-17.23 kernel. As a result I'm marking this Fix Released. Should this not be the case, please feel free to re-open this by setting the status back to New. Thanks!

Changed in linux (Ubuntu):
status: In Progress → Fix Released
Revision history for this message
Bryan Hundven (bryanhundven) wrote :

Leann,

I have tested 2.6.35-17.23 with the same pae setup, and this fixed the issue.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers