Leaves modules.devname and modules.softdep behind in /lib/modules

Bug #618591 reported by Loïc Minier
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Low
Andy Whitcroft

Bug Description

Hi

While purging linux-image-2.6.35-13-generic, I got a warning that its lib/modules dir wasn't empty:

dpkg : avertissement : lors de la suppression de linux-image-2.6.35-13-generic, le répertoire « /lib/modules/2.6.35-13-generic » n'était pas vide, donc il n'a pas été supprimé.

bee# ls /lib/modules/2.6.35-13-generic
modules.devname modules.softdep

Please also consider adding a check to avoid this class of issues in the future, it happened at least 3 times in the past already.

Thanks,

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: linux-image-2.6.35-14-generic 2.6.35-14.20
Regression: Yes
Reproducible: Yes
ProcVersionSignature: Ubuntu 2.6.35-14.20-generic 2.6.35
Uname: Linux 2.6.35-14-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: CONEXANT Analog [CONEXANT Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: lool 2091 F.... pulseaudio
CRDA: Error: [Errno 2] Aucun fichier ou dossier de ce type
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf0620000 irq 44'
   Mixer name : 'Conexant CX20561 (Hermosa)'
   Components : 'HDA:14f15051,17aa211f,00100000'
   Controls : 14
   Simple ctrls : 7
Card29.Amixer.info:
 Card hw:29 'ThinkPadEC'/'ThinkPad Console Audio Control at EC reg 0x30, fw 6EHT10WW-1.04'
   Mixer name : 'ThinkPad EC 6EHT10WW-1.04'
   Components : ''
   Controls : 1
   Simple ctrls : 1
Card29.Amixer.values:
 Simple mixer control 'Console',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Date: Mon Aug 16 12:08:47 2010
MachineType: LENOVO 2777CTO
ProcCmdLine: BOOT_IMAGE=/vmlinuz-2.6.35-14-generic root=/dev/mapper/hostname--vg0-ubuntu--root ro quiet splash
ProcEnviron:
 LANGUAGE=fr_FR:fr:en_GB:en
 PATH=(custom, user)
 LANG=fr_FR.UTF-8
 SHELL=/bin/zsh
RelatedPackageVersions: linux-firmware 1.37
SourcePackage: linux
WpaSupplicantLog:

dmi.bios.date: 03/12/2009
dmi.bios.vendor: LENOVO
dmi.bios.version: 6EET27WW (1.08 )
dmi.board.name: 2777CTO
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr6EET27WW(1.08):bd03/12/2009:svnLENOVO:pn2777CTO:pvrThinkPadX301:rvnLENOVO:rn2777CTO:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 2777CTO
dmi.product.version: ThinkPad X301
dmi.sys.vendor: LENOVO

Revision history for this message
Loïc Minier (lool) wrote :
Revision history for this message
Andy Whitcroft (apw) wrote :

This problem occurs because these files are generated by a separate package from the kernel, by modutils. When that package changes we get hit by this error. Confirmed that the same kernel installed on Lucid userspace does not exhibit this behavour, while Maverick does.

Will look at suppressing these ones in a more robust way.

Changed in linux (Ubuntu):
status: New → In Progress
importance: Undecided → Low
assignee: nobody → Andy Whitcroft (apw)
milestone: none → ubuntu-10.10-beta
tags: removed: needs-upstream-testing
Revision history for this message
Andy Whitcroft (apw) wrote :

Pushed patches to make cleanup include these files, and generally to be more agressive on files likely to be from depmod, to kernel-team list for review.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.35-16.22

---------------
linux (2.6.35-16.22) maverick; urgency=low

  [ Andy Whitcroft ]

  * debian -- more agressivly clean up after depmod on purge
    - LP: #618591

  [ Henrik Rydberg ]

  * SAUCE: hid: 3m: Simplify touchsreen emulation logic

  [ Leann Ogasawara ]

  * ubuntu: iscsitarget -- version 1.4.20.2
  * ubuntu: rtl8192se -- update to version 0017.0507.2010
  * rebase to v2.6.35.2
  * [Config] update configs following rebase to v2.6.35.2
  * [Config] update ports configs following rebase to v2.6.35.2

  [ Luke Yelavich ]

  * [Config] Enable new firewire stack on powerpc

  [ Mathieu J. Poirier ]

  * SAUCE: (drop after 2.6.35) ARM: Using gpmc function to init nand flash.
    - LP: #608266
 -- Leann Ogasawara <email address hidden> Thu, 12 Aug 2010 09:58:01 -0700

Changed in linux (Ubuntu):
status: In Progress → Fix Released
Revision history for this message
Foppe Benedictus (foppe-benedictus) wrote :

I just did an upgrade to Maverick and purged the old kernels, but I am left with both files. My new kernel is 2.6.35-22.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers