Ubuntu

USB flash drive is not detected

Reported by Mekan Guldurdiyev on 2010-08-06
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

When I plug in the USB thumb drive it doesn';t show up anywhere. I remember it worked once but not since.
I remember I had the same problem with my other computer. I know VIRTUALBOX can see it not ubuntu or so it seems since I can't see the icon anywhere.
I remember after connecting the usb drive to the guest OS in virtualbox and then disconnecting it always appeared in ubuntu.
Please help me fix this problem. Since it's very very important to be able to access my external storage devices.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: udev 151-12
ProcVersionSignature: Ubuntu 2.6.32-24.39-generic 2.6.32.15+drm33.5
Uname: Linux 2.6.32-24-generic x86_64
Architecture: amd64
CustomUdevRuleFiles: 15-huawei-e1550.rules
Date: Fri Aug 6 18:29:11 2010
GvfsMonitorLog: Monitoring events. Press Ctrl+C to quit.
HotplugNewDevices: /dev/sdc
HotplugNewMounts:

InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
MachineType: IBM 81043JG
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-24-generic root=UUID=4ff4c68e-0705-4725-be92-3afc8f10134d ro quiet splash
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: udev
Symptom: storage
Title: Removable storage device not detected as block device
UdisksMonitorLog: Monitoring activity from the disks daemon. Press Ctrl+C to cancel.
dmi.bios.date: 10/23/2005
dmi.bios.vendor: IBM
dmi.bios.version: 2GKT17AUS
dmi.board.name: IBM
dmi.board.vendor: IBM
dmi.chassis.asset.tag: �������������������������
dmi.chassis.type: 4
dmi.chassis.vendor: IBM
dmi.modalias: dmi:bvnIBM:bvr2GKT17AUS:bd10/23/2005:svnIBM:pn81043JG:pvrThinkCentreM51:rvnIBM:rnIBM:rvr:cvnIBM:ct4:cvr:
dmi.product.name: 81043JG
dmi.product.version: ThinkCentre M51
dmi.sys.vendor: IBM

Mekan Guldurdiyev (g-mekan) wrote :
Mitch Towner (kermiac) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage. I have classified this bug as a bug in linux.

When reporting bugs in the future please use apport by using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at https://wiki.ubuntu.com/ReportingBugs.

affects: ubuntu → linux (Ubuntu)
kernel-janitor (kernel-janitor) wrote :

Hi Mekan,

If you could also please test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

    [This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-upstream-testing
tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete
Rajesh (rajeshgheware) wrote :

I am using Acer Aspire Travelmate 290 Series and Ubuntu 10.04. USB worked fine for few days but not any more. When I type lsusb, this is the output:
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

However, when I plug-in any usb flash drive, it is not shown anywhere (I see no way to access it). Though this is what I see as the output of dmesg:
# dmesg | grep USB
[ 2.512617] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[ 2.513017] ehci_hcd 0000:00:1d.7: new USB bus registered, assigned bus number 1
[ 2.532026] ehci_hcd 0000:00:1d.7: USB 2.0 started, EHCI 1.00
[ 2.532158] hub 1-0:1.0: USB hub found
[ 2.532306] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
[ 2.532329] uhci_hcd: USB Universal Host Controller Interface driver
[ 2.532445] uhci_hcd 0000:00:1d.0: new USB bus registered, assigned bus number 2
[ 2.532597] hub 2-0:1.0: USB hub found
[ 2.532982] uhci_hcd 0000:00:1d.1: new USB bus registered, assigned bus number 3
[ 2.533131] hub 3-0:1.0: USB hub found
[ 2.533323] uhci_hcd 0000:00:1d.2: new USB bus registered, assigned bus number 4
[ 2.533477] hub 4-0:1.0: USB hub found
[ 925.329490] Initializing USB Mass Storage driver...
[ 925.329607] USB Mass Storage support registered.

I have similar issue. When I plug in my USB flash it is not detected at all. Restart of udev does nothing, plugging again does nothing. The only thing that helps is to execute 'sudo lsusb'.

$ dmesg | grep -E "udev|usb"

[ 0.389104] usbcore: registered new interface driver usbfs
[ 0.389131] usbcore: registered new interface driver hub
[ 0.389188] usbcore: registered new device driver usb
[ 0.775363] usb usb1: configuration #1 chosen from 1 choice
[ 0.775863] usb usb2: configuration #1 chosen from 1 choice
[ 0.776246] usb usb3: configuration #1 chosen from 1 choice
[ 0.776632] usb usb4: configuration #1 chosen from 1 choice
[ 0.777016] usb usb5: configuration #1 chosen from 1 choice
[ 1.020598] udev: starting version 151
[ 1.288082] usb 4-2: new low speed USB device using uhci_hcd and address 2
[ 1.464643] usb 4-2: configuration #1 chosen from 1 choice
[ 1.482197] usbcore: registered new interface driver hiddev
[ 1.497126] input: Logitech USB-PS/2 Optical Mouse as /devices/pci0000:00/0000:00:1d.2/usb4/4-2/4-2:1.0/input/input4
[ 1.497668] generic-usb 0003:046D:C050.0001: input,hidraw0: USB HID v1.10 Mouse [Logitech USB-PS/2 Optical Mouse] on usb-0000:00:1d.2-2/input0
[ 1.497726] usbcore: registered new interface driver usbhid
[ 1.498019] usbhid: v2.6:USB HID core driver
[ 3.421102] udev: starting version 151

# HERE IS THE UDEV RESTART
[419215.019313] udev: starting version 151

# HERE IS THE LSUSB
[419248.176074] usb 1-8: new high speed USB device using ehci_hcd and address 3
[419248.310622] usb 1-8: configuration #1 chosen from 1 choice
[419248.770699] usbcore: registered new interface driver usb-storage
[419248.774423] usb-storage: device found at 3
[419248.774428] usb-storage: waiting for device to settle before scanning
[419253.772308] usb-storage: device scan complete

-----------

I am using Ubuntu 10.04 LTS with kubuntu-desktop installed. Running KDE 4.5.0 (4:4.5.0b-0ubuntu1~lucid1~ppa2). The same issue was visible on Ubuntu 9.10.

$ uname -a
Linux kkapuscik-u 2.6.32-24-generic #39-Ubuntu SMP Wed Jul 28 06:07:29 UTC 2010 i686 GNU/Linux

$ cat /etc/*-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=10.04
DISTRIB_CODENAME=lucid
DISTRIB_DESCRIPTION="Ubuntu 10.04.1 LTS"

$ dpkg --list | grep udev
ii libudev0 151-12 udev library
ii udev 151-12 rule-based device node and kernel event mana

$ dpkg --list | grep usb
ii libusb-0.1-4 2:0.1.12-14ubuntu0.2 userspace USB programming library
ii libusb-1.0-0 2:1.0.6-1 userspace USB programming library
ii usbutils 0.86-2ubuntu1 Linux USB utilities

Jeremy Foshee (jeremyfoshee) wrote :

This bug report was marked as Incomplete and has not had any updated comments for quite some time. As a result this bug is being closed. Please reopen if this is still an issue in the current Ubuntu development release http://cdimage.ubuntu.com/daily-live/current/ . Also, please be sure to provide any requested information that may have been missing. To reopen the bug, click on the current status under the Status column and change the status back to "New". Thanks.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kj-expired
Changed in linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers