omap3 beagle XM MMC card always comes up readonly

Bug #613855 reported by Oliver Grawert on 2010-08-05
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Lee Jones
Maverick
Undecided
Lee Jones

Bug Description

trying to boot a current maverick omap3 image the MMC card device (/dev/mmcblk0) always comes up as a readonly device (the filesystem is not readonly and the card is not pysically locked into readonly mode)

Oliver Grawert (ogra) on 2010-08-05
tags: added: armel
Lee Jones (lag) on 2010-08-05
Changed in linux (Ubuntu):
assignee: nobody → Lee Jones (lag)
tags: added: iso-testing
Robert Nelson (robertcnelson) wrote :

Hi Guys,

xm: http://bazaar.launchpad.net/~beagleboard-kernel/%2Bjunk/2.6.35-devel/annotate/head:/patches/xm/0001-OMAP-omap3630-based-xm-has-no-mmc-wp-line.patch

Bx/Cx: git revert of ed8303fc111e58530e22bd29b0d7e08dced75999

From my own testing, in 2.6.35 (and 2.6.34) the pin write-protect seems busted on the mmc, even with these two patches it doesn't actually detect when the sd card has the write protect enabled.. But atleast they are write-enabled now..

Regards,

Lee Jones (lag) on 2010-08-13
Changed in linux (Ubuntu):
status: New → Confirmed
Oliver Grawert (ogra) on 2010-08-13
Changed in linux (Ubuntu Maverick):
milestone: none → ubuntu-10.10-beta
Ricardo Salveti (rsalveti) wrote :

The fix for this bug was posted already at linux-omap (at least no other since the version 6 of the patch set :-), and I can confirm that it fix this issue.

Lee, I know the patch series is not applied yet at linux-omap, but I believe the quality is now OK (it got an ack from Jarkko Nikula,
http://marc.info/?l=linux-omap&m=128230579024928&w=2). Do you think we can get it applied at our tree?

For testing purposes I added them to my ubuntu kernel tree (http://kernel.ubuntu.com/git?p=rsalveti/ubuntu-maverick.git;a=shortlog;h=refs/heads/rsalveti-master), and generated the deb http://people.canonical.com/~rsalveti/maverick/kernel/linux-image-2.6.35-19-omap_2.6.35-19.25rsalveti1_armel.deb. I'm using it since last week (at my b5, c4 and xM) and it seems to be working fine.

Lee Jones (lag) wrote :

For you Ricardo ... I'll do all I can. :)

Changed in linux (Ubuntu Maverick):
status: Confirmed → Fix Committed

I just uploaded linux-2.6.35-19.26 which should contain the patches to resolve this issue. Marking this Fix Released.

https://edge.launchpad.net/ubuntu/+source/linux/2.6.35-19.26

Changed in linux (Ubuntu Maverick):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers