[PATCH] NVIDIA GPU audio-over-HDMI: Patch required to support recent GPUs

Bug #611810 reported by Stephen Warren on 2010-07-30
70
This bug affects 10 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
Nominated for Maverick by nullack
linux-backports-modules-2.6.32 (Ubuntu)
Undecided
Unassigned
Nominated for Maverick by nullack

Bug Description

The kernel ALSA driver needs a patch applied to make audio-over-HDMI operate correctly on most supported GPUs.

The exact patch is available at http://git.alsa-project.org/?p=alsa-kernel.git;a=commitdiff;h=4289bc9c818ece46f8034616b232caaef4622984

It'd be great if this patch could be included in the standard Ubuntu kernel(s) for any/all recent or supported distro versions.

Note 1: I believe only the nvidia driver (not nv nor nouveau) support setting up audio-over-HDMI.

Note 2: Very recent GPUs (Fermi class) are not yet supported by the driver. A second patch will be forthcoming for this at some point in time, but we have to validate operation under Linux before releasing this.

Stephen Warren (srwarren) wrote :

A second patch is required to support various new GPUs in the ALSA driver:

http://git.kernel.org/?p=linux/kernel/git/tiwai/sound-2.6.git;a=commit;h=9cf2657d05f9f9e04c3e113d68bf7cef5a942070

Thanks.

Jerone Young (jerone) wrote :

@ Stephen,
       The way we work normally with these type of situations is we will pull upstream ALSA work into package linux-backports-moudles-alsa-lucid-generic package for 10.04.

        We also for OEM installs will also create dkms alsa packages that just update the hda alsa driver with upstream bits, like your patches.

affects: linux-meta (Ubuntu) → linux-backports-modules-2.6.32 (Ubuntu)
David Henningsson (diwic) wrote :

Also https://wiki.ubuntu.com/Audio/InstallingLinuxAlsaDriverModules is a convenient way to get the latest ALSA drivers.

tags: added: kernel-sound
Chris Van Hoof (vanhoof) wrote :

I did notice that the first patch listed has can be found within the Maverick kernel.

kernel-janitor (kernel-janitor) wrote :

Hi Stephen,

Please be sure to confirm this issue exists with the latest development release of Ubuntu. ISO CD images are available from http://cdimage.ubuntu.com/daily/current/ . If the issue remains, please run the following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux 611810

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

    [This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-kernel-logs
tags: added: needs-upstream-testing
tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete
Changed in linux (Ubuntu):
status: Incomplete → New
nullack (nullack) wrote :

I'm confirming this bug. It does exist on Maverick. I have Maverick installed and my test systems has three NVIDIA GTX 480s in trisli. Fermi chips are totally unsupported in Maverick for the NVIDIA GTX 4XX generation Fermi cards.

I've also nominated this bug for the Maverick release because Fermi chips are common discrete graphics cards and it's reasonable to expect that such common hardware would be supported by Ubuntu.

Changed in linux (Ubuntu):
status: New → Confirmed
razor1394 (razor1394) wrote :

I upgraded my kernel on my Maverick amd64 installation to 2.6.36-rc5 and there is now a unit called GF104 High Definition Audio Controller, 1 output, Digital Stereo (HDMI) Output

I have not been able to try it however as this computer does not have an hdmi receiver connected to it. The other computer with this card and an hdmi receiver connected to it does have lucid and I don't want to upgrade to maverick cause I would loose xbmc ppa support.

So if someone wants a try just install 2.6.36-rc6 from mainline kernel-ppa repository.

MichaelH (asylumed) wrote :

I've upgraded to the 2.6.36-rc6 mainline kernel from the ppa as razor1394 suggested and I've been able to play (and hear) sound successfully via the HDMI output. I have a 4xx series GPU, specifically an MSI GTX 460. This is on a up to date maverick install.

Thank you!

Maletor (eberner) wrote :

I am on 2.6.36-020636rc7-generic from the mainline kernel ppa. However, selecting GF104 from ALSA does not produce audio. I have an EVGA GTX 460.

Maletor (eberner) wrote :

Can you be extremely explicit in how you got this to work so that I may duplicate it?

I'm also wondering if anybody can speak to the differences in the EVGA and MSI?

MichaelH (asylumed) wrote :

I have a stock install of Maverick with just one updated package for the kernel. I'm no expert on the hardware so I can't be of any use there.

I did notice that after I installed the new kernel there were four SPDIF controls for the Nvidia card in alsamixer and only one was unmuted. I'm not exactly sure what function they have, but I unmuted them all. Maybe see if that has any effect?

Maletor (eberner) wrote :

I tried muting my IEC958 and even disabling it in the BIOS. Then I plugged the HDMI straight into my HDMI and selected GF104 from Ubuntu sound preferences and unmuting everything in alsamixer.

This was no go.

Boo.

Would love this to work.

Maletor (eberner) wrote :

/HDMI/TV

MichaelH (asylumed) wrote :

I've downgraded kernels back to a stock maverick kernel (2.6.35-22-generic) and i've installed the linux-alsa-driver-modules-2.6.35-22-generic package from the ubuntu-audio-dev ppa (as suggested in the wiki entry pointed out by David above) and everything is still working perfectly.

Andrew Somerville (andy16666) wrote :

Does Fermi HDMI audio work on 10.10? I'm considering purchasing a Geforce GT 430 based card and I can't find any confirmation that it's going to work for me.

Maletor (eberner) wrote :

It does.

Andrew Somerville (andy16666) wrote :

I'm afraid it does not. It shows up in sound preferences as HDA NVidia. I unmuted all three channels in alsamixer. I even disabled my onboard sound card. No sound comes out of my monitor though. I tested the same configuration in windows and I do have sound. So something is still broken.

Andrew Somerville (andy16666) wrote :

I'm able to get sound if I run the following command a few times form the terminal:

aplay -D plughw:1,9 /usr/share/sounds/alsa/Front_Left.wav

I have to run it repeatedly before I get any sound. Once I do get sound through the speakers, sound then works through other programs too (through pulse), but it is very distorted...almost unlistenable. So this could be an issue with pulseaudio, since sound through aplay sounds clear but sound through pulse (once I get it to work) is distorted.

Sound never plays normally after a reboot. So far I've always had to fiddle with aplay until it starts working. Then I can play through pulse.

Is this related to this bug report or something else?

Stephen Warren (srwarren) wrote :

andy16666, your issue sounds unrelated to this bug. You might have better luck with speaker-test (e.g. perhaps only have to run it once rather than N times), since I assume Front_Left.wav is a very short sample?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in linux-backports-modules-2.6.32 (Ubuntu):
status: New → Confirmed

Stephen Warren, thank you for reporting this and helping make Ubuntu better. This bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? Can you try with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you run the following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux <replace-with-bug-number>

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
David Henningsson (diwic) wrote :

This is an old bug, and we can assume these patches have reached 12.04, so marking as fix released.

Changed in linux (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers