Ubuntu

Suspend/hibernate/resume failure in Ubuntu 10.04 64-bit on HP Pavilion dv4t-1000

Reported by vysotsky on 2010-07-13
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

Since upgrading to 10.04 (amd64) I have been able to successfully use the suspend and hibernate features, however I am unable to tell if this is a problem with the suspend, hibernate, or resume processes. This is a reproducible problem that occurs every time I try to initiate suspend or hibernate in Ubuntu 10.04. (I did not have this problem in the previous version of Ubuntu that I was using, 9.04.)

Everything seems to go well at first when I try to suspend or hibernate: the screen blinks off for a moment, but then suddenly the backlight turns back on with a blank screen and the computer hangs and is totally unresponsive. I've looked through the system logs, but I'm having trouble tracking down the problem. I've looked at the syslog and the pm-suspend log, and neither of them seem to show any problem. (I'm seeing lots of messages that end with "success" before "performing suspend" and then nothing until the point where I restarted the machine.)

I've looked through the steps to triage the problem (here on this page at https://wiki.ubuntu.com/DebuggingKernelSuspendHibernateResume), and have the following information: 1) Usually this does not seem to involve a kernel panic. (I believe I may have seen a flashing caps lock light once in the many times that I've tried to suspend the laptop, but I cannot reproduce this.); and 2) When I ran pm-suspend from VT1 I saw no messages of any kind, only a blank screen.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: linux-image-2.6.32-23-generic 2.6.32-23.37
Regression: Yes
Reproducible: Yes
ProcVersionSignature: Ubuntu 2.6.32-23.37-generic 2.6.32.15+drm33.5
Uname: Linux 2.6.32-23-generic x86_64
NonfreeKernelModules: nvidia
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 2/2
   Subdevice #0: subdevice #0
   Subdevice #1: subdevice #1
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: bhorne 1694 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0x9d000000 irq 33'
   Mixer name : 'Nvidia MCP78 HDMI'
   Components : 'HDA:111d76b2,103c30f7,00100302 HDA:11c11040,103c137e,00100200 HDA:10de0003,10de0101,00100000'
   Controls : 31
   Simple ctrls : 19
Date: Tue Jul 13 13:42:26 2010
HibernationDevice: RESUME=UUID=899aace8-379e-4299-920e-8fe6463568b2
LiveMediaBuild: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100427.1)
MachineType: Hewlett-Packard HP Pavilion dv4 Notebook PC
ProcCmdLine: root=UUID=85aa3e10-0be4-456d-9d50-9fdb20bf052f ro quiet splash vga=normal nomodeset crashkernel=384M-2G:64M,2G-:128M
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
RelatedPackageVersions: linux-firmware 1.34.1
SourcePackage: linux
WpaSupplicantLog:

dmi.bios.date: 05/18/2010
dmi.bios.vendor: Insyde
dmi.bios.version: F.66
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 30F8
dmi.board.vendor: Hewlett-Packard
dmi.board.version: 99.C3
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnInsyde:bvrF.66:bd05/18/2010:svnHewlett-Packard:pnHPPaviliondv4NotebookPC:pvrF.66:rvnHewlett-Packard:rn30F8:rvr99.C3:cvnHewlett-Packard:ct10:cvrN/A:
dmi.product.name: HP Pavilion dv4 Notebook PC
dmi.product.version: F.66
dmi.sys.vendor: Hewlett-Packard

vysotsky (horne-b) wrote :
vysotsky (horne-b) wrote :

Follow-up: I noticed the " needs-upstream-testing" tag on this bug report, so I tried using the latest daily upstream kernel (on July 13th) but saw no difference when I tried to suspend or hibernate.

Howard Cheng (howard-cheng) wrote :

I have a similar problem. Just installed 10.04LTS (amd64) on my new computer (Gateway DX4831-03C) with the latest updates, using fglrx driver.

Suspend and hibernate both fail at invocation: stuck at a blank screen (not power saving mode) and the computer is no longer responsive.

Howard Cheng (howard-cheng) wrote :

My pm-suspend.log.

I have turned off fglrx and just used the radeon driver, but still the same problem. The only difference is that my monitor goes into power saving mode before it hangs.

SteveLoughran (steve-loughran) wrote :

I'm seeing this, laptop is hp elitebook 6930p with ATI card that worked under 9.04 provided you blacklisted the sd card reader.

Now it hangs on the second or third hibernate or suspend after a laptop has booted. First time, fine, second, usually fine. Third: never. Also, after the reboot, the network is disabled.

1. There's some discussion on this in various mail lists, search for : ubuntu 10.4 laptop hang on suspend. Again, the disabled network is a common feature, implying whatever causes the hang happens after network shutdown
2. I've tried various 32 bit and PAE-enabled kernels: 2.6.32-21 to 2.6.32-24 inclusive; same behaviour.
3. Problem occurs from the GUI, ACPI own actions (eg attempting to hibernate on low battery) or from the commandline
4. Problem is independent of whether the laptop is on AC or battery.
5. on my laptop, the non graphical terminals turned out not to work with the ATI driver. I've switched to the OSS driver and will do some more experiments

SteveLoughran (steve-loughran) wrote :

Update: removing the ATI display driver and my machine suspends and resumes happily. This implies its a bug in the ATI closed source display driver -not something that anyone else can fix.

I tried the debugging kernel suspend/resume tricks, but no crash report gets generated. Is there any way to force some stack trace during a suspend or otherwise debug a display driver that is hanging on suspend? Alternatively, how could we improve the OS so that if a driver doesn't suspend properly, that failure is detected and acted on, rather than leaving the laptop to stay live and overheating as it is transported?

I can possibly see how to do failure detection , but acting on the failure, that's tricky.

Chris (tubsc66) wrote :

Im having a similar problem, since upgrading to 10.04, I have no hibernate or suspend tabs on the drop down box, they're completely missing. I also have no sound, no sound card detected. Every once and awhile, when I reboot, I'll have a full drop down menu and I have sound, but its very infrequent. Very frustrating, Ive edited my GRUB file in a number of different ways, sometimes fix works for a little while, but lately, I havent been able to get these functions back at all. When I log into root, the drop down menu looks and performs as its supposed to, I just cant access my desktop items from there. Ive been an Ubuntu user for almost a year, I used 9.10 for a long time and was happy with everything. Upgrading was a BIG mistake. My computer is an HP desktop with an AMD 64 processor, any ideas? Thanks!

Chris

Brad Figg (brad-figg) on 2010-12-03
tags: added: acpi-brightness
Brad Figg (brad-figg) on 2011-04-06
Changed in linux (Ubuntu):
status: New → Confirmed
Jason Azat (13l0yp-jason) wrote :

I have the same issue on HP Pavilion desktop a6110n. Bug #946018

vysotsky, thank you for reporting this and helping make Ubuntu better. This bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please provide the information following https://wiki.ubuntu.com/DebuggingKernelSuspendHibernateResume ? As well, can you try with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ . However, note you can only test Suspend, not Hibernate, when using a LiveCD. If the issue remains, run the following command in the development release from a Terminal (Applications->Accessories->Terminal) as it will automatically gather and attach updated debug information to this report.

apport-collect -p linux <BUGNUMBER>

Additionally, if you could try to reproduce this with the upstream mainline kernel that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.

Please let us know your results. Thanks in advance.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: needs-bisect
vysotsky (horne-b) wrote :

Dear Mr. Penalver,

I'm afraid that since reporting this bug I've upgraded to Ubuntu 12.04, and I no longer experience this problem. I had a little trouble with suspend when I first began using 12.04 (https://bugs.launchpad.net/ubuntu/+source/gnome-power-manager/+bug/962617), but that problem seems to have been resolved by an update over the course of the last month.

If I can still be of any help somehow, please do let me know.

vysotsky, this bug report is being closed due to your last comment regarding this being fixed with an update. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status. Thank you again for taking the time to report this bug and helping to make Ubuntu better. Please submit any future bugs you may find.

Changed in linux (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers