World of Warcraft crashes at login with 2.6.35

Bug #604261 reported by Bluescreen on 2010-07-11
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Medium
Wine
Won't Fix
Medium
linux (Ubuntu)
Undecided
Unassigned

Bug Description

A bug affecting wine (most notably WoW) users was introduced somewhere after 2.6.32
A fix was found, which has been merged into 2.6.35-rc4.

See https://bugzilla.kernel.org/show_bug.cgi?id=16315

I'm running lts-backport-maverick, giving me:
linux-image-2.6.35-7-generic_2.6.35-7.11~lucid1

In the git repo, I can see the fix is included in this kernel version.
(commit# a1e80fafc9f0742a1776a0490258cb64912411b0)

However, running the small test program given on the kernel bugzilla page, still segfaults.

So it appears that the ubuntu kernel behaves a bit differently compared to vanilla and the problem still persists.
---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: mathijs 2613 F.... xfce4-mixer-plu
                      mathijs 2678 F.... xfce4-volumed
 /dev/snd/controlC1: mathijs 2613 F.... xfce4-mixer-plu
                      mathijs 2678 F.... xfce4-volumed
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xfebf8000 irq 44'
   Mixer name : 'Analog Devices AD1988'
   Components : 'HDA:11d41988,104381e1,00100400'
   Controls : 50
   Simple ctrls : 29
Card1.Amixer.info:
 Card hw:1 'Headset'/'Logitech Logitech USB Headset at usb-0000:00:1d.0-1, full speed'
   Mixer name : 'USB Mixer'
   Components : 'USB046d:0a14'
   Controls : 4
   Simple ctrls : 2
DistroRelease: Ubuntu 10.04
HibernationDevice: RESUME=UUID=5e9d90bc-9306-4857-8c10-bb205e300a99
MachineType: System manufacturer System Product Name
NonfreeKernelModules: nvidia
Package: linux 2.6.32.23.24
PackageArchitecture: amd64
ProcCmdLine: BOOT_IMAGE=/vmlinuz-2.6.35-7-generic root=/dev/mapper/terraraid-root ro crashkernel=384M-2G:64M,2G-:128M quiet splash
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, user)
 LANG=en_US.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.35-7.11~lucid1-generic 2.6.35-rc4
Regression: No
RelatedPackageVersions: linux-firmware 1.34.1
Reproducible: Yes
RfKill:

Tags: lucid needs-upstream-testing
Uname: Linux 2.6.35-7-generic x86_64
UserGroups: adm admin audio cdrom dialout kvm lpadmin plugdev sambashare vboxusers wireshark
dmi.bios.date: 07/02/2007
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 1201
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: P5B-V
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1201:bd07/02/2007:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5B-V:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer

---
Architecture: amd64
DistroRelease: Ubuntu 10.04
NonfreeKernelModules: nvidia
Package: linux 2.6.32.23.24
PackageArchitecture: amd64
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, user)
 LANG=en_US.utf8
 SHELL=/bin/bash
Tags: lucid
Uname: Linux 2.6.35-020635rc4-generic x86_64
UnreportableReason: The running kernel is not an Ubuntu kernel
UserGroups: adm admin audio cdrom dialout kvm lpadmin plugdev sambashare vboxusers wireshark

Today's 3.3.5 patch from blizzard seems to have KO'd WoW on all my systems. As this is a required patch, this effectively reduces WoW to garbage status (assuming its not just me).

Immediately after entering login information, a illegal instruction error occurs. This may be related to the introduction of Blizzard's "RealID" system, which uses a 'Battle.net.dll' that is known from Starcraft 2 Beta to have anti-debugging measures in it. The patch that was created for SC2 to work around this does not work in my case.

I ran a +relay trace and generated a 4G (!!) log file, the last 5000 lines of which are here:
http://www.infernalsoul.net/Junk/Dump/5000.log

The illegal instruction occurs at line 2492. I could be mistaken, but it looks like it is indeed attempting anti-debugging nonsense immediately before the error. I am recompiling wine on an older GCC version (using Arch linux/AUR packaging scripts which are basically just ./configure && make) to rule out those issues, but this could take a while.

Let me know what else I can do to be of assistance

I spoke with him on IRC and the SC2 hacks don't seem to work. Hopefully a finished SC2 patch fixes this issue as well but Blizzard might have added some more unsupported protections, so I'm keeping this bug open.

Don't panic yet.

While there were issues with 3.3.5 PTR (and claims of wldap32.dll native fixing the problem -- see http://forum.winehq.org/viewtopic.php?t=8688 , http://www.wowwiki.com/Wine_troubleshooting#Post-3.3.5_login_issues and its link), I don't think we're running into exactly that yet.

Maintenance is still ongoing, and while before using native wldap32.dll at least got the game to hard crash for me, now it has 0 impact. I think this is just server maintenance -- though it is likely there'll be a bug to fix once that's done. See http://forums.worldofwarcraft.com/thread.html?topicId=25552425015 .

Wait until tomorrow, in other words :)

Partial nevermind -- updated to 3.3.5 via an online mirror, now I get a hard crash with or without native wldap32.dll.

Will provide backtrace if you want (and specify how you want it done).

If you have a backtrace, add it to here as an attachment.

In , Drevi (drevix) wrote :

I can confirm this. I try the native dll method but the game still crashes at login attempt.

What a sad day for wow linux users.

147 comments hidden view all 226 comments

FYI for Fedora 13 users, Red Hat has back ported this fix into the latest kernel update for Fedora 13 (kernel-2.6.33.6-147.fc13).

https://bugzilla.redhat.com/show_bug.cgi?id=609548

-Jase

Same thing with PCLinuxOS. Wow crashed when clicking login using kernel 2.6.33.5 but was fixed when the kernel was downgraded to 2.6.32.15.

In , seanj (seanj) wrote :

(In reply to comment #154)
> Same thing with PCLinuxOS. Wow crashed when clicking login using kernel
> 2.6.33.5 but was fixed when the kernel was downgraded to 2.6.32.15.

A fix is included in Linux kernel 2.6.35-rc4. I compiled and installed this kernel on Slackware 13.1 and WoW worked without any extra fiddling.

187 comments hidden view all 226 comments

Please give us more information by running this command: "apport-collect 604261"

Can you try the latest mainline build kernel? You can see how to do it here: https://wiki.ubuntu.com/KernelTeam/MainlineBuilds

Changed in linux (Ubuntu):
status: New → Incomplete

apport information

tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

description: updated

Ok, I ran apport-collect.

Switched to mainline 2.6.35-rc4.
It seems the problem is there too, so I'll take my bug upstream

Thank you for this information.
As I said, you should test the mainline build kernel (it is unmodified). You can see how to do here: https://wiki.ubuntu.com/KernelTeam/MainlineBuilds

Changed in linux (Ubuntu):
status: Incomplete → Confirmed

Whoops, didn't see your last post. Sorry for that.

164 comments hidden view all 226 comments

There is a quick fix for FreeBSD amd64 users: http://lists.freebsd.org/pipermail/freebsd-hackers/2010-July/032330.html

This is a patch for testing, but it works for me on FreeBSD 8.0-RELEASE-p3 and wine 1.2rc4.

Note: game still crashes if you enter wrong password

For me (ubuntu lucid 64bit) I still get a crash on login with latest backports-kernel (2.6.35-7.11 which includes 2.6.35-rc4).

Stock lucid kernel works, but I need some stuff in the backports-kernel.

So apparently the kernel fix does not work for me.
Are there any other known WoW issues regarding newer kernels?

For me, WoW crashes with "Internal errors: Invalid parameters received". The last console output is:

fixme:wininet:InternetSetOptionW Option INTERNET_OPTION_CONNECT_TIMEOUT (5000): STUB
fixme:wininet:InternetSetOptionW INTERNET_OPTION_SEND/RECEIVE_TIMEOUT 5000
fixme:wininet:InternetSetOptionW Option INTERNET_OPTION_CONNECT_TIMEOUT (5000): STUB
fixme:wininet:InternetSetOptionW INTERNET_OPTION_SEND/RECEIVE_TIMEOUT 5000
fixme:reg:GetNativeSystemInfo (0x374042c4) using GetSystemInfo()
fixme:wininet:InternetSetOptionW Option INTERNET_OPTION_CONTEXT_VALUE; STUB
fixme:wininet:InternetSetOptionW Option INTERNET_OPTION_CONTEXT_VALUE; STUB
wine: Unhandled page fault on read access to 0x34aa7821 at address 0x3ccbcd1f (thread 0028), starting debugger...
Can't attach process 0027: error 5

I had no such problem on Ubuntu Lucid. Running Maverick amd64 with kernel 2.6.35-rc4, which has the SIGTRAP patch applied. So it must be a different issue.

So I upgraded my Linux from OpenSuSE 11.2 to 11.3, and after getting everything set up i try to get into Warcraft and see that it crashes as soon as i get to the loading screen, it crashes.

Thankfully i was able to come here and see that the problem isn't in my Wine, but in the new Kernel that comes with 11.3. And even better that there was already an answer for it.

The only problem is that i'm not really sure where to go from here. I've never patched a kernel before and don't really know where to start. I tried following the forum link above which said that there would be discussion on how to do it and such, but there are only 5 posts all asking about what the problem is, and not discussing the solution.

If anyone can help me to patch my kernel, step by step, I'd be most appreciative. The current Kernel that 11.3 uses is 2.6.34-12, which i understand is a SuSE specific deviation. Can i just patch to that version, or do i need to download a whole new source from kernel.org and patch to that?

If anyone could provide a link with step by step instructions, or can email me with that help, I'd be very grateful.

BTW: I tried downgrading my kernel back to 2.6.31 (vanilla) using the 11.2 repository, but that seems to cause even more issues as Compiz isn't working, and WoW crashes as soon as the launcher comes up.

This isn't the appropriate place for general discussion (kernel patching for example).

Ask in the SUSE forums for their advised method of applying a kernel patch, or if they offer a older stable kernel from 2.6.32 or earlier you can downgrade to.

I apologize. I have as a matter of fact posted in the openSuSE forums about this very problem, and haven't yet gotten an answer.

I do agree that this isn't an area for 'general' talk of patching kernels, but I WAS asking about applying the specific patch that the bug being spoken of in the thread requires, that was developed by those that post in this thread. If you notice I also did ask anyone to email me DIRECTLY, not to discuss it on the list.

Again I apologize if my post was in error or offended anyone, I just figured that the people who were working on this very bug would be able to be a help to me. Should anyone wish to help, I would still appreciate if you could send me an email that would either help guide me through it, or point me towards a site that will help.

Please do NOT respond in this thread.

*** Bug 23713 has been marked as a duplicate of this bug. ***

*** Bug 23806 has been marked as a duplicate of this bug. ***

I reported a similar issue there:
http://bugs.winehq.org/show_bug.cgi?id=23858

With Starcraft 2: 1.0.1.16195 and 2.6.35-rc6 kernel.

ACCESS_VIOLATION after login with battle.net account.

I was not sure it was the same issue since upgrading the kernel didn't resolved the problem.

Since I didn't see this directly mentioned anywhere else...

I'm now on Gentoo 2.6.35 with Wine 1.3.0. I'm successfully getting into the game.

Everyone may have already expected that but since I just picked up 2.6.35 in last nights sync this was my first reasonable chance to test it. :D

OK, so it looks like this is fixed now, the solution being 'upgrade to 2.6.35+'.

On Ubuntu Lucid amd64 with 2.6.35 from kernel ppa, wow still crashes on login

(In reply to comment #167)
> On Ubuntu Lucid amd64 with 2.6.35 from kernel ppa, wow still crashes on login

For those still having this issue, I'd recommend that you look at your kernel's update log for the specific patch the resolves the issue. As in my case, (Fedora 13) the kernel update that resolved the issue specifically quoted this defect in the patch log, so I knew that kernel and beyond were a go.

-Jase

In , Focht (focht) wrote :

*** Bug 23222 has been marked as a duplicate of this bug. ***

This also still happens after upgrading to a vanilla 2.6.36-rc1, on my x86_64 on wine 1.3

I've been bisecting kernels since the patch that fixes SIGTRAP, and here are my results so far (also I have really fallen in love with kexec in the process :) :

git bisect log
# bad: [da5cabf80e2433131bf0ed8993abc0f7ea618c73] Linux 2.6.36-rc1
# good: [a1e80fafc9f0742a1776a0490258cb64912411b0] x86: Send a SIGTRAP for user icebp traps
git bisect start 'v2.6.36-rc1' 'a1e80fa'
# good: [cece1945bffcf1a823cdfa36669beae118419351] net: disable preemption before call smp_processor_id()
git bisect good cece1945bffcf1a823cdfa36669beae118419351
# bad: [d71048e22f47725a5808ea2e4e1e72fa36c1a788] Merge branch 'omap-for-linus' of git://git.kernel.org/pub/scm/linux/kernel/git/tmlind/linux-omap-2.6
git bisect bad d71048e22f47725a5808ea2e4e1e72fa36c1a788
# bad: [ab69bcd66fb4be64edfc767365cb9eb084961246] Merge git://git.kernel.org/pub/scm/linux/kernel/git/gregkh/driver-core-2.6
git bisect bad ab69bcd66fb4be64edfc767365cb9eb084961246
# good: [9779714c8af09d57527f18d9aa2207dcc27a8687] Merge branch 'kms-merge' of git://git.kernel.org/pub/scm/linux/kernel/git/jwessel/linux-2.6-kgdb
git bisect good 9779714c8af09d57527f18d9aa2207dcc27a8687
# good: [3a3527b6461b1298cc53ce72f336346739297ac8] Merge branch 'core-rcu-for-linus' of git://git.kernel.org/pub/scm/linux/kernel/git/tip/linux-2.6-tip
git bisect good 3a3527b6461b1298cc53ce72f336346739297ac8
# bad: [9da79ab83ee33ddc1fdd0858fd3d70925a1bde99] tracing/kprobes: unregister_trace_probe needs to be called under mutex
git bisect bad 9da79ab83ee33ddc1fdd0858fd3d70925a1bde99
# bad: [b7dcb857cc3eb89136111fefe89780129c1af1d7] perf probe: Support static and global variables
git bisect bad b7dcb857cc3eb89136111fefe89780129c1af1d7
# bad: [a1ac1d3c085420ea8c809ebbee3bb212ed3616bd] perf record: Add option to avoid updating buildid cache
git bisect bad a1ac1d3c085420ea8c809ebbee3bb212ed3616bd
# bad: [68aa00ac0a82e9a876c799bf6be7622b8f1c8517] perf, x86: Make a second write to performance counter if needed
git bisect bad 68aa00ac0a82e9a876c799bf6be7622b8f1c8517
# bad: [bafb67470b294810f62db40b348643062255702b] perf tools: Allow building perf source tarballs on non-configured tree
git bisect bad bafb67470b294810f62db40b348643062255702b
# bad: [45de34bbe3e1b8f4c8bc8ecaf6c915b4b4c545f8] perf buildid: add perfconfig option to specify buildid cache dir
git bisect bad 45de34bbe3e1b8f4c8bc8ecaf6c915b4b4c545f8
# bad: [c45c6ea2e5c57960dc67e00294c2b78e9540c007] perf tools: Add the ability to specify list of cpus to monitor
git bisect bad c45c6ea2e5c57960dc67e00294c2b78e9540c007
# bad: [761844b9c68b3c67b085265f92ac0675706cc3b3] perf report: Make -D print sampled CPU
git bisect bad 761844b9c68b3c67b085265f92ac0675706cc3b3

I have a feeling that either bisect or I picked something wrong... this last commit (which bisect says is the first bad commit) doesn't even come after the icebp patch.

Created attachment 30245
A list of kernel commits that may affect this bug.

Alright, what a fun lunch break :P

Using just the data available, I narrowed it down to the range:

v2.6.35..9da78ab

It breaks on 9da78ab, but works on v2.6.35

There are 148 commits between the two.

Filtering by paths (I think the problem is in arch/x86, not sure though), and removing the merge commits, this leaves:

$ git log --oneline v2.6.35...9da79ab83ee33ddc -- arch/x86 | grep -v Merge
cc05152 x86,mmiotrace: Add support for tracing STOS instruction
4c21adf x86 cpufreq, perf: Make trace_power_frequency cpufreq driver independent
39ef13a perf, x86: P4 PMU -- redesign cache events
567a9fd kprobes/x86: Fix kprobes to skip prefixes correctly
f7809da x86: Support for instruction breakpoints
0c4519e x86: Set resume bit before returning from breakpoint exception
c882e0f x86, perf: Add power_end event to process_*.c cpu_idle routine
018378c x86: Unify save_stack_address() and save_stack_address_nosched()
147ec4d x86: Make save_stack_address() !CONFIG_FRAME_POINTER friendly
e785059 perf: Convert perf_event to local_t
1996bda arch: Implement local64_t
68aa00a perf, x86: Make a second write to performance counter if needed
8d2cacb perf: Cleanup {start,commit,cancel}_txn details
b0f82b8 perf: Drop the skip argument from perf_arch_fetch_regs_caller
c9cf4db x86: Unify dumpstack.h and stacktrace.h
e768aee perf, x86: Small fix to cpuid10_edx
45c34e0 Oprofile: Change CPUIDS from decimal to hex, and add some comments

The full list without the path filter is attached.

Anyone more kernel-knowledgeable want to chime in?

Alright, after a rebasing followed by more rebasing, I have isolated the commit that causes WoW to crash:

f7809da x86: Support for instruction breakpoints

Everything is peachy before this commit.

I reverted this commit on my 2.6.36-rc1, and now I can log in without any issue.

181 comments hidden view all 226 comments
Maia Everett (linneris) wrote :

WoW does not crash for me with the mainline kernel 2.6.35-020635-generic, but crashes with all Maverick kernels to date.

According to investigation done in the Wine bug report http://bugs.winehq.org/show_bug.cgi?id=23323 , and here in https://bugzilla.kernel.org/show_bug.cgi?id=16315 , it seems the responsible commit in the upstream kernel is "f7809da x86: Support for instruction breakpoints". Going to check with -17.

summary: - fix for kernel bug 16315 does not work for ubuntu
+ World of Warcraft crashes at login with 2.6.35
Maia Everett (linneris) wrote :

Just checked: the bug still persists with 2.6.35-17 and does not occur with mainline 2.6.35.2 (2.6.35-02063502).

Dave Thorn (davet-spod) wrote :

Tried installing

http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.35.3-maverick/

WoW still crashes at startup.

Maia Everett (linneris) wrote :

Specifically at *startup*? Because for me, it crashes after I input my Battle.net credentials and press login.

Dave Thorn (davet-spod) wrote :

For "some weeks" now I've had it intermittently crashing after hitting 'Login'. The last few days it almost always crashes at startup - although sometimes I can get in and play for a while before it crashes.

Sometimes I see it open a window (I played windowed) and hear a second or so of the login screen sounds.

I've just upgraded to wine 1.3 and now I don't see/hear the login at all.

http://www.spod.org/~davet/wow_error.png

178 comments hidden view all 226 comments
In , Prter (prter) wrote :

Created attachment 30278
Wine fixmes

In kernels 2.6.33.6-147.2.4.fc13 and 2.6.33.8-149.fc13 the bug appears to still affect StarCraft II, even though they both have the icebp traps patch by Frederic. My 2.6.33.6 also lacks the "Support for instruction breakpoints" patch which Kelvie Wong believes causes the problem.

I have been attempting this with the described kernels on a Thinkpad T60 with the x11-drv-ati driver (which apparently shows up in lsmod as "radeon"?).

The program is crashing while loading, before the log in screen.

It may be that this is a slightly different ACCESS_VIOLATION bug, but I suspect it is at least closely related. I shall also attach my blizzard error and backtrace report.

In , Prter (prter) wrote :

Created attachment 30279
Blizzard Error Report

(In reply to comment #176)
> Created an attachment (id=30279) [details]
> Blizzard Error Report

I am pretty sure this is a separate issue. The blizzard crash handler shouldn't even get called for this issue.

Changed in wine:
status: Unknown → Confirmed

(In reply to comment #158)

Just wanted to say, this is still an issue on wine-1.3.1 and vanilla kernel 2.6.36-rc3. As it's mentioned in the original post, this might be a different issue from the originally reported one - should a new report be opened ?

(In reply to comment #178)
> (In reply to comment #158)
>
> Just wanted to say, this is still an issue on wine-1.3.1 and vanilla kernel
> 2.6.36-rc3. As it's mentioned in the original post, this might be a different
> issue from the originally reported one - should a new report be opened ?

https://bugzilla.kernel.org/show_bug.cgi?id=16315#c26

It's fixed with this patch here, and I presume it will be in the next RC.

Kelvie,

I couldn't fully follow the issue you were tracking here and on the kernel bugtracker.

Is this an issue introduced after 2.6.35 (so in 2.6.36-rc1)?
Or another (related) issue to the one that was fixed earlier?

For me, WoW still doesn't work, so I would like to know if I should just wait for this fix to be included, or start debugging it and track down if I'm watching the right bug.

Situation:
Ubuntu Lucid amd64
default kernel (2.6.32-24-generic): everything works
kernel ppa (2.6.35-19-generic): crash upon login - sometimes with blizzard bug report tool, sometimes wine message about bad instruction.
I tried the "mainline" 2.6.35 from ubuntu kernel ppa, but same issues there.

both 2.6.35's contain the fix from earlier.

(In reply to comment #180)
> Kelvie,
>
> I couldn't fully follow the issue you were tracking here and on the kernel
> bugtracker.
>
> Is this an issue introduced after 2.6.35 (so in 2.6.36-rc1)?
> Or another (related) issue to the one that was fixed earlier?
>
> For me, WoW still doesn't work, so I would like to know if I should just wait
> for this fix to be included, or start debugging it and track down if I'm
> watching the right bug.
>
> Situation:
> Ubuntu Lucid amd64
> default kernel (2.6.32-24-generic): everything works
> kernel ppa (2.6.35-19-generic): crash upon login - sometimes with blizzard bug
> report tool, sometimes wine message about bad instruction.
> I tried the "mainline" 2.6.35 from ubuntu kernel ppa, but same issues there.
>
> both 2.6.35's contain the fix from earlier.

It's hard to tell -- I am not sure what patches the Ubuntu guys put on.

To summarize, this is what we know:

1. Commit 08d6832 breaks the login
2. Commit a1e80fa fixes commit 08d6832 (this is in 2.6.35)
3. Commit f7809da also breaks the login (this is in 2.6.36-rc1 and later)
4. Frederick's new patch fixes commit f7809da (this hasn't been checked in)

So, it will break

1. If your kernel has 08d6832 and not a1e80fa

OR

2. If you have commit f7809da

OR

3. Some other issue.

*** Bug 24227 has been marked as a duplicate of this bug. ***

Changed in wine:
importance: Unknown → Medium
184 comments hidden view all 226 comments
Scott Ritchie (scottritchie) wrote :

I think the kernel issue might be fixed and that the new ptrace protection is causing the login crash:

http://bugs.winehq.org/show_bug.cgi?id=24193

Please retest disabling ptrace protection

185 comments hidden view all 226 comments

For all those who upgrade to current maverick:

the 2.6.32-25 kernel from lucid-repos allows for wow to work. (and no errors in other apps so far)

the one in maverick (2.6.35-22) does NOT let you play wow, eve-online works ;)

that is at least the generic-pae on x86 install on my laptop.
Intel(R) Core(TM)2 Duo CPU T9400 @ 2.53GHz
nVidia Corporation G96 [GeForce 9600M GS]

The one in maverick (2.6.35-*) does let you play wow.
At least for me it turned out the bug was not this one reported here, but rather http://bugs.winehq.org/show_bug.cgi?id=24193

As a workaround I turn off (0) this new ubuntu security feature before WoW and switch it back on afterwards (1).

(as root)
echo 0 > /proc/sys/kernel/yama/ptrace_scope

Disabling security features is not as bad as it sounds.
Vanilla 2.6.35 does not contain it.
Everything before 2.6.35 doesn't as well.
So you will be "as secure as lucid" so to speak.

Thanks a lot, I can confirm this is working.
running 2.6.35-22-generic-pae on maverick with the security feature off and wow runs fine.

And after compiling wine myself using these patches:
http://art.ified.ca/?page_id=40
pulseaudiosupport is back as well.

No crash so far.

The option of turning the security feature off should be mentioned in any WoW-by-Wine report, as it will affect alot of people and the solution to it seems to be rather complicated (starting at the logical level of wineserver and its child processes?). Thanks again, I would not have found this otherwise.

(In reply to comment #184)
> The one in maverick (2.6.35-*) does let you play wow.
> At least for me it turned out the bug was not this one reported here, but
> rather http://bugs.winehq.org/show_bug.cgi?id=24193
>
> As a workaround I turn off (0) this new ubuntu security feature before WoW and
> switch it back on afterwards (1).
>
> (as root)
> echo 0 > /proc/sys/kernel/yama/ptrace_scope
>
> Disabling security features is not as bad as it sounds.
> Vanilla 2.6.35 does not contain it.
> Everything before 2.6.35 doesn't as well.
> So you will be "as secure as lucid" so to speak.

I can also confirm this is working in maverick. I was starting to give up hope of
playing!

How did you manage to tun the security feature off?

When I try this:

"sudo echo 0 > /proc/sys/kernel/yama/ptrace_scope"

I got the following output:

"bash: /proc/sys/kernel/yama/ptrace_scope: Permission denied"

And I'm not able to run an older/newer (beta/mainline) kernel. The installation process wents fine but when I try to boot I don't have a gui anymore :/

(In reply to comment #187)
> How did you manage to tun the security feature off?
>
> When I try this:
>
> "sudo echo 0 > /proc/sys/kernel/yama/ptrace_scope"
>
> I got the following output:
>
> "bash: /proc/sys/kernel/yama/ptrace_scope: Permission denied"
>
>
> And I'm not able to run an older/newer (beta/mainline) kernel. The installation
> process wents fine but when I try to boot I don't have a gui anymore :/

The way that is interpreted is:
(sudo echo 0) > /proc/sys/kernel/blah/blah
Meaning you only used sudo to run echo, which bash then tried to write (without sudo permissions).

You'd need to either do:
echo 0 | sudo tee /proc/sys/kernel/etc/etc
or
sudo sh -c "echo 0 > /proc/sys/blah/blah"

Anyway, this isn't a wine bug, the two issues that cause it are well known and addressed... I'd say this can be closed.

Yes, I think enough time has passed for this issue to be mostly gone.

Closing invalid.

Changed in wine:
status: Confirmed → Invalid
Changed in linux:
status: Unknown → Confirmed
Changed in linux:
importance: Unknown → Medium

*** Bug 21809 has been marked as a duplicate of this bug. ***

192 comments hidden view all 226 comments

Our site of acquaintances helps people from all world in search of second half.

tags: added: amd64 lucid needs-upstream-testing

Bluescreen, thank you for reporting this bug and heling make Ubuntu better. This bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? Can you try with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you run the following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux <replace-with-bug-number>

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Changed in linux:
status: Confirmed → Fix Released
192 comments hidden view all 226 comments
Changed in wine:
status: Invalid → Won't Fix
Displaying first 40 and last 40 comments. View all 226 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.