touchpad doesn't work at all in Sony VAIO F

Bug #601239 reported by Anna Tassinari on 2010-07-03
48
This bug affects 8 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

Touchpad doesn't work at all in Lucid on my new Sony VAIO F series laptop. It is not listed in the devise list (cat /proc/bus/input/devices), so I can't even tell whether I have synaptics or Alps touchpad.

WORKAROUND: Edit /etc/default/grub to include GRUB_CMDLINE_LINUX="i8042.nopnp"
2. Run: sudo update-grub
3. Reboot.

uname -a
Linux ania-vaio 2.6.32-21-generic #32-Ubuntu SMP Fri Apr 16 08:09:38 UTC 2010 x86_64 GNU/Linux

tags: added: kj-triage

checked under Windows - it says it is an ALPS touchpad.
I read that synaptics driver is good also for ALPS touchpads - synaptics doesn't seem to be loaded along with other modules (lsmod returns nothing synaptics related), even though I added Load 'synaptics' to xorg.conf..

Terry Rigby (terry-pctek) wrote :

I also have the same problem with my Vaio VPCF121FD. I also show an ALPS touchpad in windows. my lshw and lshal are attached.

Terry Rigby (terry-pctek) wrote :
Terry Rigby (terry-pctek) wrote :

I've found a solution for this. See post #2 on thread http://ubuntuforums.org/showthread.php?t=1150077&highlight=vaio+series

1. Edit /etc/default/grub to include GRUB_CMDLINE_LINUX="i8042.nopnp"
2. Run: sudo update-grub
3. Reboot.

This worked !!! Thanks Terry!!

Just for the record, if anyone else stumbles upon this fix: It worked, even though my /var/log/Xorg.0.log did not include this line: "PNP: PS/2 appears to have AUX port disabled, if this is incorrect please boot with i8042.nopnp"

Changed in linux (Ubuntu):
status: New → Fix Committed
Terry Rigby (terry-pctek) wrote :

I'd like to note that the "fix" I posted is more of a workaround. The touchpad works more like a ps2 mouse and adjusting sensitivity settings etc doesnt work. Sometimes, the mouse seems to jump around and it can be hard to control where it goes. I am guessing there will eventually be a "proper" solution to the missing driver but this workaround does work in the meantime

Robert Hooker (sarvatt) wrote :

Can you run this command and also attach the resulting file?

sudo acpidump -o ~/acpidump.txt

Terry Rigby (terry-pctek) wrote :

Here you go

This problem affects my vaio serie E, too. How can I be usefull?

Jeremy Foshee (jeremyfoshee) wrote :

switching back to Triaged and assigning to Robert Hooker so that he can review the info he requested.

~JFo

Changed in linux (Ubuntu):
status: Fix Committed → Triaged
assignee: nobody → Robert Hooker (sarvatt)
Dan (daniel-jediinc) wrote :

Have the same problem with my Vaio VGN-FE41M (ALPS)

No improvement under Ubuntu 11 either...

workaround not working

any news?

Thanks

Robert Hooker (sarvatt) on 2013-04-10
Changed in linux (Ubuntu):
assignee: Robert Hooker (sarvatt) → nobody

Anna Tassinari, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

Also, could you please test the latest upstream kernel available following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Please do not test the daily kernel folder, but the one all the way at the bottom. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-v3.12-rc2

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

description: updated
Changed in linux (Ubuntu):
status: Triaged → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers