168c:0024 Atheros AR5008 on Ubuntu 10.04 with either ath9k or ndiswrapper drivers cause excessive CPU wakeup

Bug #600942 reported by Ivan Potapenko on 2010-07-02
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
dpkg (Ubuntu)
Undecided
Unassigned
libselinux (Ubuntu)
Undecided
Unassigned
linux (Ubuntu)
High
Unassigned

Bug Description

I have recently tried to upgrade my netbook (edit: it is a Notus A12) with an Atheros AR5008 Wifi card from Ubuntu 8.04 to 10.04. This was done by a clean install (not the Ubuntu dist-upgrade procedure).

Everything worked fine except for the wireless card. When using 8.04 I used ndiswrapper with great success. Now, both the ndiswrapper and ath9k drivers give me a very strange problem: They wake up CPU excessively making the whole system slow and unresponsive. This usually happens after I have connected to a network and try to transfer any substantial amount of data.

If you take a look at powertop output you can see that wakeup number usually is below approximately 1500 (even with heavy usage of wifi with Ubuntu 8.04). However on Lucid I get often numbers ranging from 5000 to 15000 which is ridiculously high.

Once the excessive wakeups have begun, no iwconfig power saving configuration or even rmmod-ing the driver helps. Installing wireless from backports does not alleviate the problem either.

This is also present on most other major distributions (OpenSUSE, Fedora Core) as well as Ubuntu derivatives (Mint etc). The only exception is Arch which uses a newer kernel version (which may or may not have something to do with the problem).

Ivan Potapenko (i-o-potapenko) wrote :
Ivan Potapenko (i-o-potapenko) wrote :
Ivan Potapenko (i-o-potapenko) wrote :
Ivan Potapenko (i-o-potapenko) wrote :
tags: added: ath9k kernel-bug ndiswrapper wireless
description: updated
Ivan Potapenko (i-o-potapenko) wrote :

Some further observations: There are neither errors nor warnings in any of the system logs. As I stated earlier, rmmod-ing the given wireless driver (be it ndiswrapper or ath9k) does not help once the problem arises. However, suspending to RAM and then resuming fixes the problem until it inevitably reoccurs when trying to transfer some data over the wifi. Strangely though, switching off the wireless card (either with the physical hardware switch on the side of the laptop or with the function keys) does not help.

I have now compiled two custom kernels: 2.3.34 and 2.3.35-rc3. Kernel configs were copied from the Ubuntu stock kernel (2.3.32-23) and the rest of the configuration was left at default values (answering "yes" to all queries by "make oldconfig"). From what I can see the problem is almost gone in both of these two kernels, however it does occur randomly after prolonged periods of wifi use.

description: updated
tags: added: kj-triage
Brad Figg (brad-figg) on 2010-12-03
tags: added: acpi-apic
Brad Figg (brad-figg) on 2011-05-04
Changed in linux (Ubuntu):
status: New → Confirmed

Ivan Potapenko, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? Can you try with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you run the following command in the development release from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux <replace-with-bug-number>

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please do not test the kernel in the daily folder, but the one all the way at the bottom. Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. As well, please comment on which kernel version specifically you tested.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream', and comment as to why specifically you were unable to test it.

Please let us know your results. Thanks in advance.

tags: added: kernel-wifi needs-upstream-testing
removed: wireless
tags: removed: ath9k kernel-bug ndiswrapper
summary: - Atheros AR5008 on Ubuntu 10.04 with either ath9k or ndiswrapper drivers
- cause excessive CPU wakeup
+ 168c:0024 Atheros AR5008 on Ubuntu 10.04 with either ath9k or
+ ndiswrapper drivers cause excessive CPU wakeup
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
importance: Undecided → High
dino99 (9d9) wrote :

Lucid is no more a supported version now

Changed in linux (Ubuntu):
status: Incomplete → Invalid
affects: linux (Fedora) → libselinux (Ubuntu)
Changed in libselinux (Ubuntu):
status: New → Invalid
dino99 (9d9) on 2015-05-01
affects: linux (openSUSE) → dpkg (Ubuntu)
Changed in dpkg (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers