No video on beagleboard with 2.6.35 kernels.

Bug #597904 reported by Tobin Davis on 2010-06-23
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Critical
Mathieu Poirier
Maverick
Critical
Mathieu Poirier

Bug Description

When testing the 2.6.35 series kernels on beagleboard (omap3), there was no video output. This was believed to have been due to bug 594382, but in reviewing the logs on that bug, I am seeing the same error message before the daisy chain errors start.

The error is:

[ 2.054840] omapfb omapfb: no displays
[ 2.058654] omapfb omapfb: failed to setup omapfb
[ 2.063476] omapfb: probe of omapfb failed with error -22

Full console log output is attached.

Tobin Davis (gruemaster) wrote :
Tobin Davis (gruemaster) on 2010-06-23
Changed in linux (Ubuntu):
assignee: nobody → Mathieu Poirier (mathieu.poirier)
Oliver Grawert (ogra) wrote :

blocks image builds, setting to critical

Changed in linux (Ubuntu Maverick):
importance: Undecided → Critical
milestone: none → maverick-alpha-2
Jeremy Foshee (jeremyfoshee) wrote :

Tobin, is there any way to get apport logs from the machine?

Thanks!

~JFo

Changed in linux (Ubuntu Maverick):
status: New → Incomplete
Tobin Davis (gruemaster) wrote :

I was able to get some apport data after making a custom image that included apport (and all of its dependencies), configuring a serial tty, and several other magic bits, but on these experimental kernels and images this is sometimes not even a possibility. Please do not mark the armel bugs as incomplete.

Changed in linux (Ubuntu Maverick):
status: Incomplete → New
Changed in linux (Ubuntu Maverick):
milestone: maverick-alpha-2 → maverick-alpha-3
Oliver Grawert (ogra) wrote :

this is a blocker for alpha2 images, we cant build *any* images if it isnt resolved before, moving the milestone back to A2

Changed in linux (Ubuntu Maverick):
milestone: maverick-alpha-3 → maverick-alpha-2
Tobin Davis (gruemaster) wrote :

Unable to collect apport data as the kernel is out of release. Since we don't have a stable kernel to fall back on for Maverick, minicom logs will have to suffice.

Tobin Davis (gruemaster) wrote :

Even after installing linux-image-omap from the latest update, apport still is too difficult to get data into this report. I used ubuntu-bug -f -p linux -s kernel-2.6.35-6.apport to create the report file per https://help.ubuntu.com/community/ReportingBugs using the headless remote system procedure, but when trying to update this bug report on a different system, apport is trying to collect information on my desktop (different arch, different release). I have attached the generated file for anyone interested.

Changed in linux (Ubuntu Maverick):
status: New → In Progress

The problem is caused by DSS devices not recognized by the kernel when initializing the frame buffer subsystem.

The two DSS devices - "dvi" and "tv" - are both devifed and passed to "platform_add_devices" in "board-omap3beagle.c"

For some reason they don't seem to make it to the "platform_device" structure passed to "omapfb_probe", hence the error messages.

The omapfb driver couldn't locate its display sink because of
an initialisation error in the DSS subsystem. This error was
caused by a missing 'vdds_sdi' entry in the board power regulator list.

Changed in linux (Ubuntu Maverick):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.35-6.8

---------------
linux (2.6.35-6.8) maverick; urgency=low

  [ Mathieu J. Poirier ]

  * ARM: Adding regulator supply for vdds_sdi.
    - LP: #597904
 -- Leann Ogasawara <email address hidden> Sun, 27 Jun 2010 16:34:43 -0700

Changed in linux (Ubuntu Maverick):
status: Fix Committed → Fix Released
Tobin Davis (gruemaster) wrote :

Fix verified - system boots with video OK.

tags: added: verification-done
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers