WiFi Link 6000 Series (rev 35) crashes regularly on N network

Bug #594889 reported by Robert Collins on 2010-06-15
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Manoj Iyer

Bug Description

I get the following in dmesg:
[10622.059405] iwlagn 0000:02:00.0: iwl_tx_agg_start on ra = 00:22:75:34:c9:75 tid = 0
[15136.595098] iwlagn 0000:02:00.0: Microcode SW error detected. Restarting 0x2000000.
[15136.697348] Registered led device: iwl-phy2::radio
[15136.697493] Registered led device: iwl-phy2::assoc
[15136.697616] Registered led device: iwl-phy2::RX
[15136.698101] Registered led device: iwl-phy2::TX

(the 10622 item is just to show how big a gap there is from the last message to the point where it crashes.)

Then I rmmod iwlagn and modprobe it:
[15181.819232] iwlagn 0000:02:00.0: Stopping AGG while state not ON or starting
[15181.819240] iwlagn 0000:02:00.0: queue number out of range: 0, must be 10 to 19
[15181.873118] mac80211-phy2: failed to remove key (0, 00:22:75:34:c9:75) from hardware (-16)
[15181.873163] wlan0: deauthenticating from 00:22:75:34:c9:75 by local choice (reason=3)
[15182.063095] mac80211-phy2: failed to remove key (1, ff:ff:ff:ff:ff:ff) from hardware (-16)
[15183.513428] iwlagn 0000:02:00.0: PCI INT A disabled
[15183.550787] iwlagn: Intel(R) Wireless WiFi Link AGN driver for Linux, 1.3.27k
[15183.550789] iwlagn: Copyright(c) 2003-2009 Intel Corporation
[15183.550898] iwlagn 0000:02:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[15183.550930] iwlagn 0000:02:00.0: setting latency timer to 64
[15183.551318] iwlagn 0000:02:00.0: Detected Intel Wireless WiFi Link 6000 Series 3x3 AGN REV=0x74
[15183.571743] iwlagn 0000:02:00.0: Tunable channels: 13 802.11bg, 24 802.11a channels
[15183.571818] iwlagn 0000:02:00.0: irq 34 for MSI/MSI-X
[15183.572488] phy3: Selected rate control algorithm 'iwl-agn-rs'
[15183.578453] iwlagn 0000:02:00.0: firmware: requesting iwlwifi-6000-4.ucode
[15183.582158] iwlagn 0000:02:00.0: loaded firmware version 9.193.4.1
[15183.889190] Registered led device: iwl-phy3::radio
[15183.889231] Registered led device: iwl-phy3::assoc
[15183.889270] Registered led device: iwl-phy3::RX
[15183.889302] Registered led device: iwl-phy3::TX
[15183.926730] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[15195.426952] wlan0: deauthenticating from 00:22:75:34:c9:75 by local choice (reason=3)
[15195.427011] wlan0: direct probe to AP 00:22:75:34:c9:75 (try 1)
[15195.434347] wlan0: direct probe responded
[15195.434354] wlan0: authenticate with AP 00:22:75:34:c9:75 (try 1)
[15195.436342] wlan0: authenticated
[15195.436372] wlan0: associate with AP 00:22:75:34:c9:75 (try 1)
[15195.450316] wlan0: RX AssocResp from 00:22:75:34:c9:75 (capab=0x411 status=0 aid=1)
[15195.450321] wlan0: associated
[15195.465389] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[15204.695096] iwlagn 0000:02:00.0: iwl_tx_agg_start on ra = 00:22:75:34:c9:75 tid = 0

And it runs for a while longer before dying.

Note that the restarting at 0x2000... string shows up in other bug reports, but its a generic error handler in the firmware : this isn't the same as previous bugs solved for older cards in older kernels; so I'm filing a new bug.

Lenovo x201s, i7 -640m, lucid 64-bit.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: linux-image-2.6.32-22-generic 2.6.32-22.36
Regression: No
Reproducible: Yes
ProcVersionSignature: Ubuntu 2.6.32-22.36-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-22-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: HDA Generic [HDA Generic]
   Subdevices: 0/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: robertc 2122 F.... pulseaudio
 /dev/snd/pcmC0D0c: robertc 2122 F...m pulseaudio
 /dev/snd/pcmC0D0p: robertc 2122 F...m pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf2520000 irq 17'
   Mixer name : 'Intel G45 DEVIBX'
   Components : 'HDA:14f15069,17aa2156,00100301 HDA:80862804,17aa21b5,00100000'
   Controls : 10
   Simple ctrls : 5
Card29.Amixer.info:
 Card hw:29 'ThinkPadEC'/'ThinkPad Console Audio Control at EC reg 0x30, fw 6QHT28WW-1.09'
   Mixer name : 'ThinkPad EC 6QHT28WW-1.09'
   Components : ''
   Controls : 1
   Simple ctrls : 1
Card29.Amixer.values:
 Simple mixer control 'Console',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Date: Wed Jun 16 11:35:18 2010
HibernationDevice: RESUME=UUID=84925f2f-3b6b-4158-85ca-40820257d8d8
Lsusb:
 Bus 002 Device 002: ID 8087:0020
 Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 001 Device 003: ID 147e:2016 Upek Biometric Touchchip/Touchstrip Fingerprint Sensor
 Bus 001 Device 002: ID 8087:0020
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: LENOVO 5129CTO
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-22-generic root=UUID=f297d373-2af3-4b52-96ec-12ade57cfa8c ro quiet splash
ProcEnviron:
 LANGUAGE=la_AU:tlh_GB:tlh:en
 PATH=(custom, user)
 LANG=la_AU.utf8
 SHELL=/bin/bash
RelatedPackageVersions: linux-firmware 1.34
SourcePackage: linux
WpaSupplicantLog:

dmi.bios.date: 04/20/2010
dmi.bios.vendor: LENOVO
dmi.bios.version: 6QET44WW (1.14 )
dmi.board.name: 5129CTO
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr6QET44WW(1.14):bd04/20/2010:svnLENOVO:pn5129CTO:pvrThinkPadX201s:rvnLENOVO:rn5129CTO:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 5129CTO
dmi.product.version: ThinkPad X201s
dmi.sys.vendor: LENOVO

Robert Collins (lifeless) wrote :
Jeremy Foshee (jeremyfoshee) wrote :

Hi Robert,

If you could also please test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

    [This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete

Rather than run a mainline kernel [unsupported, no real way to
quantify risk] on my production laptop that I need to have working
with the upcoming LP epic and distro sprints, I'll bring the AP I have
trouble with with me, and if someone wants to grab the SD image I was
testing plymouth stuff with for folk with them, I will use it to test
this too.

Manoj Iyer (manjo) wrote :

The upstream bug https://bugzilla.kernel.org/show_bug.cgi?id=15374 claims that the following 4 patches resolve this issue, although the main issue here is that there is an error in the microcode and that has not been fixed yet. So the problem might not go away until the microcode is fixed.

Subject: [PATCH 1/4] mac80211: tear down all agg queues when restart/reconfig hw
Subject: [PATCH 2/4] iwlwifi: check for aggregation frame and queue
Subject: [PATCH 3/4] iwlwifi: clear all tx queues when firmware ready
Subject: [PATCH 4/4] iwlwifi: clear all the stop_queue flag after load firmware

Patches 1,3, and 4 are in Lucid, patch 2 uses a newer version of the function ieee80211_stop_tx_ba_session() and so the build fails. This will require back porting a list of patches to get it to build. But, it still wont fix the real issue which is broken microcode. Maverick kernel should have all these patches already. I tried to build a lucid kernel last night, but gave up after a few attempts at backporting from upstream.

tags: added: kernel-candidate kernel-needs-review
tags: added: kernel-reviewed
removed: kernel-needs-review
Robert Collins (lifeless) wrote :

the maverick-lts-backport kernel has something weird going on: when
trying to login (gdm) it switched VT to 1 on me, a couple of times,t
hen after logging in I only was able to click my mouse once before X
appears to freeze :(.

Manoj Iyer (manjo) wrote :

Robert,

Can you please try linux-backports-modules compat-wireless Linux modules for your version of the kernel/Ubuntu release ? You should be able to apt-get install these modules.

Changed in linux (Ubuntu):
assignee: nobody → Manoj Iyer (manjo)
G. S. Marzot (marz) wrote :

I believe I have the same problem. Ubuntu 10.04 LTS upgraded to kernel 2.6.35-6.9 x86_64. I will try installing the modules mentioned above but were not found as typed.

151.881283] iwlagn 0000:03:00.0: Microcode SW error detected. Restarting 0x20000

http://codepad.org/gqi717Ul

G. S. Marzot (marz) wrote :

also should mention HW (Lenovo T410 2516-CTO) Ultimate-N 6300 wireless

I am away from my AP at the moment, will report back in a few weeks when
I'm near it again.

Thanks,
Rob

Filip Arlet (filip-arlet) wrote :

same error on 4965AGN. I think its 11n problem. I disabled n network by adding:
options iwlagn 11n_disable=1
into any .conf file in /etc/modprobe.d and it works. But its not a fix only a workaround.
Something is definitely wrong with iwlagn firmware on 802.11n type networks.
Im adding a dmesg log, but i dont think it will be useful.
Filip

Jeremy Foshee (jeremyfoshee) wrote :

Filip,
   Please file a new bug for your issue. We like to keep different hardware on separate bugs.

Thanks!

~Jfo

tags: removed: kernel-candidate
Tim Gardner (timg-tpi) wrote :

Filip - please start a new bug 'cause the i4965 has completely different HW and firmware from the i6300.

Tim Gardner (timg-tpi) wrote :

Robert - can you post the manufacturer and model of your AP ?

delkin double-n+ wireless router model # f6d6230-4

Cheers,
Rob

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.