Please enable vmware-balloon driver in kernel config

Bug #592039 reported by Dmitry Torokhov on 2010-06-10
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Andy Whitcroft
Maverick
Medium
Andy Whitcroft

Bug Description

VMware would like to have our balloon driver enabled by default in distribution kernels to improve customer experience and reduce number of third-party modules being loaded into the kernel.

Please change the kernel configuration for Ubuntu 10.10 so that vmware-balloon driver is compiled as a module (CONFIG_VMWARE_BALLOON=m). The driver has to be compiled as a module to allow our installer detect that the driver is being supplied by the distribution and prevent installer from overwriting it.

Also please ocnsider applying the following patch to the driver which fixes issue with the driver may start consuming excessive
amount of memory during torture tests. The patch is in 2.6.32-rc2 and should make its way to stable as well.

Thanks.

CVE References

Dmitry Torokhov (dtor) wrote :
tags: added: kernel-workflow
tags: added: kj-triage
tags: added: patch
Changed in linux (Ubuntu):
status: New → Triaged
importance: Undecided → Wishlist
importance: Wishlist → Medium
tags: added: kernel-core kernel-needs-review
removed: kernel-workflow
Andy Whitcroft (apw) on 2010-06-21
tags: added: kernel-reviewed
removed: kernel-needs-review
Changed in linux (Ubuntu):
assignee: nobody → Andy Whitcroft (apw)
milestone: none → maverick-alpha-3
status: Triaged → Fix Released
Andy Whitcroft (apw) wrote :

This patch is already in the v2.6.35-rc3 kernel which Maverick is based on. Config option is not enabled, will spin a patch to enable for Maverick.

Changed in linux (Ubuntu):
status: Fix Released → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.35-5.6

---------------
linux (2.6.35-5.6) maverick; urgency=low

  [ Amit Kucheria ]

  * [Config] update omap flavour description

  [ Andy Whitcroft ]

  * update to ubuntu-debian:508b7aa34b578c0d1e51bfb571f2bfb824dc65ac
    - LP: #570500, #576274
  * SAUCE: add option to hand off all kernel parameters to init
    - LP: #586386
  * [Config] enable passing all kernel command line to init
    - LP: #586386
  * [Config] disable CONFIG_VMI
    - LP: #537601
  * [Config] enable CONFIG_IPV6_SIT_6RD
    - LP: #591869
  * [Config] enable CONFIG_VMWARE_BALOON as module
    - LP: #592039

  [ Leann Ogasawara ]

  * Revert "SAUCE: pm: Config option to disable handling of console during
    suspend/resume"
    - LP: #594885
  * [Config] Remove CONFIG_PM_DISABLE_CONSOLE
  * [Config] ports: enable passing all kernel command line to init
    - LP: #586386
  * [Config] Enable CONFIG_FB_VESA=y for x86
  * [Config] Add CONFIG_FRAMEBUFFER_CONSOLE=y to config enforcer
  * [Config] Add CONFIG_FB_VESA=y for x86 to config enforcer
  * [Config] Enable CONFIG_TASK_DELAY_ACCT=y
    - LP: #493156

  [ Mathieu Poirier ]

  * ARM: Adding MosChip MCS7830 to nic-usb
    - LP: #584920

  [ Upstream Kernel Changes ]

  * Revert "[Upstream] docbook: need xmldoclinks for all doc types"
  * docbook: need xmldoclinks for all doc types
  * perf probe: Add kernel source path option
 -- Leann Ogasawara <email address hidden> Thu, 17 Jun 2010 08:05:29 -0700

Changed in linux (Ubuntu):
status: In Progress → Fix Released
Dmitry Torokhov (dtor) wrote :

Unfortunately the driver is still missing from "linux-virtual" package.

Dmitry Torokhov (dtor) wrote :

Please add the driver to "linux-virtual" package so that all flavors of kernel woudl have it by default.

Changed in linux (Ubuntu):
status: Fix Released → New
Andy Whitcroft (apw) on 2010-12-21
Changed in linux (Ubuntu):
status: New → In Progress
Changed in linux (Ubuntu Maverick):
importance: Undecided → Medium
milestone: none → maverick-updates
Changed in linux (Ubuntu):
milestone: maverick-alpha-3 → natty-alpha-2
Andy Whitcroft (apw) wrote :

Natty: confirmed that the module is configured on but not included in the virtual.inclusion-list. Added and pushed to natty.

Changed in linux (Ubuntu):
status: In Progress → Fix Committed
Dmitry Torokhov (dtor) wrote :

Any chance it could also make to Maverick updates? I am not quite familiar with Ubuntu work flow so please bear with me...

Thanks,
Dmitry

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.37-11.25

---------------
linux (2.6.37-11.25) natty; urgency=low

  [ Andy Whitcroft ]

  * [Config] d-i -- add hpsa to the list of block devices
    - LP: #684304
  * [Config] add vmw-balloon driver to -virtual flavour
    - LP: #592039
  * rebase to v2.6.37-rc7

  [ Upstream Kernel Changes ]

  * rebase to v2.6.37-rc7
 -- Andy Whitcroft <email address hidden> Tue, 21 Dec 2010 13:35:28 +0000

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Andy Whitcroft (apw) on 2010-12-22
Changed in linux (Ubuntu Maverick):
assignee: nobody → Andy Whitcroft (apw)
status: New → In Progress

Accepted into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in linux (Ubuntu Maverick):
status: In Progress → Fix Committed
tags: added: verification-needed
Steve Conklin (sconklin) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed' to 'verification-done'.

If verification is not done by one week from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

Dmitry Torokhov (dtor) wrote :

Verified that the driver is present in package linux-image-2.6.35-25-virtual. Thanks!

tags: removed: verification-needed
tags: added: verification-done
Launchpad Janitor (janitor) wrote :
Download full text (24.4 KiB)

This bug was fixed in the package linux - 2.6.35-25.44

---------------
linux (2.6.35-25.44) maverick-proposed; urgency=low

  [ Upstream Kernel Changes ]

  * Revert "drm/radeon/kms: properly compute group_size on 6xx/7xx"
    - LP: #703553

linux (2.6.35-25.43) maverick-proposed; urgency=low

  [ Brad Figg ]

  - LP: #697948

  [ Andy Whitcroft ]

  * [Config] add vmware-balloon driver to -virtual flavour
    - LP: #592039

  [ Manoj Iyer ]

  * SAUCE: Enable jack sense for Thinkpad Edge 13
    - LP: #685015

  [ Robert Hooker ]

  * Revert "(pre-stable): input: Support Clickpad devices in ClickZone
    mode"
    - LP: #669399

  [ Stefan Bader ]

  * Set virtual flavour maximum of domain visible memory to 70G
    - LP: #667796

  [ Takashi Iwai ]

  * SAUCE: input: Support Clickpad devices in ClickZone mode
    - LP: #516329

  [ Tim Gardner ]

  * [Config] Add nfsd modules to -virtual flavour
    - LP: #688070
  * [Config] Added autofs4.ko to -virtual flavour
    - LP: #692917

  [ Upstream Kernel Changes ]

  * intel_idle: delete substates DEBUG modparam
    - LP: #684888
  * intel_idle: delete power_policy modparam, and choose substate functions
    - LP: #684888
  * intel_idle: add support for Westmere-EX
    - LP: #684888
  * intel_idle: recognize Lincroft Atom Processor
    - LP: #684888
  * x86, mwait: Move mwait constants to a common header file
    - LP: #684888
  * intel_idle: Change mode 755 => 644
    - LP: #684888
  * intel_idle: add missing __percpu markup
    - LP: #684888
  * cpuidle: extend cpuidle and menu governor to handle dynamic states
    - LP: #684888
  * intel_idle: Voluntary leave_mm before entering deeper
    - LP: #684888
  * intel_idle: enable Atom C6
    - LP: #684888
  * intel_idle: simplify test for leave_mm()
    - LP: #684888
  * intel_idle: delete bogus data from cpuidle_state.power_usage
    - LP: #684888
  * intel_idle: add initial Sandy Bridge support
    - LP: #684888
  * intel_idle: do not use the LAPIC timer for ATOM C2
    - LP: #684888
  * staging: usbip: Notify usb core of port status changes
    - LP: #686158
  * staging: usbip: Process event flags without delay
    - LP: #686158
  * Staging: phison: fix problem caused by libata change
    - LP: #686158
  * perf_events: Fix bogus AMD64 generic TLB events
    - LP: #686158
  * perf_events: Fix bogus context time tracking
    - LP: #686158
  * powerpc/perf: Fix sampling enable for PPC970
    - LP: #686158
  * pcmcia: synclink_cs: fix information leak to userland
    - LP: #686158
  * sched: Drop all load weight manipulation for RT tasks
    - LP: #686158
  * sched: Fix string comparison in /proc/sched_features
    - LP: #686158
  * bluetooth: Fix missing NULL check
    - LP: #686158
  * futex: Fix errors in nested key ref-counting
    - LP: #686158
  * cifs: fix broken oplock handling
    - LP: #686158
  * libahci: fix result_tf handling after an ATA PIO data-in command
    - LP: #686158
  * mm, x86: Saving vmcore with non-lazy freeing of vmas
    - LP: #686158
  * x86, cpu: Fix renamed, not-yet-shipping AMD CPUID feature bit
    - LP: #686158
  * x86, kexec: Make sure to stop all CPUs before exiting the kernel
    - LP: #686158
  * x86, olpc: Don...

Changed in linux (Ubuntu Maverick):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers