Lenovo Thinkpad x100e freezes when X blanks screen

Bug #591699 reported by Brian Candler on 2010-06-09
48
This bug affects 7 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

[Moved from #535653. I have no problem with X starting up, but only when X blanks screen]

Machine is a Lenovo Thinkpad X100e model NTS5EUK:
AMD Turion(tm) Neo X2 Dual Core Processor L625 stepping 02
+ 2GB RAM, internal WLAN (realtek) and WWAN (Gobi 2000) cards. BIOS version reported is 1.21. Originally I had turned on the AMD virtualisation extensions in the BIOS, but I've now switched this back, so BIOS is at defaults including

    Config > CPU > AMD V(TM) Technology = Disabled
    Security > Memory Protection > Exection Protection = Enabled

In #535653 I reported this problem with amd64, but I've now installed i386 from scratch with exactly the same behaviour.

The laptop is connected to an Ethernet LAN and a USB CD-ROM. I have not configured wireless at all.

I can reproduce the problem as follows.
* Install Lucid 10.4 desktop i386 from CD
* apt-get update && apt-get dist-upgrade && apt-get install openssh-server
* echo "options radeon modeset=0" > /etc/modprobe.d/radeon-kms.conf
* cat >/etc/X11/xorg.conf
    Section "ServerFlags"
    Option "BlankTime" "1"
    EndSection
* reboot, let it come up to the gdm screen, then don't touch it

From another machine on the same LAN, copy a large file using scp, e.g.
    scp ubuntu-10.04-desktop-i386.iso brian@x.x.x.x:/var/tmp/

You can also periodically check the network health from another window:
    while date && ssh brian@x.x.x.x hostname; do sleep 9; done

What happens is: after 1 minute the X screen blanks. At this very instant, the laptop network connection freezes: the scp session stalls, and the laptop won't respond to ping. Moving the trackpoint, the screen comes back to life, but then the laptop is in a very fragile state and soon crashes. For example, pressing Ctrl-Alt-F1 usually freezes it instantly. Selecting "reboot" from the power menu will start the reboot process, but leave it frozen on a blank purple screen (possibly at the point of changing video mode again?). At this point the machine has to be hard powered off by pressing and holding the power button.

Extra data points:
* Login, open a terminal and type "xset s noblank" then repeat the test: the machine does NOT freeze. (I get a big "X" and a chequerboard pattern instead of the screen being fully blanked).

I think this all suggests that the X blanking is the culprit, although it's not clear why the machine should stop talking to ethernet instantly but continue along in a crippled state otherwise. (Interrupts?)

I did previous testing with amd64, recorded under #535653, but I have not repeated these tests with i386 yet. I found that:
* leaving the screen in text mode (via ctrl-alt-F1) does not crash, even if the text mode screen blanks
* installing fglrx driver didn't make a difference

Also, I was able to reproduce the problem on the train this morning on battery. All of the rest of my tests have been with mains connected.

There are two warning messages which flash up while the machine boots, I think they are these two lines from dmesg:

[ 11.310661] shpchp 0000:00:01.0: Cannot reserve MMIO region
[ 11.764446] thinkpad_acpi: Not yet supported ThinkPad detected!

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: linux-image-2.6.32-22-generic 2.6.32-22.36
Regression: No
Reproducible: Yes
ProcVersionSignature: Ubuntu 2.6.32-22.36-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-22-generic i686
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: SB [HDA ATI SB], device 0: CONEXANT Analog [CONEXANT Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: brian 1395 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'SB'/'HDA ATI SB at 0xd0600000 irq 16'
   Mixer name : 'Conexant CX20582 (Pebble)'
   Components : 'HDA:14f15066,17aa21b2,00100302'
   Controls : 12
   Simple ctrls : 10
Date: Wed Jun 9 12:32:46 2010
HibernationDevice: RESUME=UUID=8506a093-2f4a-42b5-a0b3-fedceb946b13
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
MachineType: LENOVO 35085EG
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-22-generic root=UUID=750a8dc7-cec8-4a9d-bf77-4963ad9827e9 ro quiet splash
ProcEnviron:
 LANG=en_GB.utf8
 SHELL=/bin/bash
RelatedPackageVersions: linux-firmware 1.34
RfKill:

SourcePackage: linux
dmi.bios.date: 03/26/2010
dmi.bios.vendor: LENOVO
dmi.bios.version: 6XET37WW (1.21 )
dmi.board.name: INVALID
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr6XET37WW(1.21):bd03/26/2010:svnLENOVO:pn35085EG:pvrThinkPadX100e:rvnLENOVO:rnINVALID:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 35085EG
dmi.product.version: ThinkPad X100e
dmi.sys.vendor: LENOVO

Brian Candler (b-candler) wrote :
Brian Candler (b-candler) wrote :

Did "apt-get fglrx" and reboot, same behaviour.

I will attach /var/log/Xorg.0.log and /var/log/messages both for radeon (original) and after installing fglrx.

The messages file has a few "[drm] Resetting GPU" lines, not sure if they are relevant.

Brian Candler (b-candler) wrote :
Brian Candler (b-candler) wrote :
Brian Candler (b-candler) wrote :
Brian Candler (b-candler) wrote :

As another experiment, I changed the kernel to this mainline one:

http://kernel.ubuntu.com/~kernel-ppa/mainline/drm-next/current/linux-image-2.6.34-996-generic_2.6.34-996.201006021548_i386.deb

When the screen blanked, the network died as before. But then moving the trackpoint or pressing a key didn't wake up the screen either; it just stayed completely black.

At the moment it's looking like my best workaround is going to be to turn off everything which might possibly blank the screen (in which case I may as well reinstall amd64 too)

Brian Candler (b-candler) wrote :

Updated BIOS to 1.23-1.19 using CD image from
http://www-307.ibm.com/pc/support/site.wss/document.do?lndocid=MIGR-74277

No change :-(

Brian Candler (b-candler) wrote :

Trying another kernel, this time:
http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.35-rc1-lucid/linux-image-2.6.35-020635rc1-generic_2.6.35-020635rc1_i386.deb
(referred to from bug #557736 which is about thinkpad_acpi not loading)

Results:
* No warning about thinkpad_acpi at bootup (still one about "Cannot reserve MMIO region" though)
* Network continued for a while after screen blanking, but then still locked up. Again, once the lookup had occurred, I could wake up the screen by moving trackpoint - but then clicking on the 'shutdown' option in the gdm screen caused the machine to hang hard, mouse cursor frozen.
* after reboot, lsmod shows thinkpad_acpi present
* Fn-F5 enables bluetooth (but I still can't see my WWAN card)

So some improved functionality, but no resolution to this lockup problem :-(

Even if it did, I'm not sure I'd be happy running an rc kernel which is 3 clicks ahead of the standard Lucid one...

Jeremy Foshee (jeremyfoshee) wrote :

Hi Brian,

If you could also please test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

    [This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete
Brian Candler (b-candler) wrote :

As hopefully you can see described above, I've tried two upstream kernels without fixing the problem:

http://kernel.ubuntu.com/~kernel-ppa/mainline/drm-next/current/linux-image-2.6.34-996-generic_2.6.34-996.201006021548_i386.deb

http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.35-rc1-lucid/linux-image-2.6.35-020635rc1-generic_2.6.35-020635rc1_i386.deb

If you'd like me to try another one please point me to specifically which one. I note that

http://kernel.ubuntu.com/~kernel-ppa/mainline/daily/current/

contains no kernel (only linux-headers, linux-source, and BUILD.LOG)

tags: removed: needs-upstream-testing
Brian Candler (b-candler) wrote :

Tried updating BIOS to 1.25, but it doesn't make any difference.

I do have a very quick way to replicate the problem now, using xset:
(1) login to gdm and bring up a terminal window
(2) from another device, start scp'ing a large file to the thinkpad:
    scp something.iso x.x.x.x:/dev/null
(3) on the thinkpad, type "xset s 1"

After one second the screen blanks, and a couple of seconds later the scp freezes. Moving the pointer on the thinkpad brings the screen back to life, but it crashes soon afterwards.

Changed in linux (Ubuntu):
status: Incomplete → Triaged
importance: Undecided → Medium
tags: added: kernel-graphics
removed: graphics
René Fleschenberg (rene.f) wrote :

I am having similar problems with a ThinkPad x100e and Kubuntu lucid. Most of the time, the machine will freeze after logging into KDM, at the beginning of KDE startup.

René Fleschenberg (rene.f) wrote :

I tried the latest mainline kernel (linux-image-2.6.36-999-generic_2.6.36-999.201008220905_i386.deb). The issue seems to be fixed there.

ThorbjørnTux (martsummsw) wrote :

#13
Can you tell us how you installed this kernel.
I tried with two different linux-image-2.6.36-999-generic_2.6.36-999.201009xxhhmm_i386.deb
(Installed with dpkg -i However X failed to start with this kernel on kubuntu)

ThorbjørnTux (martsummsw) wrote :

Well probably the fglrx needed some new kernel modules ... (!)
However with rc4 the wireless network did not just work. I guess I will just wait ...

ThorbjørnTux (martsummsw) wrote :

I begin to feel unsure if this Bug contains more than one bug.....
My problem with kubuntu 9.04->10.10 seems to be that it can go to sleep but not wake up.
This only happens if wired network is enabled. If I am on a wireless network it will only disconnect - but wake up ...

Could somebody check if this issue is reproducible when only gdm window left alone even though the Xorg will blank the screen. I am experiencing something similar on my (Debian) system, but the sympthoms does not look the same fully. E.g. in my case the system did not freeze if the gdm login left open even when after the screen goes blank.

I am using Debian system, but though that additional info will be applicable here too. Here is corresponding bug in Debian BTS:

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=605909

Looks to be a kind of similar problem.

Bryce Harrington (bryce) on 2011-06-28
tags: removed: xorg-needs-kernel-fix
tags: added: kernel-handoff-graphics

Brian Candler, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

Also, could you please test the latest upstream kernel available following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Please do not test the daily kernel folder, but the one all the way at the bottom. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-v3.12-rc3

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

Changed in linux (Ubuntu):
status: Triaged → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.