[Maverick] omap flavour does not work on beagle XM board

Bug #589624 reported by Oliver Grawert on 2010-06-04
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Lee Jones

Bug Description

trying to boot the omap flavour of maverick on a beagle XM results in an oops

Oliver Grawert (ogra) wrote :
Changed in linux (Ubuntu):
importance: Undecided → High
tags: added: armel
Andy Whitcroft (apw) on 2010-06-04
tags: added: maverick
summary: - omap flavour does not work on beagle XM board
+ [Maverick] omap flavour does not work on beagle XM board
Jeremy Foshee (jeremyfoshee) wrote :

Hi Oliver,

Please be sure to confirm this issue exists with the latest development release of Ubuntu. ISO CD images are available from http://cdimage.ubuntu.com/daily-live/current/ . If the issue remains, please run the following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux 589624

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

    [This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-kernel-logs
tags: added: needs-upstream-testing
tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete
Changed in linux (Ubuntu):
status: Incomplete → Triaged
Oliver Grawert (ogra) on 2010-06-11
Changed in linux (Ubuntu):
milestone: none → maverick-alpha-2
Lee Jones (lag) wrote :

Hi Oliver,

When was the last time you tried to boot?

Have you tried upgrading to the latest kernel (Ubuntu-2.6.35-6.9)?

I have been booting successfully on the XM for a few days now.

Would you be kind enough to try again and report back here please?

Changed in linux (Ubuntu):
assignee: nobody → Lee Jones (lag)
Lee Jones (lag) on 2010-08-20
Changed in linux (Ubuntu):
status: Triaged → In Progress
Oliver Grawert (ogra) on 2010-08-20
Changed in linux (Ubuntu):
milestone: maverick-alpha-2 → ubuntu-10.10-beta
Ricardo Salveti (rsalveti) wrote :

Currently it seems that the only bug that's blocking xM is bug 613855. With that fixed xM will probably work fine.

If you want to test I generated a kernel at http://people.canonical.com/~rsalveti/maverick/kernel/linux-image-2.6.35-19-omap_2.6.35-19.25rsalveti1_armel.deb with the proposed fix for bug 613855. With this kernel it seems that everything works fine, besides a kernel trace that shouldn't affect much:
[ 0.000000] ------------[ cut here ]------------
[ 0.000000] WARNING: at /home/ubuntu/kernel/ubuntu-maverick/arch/arm/mach-omap2/serial.c:727 omap_serial_init_port+0x88/0x1f8()
[ 0.000000] (null): can't init uart3, no clocks available
[ 0.000000] Modules linked in:
[ 0.000000] [<c004c438>] (unwind_backtrace+0x0/0x100) from [<c051334c>] (dump_stack+0x18/0x1c)
[ 0.000000] [<c051334c>] (dump_stack+0x18/0x1c) from [<c0081a78>] (warn_slowpath_common+0x5c/0x6c)
[ 0.000000] [<c0081a78>] (warn_slowpath_common+0x5c/0x6c) from [<c0081b2c>] (warn_slowpath_fmt+0x38/0x40)
[ 0.000000] [<c0081b2c>] (warn_slowpath_fmt+0x38/0x40) from [<c0010814>] (omap_serial_init_port+0x88/0x1f8)
[ 0.000000] [<c0010814>] (omap_serial_init_port+0x88/0x1f8) from [<c00109b4>] (omap_serial_init+0x30/0x3c)
[ 0.000000] [<c00109b4>] (omap_serial_init+0x30/0x3c) from [<c00125e0>] (omap3_beagle_init+0x6c/0xfc)
[ 0.000000] [<c00125e0>] (omap3_beagle_init+0x6c/0xfc) from [<c000c660>] (customize_machine+0x24/0x2c)
[ 0.000000] [<c000c660>] (customize_machine+0x24/0x2c) from [<c00443bc>] (do_one_initcall+0x3c/0x1dc)
[ 0.000000] [<c00443bc>] (do_one_initcall+0x3c/0x1dc) from [<c00085b4>] (do_basic_setup+0x64/0x74)
[ 0.000000] [<c00085b4>] (do_basic_setup+0x64/0x74) from [<c0008654>] (kernel_init+0x90/0x120)
[ 0.000000] [<c0008654>] (kernel_init+0x90/0x120) from [<c0045af4>] (kernel_thread_exit+0x0/0x8)
[ 0.000000] ---[ end trace da227214a82491b7 ]---

Note: as my xM (P8) has memory issues, I need to boot it with mem=256M.

Ricardo Salveti (rsalveti) wrote :

Working fine with current pre-installed 20100830 image (besides the serial trace).

Changed in linux (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments