kernel BUG at /build/buildd/linux-ti-omap-2.6.33/drivers/video/omap2/dss/core.c:323!

Bug #588243 reported by Zygmunt Krynicki on 2010-06-01
26
This bug affects 3 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Bryan Wu
linux-ti-omap (Ubuntu)
High
Bryan Wu

Bug Description

Crashed during shutdown.
Lucid omap3 kernel on a beagle board rev C4
Video output via HDMI link to a HDMI monitor

[ OK ]ounting weak filesystems...
 * Will now halt
[ 920.850830] kernel BUG at /build/buildd/linux-ti-omap-2.6.33/drivers/video/omap2/dss/core.c:323!
[ 920.860107] Unable to handle kernel NULL pointer dereference at virtual address 00000000
[ 920.868560] pgd = c 3 920.871368] [00000000] *pgd=00000000
[ 920.875091] Internal error: Oops: 805 [#1]
[ 920.879302] last sysfs file: /sys/kernel/uevent_seqnum
[ 920.884613] Modules linked in: asix usbnet omap_wdt musb_hdrc twl4030_usb leds_gpio
[ 920.892608] CPU: 0 Not tainted (2.6.33-60-Ubuntu)
[ 920.898620] PC is at __bug+0x18/0x24
[ 920.902313] LR is at __bug+0x14/0x24
[ 920.906036] pc : [<c00375f0>] lr : [<c00375ec>] psr: 60000013
[ 920.906036] sp : cefd5e 800000000 fp : 00000000
[ 920.917816] r10: 00000000 r9 : cefd4000 r8 : c0033ba8
[ 920.923217] r7 : 00000000 r6 : c026dd24 r5 : cefd5e50 r4 : 00000003
[ 920.929901] r3 : 00000000 528 r1 : c05be880 r0 : 0000006a
[ 920.936645] Flags: nZCv IRQs on FIQs on Mode SVC_32 ISA ARM Segment user
[ 920.943969] Control: 10c5387d Table: 8f368019 DAC: 00000015
[ 920.94c8ess halt (pid: 531, stack limit = 0xcefd42e8)
[ 920.955780] Stack: (0xcefd5e28 to 0xcefd6000)
8[688] 5e40: 00000000 c026dd34 c05b6d70 c02a0acc cf846a78 ced8fd70 bf00d0b8 c05bd6e0c027731c
[ 920.977111] 5e60: c065dfc4 4321fedc 00000058 c02a23d4 c02a23bc c029db94 4321fedc 28121969
[ 920.985533]21fedc c0074ed8 4321fedc c0075094 00000000 4002c000 00000000 ceea6548
[ 920.993927] 5ea0: ceed53c0 cf368000 cf369000 00000000 00000000 c00d69c0 0000000d 00000000
[ 921.002349] 5ec0: 0000001 cefd5fb0 80000007 ceed53c0 4002c3fc 000000c6 cefd5fb0
[ 921.010772] 5ee0: 80000007 c042fc24 c05be2b8 ffffffff 00000007 c05ae474 4002c3fc cefd5fb0
[ 921.019165] 5f00: 00000000 00000000 0a03325c ced6c580 c05be288 cefd5f6c c042c348
[ 921.027587] 5f20: cefd5f34 cf35ed40 00000013 c042c670 0001ab3f 00000000 66ed3516 000000d6
[ 921.036010] 5f40: 00007736 00000000 0067d7ac cefd10ac 00000000 00000024 00000000
[ 921.044403] 5f60: cefd4000 00000000 cefd5f7c c042c670 40000001 ceeaa440 00000000 ceeaa400
[ 921.052825] 5f80: 00000000 c010f050 2a009f3c 00000002 0000000002000002 beb67c88
[ 921.061248] 5fa0: 00000058 c0033a00 2a009f3c 00000002 fee1dead 28121969 4321fedc 00000058
[ 921.069641] 5fc0: 2a009f3c 00000002 beb67c88 00000058 00000000 00000000 2a000f00
[ 921.083007] 5fe0: 2a009f50 beb67c88 2a00128f 400c0c32 00000030 fee1dead 00000000 00000000
5[58] [<c0267d98>] (dss_clk_disable+0x80/0x98) from [<c026dbd0>] (omapdss_dpi_display_disable+0x20/0x3c)
[ 921.124725] [<c026dbd0>] (omapdss_dpi_display_disable+0x20/0x3c) from [<c027731c>] _gdisable+0xc/0x18)
[ 921.140502] [<c027731c>] (generic_panel_disable+0xc/0x18) from [<c026dd34>] (dss_disable_device+0x10/0x18)
[ 921.155639] [<c026dd34>] (dss_disable_device+0x10/0x18) f0o2a0acc>] (bus_for_each_dev+0x60/0x8c)
[ 921.170501] [<c02a0acc>] (bus_for_each_dev+0x60/0x8c) from [<c02a23d4>] (platform_drv_shutdown+0x18/0x1c)
[ 921.185699] [<c02a23d4>] (platform_drv8s/0x1c) from [<c029db94>] (device_shutdown+0x84/0xac)
[ 921.200897] [<c029db94>] (device_shutdown+0x84/0xac) from [<c0074ed8>] (kernel_halt+0xc/0x24)
[ 921.215179] [<c0074ed8>] (kernel_ha)t from [<c0075094>] (sys_reboot+0x15c/0x1ec)
[ 921.229309] [<c0075094>] (sys_reboot+0x15c/0x1ec) from [<c0033a00>] (ret_fast_syscall+0x0/0x2c)
[ 921.243927] Code: e1a01000 e59f000c eb0fd235000 (e5833000)
[ 921.258483] OMAPFB: pan_display(0)
[ 921.267669] OMAPFB: setcmap
[ 921.276062] OMAPFB: setcmap
[ 921.297393] OMAPFB: setcmap
[ 921.305725] ---[ end trace 99e3d6f6
                                      0Segmentation fault

Revision history for this message
Zygmunt Krynicki (zyga) wrote :

Linux localhost.localdomain 2.6.33-500-omap #6-Ubuntu Thu Apr 15 08:44:09 UTC 2010 armv7l GNU/Linux

Revision history for this message
Jeremy Foshee (jeremyfoshee) wrote :

Hi Zygmunt,

Please be sure to confirm this issue exists with the latest development release of Ubuntu. ISO CD images are available from http://cdimage.ubuntu.com/daily-live/current/ . If the issue remains, please run the following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux 588243

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

    [This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-kernel-logs
tags: added: needs-upstream-testing
tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete
Revision history for this message
Zygmunt Krynicki (zyga) wrote :

Jeremy: this bug is present in the latest release. I don't have the installation that caused it before so I'm not sure if running apport-collect will make sense anymore. I have a more stable installation and I will try to reproduce this issue again there.

For the record: this is the ubuntu-on-arm initiative, OMAP TI kernel on the beagleboard rev c4

Paul Larson (pwlars) on 2010-06-07
Changed in linux (Ubuntu):
status: Incomplete → New
tags: added: armel linaro
Revision history for this message
Paul Larson (pwlars) wrote :

bah, invalidating the linux task because I opened a new one insead of converting :(

Changed in linux (Ubuntu):
status: New → Invalid
Changed in linux-ti-omap (Ubuntu):
assignee: nobody → Bryan Wu (cooloney)
Revision history for this message
Bryan Wu (cooloney) wrote :

Zygmunt,

Do you still face this issue on your Beagle board? I don't have hardware yet.

It looks like that this oops was generated here:

drivers/video/omap2/dss/core.c:323
----
void dss_clk_disable(enum dss_clock clks)
{
        if (cpu_is_omap34xx()) {
                unsigned num_clks = count_clk_bits(clks);

                BUG_ON(core.num_clks_enabled < num_clks);

                if (core.num_clks_enabled == num_clks)
                        save_all_ctx();
        }

        dss_clk_disable_no_ctx(clks);
}

Thanks,
-Bryan

Revision history for this message
Robert Nelson (robertcnelson) wrote :

Bryan,

Talked to upstream about this a month ago:

http://www.spinics.net/lists/linux-omap/msg30138.html

Till there's a significant rewrite i'm using this quick workaround that hides the problem, buy un-suspending the display before reboot..

http://bazaar.launchpad.net/~beagleboard-kernel/+junk/2.6-stable/annotate/head:/patches/dss2/reboot-fix.diff

Regards,

Revision history for this message
Paul Larson (pwlars) wrote :

I'm still hitting this on the Linaro image with 2.6.35-14-omap

Revision history for this message
Paul Larson (pwlars) wrote :

Reopening the Linux task, it seems the omap kernel no longer has a separate source package. This happens whenever I try to reboot, or shutdown the system, and as noted in a previous comment, is a known upstream bug as well.

Changed in linux (Ubuntu):
importance: Undecided → High
status: Invalid → Triaged
Revision history for this message
Lee Jones (lag) wrote :

Bryan,

Robert suggests that this may be the fix for this issue.

http://www.spinics.net/lists/linux-omap/msg34582.html

Revision history for this message
Robert Nelson (robertcnelson) wrote :

Just finished testing on my 2.6.35 kernel, and it fixes the bug for me.. It's also much cleaner then my own solution..

Regards,

Revision history for this message
Bryan Wu (cooloney) wrote :

Robert and Lee,

Thanks for pointing out this. I've reproduced this issue on my board.

And will try the patch in the mail list.

-Bryan

Revision history for this message
Bryan Wu (cooloney) wrote :

I tested the version 2 patch from Stanley Miao and uploaded it into my git tree
http://kernel.ubuntu.com/git?p=roc/ubuntu-lucid.git;a=shortlog;h=refs/heads/lp588243

Please find a kernel for testing:
http://people.canonical.com/~roc/kernel/lp588243/

I am still waiting for the review from maintainers for this patch. If it is merged into upstream linux-omap tree, I will backport to lucid and maverick soon.

-Bryan

Changed in linux-ti-omap (Ubuntu):
status: New → In Progress
importance: Undecided → Medium
importance: Medium → High
Changed in linux (Ubuntu):
status: Triaged → In Progress
assignee: nobody → Bryan Wu (cooloney)
tags: added: lucid maverick verification-needed
Revision history for this message
Mathieu Poirier (mathieu.poirier) wrote :

Stanley Miao's patch has been submitted and should be applied shortly:

http://bugs.launchpad.net/bugs/588243

Changed in linux (Ubuntu):
status: In Progress → Fix Committed
Changed in linux-ti-omap (Ubuntu):
status: In Progress → Fix Committed
Revision history for this message
Leann Ogasawara (leannogasawara) wrote :

This should be resolved as of 2.6.35-21.30. Marking Fix Released for Maverick.

linux (2.6.35-21.30) maverick; urgency=low

  [ Andy Whitcroft ]

  * SAUCE: fbcon -- fix OOPs triggered by race prevention fixes
    - LP: #614008

  [ Daniel Lezcano ]

  * SAUCE: fix compilation warning when CONFIG_SECURITY is not set

  [ Henrik Rydberg ]

  * SAUCE: Input: wacom - add fuzz parameters to features
  * SAUCE: Input: wacom - collect device quirks into single function
  * SAUCE: Input: wacom - add support for the Bamboo Touch trackpad
  * SAUCE: Input: wacom - add a quirk for low resolution Bamboo devices
  * SAUCE: hid: ntrig: Remove unused device ids
  * SAUCE: hid: ntrig: remove sysfs nodes
  * SAUCE: hid: ntrig: Correct logic for quirks
  * SAUCE: hid: ntrig: zero-initialize ntrig struct
  * SAUCE: hid: ntrig: Setup input filtering manually
  * SAUCE: hid: ntrig: New ghost-filtering event logic

  [ Leann Ogasawara ]

  * SAUCE: ndiswrapper: Initialize buffer index and check its value
    - LP: #613796

  [ Manoj Iyer ]

  * SAUCE: Add support for Intellimouse Mode in ALPS touchpad on Dell E2
    series Laptops
    - LP: #632884

  [ Ping Cheng ]

  * SAUCE: Input: wacom - parse the Bamboo device family

  [ Rafi Rubin ]

  * SAUCE: hid: ntrig: identify firmware version (wiggled)

  [ Tim Gardner ]

  * [Config] CONFIG_NL80211_TESTMODE=n

  [ Upstream Kernel Changes ]

  * Revert "input: mt: Add support for the Bamboo Touch trackpad"
  * e1000e: initial support for 82579 LOMs
  * e1000e: correct MAC-PHY interconnect register offset for 82579
  * (pre-stable) ALSA: hda - Add a new hp-laptop model for Conexant 5066,
    tested on HP G60
    - LP: #587388
  * DSS2: Don't power off a panel twice
    - LP: #588243
  * mmc: build fix: mmc_pm_notify is only available with CONFIG_PM=y
  * Input: i8042 - reset keyboard controller wehen resuming from S2R
    - LP: #86820
  * ALSA: hda - Fix beep frequency on IDT 92HD73xx and 92HD71Bxx codecs
    - LP: #414795
  * agp/intel: Support the extended physical addressing bits on
    Sandybridge.
    - LP: #632488
  * drm/i915,intel_agp: Add support for Sandybridge D0
    - LP: #632488
  * (pre-stable) intel_agp,i915: Add more sandybridge graphics device ids
    - LP: #632488
  * mmc: omap: fix for bus width which improves SD card's peformance.
 -- Leann Ogasawara <email address hidden> Tue, 07 Sep 2010 09:58:52 -0700

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Revision history for this message
Tobin Davis (gruemaster) wrote :

Marking as fix released as this was fixed a long time ago.

Changed in linux-ti-omap (Ubuntu):
status: Fix Committed → Fix Released
Revision history for this message
Paolo Pisati (p-pisati) wrote :
Download full text (3.8 KiB)

still present in Lucid:

 * Will now restart
[10485.309844] kernel BUG at /home/flag/canonical/ubuntu-lucid/drivers/video/omap2/dss/core.c:323!
[10485.318664] Unable to handle kernel NULL pointer dereference at virtual address 00000000
[10485.326873] pgd = cc754000
[10485.329620] [00000000] *pgd=00000000
[10485.333221] Internal error: Oops: 805 [#1]
[10485.337310] last sysfs file: /sys/kernel/kexec_loaded
[10485.342407] Modules linked in: nls_iso8859_1 nls_cp437 omap_wdt leds_gpio
[10485.349243] CPU: 0 Not tainted (2.6.33-502-omap #10)
[10485.354614] PC is at __bug+0x1c/0x24
[10485.358184] LR is at __bug+0x18/0x24
[10485.361785] pc : [<c0038a78>] lr : [<c0038a74>] psr: 60000013
[10485.361785] sp : c1513e20 ip : 00000000 fp : 00000000
[10485.373321] r10: 00000000 r9 : c1512000 r8 : c0034c08
[10485.378570] r7 : c02a59fc r6 : c1513e48 r5 : 00000000 r4 : 00000003
[10485.385131] r3 : 00000000 r2 : c062a928 r1 : 60000013 r0 : 00000069
[10485.391693] Flags: nZCv IRQs on FIQs on Mode SVC_32 ISA ARM Segment user
[10485.398864] Control: 10c5387d Table: 8c754019 DAC: 00000015
[10485.404632] Process reboot (pid: 3701, stack limit = 0xc15122e8)
[10485.410675] Stack: (0xc1513e20 to 0xc1514000)
[10485.415069] 3e20: 00000002 c029e92c c0622fd8 c02a58a8 c0622fd8 c02b0718 00000000 c02a5a0c
[10485.423278] 3e40: 00000002 c02dd620 cf846a78 ceee3870 c0342720 c06297b0 c06ca1c4 01234567
[10485.431488] 3e60: 00000003 c02df14c c02df134 c02da4fc 00000000 c062c078 01234567 c0079bf0
[10485.439727] 3e80: 00000000 c0079c28 00000000 c0079db4 00020002 4002d000 00000000 cf9bd180
[10485.447937] 3ea0: cee45540 cc754000 cc755000 00000000 00000000 c00e4480 0000000c 00000000
[10485.456146] 3ec0: 00000000 c14d41f0 c1513fb0 80000007 cee45540 4002d3cc 000000c8 c1513fb0
[10485.464385] 3ee0: 80000007 c0497bdc c153e01c c14d4e80 00000007 c061a6dc 4002d3cc c1513fb0
[10485.472595] 3f00: 00000004 00000000 2a009f3c c0034260 0000000f c005c4d4 000001c8 c0494638
[10485.480804] 3f20: 0001e848 00000000 c062a358 c063791c c061a940 c0629d10 4d23435b 00000989
[10485.489044] 3f40: 00007735 00000000 0046509a c1512000 c063827c 00000000 00000024 00000000
[10485.497253] 3f60: c1512000 00000000 c1513f7c c0494638 00000001 c14e4a40 00000001 c14e4a00
[10485.505462] 3f80: 00000001 c011ff10 2a009f3c 00000000 00000000 2a009f3c 00000000 00000000
[10485.513702] 3fa0: 00000058 c0034a60 2a009f3c 00000000 fee1dead 28121969 01234567 00000003
[10485.521911] 3fc0: 2a009f3c 00000000 00000000 00000058 00000004 00000000 2a009f3c 00000000
[10485.530120] 3fe0: 00000058 bebb8cac 400d63ad 4004f896 00000030 fee1dead 00000000 00000000
[10485.538360] [<c0038a78>] (__bug+0x1c/0x24) from [<c029e92c>] (dss_clk_disable+0x88/0x98)
[10485.546508] [<c029e92c>] (dss_clk_disable+0x88/0x98) from [<c02a58a8>] (omapdss_dpi_display_disable+0x20/0x3c)
[10485.556579] [<c02a58a8>] (omapdss_dpi_display_disable+0x20/0x3c) from [<c02b0718>] (generic_panel_disable+0xc/0x18)
[10485.567047] [<c02b0718>] (generic_panel_disable+0xc/0x18) from [<c02a5a0c>] (dss_disable_device+0x10/0x18)
[10485.576782] [<c02a5a0c>] (dss_disable_device+0x10/0x18) from [<c02dd620>] (bus_for_each_dev+0x60/0x8c)
[10485.586151] [<c02dd620>] (bus_for_e...

Read more...

Changed in linux-ti-omap (Ubuntu):
status: Fix Released → Confirmed
Revision history for this message
Tobin Davis (gruemaster) wrote :

Marking as won't fix. Lucid was the beginning of the enablement of this system, and this was fixed in Maverick. The lucid image for this system was a tech preview release only.

Changed in linux-ti-omap (Ubuntu):
status: Confirmed → Triaged
status: Triaged → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments