[regression] RT2800 wireless does not work

Bug #588113 reported by Seth Hikari on 2010-06-01
64
This bug affects 12 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

01:09.0 Network controller: RaLink RT2760 Wireless 802.11n 1T/2R Cardbus

In Linux Kernel 2.6.34-5 will not connect to network. Can see them though. Open or not. Receive message at boot

May 30 18:46:54 Twilight-Linux kernel: [ 1370.140528] phy0 -> rt2x00pci_regbusy_read: Error - Indirect register access failed: offset=0x00007010, value=0x05100000
May 30 18:46:54 Twilight-Linux kernel: [ 1370.141050] phy0 -> rt2x00pci_regbusy_read: Error - Indirect register access failed: offset=0x00007010, value=0x05100000
May 30 18:46:54 Twilight-Linux kernel: [ 1370.141561] phy0 -> rt2x00pci_regbusy_read: Error - Indirect register access failed: offset=0x00007010, value=0x05100000
May 30 18:46:54 Twilight-Linux kernel: [ 1370.161768] phy0 -> rt2800pci_mcu_status: Error - MCU request failed, no response from hardware
May 30 18:46:54 Twilight-Linux kernel: [ 1370.293530] ADDRCONF(NETDEV_UP): wlan0: link is not ready
May 30 18:47:13 Twilight-Linux kernel: [ 1389.800527] phy0 -> rt2x00pci_regbusy_read: Error - Indirect register access failed: offset=0x00007010, value=0x05100000
May 30 18:47:13 Twilight-Linux kernel: [ 1389.801050] phy0 -> rt2x00pci_regbusy_read: Error - Indirect register access failed: offset=0x00007010, value=0x05100000
May 30 18:47:13 Twilight-Linux kernel: [ 1389.801561] phy0 -> rt2x00pci_regbusy_read: Error - Indirect register access failed: offset=0x00007010, value=0x05100000
May 30 18:47:13 Twilight-Linux kernel: [ 1389.821769] phy0 -> rt2800pci_mcu_status: Error - MCU request failed, no response from hardware

Using 2.6.34-2 to send this, works fine in this kernel
---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.22.1.
Architecture: amd64
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'NVidia'/'HDA NVidia at 0xfe020000 irq 21'
   Mixer name : 'Nvidia MCP77/78 HDMI'
   Components : 'HDA:11d4198b,1043829b,00100400 HDA:10de0002,10de0101,00100000'
   Controls : 52
   Simple ctrls : 28
Card1.Amixer.info:
 Error: command ['amixer', '-c', '1', 'info'] failed with exit code 1: amixer: Mixer load hw:1 error: Invalid argument
 Card hw:1 'CameraB404271'/'OmniVision Technologies, Inc. USB Camera-B4.04.27.1 at usb-0000:00:04.1-3, high'
   Mixer name : 'USB Mixer'
   Components : 'USB1415:2000'
   Controls : 1
Card1.Amixer.values: Error: command ['amixer', '-c', '1'] failed with exit code 1: amixer: Mixer hw:1 load error: Invalid argument
DistroRelease: Ubuntu 10.10
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Alpha amd64 (20100602.2)
MachineType: System manufacturer System Product Name
Package: linux (not installed)
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.34-5-generic root=UUID=bc8dd064-b538-44a0-82ae-7d0a91fa98e9 ro quiet splash
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.34-5.13-generic 2.6.34
Regression: Yes
RelatedPackageVersions: linux-firmware 1.35
Reproducible: Yes
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
StagingDrivers: rt2860sta
Tags: maverick networking regression-potential needs-upstream-testing staging
Title: [STAGING]
Uname: Linux 2.6.34-5-generic x86_64
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 01/05/2009
dmi.bios.vendor: Phoenix Technologies, LTD
dmi.bios.version: ASUS M3N-HT Deluxe ACPI BIOS Revision 1901
dmi.board.name: M3N-HT DELUXE
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: 1.XX
dmi.chassis.asset.tag: 123456789000
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnPhoenixTechnologies,LTD:bvrASUSM3N-HTDeluxeACPIBIOSRevision1901:bd01/05/2009:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnM3N-HTDELUXE:rvr1.XX:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer

Seth Hikari (sethhikari) wrote :

Maybe duplicate of Bug #539794 ?

tags: added: maverick regression-potential
Jeremy Foshee (jeremyfoshee) wrote :

Hi Seth,

Please be sure to confirm this issue exists with the latest development release of Ubuntu. ISO CD images are available from http://cdimage.ubuntu.com/daily-live/current/ . If the issue remains, please run the following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux 588113

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

    [This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-kernel-logs
tags: added: needs-upstream-testing
tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete
Seth Hikari (sethhikari) wrote :

I have ran the daily build CD and it also contains this bug, I will compile the upstream kernel to see if it may still be present there.

tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Jeremy Foshee (jeremyfoshee) wrote :

Seth,
   Compiling shouldn't be necessary. The link above to the mainline builds should get you to an image to test on from the Kernel PPA.

Thanks!

~JFo

Seth Hikari (sethhikari) wrote :

Oh that would of been nice to know for the last kernel bug I worked on. But I have just tested that current 2.6.35-rc1 and the bug is not present there.

tags: removed: needs-kernel-logs needs-upstream-testing
Changed in linux (Ubuntu):
status: Incomplete → New
tags: added: kernel-net
Changed in linux (Ubuntu):
status: New → Triaged
tags: added: iso-testing
Seth Hikari (sethhikari) wrote :

Seems to be fixed in kernel 2.6.35-1

Changed in linux (Ubuntu):
status: Triaged → Fix Released

I have this problem with the latest daily live cd on my netbook. Also note that in Lucid the rt3090sta driver was used, but now rt2800usb and rt2870sta are loaded (I don't have a usb version).

BTW, using this kernel: http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.36-rc5-maverick/ it all seems to work fine when installed on Lucid.

Guy Taylor (thebiggerguy) wrote :

This is in 10.10 fully update (15/10/2010)

Log:
phy0 -> rt2x00pci_regbusy_read: Error - Indirect register access failed: offset=0x0000101c, value=0xffffffff

Version:
$ cat /proc/version
Linux version 2.6.35-22-generic (buildd@vernadsky) (gcc version 4.4.5 (Ubuntu/Linaro 4.4.4-14ubuntu5) ) #35-Ubuntu SMP Sat Oct 16 20:36:48 UTC 2010

Kenny Strawn (kenny-strawn) wrote :

Can reproduce this problem on Quantal (3.5.0-23) as well, so I think this report needs to be reopened...

Kenny Strawn (kenny-strawn) wrote :

And attached is my "dmesg | grep regbusy" output on Quantal (using a Linksys WMP600N desktop PCI adapter, which happens to have an RT2860 chip) to confirm the issue...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers