aufs oops in au_do_open() on maverick live system boot

Bug #587888 reported by Martin Pitt on 2010-05-31
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Critical
Andy Whitcroft
Maverick
Critical
Andy Whitcroft

Bug Description

I just built the first maverick desktop CD: http://cdimage.ubuntu.com/daily-live/current/ (20100531 at the time of this report). When booting, the plymouth screen stays on forever. When booting without splash and quiet, you can see that there are three oopses in the aufs module.

Attaching screenshot of the oops.

This was confirmed on both i386 and amd64, with the 2.6.34-5.12 kernel.

Martin Pitt (pitti) wrote :
Changed in linux (Ubuntu Maverick):
assignee: nobody → Canonical Kernel Team (canonical-kernel-team)
importance: Undecided → Critical
milestone: none → maverick-alpha-2
status: New → Triaged
Martin Pitt (pitti) wrote :

Setting to alpha-2 for now. It's not the end of the world if we release alpha-1 without desktop images. If it's an easy fix, it'd be great to have, of course. Thanks in advance!

Andy Whitcroft (apw) on 2010-06-01
Changed in linux (Ubuntu Maverick):
assignee: Canonical Kernel Team (canonical-kernel-team) → Andy Whitcroft (apw)
Andy Whitcroft (apw) wrote :

Hrm, so far not managed to reproduce this booted onto the 2.6.34-5 kernel. Below I have mounted a faked squashfs filesystem loop back on /root/RO, I have also mounted a tmpfs on RW, and then unioned them onto /root/ROOT. Basic functionality seems to work:

  # df
  [...]
  /dev/loop0 128 128 0 100% /root/RO
  tmpfs 1021280 20 1021260 1% /root/RW
  aufs 1021280 20 1021260 1% /root/ROOT
  # cat /proc/version_signature
  Ubuntu 2.6.34-5.12-generic 2.6.34

It appears Kees is able to reproduce this oops as reported in bug 585175, which I'll mark as a duplicate here.

"Trivial use of aufs doesn't crash, but trying to start up an aufs directory from schroot fails, and then the umount cannot even clean it up. During set up, it's /etc/schroot/setup.d/22nssdatabases that finally triggers the issue."

Kees Cook (kees) wrote :

To reproduce this:

mk-sbuild lucid
schroot -c lucid-amd64 (or lucid-i386, whatever is native for you)

(requires ubuntu-dev-tools, and that you've run mk-sbuild at least once before to set up the permissions, etc)

Andy Whitcroft (apw) wrote :

I have updated the aufs2 version to the latest for 2.6.34 and it seems to allow me to boot the live CD at least. Pushed patches to the kernel-team list for review.

Changed in linux (Ubuntu Maverick):
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.34-5.13

---------------
linux (2.6.34-5.13) maverick; urgency=low

  [ Andy Whitcroft ]

  * Revert "ubuntu: AUFS -- aufs2 20091209"
  * Revert "ubuntu: AUFS -- export various core functions
    (aufs2-standalone.patch)"
  * Revert "ubuntu: AUFS -- export various core functions
    (aufs2-base.patch)"
  * ubuntu: AUFS -- aufs2 base patch for linux-2.6.34
    - LP: #587888
  * ubuntu: AUFS -- aufs2 standalone patch for linux-2.6.34
    - LP: #587888
  * ubuntu: AUFS -- update to standalone 2.6.34 as at 20100601
    - LP: #587888
  * [Config] AUFS -- enable aufs options
    - LP: #587888
 -- Leann Ogasawara <email address hidden> Tue, 01 Jun 2010 08:56:43 -0700

Changed in linux (Ubuntu Maverick):
status: In Progress → Fix Released
Andy Whitcroft (apw) on 2010-06-02
Changed in linux (Ubuntu Maverick):
milestone: maverick-alpha-2 → maverick-alpha-1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related blueprints

Bug attachments