Ubuntu

[HP G60]0x103c360b Conexant CX20583 (Pebble HSF) Internal mic not functional

Reported by NoOp on 2010-05-30
32
This bug affects 5 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
David Henningsson
Maverick
Undecided
Unassigned

Bug Description

=== Current workaround ===
1) Make sure no other extra sound drivers are installed, e g packages beginning with "linux-backports-modules-alsa-"
2) Download and install
http://people.canonical.com/~diwic/temp/alsa-intel-hda-update-diwic-hp-g60-dkms_1.0.23_all.deb
3) Reboot
===

Internal mic is not working in lucid 10.04.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: alsa-base 1.0.22.1+dfsg-0ubuntu3
ProcVersionSignature: Ubuntu 2.6.32-22.33-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-22-generic x86_64
AlsaVersion:
 Advanced Linux Sound Architecture Driver Version 1.0.22.1.
 Compiled on Apr 29 2010 for kernel 2.6.32-22-generic (SMP).
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: CONEXANT Analog [CONEXANT Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: lucid 1429 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xd4700000 irq 30'
   Mixer name : 'Intel G45 DEVCTG'
   Components : 'HDA:14f15067,103c360b,00100301 HDA:80862802,80860101,00100000'
   Controls : 12
   Simple ctrls : 7
Date: Sat May 29 18:05:20 2010
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Beta amd64 (20100318)
PackageArchitecture: all
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: alsa-driver
dmi.bios.date: 09/11/2009
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: F.53
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 3612
dmi.board.vendor: Wistron
dmi.board.version: 09.66
dmi.chassis.asset.tag: Chassis Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: Wistron
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnHewlett-Packard:bvrF.53:bd09/11/2009:svnHewlett-Packard:pnHPG60NotebookPC:pvr0392120000200C10000020000:rvnWistron:rn3612:rvr09.66:cvnWistron:ct10:cvrChassisVersion:
dmi.product.name: HP G60 Notebook PC
dmi.product.version: 0392120000200C10000020000
dmi.sys.vendor: Hewlett-Packard

NoOp (glgxg) wrote :
NoOp (glgxg) on 2010-05-30
summary: - Internal mic not functional
+ Conexant CX20583 (Pebble HSF) Internal mic not functional
NoOp (glgxg) wrote :

$ apt-cache policy linux-backports-modules-alsa-lucid-generic
linux-backports-modules-alsa-lucid-generic:
  Installed: 2.6.32.22.23
  Candidate: 2.6.32.22.23
  Version table:
 *** 2.6.32.22.23 0
        500 http://archive.ubuntu.com/ubuntu/ lucid-updates/main Packages
        100 /var/lib/dpkg/status
     2.6.32.21.22 0
        500 http://archive.ubuntu.com/ubuntu/ lucid/main Packages

options snd-hda-intel model=olpc-xo-1_5
or
options snd-hda-intel model=dell-vostro
resolves the headphone/speaker issue on my HP G60-530US Notebook with 'linux-backports-modules-alsa-lucid-generic' installed in lucid. However the internal mic no longer works afterwards. alsa-base.conf attached.

NoOp (glgxg) on 2010-06-02
summary: - Conexant CX20583 (Pebble HSF) Internal mic not functional
+ 0x103c360b Conexant CX20583 (Pebble HSF) Internal mic not functional
NoOp (glgxg) on 2010-06-13
tags: added: kernel-bug

Still no responses to this bug & it is still apparent in 10.04 2.6.32-24-generic.

Have you tried updating your alsa drivers, as outlined here: https://wiki.ubuntu.com/Audio/InstallingLinuxAlsaDriverModules^

If not, please update as above, and report back as to whether this helps.

 affects ubuntu/alsa-driver
 status incomplete

Changed in alsa-driver (Ubuntu):
status: New → Incomplete

So let me get this correct... you are recommending that a standard user install packages from:
sudo add-apt-repository ppa:ubuntu-audio-dev/ppa
"Crack of the Day" builds of alsa-driver code.
to troubleshoot this issue? Sorry, but I've been there & done that months ago (see:
https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/477154?comments=all
and
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/573284
(start around comment #9)
and please see:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/573284/comments/5

I'm already using linux-backports-modules-alsa in order to get the speaker/headphone jack working properly. I'll not install ppa:ubuntu-audio-dev/ppa (I just had to do an in-place reinstall to get the partition that I'd tested this on previously back to working condition). I suggest that you take the existing information provided and work on the issue. I can provide an updated alsa-info.txt if needed, and sincerely appreciate the offer to assist, the but to suggest that I install a daily/dev/ppa series of packages to troubleshoot the issue isn't viable IMO.

Note that the CX20582's also still have this issue as well. Again, thanks for having a look - if you can help sort this out a *lot* of folks will be very happy.

David Henningsson (diwic) wrote :

NoOp, I (and Luke) recommend people to try c-o-d for regular users because it is seldom unstable and because they are easy to uninstall.

Looking at your codec it indeed looks like the ADC path is not configured correctly, and if none of the models (I assume you've already tried them all) are working correctly, a new model needs to be written. Doing that requires a user willing to test, perhaps several unstable versions of the driver until it works. Are you willing to do that?

David Henningsson (diwic) wrote :

If you do, the first thing I'd like you to do is to download and install snd-hda-tools from ppa:ubuntu-audio-dev and start "sudo hda_analyzer", then go to node 0x14, and make sure connection 0x17 is selected.

> If you do, the first thing I'd like you to do is to download and install
> snd-hda-tools from ppa:ubuntu-audio-dev and start "sudo hda_analyzer",
> then go to node 0x14, and make sure connection 0x17 is selected.
>

I'll put a new 10.04 install on a test partition on the laptop, test &
report back today. Shall I also add
linux-backports-modules-alsa-lucid-generic and modify the
/etc/modprobe.d/alsa-base.conf file to add:
options snd-hda-intel model=olpc-xo-1_5
or do you want it run only with ppa:ubuntu-audio-dev packages?

NoOp, thanks for reporting back. I'd like you to run with ppa:ubuntu-audio-dev packages only.

As for initial model selection, can you give me a summary of what models you've tested so far, and what the results were of the different models were?

Changed in alsa-driver (Ubuntu):
status: Incomplete → In Progress
assignee: nobody → David Henningsson (diwic)
NoOp (glgxg) wrote :

OK. I've got the test partition up & working. With a base install & no additional packages/ppa's/backports, the internal mic does work... providing that I enable it as Mic F in gnome-alsamixer (see screenshot). No model is specified in /etc/modprobe.d/alsa-base.conf. I'll get an alsa-info.txt snapshot of the machine in this state before adding the dev ppa.

Note: The problem (internal mic not working) occurs when adding linux-backports-alsa-lucid-generic and modifying /etc/modprobe.d/alsa-base.conf to add model="olpc-xo-1_5" to fix the separate problem with the speakers & headphones enabled at the same time. The backports/model resolves the speakers/headphone issue, but in the process the internal mic no longer works (external mic via the mic jack does continue to work).

NoOp (glgxg) wrote :

alsa-info.txt_testpartition

Here is the snapshot of the machine w/no added packages (backports/ppa etc).

NoOp (glgxg) wrote :
NoOp (glgxg) wrote :

My apologies... I just realized that I _did_ have linux-backports-alsa-lucid-generic installed. I'll remove & start again before adding the ppa.

NoOp (glgxg) wrote :

Alsa-info without backports. Internal mic is not working. Also note the difference in gnome-alsamixer. I'll do the dev ppa next.

NoOp (glgxg) wrote :

Screenshot of gnome-alsamixer with backports removed.

NoOp (glgxg) wrote :

dev ppa added &
sudo apt-get install linux-alsa-driver-modules-$(uname -r)
sudo apt-get snd-hda-tools.

Rebooted & select Mic F in gnome-alsamixer - internal mic working (speakers/headphones on at same time).
Attaching alsa-info & gnome-alsamixer screenshot.

NoOp (glgxg) wrote :
NoOp (glgxg) wrote :

sudo hda_analyzer:

As instructed in comment #8 I go to node 0x14 - there is not option to select 0x17 from there. Screenshot attached (node editor is blank/empty).

$ sudo hda_analyzer
/usr/bin/hda_analyzer:173: DeprecationWarning: Use the new widget gtk.Tooltip
  self.tooltips = gtk.Tooltips()
/usr/bin/hda_analyzer:189: DeprecationWarning: Use the new widget gtk.Tooltip
  self.tooltips.set_tip(button, "README! Show the purpose of this program.")
/usr/bin/hda_analyzer:193: DeprecationWarning: Use the new widget gtk.Tooltip
  self.tooltips.set_tip(button, "Revert settings for selected codec.")
/usr/bin/hda_analyzer:197: DeprecationWarning: Use the new widget gtk.Tooltip
  self.tooltips.set_tip(button, "Show settings diff for selected codec.")
Traceback (most recent call last):
  File "/usr/bin/hda_analyzer", line 336, in selection_changed_cb
    self.__refresh()
  File "/usr/bin/hda_analyzer", line 304, in __refresh
    self.load()
  File "/usr/bin/hda_analyzer", line 363, in load
    self.__build_node(n)
  File "/usr/bin/hda_analyzer", line 833, in __build_node
    dev = node.get_device()
  File "/usr/share/snd-hda-tools/hda_codec.py", line 657, in get_device
    return self.codec.get_device(self.nid)
  File "/usr/share/snd-hda-tools/hda_codec.py", line 1214, in get_device
    return self.proc_codec.get_device(nid)
  File "/usr/share/snd-hda-tools/hda_proc.py", line 762, in get_device
    node = self.proc_nids[nid]
KeyError: 20

NoOp (glgxg) wrote :

Added 'options snd-hda-intel model="olpc-xo-1_5"' to /etc/modprobe.d/alsa-base.conf in order to fix the speaker/headphone issue; both work properly after adding: internal speakers turn off when headphones plugged in, and turn back on when headphones are unplugged. However, now the internal mic no longer works (external mic plugged in does work).

Alsa-info & gnome-alsamixer screenshot attached.

NoOp (glgxg) wrote :
NoOp (glgxg) wrote :

Sorry, forgot to mention that hda analyzer is showing this on 0x14:

Node 0x14 [Audio Input] wcaps 0x100d1b: Stereo Amp-In R/L
  Amp-In caps: ofs=0x4a, nsteps=0x50, stepsize=0x03, mute=1
  Amp-In vals: [0x50 0x50] [0x80 0x80] [0x50 0x50] [0x80 0x80]
  Converter: stream=1, channel=0
  SDI-Select: 0
  PCM:
    rates [0x160]: 44100 48000 96000
    bits [0xe]: 16 20 24
    formats [0x1]: PCM
  Power: setting=D0, actual=D0
  Connection: 4
     0x17* 0x18 0x23 0x24

David Henningsson (diwic) wrote :

NoOp, thanks for the report. I've made a first version of the patch for you. For this test, you should first make sure that the audio drivers from ppa:ubuntu-audio-dev is *not* installed, and that no model is selected. Then download and install http://people.canonical.com/~diwic/temp/alsa-intel-hda-update-diwic-hp-g60-dkms_1.0.23_all.deb (make sure it installs without errors), and reboot.

If everything works:
* speakers should auto-mute when hp is plugged in
* auto-switch to external mic when plugged in (internal mic should work otherwise), i e no manual mic selection
* you won't have any SPDIF anymore, since it is not physically present.

Can you see if this is working for you, and regardless of which, post an alsa-info with this new patch enabled. Thanks!

NoOp (glgxg) wrote :

Removed dev ppa (linux-alsa-driver-modules), removed the model from alsa-base.conf. Rebooted and then installed the .deb patch. Rebooted again.

Close: Speakers & Heaphones work properly. Internal mic still not working, external mic works.

Attached is the alsa-info. And thanks for working on this issue.

David Henningsson (diwic) wrote :

Okay. I've made a second version of the patch, please download and install http://people.canonical.com/~diwic/temp/alsa-intel-hda-update-diwic-hp-g60-dkms_1.0.23_all.deb , reboot. Check whether everything is working now, and if the internal mic is still not working, could you please give me one alsa-info with the ext mic plugged in, and one with the ext mic unplugged (i e when the int mic should be active)? Thanks!

NoOp (glgxg) wrote :

Yes! David you are the man! Everything is working; speakers, headphones, internal mic, and external mic!! Thank you, thank you, thank you!

I am attaching alsa-info for internal mic and external mic.

Thanks again David.

Gary Lee

NoOp (glgxg) wrote :
description: updated
description: updated
David Henningsson (diwic) wrote :

Cool, great we got this sorted out! Status update - upstream ALSA has accepted the patch and I'm trying to make sure we'll have sound working G60 in Maverick out-of-the-box.
Thanks for the cooperation :-)

Changed in alsa-driver (Ubuntu):
status: In Progress → Fix Committed
NoOp (glgxg) wrote :

David, just want to let you know that I did a 10.10 maverick network update on that test partition on the laptop this evening & all bits are working properly: speakers work, headphones work (speakers are mute while headphones plugged in), internal mic works, external mic works. I did not uninstall your .deb before upgrading so if you'd like any alsa-info etc., information let me know. I can also perform a clean 10.10 install over the upgraded 10.04 to 10.10 after you've sufficient information from the upgrade if you'd like.

David Henningsson (diwic) wrote :

@NoOp, once this bug turns from "Fix committed" to "fix released" by the Launchpad Janitor (and the package reaches your mirror etc) you can expect it to be working without my deb, until then you'll need my deb to make it work.

Hi David,
I met this problem on my lenovo thinkpad x100e laptop. Internal microphone doesn't work on 10.04 and just upgraded to maverik. I've installed also your deb, but it doesn't help. Please help alsa_info with your deb installed.
Adam

David Henningsson (diwic) wrote :

 @Adam, you're having different hardware, so your mic bug is a different one. Please file a new bug using the "ubuntu-bug audio" terminal command. Thank you!

summary: - 0x103c360b Conexant CX20583 (Pebble HSF) Internal mic not functional
+ [HP G60]0x103c360b Conexant CX20583 (Pebble HSF) Internal mic not
+ functional

This should be resolved as of 2.6.35-21.30. Marking Fix Released for Maverick.

linux (2.6.35-21.30) maverick; urgency=low

  [ Andy Whitcroft ]

  * SAUCE: fbcon -- fix OOPs triggered by race prevention fixes
    - LP: #614008

  [ Daniel Lezcano ]

  * SAUCE: fix compilation warning when CONFIG_SECURITY is not set

  [ Henrik Rydberg ]

  * SAUCE: Input: wacom - add fuzz parameters to features
  * SAUCE: Input: wacom - collect device quirks into single function
  * SAUCE: Input: wacom - add support for the Bamboo Touch trackpad
  * SAUCE: Input: wacom - add a quirk for low resolution Bamboo devices
  * SAUCE: hid: ntrig: Remove unused device ids
  * SAUCE: hid: ntrig: remove sysfs nodes
  * SAUCE: hid: ntrig: Correct logic for quirks
  * SAUCE: hid: ntrig: zero-initialize ntrig struct
  * SAUCE: hid: ntrig: Setup input filtering manually
  * SAUCE: hid: ntrig: New ghost-filtering event logic

  [ Leann Ogasawara ]

  * SAUCE: ndiswrapper: Initialize buffer index and check its value
    - LP: #613796

  [ Manoj Iyer ]

  * SAUCE: Add support for Intellimouse Mode in ALPS touchpad on Dell E2
    series Laptops
    - LP: #632884

  [ Ping Cheng ]

  * SAUCE: Input: wacom - parse the Bamboo device family

  [ Rafi Rubin ]

  * SAUCE: hid: ntrig: identify firmware version (wiggled)

  [ Tim Gardner ]

  * [Config] CONFIG_NL80211_TESTMODE=n

  [ Upstream Kernel Changes ]

  * Revert "input: mt: Add support for the Bamboo Touch trackpad"
  * e1000e: initial support for 82579 LOMs
  * e1000e: correct MAC-PHY interconnect register offset for 82579
  * (pre-stable) ALSA: hda - Add a new hp-laptop model for Conexant 5066,
    tested on HP G60
    - LP: #587388
  * DSS2: Don't power off a panel twice
    - LP: #588243
  * mmc: build fix: mmc_pm_notify is only available with CONFIG_PM=y
  * Input: i8042 - reset keyboard controller wehen resuming from S2R
    - LP: #86820
  * ALSA: hda - Fix beep frequency on IDT 92HD73xx and 92HD71Bxx codecs
    - LP: #414795
  * agp/intel: Support the extended physical addressing bits on
    Sandybridge.
    - LP: #632488
  * drm/i915,intel_agp: Add support for Sandybridge D0
    - LP: #632488
  * (pre-stable) intel_agp,i915: Add more sandybridge graphics device ids
    - LP: #632488
  * mmc: omap: fix for bus width which improves SD card's peformance.
 -- Leann Ogasawara <email address hidden> Tue, 07 Sep 2010 09:58:52 -0700

affects: alsa-driver (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
NoOp (glgxg) wrote :

Confirmed working on my HP G60-53US laptop (partition running 10.10 Maverick test partition):

$ apt-cache policy linux-image-2.6.35-21-generic
linux-image-2.6.35-21-generic:
  Installed: 2.6.35-21.31
  Candidate: 2.6.35-21.31
  Version table:
 *** 2.6.35-21.31 0
        500 http://archive.ubuntu.com/ubuntu/ maverick/main amd64 Packages
        100 /var/lib/dpkg/status

1. Purged David's alsa-intel-hda-update-diwic-hp-g60-dkms_1.0.23_all.deb (thanks again David).
2. Rebooted with linux-image-2.6.35-21-generic.
3. Tested laptop speakers using Rythmbox. Laptop speakers work, plugging in external headset (standard earbuds) works (laptop speakers mute properly when headset is plugged in & speakers turn back on when headset is unplugged).
4. Tested internal/external mic function using guvcview. Internal mic works, external mic works.

All appears to now be working properly - thanks!

Any possibility that this can/will be backported to lucid 10.04 LTS?

David Henningsson (diwic) wrote :

It will, in time - it is currently working its way through upstream.

Accepted linux into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in linux (Ubuntu Maverick):
status: New → Fix Committed
tags: added: verification-needed
NoOp (glgxg) wrote :

@Martin: sorry, I've been travelling. I'll try to test later this evening or tomorrow & will report back then.

NoOp (glgxg) wrote :

Works (mic and headphones). Still waiting for lucid fix... thanks.

Martin Pitt (pitti) on 2010-11-02
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :
Download full text (16.2 KiB)

This bug was fixed in the package linux - 2.6.35-23.40

---------------
linux (2.6.35-23.40) maverick-proposed; urgency=low

  [ Brad Figg ]

  * No change rebuild.

linux (2.6.35-23.39) maverick-proposed; urgency=low

  [ Brad Figg ]
    - LP: #676214

  [ Ricardo Salveti de Araujo ]

  * SAUCE: ARM: OMAP3: beagle: use GPIO2 on the xM A3 to turn DVI on
    - LP: #663642

linux (2.6.35-23.38) maverick-proposed; urgency=low

  [ Brad Figg ]

  * Revert "SAUCE: ARM: OMAP3: beagle: use GPIO2 on the xM A3 to turn DVI
    on"

  [ Upstream Kernel Changes ]

  * Revert "(upstream) ALSA: hda - Apply ALC269 VAIO fix-up to all Sony
    laptops with ALC269"
  * Revert "ALSA: HDA: Correctly apply position_fix quirks for ATI and VIA
    controllers"
  * Buglink Fixup for reverted unverified fixes

linux (2.6.35-23.37) maverick-proposed; urgency=low

  [ Brad Figg ]

  * ARM: Temporarily disable module check for armel

linux (2.6.35-23.36) maverick-proposed; urgency=low

  [ Andy Whitcroft ]

  * reduce disk usage during buildd builds
    - LP: #645653

  [ Brad Figg ]

  * ARM: Temporarily disable module check for armel

  [ Enric Balletbo i Serra ]

  * ARM: igepv2: Adding support for VBUS and overcurrent
    - LP: #651589
  * ARM: igepv2: Fix and improve LED handling
    - LP: #654582
  * ARM: igepv2: Introduce function to dectect HW version
    - LP: #654586
  * ARM: igepv2: Fix handling of GPIOs for WLAN-BT combo
    - LP: #654590
  * ARM: igepv2: Add i2c eeprom driver to read EDID
    - LP: #654594
  * ARM: igepv2: Remove VMMC2 regulator
    - LP: #654595

  [ Leann Ogasawara ]

  * ARM: Temporarily disable module check for armel

  [ Mathieu Poirier ]

  * SAUCE: ARM: Add DSS2 support for Overo board
    - LP: #660811

  [ Maurus Cuelenaere ]

  * SAUCE: ARM: OMAP3: Add S-Video output to IGEPv2 board
    - LP: #607250

  [ Ricardo Salveti de Araujo ]

  * [Config] Remove CONFIG_FIXED_PHY and move CONFIG_SMSC911X from m to y
    for omap
    - LP: #645689
  * SAUCE: ARM: OMAP3: Adding vdd_sdi regulator supply to IGEPv2 board
    - LP: #607250
  * SAUCE: ARM: OMAP3: beagle: use GPIO2 on the xM A3 to turn DVI on
    - See: #663642

  [ Upstream Kernel Changes ]

  * Revert "(pre-stable) ALSA: HDA: Use model=auto for LG R510"
  * Revert "(pre-stable) ALSA: hda - Rename iMic to Int Mic on Lenovo
    NB0763"
  * Revert "Input: appletouch - fix integer overflow issue"
  * Revert "ALSA: hda - Handle pin NID 0x1a on ALC259/269"
  * Revert "ALSA: hda - Handle missing NID 0x1b on ALC259 codec"
  * Revert "(pre-stable) ALSA: hda - Add a new hp-laptop model for Conexant
    5066, tested on HP G60"
  * Revert "mmc: build fix: mmc_pm_notify is only available with
    CONFIG_PM=y"
  * Revert "mmc: fix all hangs related to mmc/sd card insert/removal during
    suspend/resume"
  * Revert "(pre-stable) bounce: call flush_dcache_page() after
    bounce_copy_vec()"
  * Revert "Input: i8042 - reset keyboard controller wehen resuming from
    S2R"
  * Revert "ALSA: HDA: Enable internal speaker on Dell M101z"
  * Revert "(pre-stable) drm/i915: don't enable self-refresh on Ironlake"
  * Revert "drm/i915: Allow LVDS on pipe A on gen4+"
  * (pre-stable) ACPI: enable repeated...

Changed in linux (Ubuntu Maverick):
status: Fix Committed → Fix Released
Alan N (anise) wrote :

@adam - can you place a link to the bug you filed ? I am having same issue.

Hi,
I did not open new case. It's working in Ubuntu 10.10 (kernel 2.6.35-22) with settings:
/etc/modprobe.d/alsa-base.conf :
options snd-hda-intel model=lenovo-101e
options snd-hda-intel position_fix=1 enable=yes

NoOp (glgxg) wrote :

Re comments #34 & #35: I attempted to nominate for lucid but keep getting a launchpad opps error. Can someone *please* nominate for Lucid so that we can get the fix added there as well?

@David
I have a Toshiba Qosmio X500 with an Intel HDA sound card with the Conexant CX20583 (Pebble HSF).
After installing HDAAnalizer.py and after changing the connection from 0x23 to 0x17, the internal mic started to work.
I hope this helps you to develop a solution for other users.
Let me know if I can be of help.

David Henningsson (diwic) wrote :

@Marcelo, thanks for your report; unfortunately, it won't help us without you filing a new bug, e g with "ubuntu-bug audio", so we can get the proper information about your hardware, ask you to test with the latest snapshot etc.

For those of you having problems with the mic in the Toshiba Qosmio, this might help you:
http://ubuntuforums.org/showthread.php?p=10532125#post10532125

To post a comment you must log in.