Acer Travelmate 8000 nohz=off needed

Bug #587213 reported by zanny
36
This bug affects 6 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Expired
Medium
Unassigned

Bug Description

The system can boot also without the "nohz=off" kernel parameter, but in this case it freezes in about half a minute or less. With "nohz=off" the system boots and works

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: linux-image-2.6.32-22-generic 2.6.32-22.33
Regression: No
Reproducible: Yes
ProcVersionSignature: Ubuntu 2.6.32-22.33-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-22-generic i686
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: gab 1475 F.... pulseaudio
 /dev/snd/pcmC0D0p: gab 1475 F...m pulseaudio
CRDA: Error: command ['iw', 'reg', 'get'] failed with exit code 1: nl80211 not found.
Card0.Amixer.info:
 Card hw:0 'I82801DBICH4'/'Intel 82801DB-ICH4 with ALC202 at irq 10'
   Mixer name : 'Realtek ALC202 rev 0'
   Components : 'AC97a:414c4740'
   Controls : 37
   Simple ctrls : 23
CurrentDmesg:
 [ 40.632685] tg3: eth0: Link is up at 100 Mbps, full duplex.
 [ 40.632690] tg3: eth0: Flow control is on for TX and on for RX.
 [ 40.632881] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
 [ 41.950553] ttyS1: LSR safety check engaged!
 [ 51.056027] eth0: no IPv6 routers present
Date: Sat May 29 13:02:23 2010
HibernationDevice: RESUME=UUID=4236a3f5-2acb-453a-802a-ecfbea4669c6
Lsusb:
 Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 002: ID 04b4:6560 Cypress Semiconductor Corp. CY7C65640 USB-2.0 "TetraHub"
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: Acer TravelMate 8000
ProcCmdLine: root=/dev/sda7 ro nohz=off quiet splash
ProcEnviron:
 LANG=it_IT.utf8
 SHELL=/bin/bash
RelatedPackageVersions: linux-firmware 1.34
RfKill:

SourcePackage: linux
WpaSupplicantLog:

dmi.bios.date: 01/31/2005
dmi.bios.vendor: ACER
dmi.bios.version: 3A20
dmi.board.name: TravelMate 8000
dmi.board.vendor: Acer
dmi.board.version: Rev 1.0
dmi.chassis.asset.tag: ��������������������������������
dmi.chassis.type: 10
dmi.chassis.vendor: Acer
dmi.chassis.version: Rev.1
dmi.modalias: dmi:bvnACER:bvr3A20:bd01/31/2005:svnAcer:pnTravelMate8000:pvrRev1:rvnAcer:rnTravelMate8000:rvrRev1.0:cvnAcer:ct10:cvrRev.1:
dmi.product.name: TravelMate 8000
dmi.product.version: Rev 1
dmi.sys.vendor: Acer

Revision history for this message
zanny (zanny) wrote :
zanny (zanny)
summary: - nohz=off needed
+ Acert Travelmate 8000 nohz=off needed
Revision history for this message
Jeremy Foshee (jeremyfoshee) wrote : Re: Acert Travelmate 8000 nohz=off needed

Hi zanny,

If you could also please test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

    [This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete
Revision history for this message
zanny (zanny) wrote :

Tested with 2.6.34-999-generic #201005261208 SMP Wed May 26 12:12:50 UTC 2010 i686 GNU/Linux

The system boots also without nohz=off, and does not freeze even if the avarage load is pretty high and the process "udevd" is constantly using 95 % of the CPU even if the system is "at rest".

Attached please find dmesg

Revision history for this message
zanny (zanny) wrote :
tags: removed: needs-upstream-testing
Changed in linux (Ubuntu):
status: Incomplete → Triaged
importance: Undecided → Medium
Shahar Or (mightyiam)
summary: - Acert Travelmate 8000 nohz=off needed
+ Acer Travelmate 8000 nohz=off needed
Revision history for this message
zanny (zanny) wrote :
Download full text (4.1 KiB)

just to add that running 2.6.32-25-generic #43-Ubuntu SMP Wed Sep 1 09:46:39 UTC 2010 i686 GNU/Linux, if I boot without "nohz=off" I get error messages like in https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-ati/+bug/586243?comments=all:

ep 7 23:26:54 mick-laptop kernel: [ 347.754343] [drm:radeon_ib_schedule] *ERROR* radeon: couldn't schedule IB(0).
Sep 7 23:26:54 mick-laptop kernel: [ 347.754346] [drm:radeon_cs_ioctl] *ERROR* Faild to schedule IB !
Sep 7 23:26:54 mick-laptop kernel: [ 347.754376] [drm:radeon_ib_schedule] *ERROR* radeon: couldn't schedule IB(1).
Sep 7 23:26:54 mick-laptop kernel: [ 347.754379] [drm:radeon_cs_ioctl] *ERROR* Faild to schedule IB !
Sep 7 23:26:54 mick-laptop kernel: [ 347.765791] [drm:radeon_ib_schedule] *ERROR* radeon: couldn't schedule IB(2).
Sep 7 23:26:54 mick-laptop kernel: [ 347.765794] [drm:radeon_cs_ioctl] *ERROR* Faild to schedule IB !
Sep 7 23:26:54 mick-laptop kernel: [ 347.766126] [drm:radeon_ib_schedule] *ERROR* radeon: couldn't schedule IB(3).
Sep 7 23:26:54 mick-laptop kernel: [ 347.766129] [drm:radeon_cs_ioctl] *ERROR* Faild to schedule IB !
Sep 7 23:26:54 mick-laptop kernel: [ 347.766866] [drm:radeon_ib_schedule] *ERROR* radeon: couldn't schedule IB(4).
Sep 7 23:26:54 mick-laptop kernel: [ 347.766870] [drm:radeon_cs_ioctl] *ERROR* Faild to schedule IB !
Sep 7 23:26:54 mick-laptop kernel: [ 347.769669] [drm:radeon_ib_schedule] *ERROR* radeon: couldn't schedule IB(5).
Sep 7 23:26:54 mick-laptop kernel: [ 347.769673] [drm:radeon_cs_ioctl] *ERROR* Faild to schedule IB !
Sep 7 23:26:54 mick-laptop kernel: [ 347.769704] [drm:radeon_ib_schedule] *ERROR* radeon: couldn't schedule IB(6).
Sep 7 23:26:54 mick-laptop kernel: [ 347.769706] [drm:radeon_cs_ioctl] *ERROR* Faild to schedule IB !
Sep 7 23:26:54 mick-laptop kernel: [ 347.781450] [drm:radeon_ib_schedule] *ERROR* radeon: couldn't schedule IB(7).
Sep 7 23:26:54 mick-laptop kernel: [ 347.781454] [drm:radeon_cs_ioctl] *ERROR* Faild to schedule IB !
Sep 7 23:26:54 mick-laptop kernel: [ 347.784999] [drm:radeon_ib_schedule] *ERROR* radeon: couldn't schedule IB(8).
Sep 7 23:26:54 mick-laptop kernel: [ 347.785003] [drm:radeon_cs_ioctl] *ERROR* Faild to schedule IB !
Sep 7 23:26:54 mick-laptop kernel: [ 347.785033] [drm:radeon_ib_schedule] *ERROR* radeon: couldn't schedule IB(9).
Sep 7 23:26:54 mick-laptop kernel: [ 347.785036] [drm:radeon_cs_ioctl] *ERROR* Faild to schedule IB !
Sep 7 23:26:54 mick-laptop kernel: [ 347.797480] [drm:radeon_ib_schedule] *ERROR* radeon: couldn't schedule IB(10).
Sep 7 23:26:54 mick-laptop kernel: [ 347.797484] [drm:radeon_cs_ioctl] *ERROR* Faild to schedule IB !
Sep 7 23:26:54 mick-laptop kernel: [ 347.797860] [drm:radeon_ib_schedule] *ERROR* radeon: couldn't schedule IB(11).
Sep 7 23:26:54 mick-laptop kernel: [ 347.797863] [drm:radeon_cs_ioctl] *ERROR* Faild to schedule IB !
Sep 7 23:26:54 mick-laptop kernel: [ 347.798597] [drm:radeon_ib_schedule] *ERROR* radeon: couldn't schedule IB(12).
Sep 7 23:26:54 mick-laptop kernel: [ 347.798601] [drm:radeon_cs_ioctl] *ERROR* Faild to schedule IB !
Sep 7 23:26:54 mick-laptop kernel: [ 347.800341] [drm:radeon_ib_schedul...

Read more...

Revision history for this message
Christopher M. Peñalver (penalvch) wrote :

zanny, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

Also, could you please test the latest upstream kernel available following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Please do not test the daily kernel folder, but the one all the way at the bottom. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-v3.12-rc2

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

Changed in linux (Ubuntu):
status: Triaged → Incomplete
Revision history for this message
Bernmeister (thebernmeister) wrote :

FWIW, this is still an issue in Ubuntu 13.04 (and Lubuntu 13.04).

Unfortunately the laptop in question recently stopped booting up and I've not had a chance to get it fixed (if possible)...so I can't test the most recent build.

Revision history for this message
Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers