[STAGING] maverick amd64 regression: can not connect to ad-hoc WEP WLAN

Bug #584266 reported by Wolfgang Kufner on 2010-05-22
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

STATUS: (2011-03-01)
fixed rt2800pci is now in maverick-proposed

SUMMARY UPDATE:
This bug touches on two different drivers for the same hardware. The in kernel, preferred rt2800pci and the rt2860sta from staging (which linux wireless developers are not happy with, but is needed where the rt2800pci does not yet work):
In maverick the rt2800pci driver (rt2x00 project) is the default driver for this hardware. This driver also works in ad hoc mode. This works well on 32 bit. On 64 bit this driver does not work because of the 64bit-only bug 659143 (load_firmware: Error). If that bug were fixed ad hoc would hopefully work as well for 64bit and _for_this_particular_hardware nothing more would have to be done.
The default driver for lucid for this hardware was rt2860sta (version 1.8.1.1) from staging, which could do ad hoc. In maverick rt2860sta (version 2.1.0.0) is included and can be used by blacklisting the default rt2800pci. Maverick's version of the rt2860sta fails in ad hoc mode. I have compiled the latest GPL driver ralink provides on their website. It is version 2.4.0.0 and works well in ad hoc mode. (The release notes for that version mention: "Fix Adhoc issue." (see https://bugs.launchpad.net/ubuntu/+source/linux/+bug/594866/comments/11).)

REFERENCES:
The version of the rt2860sta driver can by found in drivers/staging/rt2860/rt_linux.h #define STA_DRIVER_VERSION statement.

(With WPA it did not work in lucid either. Connecting to a router in infrastructure mode with WPA works well.)

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: linux-image-2.6.34-3-generic 2.6.34-3.10
Regression: Yes
Reproducible: Yes
ProcVersionSignature: Ubuntu 2.6.34-3.10-generic 2.6.34
Uname: Linux 2.6.34-3-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.22.1.
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: wolfgang 1368 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf4800000 irq 29'
   Mixer name : 'Intel G45 DEVCTG'
   Components : 'HDA:10ec0268,1025013c,00100101 HDA:14f12c06,10250093,00100000 HDA:80862802,80860101,00100000'
   Controls : 21
   Simple ctrls : 12
Date: Sat May 22 18:21:55 2010
HibernationDevice: RESUME=UUID=96c61eac-dc69-402b-9288-ac5469b10eec
MachineType: Acer Extensa 5630
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.34-3-generic root=UUID=c8f90551-03c2-4d41-93e1-df346762f95b ro quiet splash
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
RelatedPackageVersions: linux-firmware 1.34
RfKill:
 0: acer-wireless: Wireless LAN
  Soft blocked: no
  Hard blocked: no
SourcePackage: linux
StagingDrivers: rt2860sta
Title: [STAGING]
dmi.bios.date: 12/05/2008
dmi.bios.vendor: Phoenix Technologies LTD
dmi.bios.version: V1.25
dmi.board.name: Homa
dmi.board.vendor: Acer
dmi.board.version: Rev
dmi.chassis.type: 10
dmi.chassis.vendor: Acer
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnPhoenixTechnologiesLTD:bvrV1.25:bd12/05/2008:svnAcer:pnExtensa5630:pvr0100:rvnAcer:rnHoma:rvrRev:cvnAcer:ct10:cvrN/A:
dmi.product.name: Extensa 5630
dmi.product.version: 0100
dmi.sys.vendor: Acer

Jeremy Foshee (jeremyfoshee) wrote :

Hi Wolfgang,

If you could also please test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

    [This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete

Just tried with maverick with ubuntu's mainline build of 2.6.35rc1. It can not connect either.
It is trying with the rt2860sta module again, as before. (The rt2800pci is not even included in that build. Not sure whether that is supposed to work already.)

I also tried todays maverick iso. Does not connect either.

tags: removed: needs-upstream-testing
Changed in linux (Ubuntu):
status: Incomplete → Triaged
importance: Undecided → Medium
tags: added: kernel-needs-review kernel-net
Seth Hikari (sethhikari) wrote :

Check to make sure you bug is not the same as this one bug#588113 the RT26xxsta don't seem to be working at all anymore

Andy Whitcroft (apw) on 2010-06-07
tags: added: kernel-reviewed
removed: kernel-needs-review

Did some more testing on lucid with the mainline builds on this ad-hoc WEP use case:
In lucid kernel 2.6.32 is the last one working. 2.6.33 and 2.6.34 fail with same symptoms.

Details of the tested kernels for reference:
Linux version 2.6.32-0206321505-generic (root@zinc) (gcc version 4.2.3 (Ubuntu 4.2.3-2ubuntu7)) #0206321505 SMP Wed Jun 2 19:09:40 UTC 2010
Linux version 2.6.33-02063305-generic (root@zinc) (gcc version 4.2.3 (Ubuntu 4.2.3-2ubuntu7)) #02063305 SMP Tue Jun 1 15:08:11 UTC 2010
Linux version 2.6.34-020634-generic (root@zinc) (gcc version 4.2.3 (Ubuntu 4.2.3-2ubuntu7)) #020634 SMP Mon May 17 19:27:49 UTC 2010

Changed in linux (Ubuntu):
assignee: nobody → Rishav Thakker (thakker-rishav)
assignee: Rishav Thakker (thakker-rishav) → nobody

Tried out todays kubuntu maverick i386 live booted via grub2 loopmount (on the same hardware):
it worked right out of the box :-)
The network management panel says the driver is rt2800pci.

lsmod|grep rt
rt2860sta 504366 0
rt2800pci 8565 0
I had expected a one behind one of them.

And we have another winner with ubuntu maverick i386 live :-) . Connects fine out of the box.
All details exactly as with kubuntu i386 in the post above.

summary: - [STAGING] maverick regression: can not connect to ad-hoc WEP WLAN
+ [STAGING] maverick amd64 regression: can not connect to ad-hoc WEP WLAN
description: updated

Just connected on maverick with:

2.6.32-02063213-generic #02063213 SMP Mon May 17 11:08:46 UTC 2010 x86_64
(This kernel is from the ubuntu mainline kernel ppa. Compiled for _lucid_ .)

filename: /lib/modules/2.6.32-02063213-generic/kernel/drivers/staging/rt2860/rt2860sta.ko
version: 1.8.1.1

(btw: this kernel has the flicker bug 538648. This with current xorg-edgers.)

description: updated
description: updated

My fix for bug 659143 is now in linux-next. With that the rt2800pci driver now works fine in AdHoc mode on amd64, so there is no need anymore for the rt2860sta.
It might take some time till the fix is available in nicely prepackaged form. For now it is already available via the latest bleeding edge daily compat-wireless tarball. More info in comment 16 of bug 659143.

Since bringing the fix for bug 659143 into ubuntu will fix this matter here also I will set this a duplicate.

description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers