Ubuntu

Creative ViBRA16X - CT4170 Not activated on new install

Reported by RedTDI on 2006-09-01
10
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

I have just installed 6.06.1 on a machine that was running Suse 10.1, and the sound card seems to be found but the sound doesn't work when Ubuntu 6.06.1 is installed.

I have an ISA card that is PnP. Creative ViBRA16X - CT4170

DMESG: shows
isapnp: Scanning for PnP cards...
pnp: SB audio device quirk - increasing port range
isapnp: Card "Creative ViBRA16X PnP"
isapnp: 1 Plug & Play card detected total

So it looks like the card is found and just not activated, but I am don't know how to proceed from there. Is there some kind of work around that will activate the sound card in Ubuntu?

I have the same problem. Confirming.
Kernel version: 2.6.15-27-386 #1 PREEMPT Sat Sep 16 01:51:59 UTC 2006 i686 GNU/Linux

I have managed to solve the problem.

Steps:
1. Download isapnptools package from http://packages.ubuntulinux.org/breezy/base/isapnptools . This is version for breezy, but it works in Dapper. There is no version for Dapper.
2. Install it using dpkg -i path-to-downloaded file .
3. Create and edit file /etc/isapnp.conf and put the following contents in it:
(READPORT 0x0273)
(ISOLATE PRESERVE)
(IDENTIFY *)
(VERBOSITY 2)
(CONFLICT (IO FATAL)(IRQ FATAL)(DMA FATAL)(MEM FATAL)) # or WARNING

(CONFIGURE CTL00f4/-1 (LD 0
(INT 0 (IRQ 5 (MODE +E)))
(DMA 0 (CHANNEL 0))
(DMA 1 (CHANNEL 1))
(IO 0 (SIZE 16) (BASE 0x0240))
(IO 1 (SIZE 2) (BASE 0x0300))
(IO 2 (SIZE 4) (BASE 0x0388))
 (NAME "CTL00f4/-1[0]{Audio }")
(ACT Y)
))

(WAITFORKEY)
4. Run "isapnp /etc/isapnp.conf". If it reports errors, you must change configuration above (it is suited to my setup). Try "pnpdump -c" and put its output in /etc/isapnp.conf file. If it does not help, you must find correct configuration manually, for example change port to 0x220. For full list of possible values run pnpdump. Note that if you change the configuration, you must change options for modprobe below.
5. Create and edit file /etc/modprobe.d/sbvibra and put the following options in it:
alias snd-card-0 snd_sb16
options snd_sb16 port=0x240 irq=5 dma8=0 dma16=1 isapnp=0
6. Run "update-modules"
7. Run "modprobe snd-card-0". If it works OK (check if "ls -l /dev/dsp" shows that file is present), perform the steps below to make setup permanent:
8. Append following line to /etc/modules:
snd-card-0
8. Go to system configuration (in GUI) and choose "Services". Enable "isapnp" service and tick option to start it at boot.

Here is output of dmesg after boot. sb module is not loaded.

Here are messages printed when I run manually "modprobe snd_sb16". Options in modprobe configuration file were:
options snd_sb16 port=0x240 irq=5 dma8=0 dma16=1 isapnp=0

The same message is printed when trying "modprobe snd_sb16 isapnp=1".
When I run without setting modprobe options, message is similar, without first line, i.e.:
[62553.212837] Sound Blaster 16 soundcard not found or device busy
[62553.223456] In case, if you have AWE card, try snd-sbawe module

So it seems running isapnp tool to set up card before loading snd_sb16 module is necessary.

Beginning with the Hardy Heron 8.04 development cycle, all open Ubuntu kernel bugs need to be reported against the "linux" kernel package. We are automatically migrating this linux-source-2.6.15 kernel bug to the new "linux" package. We appreciate your patience and understanding as we make this transition. Also, if you would be interested in testing the upcoming Intrepid Ibex 8.10 release, it is available at http://www.ubuntu.com/testing . Please let us know your results. Thanks!

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Bieleke (pbielen) wrote :

Even on the new kernel this issue still remains.
Just did a fresh install and indeed, no sound.
No sb drivers loaded in lsmod.
Bad or missing 16 bit dma channel

Changed in linux (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers