unstable wireless with iwlagn

Bug #583210 reported by Jean-Christophe Baptiste on 2010-05-20
36
This bug affects 5 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
Nominated for Lucid by Jean-Christophe Baptiste

Bug Description

Wireless had always (for years) worked great on my laptop (Thinkpad T61), until I switched from openSUSE to Ubuntu Lucid few days ago.
Since then, my wifi connection has been very unstable, always flapping. Randomly but as frequent as every 3 or 4 minutes, it disconnects and reconnects. It is of course extremely annoying.

My card :
% lspci | grep Wireless
03:00.0 Network controller: Intel Corporation PRO/Wireless 4965 AG or AGN [Kedron] Network Connection (rev 61)

Please find the daemon, dmesg and syslog logs attached below.

I tried installing the backported modules without any more luck.

Thank you in advance for your help. This is the only issue I am having so far on this great distro :)

The bug is still there and extremely annoying. I have tried all possible tips I found on forums or previous bug reports :
 - deactivate hardware encryption (modprobe iwlagn swcrypto=1)
 - tried all kind of encryption combinations (WPA2 only, WPA only, TKIP, AES, WPA+WPA2, etc, except WEP)

I can't understand why there is such a regression with such old and common hardware.

affects: ubuntu → linux (Ubuntu)

I was able to solve the problem.

On my Wifi router, I had customized settings concerning the beacon and DTIM intervals (higher than default, to reduce the number of packets sent).

After I resetted these parameters to their default values (respectively 100 and 1), the stability issues vanished.
Note that I spent a lot of time trying all possible settings (signal, encryption, power) on the Tomato firware of my Linksys, so I am 100% certain that these parameters are the only causes of my problems.

Something must have changed with the new driver (not the firmware because it is the same on all distros around) in the kernel, that makes it more sensitive to exotic configurations.

tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Invalid

Invalid? Hmm not so sure. If so why wireless had always worked fine with openSUSE 11.x, Windows Vista, etc.
Even though I found a workaround, the behaviour is not normal and may hide more problem (I encountered a few kernel crash while unloading / reloading the iwlagn module).

So please don't mark it as invalid.

Changed in linux (Ubuntu):
status: Invalid → New
Jeremy Foshee (jeremyfoshee) wrote :

In your last to the bug, you indicated that you had solved the issue by manipulating your access point. In your words, "I was able to solve the problem." This is an indication that the issue was resolved by a source other than the software and would, therefore, be invalid. Now you are indicating that there were other problems that you did not mention in your previous posting that would have been relevant to the situation.

If you have data from the kernel crashes you mentioned, please post them here.

~JFo

Changed in linux (Ubuntu):
status: New → Incomplete

Sorry but I am not a native English speaker so such misunderstandings are likely to happen.
I don't have data from the kernel crash for now, but if I get it, I will fill another bug.

Concerning this bug, I indeed found a workaround, but I don't think it is acceptable.

Hardware that works with any other OS should work with Ubuntu Lucid the same way. What is this different ? Why did it fail that I had to reconfigure my wifi router ?
So the issue is still here, sure not high priority, but it requires more investigation and I think to be kept open in case more people have the same problem.

Changed in linux (Ubuntu):
status: Incomplete → New
Mark (mswal2846) wrote :

There are MANY instances of this problem in the Forums. This is definitely a problem in Ubuntu (and maybe other Linux distros .... I only use Ubuntu) and NOT a problem when running XP and Windows7. I have this connection stability problem at home, at work, and while traveling at hotels (I travel every other week). I do not believe this to be a router issue, but some sort of driver/kernal/NetworkManager issue. Often my only option is to use my wireless WAN (AT&T) card ... which, amazingly, is much more stable.

If I can provide info that will help, just let me know what you require.

I had this with Lucid. After upgrading to Maverick Alpha 3 the problem disappeared for a while. A couple of days ago the problem reappeared again.

  Hi Michael,

I'm trying the backport packages ... so far so good ... I've gone the
whole day without any drops .... but we'll see.

Regards,

Mark Swallow

Cell: 919.931.2662 (preferred)

Email: <email address hidden>

On 08/23/2010 03:57 PM, michael.huettemann wrote:
> I had this with Lucid. After upgrading to Maverick Alpha 3 the problem
> disappeared for a while. A couple of days ago the problem reappeared
> again.
>

@Mark
Thanks for the tip, will try the backports. Meanwhile I found this: http://bugzilla.intellinuxwireless.org/show_bug.cgi?id=2214
It appears that a firmware bug could be the root of the problem.

@Mark
The current wireless backports in the Maverick archives also show the problem unfortunately.

Mark (mswal2846) wrote :

So I want to sum up my 1 week experience with the backport installed packages.

I'm:
- running Ubuntu 10.04 Lucid
- running Network Manager Applet 0.8
- on a Lenovo X200
- with 2.9G of Memory (according to the System Monitor)
- with a 320G harddrive at 67% full
- connection driver is iwlagn
- connect at work (using WEP), home (using WPA2), and various airports, hotels, coffee shops.

I want to report on my experience with the backports.

Prior to installing the backport files, I would EVERY DAY loose my wireless network connection ... sometimes in a few minutes and sometimes a few hours into the day. Reconnecting was virtually impossible. If I suspended, there was a 50/50 chance that it would connect upon waking up. USUALLY (but not always) a reboot would fix the problem.

Last Friday (8/20), I installed from Synaptic Package Manager:
- linux-backports-modules-wireless-lucid-generic
- linux-backports-modules-wireless-2.6.32-24-generic

Results:
- I did NOT have a single drop all week
- I was able to reconnect from suspend EVERY time, at least every morning when I reconnected from suspending the night before
- I've not rebooted at all since I rebooted after installing the above packages last Friday (1 week ago)

The ONLY significant difference is the application of the backports modules. I did not change NetworkManager nor my wireless LAN settings, etc.

I'm a VERY happy camper!!

Rykel from Singapore (rykel98) wrote :

I have the same Intel PRO adaptor running in Ubuntu 10.10 (Maverick).

Unfortunately, it cannot connect at all to my network.

NONE of the below procedures worked:

1. Disabling the security (WPA) on my network;
2. Installing backports-modules; and
3. Disabling 11n in the /etc/modules.d/options.

The wireless card did NOT work either in Fedora 13.

Please help.

Øyvind Stegard (oyvinst) wrote :

I also have disconnection issues on Lucid x86-64 with iwlagn wireless driver (Intel WiFi 6000 Series chipset). Going to try the backports-package now, thanks for the tip.

Øyvind Stegard (oyvinst) wrote :

Unfortunately, backports-modules didn't help. Linux wireless drivers are basically utter crap, and they have always been.

Mark (mswal2846) wrote :

There was an update that came in over the last two weeks that "regress" the backports for me. So I went back to an earlier version. Can you try installing this version from the Synaptic Package Manager: "linux-backports-modules-compat-wireless-2.6.34-2.6.32-25-generic" and so far so good. Can you try this version and see if it helps you?

Øyvind Stegard (oyvinst) wrote :

Mark <email address hidden> writes:

> There was an update that came in over the last two weeks that "regress"
> the backports for me. So I went back to an earlier version. Can you
> try installing this version from the Synaptic Package Manager: "linux-
> backports-modules-compat-wireless-2.6.34-2.6.32-25-generic" and so far
> so good. Can you try this version and see if it helps you?

Ok, I'll do that and report back, thanks.

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 583210

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete

AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 1.23-0ubuntu4
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: PCH [HDA Intel PCH], device 0: CONEXANT Analog [CONEXANT Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: siml 1682 F.... pulseaudio
CRDA: Error: [Errno 2] Datei oder Verzeichnis nicht gefunden
Card0.Amixer.info:
 Card hw:0 'PCH'/'HDA Intel PCH at 0xf2520000 irq 44'
   Mixer name : 'Intel CougarPoint HDMI'
   Components : 'HDA:14f1506e,17aa21da,00100002 HDA:80862805,80860101,00100000'
   Controls : 20
   Simple ctrls : 8
Card29.Amixer.info:
 Card hw:29 'ThinkPadEC'/'ThinkPad Console Audio Control at EC reg 0x30, fw unknown'
   Mixer name : 'ThinkPad EC (unknown)'
   Components : ''
   Controls : 1
   Simple ctrls : 1
Card29.Amixer.values:
 Simple mixer control 'Console',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [off]
DistroRelease: Ubuntu 11.10
HibernationDevice: RESUME=UUID=d4710a02-9313-447b-a348-5cb0615dee6c
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
MachineType: LENOVO 4291QS0
Package: linux (not installed)
ProcEnviron:
 LANGUAGE=de_AT:de
 PATH=(custom, no user)
 LANG=de_AT.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-12-generic root=UUID=73e553e9-3f5c-415e-92dd-96a3db970007 ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
RelatedPackageVersions:
 linux-restricted-modules-3.0.0-12-generic N/A
 linux-backports-modules-3.0.0-12-generic N/A
 linux-firmware 1.60
StagingDrivers: mei
Tags: oneiric running-unity staging
Uname: Linux 3.0.0-12-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 08/02/2011
dmi.bios.vendor: LENOVO
dmi.bios.version: 8DET51WW (1.21 )
dmi.board.asset.tag: Not Available
dmi.board.name: 4291QS0
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr8DET51WW(1.21):bd08/02/2011:svnLENOVO:pn4291QS0:pvrThinkPadX220:rvnLENOVO:rn4291QS0:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 4291QS0
dmi.product.version: ThinkPad X220
dmi.sys.vendor: LENOVO

tags: added: apport-collected oneiric running-unity staging

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Po-Hsu Lin (cypressyew) wrote :

Closing this bug with Won't fix as this kernel / release is no longer supported.
Please feel free to open a new bug report if you're still experiencing this on a newer release (Bionic 18.04.3 / Disco 19.04)
Thanks!

Changed in linux (Ubuntu):
status: Incomplete → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.