Ubuntu

Synaptics Clickpad touchpad buttons are not working

Reported by Serkan Hosca on 2010-05-19
996
This bug affects 208 people
Affects Status Importance Assigned to Milestone
Linux
Invalid
Undecided
Unassigned
Release Notes for Ubuntu
Undecided
Unassigned
Xserver Xorg Input Synaptics
Fix Released
High
linux (Ubuntu)
High
Unassigned
Declined for Lucid by Chase Douglas
xserver-xorg-input-synaptics (Ubuntu)
Undecided
Unassigned
Declined for Lucid by Chase Douglas
Maverick
Undecided
Unassigned

Bug Description

I have an HP Envy 15 second generation that comes with synaptic touchpad clickpad. I was testing the maverick kernel for machine shutdown and suspend problems with new bios. Maverick kernel does not detect the touchpad as a synaptic clickpad.

If you take a look at http://kernel.ubuntu.com/git?p=ubuntu/ubuntu-maverick.git;a=blob;f=drivers/input/mouse/synaptics.c;hb=HEAD in synaptics_init() at line 773 i should be seeing clickpad enabled in dmesg but this is what i get:
$ dmesg | grep -i synaptics
[ 10.712182] Synaptics Touchpad, model: 1, fw: 7.4, id: 0x1e0b1, caps: 0xd04771/0xe40000/0x5a0400
[ 10.790705] input: SynPS/2 Synaptics TouchPad as /devices/platform/i8042/serio1/input/input13

Please see bug for more info -> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/557072 around comment #37

---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.22.1.
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: serkan 1728 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xd4200000 irq 35'
   Mixer name : 'IDT 92HD75B2X5'
   Components : 'HDA:111d7608,103c1522,00100202'
   Controls : 14
   Simple ctrls : 9
Card1.Amixer.info:
 Card hw:1 'Generic'/'HD-Audio Generic at 0xd4120000 irq 36'
   Mixer name : 'ATI R6xx HDMI'
   Components : 'HDA:1002aa01,00aa0100,00100200'
   Controls : 4
   Simple ctrls : 1
Card1.Amixer.values:
 Simple mixer control 'IEC958',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
DistroRelease: Ubuntu 10.04
HibernationDevice: RESUME=UUID=87ad52a2-0bfd-440d-ac66-d8eaf467ce3d
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
MachineType: Hewlett-Packard HP ENVY 15 Notebook PC
NonfreeKernelModules: fglrx
Package: linux (not installed)
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.34-3-generic root=UUID=940dbb3b-1397-429d-b4ab-827d69bd8be1 ro crashkernel=384M-2G:64M,2G-:128M quiet ipv6.disable=1 elevator=noop
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.34-3.10-generic 2.6.34
Regression: Yes
RelatedPackageVersions: linux-firmware 1.34
Reproducible: Yes
Tags: lucid regression-potential needs-upstream-testing
Uname: Linux 2.6.34-3-generic x86_64
UserGroups: adm admin cdrom dialout disk lpadmin plugdev sambashare
dmi.bios.date: 04/23/2010
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: F.26
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 1522
dmi.board.vendor: Hewlett-Packard
dmi.board.version: 36.34
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnHewlett-Packard:bvrF.26:bd04/23/2010:svnHewlett-Packard:pnHPENVY15NotebookPC:pvr0494110000241900001320000:rvnHewlett-Packard:rn1522:rvr36.34:cvnHewlett-Packard:ct10:cvrN/A:
dmi.product.name: HP ENVY 15 Notebook PC
dmi.product.version: 0494110000241900001320000
dmi.sys.vendor: Hewlett-Packard

description: updated
Jeremy Foshee (jeremyfoshee) wrote :

Hi Serkan,

Please be sure to confirm this issue exists with the latest development release of Ubuntu. ISO CD images are available from http://cdimage.ubuntu.com/daily-live/current/ . If the issue remains, please run the following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux 582809

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

    [This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-kernel-logs
tags: added: needs-upstream-testing
tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete

apport information

tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Serkan Hosca (serkan-hosca) wrote :

dmesg with the mainline-ppa 2.6.34-020634-generic touchpad buttons still not working.

Serkan Hosca (serkan-hosca) wrote :

dmesg with 2.6.34-999-generic touchpad buttons not working

tags: removed: needs-upstream-testing
Serkan Hosca (serkan-hosca) wrote :

So to clear up:

2.6.32 from lucid -> touchpad buttons working.
2.6.34 maverick + mainline ppa -> touchpad buttons are not working.

tags: added: maverick
tags: added: regression-potential
tags: added: kernel-input kernel-needs-review
tags: added: kernel-candidate kernel-reviewed
removed: kernel-needs-review
Changed in linux (Ubuntu):
importance: Undecided → Medium
Andy Whitcroft (apw) on 2010-06-07
tags: removed: kernel-candidate
Jeremy Foshee (jeremyfoshee) wrote :

This bug report was marked as Incomplete and has not had any updated comments for quite some time. As a result this bug is being closed. Please reopen if this is still an issue in the current Ubuntu release http://www.ubuntu.com/getubuntu/download . Also, please be sure to provide any requested information that may have been missing. To reopen the bug, click on the current status under the Status column and change the status back to "New". Thanks.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kj-expired
Changed in linux (Ubuntu):
status: Incomplete → Expired
Serkan Hosca (serkan-hosca) wrote :

What other information is needed? I thought i added all the needed logs.

Serkan Hosca (serkan-hosca) wrote :

dmesg with 2.6.35-2-generic. Clickpad buttons are not working

Changed in linux (Ubuntu):
status: Expired → Triaged
Serkan Hosca (serkan-hosca) wrote :
Serkan Hosca (serkan-hosca) wrote :
Serkan Hosca (serkan-hosca) wrote :

The attached patch enables clickpad mode and fixes the buttons.

Based on version 2.6.35-7.11

$ uname -r
2.6.35-rc4
$ dmesg | grep -i synaptics
[ 12.250343] Synaptics Touchpad, model: 1, fw: 7.4, id: 0x1e0b1, caps: 0xd04771/0xe40000/0x5a0400
[ 12.250346] Synaptics: Clickpad mode enabled
[ 12.324242] input: SynPS/2 Synaptics TouchPad as /devices/platform/i8042/serio1/input/input12

tags: added: patch

Hi Serkan

Thanks for posting this. Does this patch enable two-finger clicking &
scrolling?

Regards
Jacob

On Thu, 2010-07-08 at 18:19 +0000, Serkan Hosca wrote:

> The attached patch enables clickpad mode and fixes the buttons.
>
> Based on version 2.6.35-7.11
>
> $ uname -r
> 2.6.35-rc4
> $ dmesg | grep -i synaptics
> [ 12.250343] Synaptics Touchpad, model: 1, fw: 7.4, id: 0x1e0b1, caps: 0xd04771/0xe40000/0x5a0400
> [ 12.250346] Synaptics: Clickpad mode enabled
> [ 12.324242] input: SynPS/2 Synaptics TouchPad as /devices/platform/i8042/serio1/input/input12
>
> ** Patch added: "fix_touchpad.patch"
> http://launchpadlibrarian.net/51585549/fix_touchpad.patch
>

Serkan Hosca (serkan-hosca) wrote :

No, that is the feature i am missing the most. This only fixes the detection of the touchpad as a clickpad for the buttons. It does this by using at the product id.

Other synaptics goodies as two finger tap right click and three finger tap middle click are missing too. Also click and drag is really hard, if not done correctly the mouse cursor jumps around all over the screen and scrolls the active window wildly.

Dana Goyette (danagoyette) wrote :

Unfortunately, this very same patch that fixes the ClickPad breaks my 3-button touchpad -- see bug 612591 .

DeeKay (bloink) wrote :

I'd like to reopen the bug, but being a n00b i probably am not allowed to.

Anyhow, I'm having the same problem with a HP Pavilion dv7 3051sg. It's from the same generation as the HP Envy15, so it is likely to be the same touchpad - at least dmesg says the same thing as above.

The patch works in so far that I can actually left/right click on the lower parts of the clickpad that have been labeled as the trackpad buttons - but a click is not registered while there's still a finger on the touchpad! I have to lift the finger from the touchpad, then click on the button areas below, then place the finger on the touchpad again in order to e.g. drag & drop.

Also, as soon as two fingers (such as when dragging and clicking at the same time) are on the clickpad, the cursor quite often jerks to the left suddenly.

I assume this has got to do with the master/slave click-approach on multitouch touchpads...

Tried getting SHMConfig to work by enabling it in xorg.conf, but synclient -m 50 still tells me that it cannot access the shared memory area...

Serkan Hosca (serkan-hosca) wrote :

You might want to give a try to this patch for xorg synaptics driver:

https://patchwork.kernel.org/patch/93837/

I have the buttons working but you can forget about click+drag events, the cursor jumps all over the screen, can't move windows and can't select text with the touchpad.

DeeKay (bloink) wrote :

Serkan: from what i gather, this patch is already included in ubuntu 10.04 - otherwise the buttons would not work at all, right? ;-)

Click and drag works, as long as you lift your finger from the clickpad and *only* click on the button area. text selection works the same way...

DeeKay (bloink) wrote :

Serkan: that inability to click & drag is probably due to the mouseclick-event not registering a secondary click as an event, with the finger on the trackpad itself being the primary click (touch the touchpad -> click left mousebutton area -> drag). If the drag-event is from a secondary click and the mousebutton is the primary click (don't touch anything -> click left mousebutton area -> drag) it works though. Seeing how primary and secondary clicks already work somewhat, it should be possible to fix that behaviour without going to multitouch-APIs like MPX or Xi2....

also, a middle mouse button would rock! ;-)
Looking at your patch that should be fairly easy to implement, and since you cannot use left+right click to simulate it on that clickpad it would really be useful, seeing how many Linux-users use the middle klick, e.g. in the shell...

DeeKay (bloink) wrote :

I just updated to xf86-input-synaptics in the latest dev version 1.2.99.1 (before: 1.2.2-1ubuntu4) to no avail. No change, it still works as buggy as described above...

Here's the synaptics bits from Xorg.0.log:

(II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/event14)
(**) SynPS/2 Synaptics TouchPad: Applying InputClass "evdev touchpad catchall"
(**) SynPS/2 Synaptics TouchPad: Applying InputClass "touchpad catchall"
(II) LoadModule: "synaptics"
(II) Loading /usr/lib/xorg/modules/input/synaptics_drv.so
(II) Module synaptics: vendor="X.Org Foundation"
(II) Synaptics touchpad driver version 1.2.99.1
(--) SynPS/2 Synaptics TouchPad: x-axis range 1472 - 5472
(--) SynPS/2 Synaptics TouchPad: y-axis range 1408 - 4448
(--) SynPS/2 Synaptics TouchPad: pressure range 0 - 255
(--) SynPS/2 Synaptics TouchPad: finger width range 0 - 0
(--) SynPS/2 Synaptics TouchPad: buttons: left right middle
(--) SynPS/2 Synaptics TouchPad: invalid finger width range. defaulting to 0 - 16
(--) SynPS/2 Synaptics TouchPad: touchpad found
(**) SynPS/2 Synaptics TouchPad: always reports core events
(II) XINPUT: Adding extended input device "SynPS/2 Synaptics TouchPad" (type: TOUCHPAD)
(**) SynPS/2 Synaptics TouchPad: (accel) MinSpeed is now constant deceleration 2.5
(**) SynPS/2 Synaptics TouchPad: MaxSpeed is now 1.7
(**) SynPS/2 Synaptics TouchPad: AccelFactor is now 0.0
(**) SynPS/2 Synaptics TouchPad: (accel) keeping acceleration scheme 1
(**) SynPS/2 Synaptics TouchPad: (accel) acceleration profile 1
(**) SynPS/2 Synaptics TouchPad: (accel) acceleration factor: 2.000
(**) SynPS/2 Synaptics TouchPad: (accel) acceleration threshold: 4
(--) SynPS/2 Synaptics TouchPad: touchpad found
(II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/mouse2)

Serkan Hosca (serkan-hosca) wrote :

Are you sure that patch is already applied? Just did apt-get source xserver-xorg-input-synaptics and grep the source for clickpad and can't find anything.

Now we are on Maverick beta and Clickpad *still* does not work.
Someone got it working in OpenSUSE by using a custom repo (as in http://www.andreas-demmer.de/en/2010/07/18/testbericht-linux-auf-dem-hp-envy-14/ ).
It is a little upsetting since many new laptops are shipping with this kind of touchpad.
Is there *anything* we can do to help fixing it? Is there any patch to make it work in 10.10's kernel?

tob (tobynbertram) wrote :

The Clickpad button detection was performed in the kernel in Ubuntu 10.04. The upstream kernel has since been changed so that the Clickpad button detection is now performed in xorg-input-synaptics. The problem is that the current Ubuntu 10.10 kernel uses the upstream kernel with patches from 10.04 for button detection. That means that there is conflicting code in the Ubuntu 10.10 kernel. Furthermore, I don't think there are provisions in Ubuntu 10.10's xorg-input-synaptics for Clickpad button detection.

The attached patch will clean up the current Ubuntu 10.10 kernel so that button detection is performed in the kernel like Ubuntu 10.04. However, The best solution would be to use the upstream Clickpad code in the kernel as well as in xorg-input-synaptics. Additionally, there are patches available to make the LED on the Clickpad work properly that should be applied.

tob (tobynbertram) wrote :

Is there any way we can get this one fixed before Maverick is released?
A lot of people are not going to like the regression. The Clickpad's buttons worked fine in Lucid.

tags: added: kernel-needs-review
removed: kernel-reviewed kj-expired
Changed in linux (Ubuntu Maverick):
milestone: none → maverick-updates
Changed in linux (Ubuntu):
importance: Medium → High
Micah Gersten (micahg) on 2011-03-30
tags: added: regression-release
removed: regression-potential
Changed in ubuntu-release-notes:
status: New → Invalid
Changed in linux (Ubuntu):
status: Triaged → Fix Released
Brian Curtis (bcurtiswx) on 2011-06-01
Changed in linux (Ubuntu):
status: Fix Released → Triaged
bugbot (bugbot) on 2011-07-27
tags: added: lucid
Changed in xserver-xorg-input-synaptics (Ubuntu Maverick):
status: New → Confirmed
Changed in xserver-xorg-input-synaptics (Ubuntu):
status: New → Confirmed
Changed in linux:
importance: Unknown → Undecided
status: Unknown → New
Changed in xserver-xorg-input-synaptics:
importance: Unknown → High
status: Unknown → Confirmed
Simon K (octav14n) on 2011-09-28
Changed in linux:
status: New → Opinion
status: Opinion → Invalid
259 comments hidden view all 339 comments

@tuxor1337: That is exactly how I felt. So, when I saw OpenSUSE 12.1 come out, knowing it already had the support I wanted, I was baffled. I said screw it, and made the switch to Gnome 3. I now have an almost fully functional HP DM1Z. If only there was no pesky watchdog timer /facepalm

While Mint 12 is coming along nicely and may have the support, I wanted to stay with the "Maverick" series. Newer kernels have other regressions that I will just suck up, so in all honesty I still look forward to this problem being fixed and a patch being released upstream!

*** Bug 43394 has been marked as a duplicate of this bug. ***

Nicolás Lichtmaier (niqueco) wrote :

In "precise" you can no longer use Sergio's package. So I've tried to apply Sergio's patch to the newer driver... It didn't compile at first... I tried to port it... I didn't understand a lot of what I was doing, but I've just followed common sense... and it worked!

Here's a working deb for the newest unreleased Ubuntu (Precise).

Nicolás Lichtmaier (niqueco) wrote :

Oh.. I haven't ever uploaded a file here. It doesn't provide a link... uhm.. well.. ok...

This is it: https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-input-synaptics/+bug/582809/+attachment/2692383/+files/xserver-xorg-input-synaptics_1.5.0%2Bgit20120101-1ubuntu2_amd64.deb

A deb for "precise".

Is there any hope for a better clickpad performance in coming versions due to the enormous advances in Xorg multitouch support pushed greatly by Peter Hutterer during the last few months?

I saw all those articles on his blog (who-t..) and wondered if this will affect clickpad support in the near future. What do you think?

(In reply to comment #9)
> Is there any hope for a better clickpad performance in coming versions due to the enormous advances in Xorg multitouch support pushed greatly by Peter Hutterer
> during the last few months?
>
> I saw all those articles on his blog (who-t..) and wondered if this will affect clickpad support in the near future. What do you think?

http://lists.x.org/archives/xorg-devel/2012-February/029132.html

ggjj11 (ggjj11) wrote :

I am also having the problem on hp touchsmart with ubuntu 11.10 (3.0.0-12-generic). (But you can perform a right click if you press left and right click at the same time.... this is strange.
Would be nice if it was fixed.

commit 6c457c0c61a0834361f45a073148db7b4c9be40b
Merge: defc1d0 fee18d8
Author: Peter Hutterer <email address hidden>
Date: Wed Mar 14 08:48:00 2012 +1000

    Merge branch 'clickpad-v3'

Changed in xserver-xorg-input-synaptics:
status: Confirmed → Fix Released

*** Bug 40118 has been marked as a duplicate of this bug. ***

*** Bug 22505 has been marked as a duplicate of this bug. ***

Vitali Kulikou (sabotatore) wrote :

Right click and drug-n-drop still doesn't work at my hp envy 14-2000.

Brad Figg (brad-figg) on 2012-03-29
no longer affects: linux (Ubuntu Maverick)
Stefan Bader (smb) wrote :

Reading through the comments and related reports it sounds to me like from the kernel side only Maverick would have issues. And with Maverick just about dropping from being supported it makes no sense to try to get it fixed.

Changed in linux (Ubuntu):
status: Triaged → Won't Fix
Hervé Fache (rvfh) wrote :

I am on Precise, and though the left click now works, the right click is still broken.

Nicolás Lichtmaier (niqueco) wrote :

This is still completely broken without using the deb I've posted... in "precise". So closing this bug looks weird.

Stefan Bader (smb) wrote :

I only closed the kernel/linux task, not the xorg one. Maybe I was wrong with that, in which case it can be set back to open. But it looked like the remaining problems where not in kernel modules but in the synaptics driver.

Nicolás Lichtmaier (niqueco) wrote :

Can't this bug be reassigned to the proper package then? This is an issue that seems to be affecting lots of people and it would be great if someone could finally fix it (and there are patches for that!).

Chase Douglas (chasedouglas) wrote :

This should all be fixed. The only remaining issue is that the right button area is not handled as a right click by default. The support for it came too late in the cycle to enable it by default. You can follow that issue in bug 972727.

Changed in xserver-xorg-input-synaptics (Ubuntu):
status: Confirmed → Fix Released
Chase Douglas (chasedouglas) wrote :

I am declining any work on Lucid because the features necessary in the kernel and the X.org stack are not available in that release. It is not feasible to backport fixes to it.

Changed in xserver-xorg-input-synaptics (Ubuntu Maverick):
status: Confirmed → Won't Fix
Vitali Kulikou (sabotatore) wrote :

Right area? Why not two fingers right click, three fingers middle click?

Hervé Fache (rvfh) wrote :

The opposite already works, and has done for quite some time.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu laptop testing tracker.

A list of all reports related to this bug can be found here:
http://laptop.qa.ubuntu.com/qatracker/reports/bugs/582809

tags: added: laptop-testing
Vitali Kulikou (sabotatore) wrote :

Do you have a progress? Release is soon, but touchpad right click and drag'n'drop still don't work. :/

Vitali Kulikou (sabotatore) wrote :

Oh.. I fixed it in my machine. I just removed psmouse kernel patch. Thank you.

3 comments hidden view all 339 comments
Mohegan (jack-mohegan) wrote :

I modify my patchs (base on Takashi work). It works with my HP Envy 17.
The modifications ares :
- Modify the synaptics.conf to add the sofbuttonareas ("Option "SoftButtonAreas" "60% 0 82% 0 40% 60% 82% 0")
- Add a new property double tap led status to works with synclient and syndaemon. So, if you disable the touchpad with double-tap on led, the syndaemon is by-pass. If you re-enable the touchpad with double-tap on led or with synclient (TouchpadOff=0), the syndaemon continues to work.
- Modify the the softbuttonaras to accept float as parameter and if right_left = middle_right, soustract 1 to middle_right (for example, 60.5% 0 82.3% 0 40% 60.5% 82.3% 0).
- To enable or disable the double tap on led, I modify the double-tap size (double of the MaxDoubleTapTime) because it was difficult to double tap on led.

Mohegan (jack-mohegan) wrote :

TODO for clickpad to work with the LED :

(Enable the proposed archive for Ubuntu 12.04 : https://wiki.ubuntu.com/Testing/EnableProposed
After dist-upgrade, do this :)

 1*) Build a xserver-xorg-input-synaptics with led support package :

a) mkdir tmpbuild
b) cd tmpbuild
c) apt-get source xserver-xorg-input-synaptics
d) cd xserver-xorg-input-synaptics-*/debian/patches
e) wget https://bugs.launchpad.net/ubuntu/+source/linux/+bug/582809/+attachment/3183411/+files/200-add_led_support_with_double_tap-synaptics-1.6.0-mohegan_V1.patch
f) ls -1 2*.patch >> series
g) cd ../..
h) sudo apt-get build-dep xserver-xorg-input-synaptics
i) debchange -i
j) Add somme comments (for example, "Add LED support with double tap") and quit.
k) debuild -us -uc -i -I
k) sudo dpkg -i ../xserver-xorg-input-synaptics_*.deb

 2*) Build a dkms module for psmouse

a) cd ..
b) apt-get source linux-image-`uname -r`
c) sudo mkdir -p /usr/src/psmouse-`uname -r`/src
d) sudo cp linux-*/drivers/input/mouse/* /usr/src/psmouse-`uname -r`/src/
e) sudo gedit /usr/src/psmouse-`uname -r`/dkms.conf
f) put this text, save the file and exit gedit : (remplace _your kernel version_ by the text obtain with the command `uname -r`. For me, it's 2.6.38-9-generic)

PACKAGE_NAME="psmouse"
PACKAGE_VERSION="_your kernel version_"
CLEAN="rm -f *.*o"

BUILT_MODULE_NAME[0]="psmouse"
MAKE[0]="make -C $kernel_source_dir M=$dkms_tree/$PACKAGE_NAME/$PACKAGE_VERSION/build/src psmouse.ko"
BUILT_MODULE_LOCATION[0]="src"
DEST_MODULE_LOCATION[0]="/updates"

AUTOINSTALL="yes"

g) wget https://bugs.launchpad.net/ubuntu/+source/linux/+bug/582809/+attachment/3183441/+files/synaptics_led_support_v2-ubuntu_12.04.patch -P /tmp
h) cd /usr/src/psmouse-`uname -r`
i) sudo patch -p1 -i /tmp/synaptics_led_support_v2-ubuntu_12.04.patch
j) sudo dkms add -m psmouse -v `uname -r`
k) sudo dkms build -m psmouse -v `uname -r`
l) sudo dkms install -m psmouse -v `uname -r`

 3*) Restart your computer and enjoy !

Please post comment if it works for you (with your configuration) !

Mohegan (jack-mohegan) wrote :

If you want try, I made my own package (for amd64). Bbut it is necessary to make the second part of my todo (dkms module).

4 comments hidden view all 339 comments
Tomas Angelo (tommyangelo) wrote :

Hello Mohegan,

  thank you very much for your how-to :: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/582809/comments/328
I followed it step by step, but it didn't work for me. My laptop is HP Probook 4530s with switchable graphic.

Mohegan (jack-mohegan) wrote :

Can you precise, please ?

FWIW, I've got a Probook 4320s and I just use this little script to make
the pad work as it should:

#!/bin/bash
# Saved to /usr/local/bin/synclient.sh
# chmod +x
synclient VertEdgeScroll=1
synclient HorizEdgeScroll=1
synclient
VertTwoFingerScroll=0

synclient
HorizTwoFingerScroll=0

synclient
RBCornerButton=3

synclient
LBCornerButton=1

synclient TapButton1=1

I use KDE so I have it set to be run at session startup through the
Session control panel. It will work with any DE, though.

Justin Chudgar | Weed, CA 96094 | 530 921 0738 | http://www.justinzane.com/

On 09/27/2012 10:41 AM, Tomas Angelo wrote:
> Hello Mohegan,
>
> thank you very much for your how-to :: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/582809/comments/328
> I followed it step by step, but it didn't work for me. My laptop is HP Probook 4530s with switchable graphic.
>

Vassili Platonov (vassilip) wrote :

@Mohegan (jack-mohegan)

Much thanks, it works for me (HP ProBook 4320s, Presice 12.04.1 amd64).
Is there a patch to 3.5.0 kernel (quantal)? I'll be grateful to for it.

Displaying first 40 and last 40 comments. View all 339 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints

Remote bug watches

Bug watches keep track of this bug in other bug trackers.