touchpad not functional on Gigabyte Spring Peak

Bug #580664 reported by Earl Malmrose on 2010-05-14
22
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Low
Kamal Mostafa
Lucid
Low
Steve Conklin

Bug Description

On a default install the touchpad does not work. Adding "i8042.noloop" to the kernel parameters does get the touchpad working.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: linux-image-2.6.32-22-generic 2.6.32-22.33
Regression: No
Reproducible: Yes
ProcVersionSignature: Ubuntu 2.6.32-22.33-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-22-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC269 Analog [ALC269 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: oem 1278 F.... pulseaudio
 /dev/snd/pcmC0D0p: oem 1278 F...m pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0x9a500000 irq 22'
   Mixer name : 'Intel G45 DEVCTG'
   Components : 'HDA:10ec0269,14581325,00100004 HDA:80862802,80860101,00100000'
   Controls : 16
   Simple ctrls : 8
Date: Fri May 14 11:21:51 2010
HibernationDevice: RESUME=UUID=46356722-1463-4e4a-b348-5c2ee34a3a3b
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
MachineType: GIGABYTE Spring Peak
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-22-generic root=UUID=9fa07e57-4668-47f0-8779-81a7ae0ecb8d ro quiet splash i8042.noloop
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
RelatedPackageVersions: linux-firmware 1.34
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
SourcePackage: linux
dmi.bios.date: 02/05/2010
dmi.bios.vendor: GIGABYTE
dmi.bios.version: ASBF07
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: GA-XXXXXXX
dmi.board.vendor: GIGABYTE
dmi.board.version: Base Board Version
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 1
dmi.chassis.vendor: Chassis Manufacturer
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnGIGABYTE:bvrASBF07:bd02/05/2010:svnGIGABYTE:pnSpringPeak:pvrASBF07:rvnGIGABYTE:rnGA-XXXXXXX:rvrBaseBoardVersion:cvnChassisManufacturer:ct1:cvrChassisVersion:
dmi.product.name: Spring Peak
dmi.product.version: ASBF07
dmi.sys.vendor: GIGABYTE

Earl Malmrose (earl) wrote :
Changed in linux (Ubuntu):
assignee: nobody → Kamal Mostafa (kamalmostafa)
Changed in linux (Ubuntu):
status: New → Confirmed
Kamal Mostafa (kamalmostafa) wrote :

The problem here appears to be caused by an improper Chassis Type in the DMI table. The problem we're working around with i8042.noloop is in code that is actually not supposed to be enabled for any laptops, but this DMI table does not indicate that it is a laptop, as indicated by "dmi.chassis.type: 1" or ...

  $ sudo dmidecode -s chassis-type
  Other

I believe that if the chassis-type was any of "{Portable, Laptop, Notebook, Sub-Notebook}" (types 8, 9, 10, and 14 respectively) then the touchpad would work correctly without requiring any special boot option.

Kamal Mostafa (kamalmostafa) wrote :

Having determined that the observed "missed key-release events" problem happens regardless of i8042.noloop, I've submitted that issue as a separate bug report LP: #607350.

Changed in linux (Ubuntu):
importance: Undecided → Low
description: updated
Kamal Mostafa (kamalmostafa) wrote :

Attached patch adds this machine to the dmi_noloop_table (effectively enabling i8042.noloop internally as intended for all laptops). This patch has been submitted to the linux-kernel and ubuntu-kernel mailing lists for review.

tags: added: patch
madbiologist (me-again) wrote :

The abovementioned patch has been included upstream in kernel 2.6.35-rc6. From the changelog:

commit 3e1bbc8d5018a05c0793c8a32b777a1396eb4414
Author: Kamal Mostafa
Date: Mon Jul 19 11:00:52 2010 -0700

    Input: i8042 - add Gigabyte Spring Peak to dmi_noloop_table

    Gigabyte "Spring Peak" notebook indicates wrong chassis-type, tripping up
    i8042 and breaking the touchpad. Add this model to i8042_dmi_noloop_table[]
    to resolve.

    BugLink: https://bugs.launchpad.net/bugs/580664

    Signed-off-by: Kamal Mostafa
    Cc: <email address hidden>
    Signed-off-by: Dmitry Torokhov

A PPA of this kernel is available at http://kernel.ubuntu.com/~kernel-ppa/mainline/

Kamal Mostafa (kamalmostafa) wrote :

Ubuntu Maverick: fix committed.

Ubuntu Lucid: use the "i8042.noloop" kernel boot parameter to work around.

Changed in linux (Ubuntu):
milestone: none → maverick-alpha-3
status: Confirmed → Fix Committed
Steve Conklin (sconklin) on 2010-08-31
Changed in linux (Ubuntu Lucid):
status: New → Fix Committed
milestone: none → lucid-updates
Steve Conklin (sconklin) wrote :

SRU Justification for Lucid

Impact: The upstream process for stable tree updates is quite similar in scope to the Ubuntu SRU process, e.g., each patch has to demonstrably fix a bug, and each patch is vetted by upstream by originating either directly from Linus' tree or in a minimally backported form of that patch.

The 2.6.32.21 upstream stable patch set is now available and contains fixes for this problem. It should be included in the Ubuntu kernel as well.

Related commits in the Lucid repo are:

24dd298 Input: i8042 - add Gigabyte Spring Peak to dmi_noloop_table

Changed in linux (Ubuntu Lucid):
assignee: nobody → Steve Conklin (sconklin)
importance: Undecided → Low

Accepted linux into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Stefan Bader (smb) wrote :

Earl, as you are the original reporter, can you please test the kernel in proposed and give feedback whether it fixes your issue. Thanks.

Earl Malmrose (earl) wrote :

Yes, with the proposed kernel (2.6.32-25) the bug is fixed.

Martin Pitt (pitti) on 2010-09-15
tags: added: verification-done
removed: verification-needed
madbiologist (me-again) on 2010-09-15
Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (43.7 KiB)

This bug was fixed in the package linux - 2.6.32-25.44

---------------
linux (2.6.32-25.44) lucid-proposed; urgency=low

  [ Brad Figg ]

  * SAUCE: (no-up) Modularize vesafb -- fix initialization
    - LP: #611471

  [ Stefan Bader ]

  * Revert "SAUCE: sync before umount to reduce time taken by ext4 umount"
    - LP: #543617, #585092

  [ Steve Conklin ]

  * Revert "SAUCE: tulip: Let dmfe handle davicom on non-sparc"
    - LP: #607824

  [ Tim Gardner ]

  * [Config] Added ums-cypress to udeb
    - LP: #576066

  [ Upstream Kernel Changes ]

  * Revert "PCI quirk: Disable MSI on VIA K8T890 systems"
    - LP: #607824
  * Revert "PCI quirks: disable msi on AMD rs4xx internal gfx bridges"
    - LP: #607824
  * Revert "(pre-stable) Input: psmouse - reset all types of mice before
    reconnecting"
    - LP: #607824
  * Revert "jbd: jbd-debug and jbd2-debug should be writable"
    - LP: #607824
  * Revert "ext4: Make fsync sync new parent directories in no-journal
    mode"
    - LP: #615548
  * Revert "ext4: Fix compat EXT4_IOC_ADD_GROUP"
    - LP: #615548
  * Revert "ext4: Conditionally define compat ioctl numbers"
    - LP: #615548
  * Revert "ext4: restart ext4_ext_remove_space() after transaction
    restart"
    - LP: #615548
  * Revert "ext4: Clear the EXT4_EOFBLOCKS_FL flag only when warranted"
    - LP: #615548
  * Revert "ext4: Avoid crashing on NULL ptr dereference on a filesystem
    error"
    - LP: #615548
  * Revert "ext4: Use bitops to read/modify i_flags in struct
    ext4_inode_info"
    - LP: #615548
  * Revert "ext4: Show journal_checksum option"
    - LP: #615548
  * Revert "ext4: check for a good block group before loading buddy pages"
    - LP: #615548
  * Revert "ext4: Prevent creation of files larger than RLIMIT_FSIZE using
    fallocate"
    - LP: #615548
  * Revert "ext4: Remove extraneous newlines in ext4_msg() calls"
    - LP: #615548
  * Revert "ext4: init statistics after journal recovery"
    - LP: #615548
  * Revert "ext4: clean up inode bitmaps manipulation in ext4_free_inode"
    - LP: #615548
  * Revert "ext4: Do not zero out uninitialized extents beyond i_size"
    - LP: #615548
  * Revert "ext4: don't scan/accumulate more pages than mballoc will
    allocate"
    - LP: #615548
  * Revert "ext4: stop issuing discards if not supported by device"
    - LP: #615548
  * Revert "ext4: check s_log_groups_per_flex in online resize code"
    - LP: #615548
  * Revert "ext4: fix quota accounting in case of fallocate"
    - LP: #615548
  * Revert "ext4: allow defrag (EXT4_IOC_MOVE_EXT) in 32bit compat mode"
    - LP: #615548
  * Revert "ext4: rename ext4_mb_release_desc() to ext4_mb_unload_buddy()"
    - LP: #615548
  * Revert "ext4: Remove unnecessary call to ext4_get_group_desc() in
    mballoc"
    - LP: #615548
  * Revert "ext4: fix memory leaks in error path handling of
    ext4_ext_zeroout()"
    - LP: #615548
  * Revert "ext4: check missed return value in ext4_sync_file()"
    - LP: #615548
  * Revert "ext4: Issue the discard operation *before* releasing the blocks
    to be reused"
    - LP: #615548
  * Revert "ext4: Fix buffer head leaks after calls to
    ext4_get_inode_loc()"
    - LP: #615548
  * Revert "ex...

Changed in linux (Ubuntu Lucid):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers