Cannot detect AC adapter status and battery charge status on Acer Aspire 4820TG

Bug #578894 reported by Tommaso R. Donnarumma on 2010-05-11
72
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Medium
linux (Ubuntu)
Medium
AceLan Kao

Bug Description

The system encounters an error while trying to read the status of the AC adapter and, as a result, it behaves as if the AC adapter were plugged. The relevant dmesg lines seem to be the following:

[ 0.944150] ACPI Error (psargs-0359): [\_PR_.CPU0._PPC] Namespace lookup failure, AE_NOT_FOUND
[ 0.944156] ACPI Error (psparse-0537): Method parse/execution failed [\_SB_.PCI0.ACAD._PSR] (Node ffff88013384d720), AE_NOT_FOUND
[ 0.944207] ACPI Exception: AE_NOT_FOUND, Error reading AC Adapter state (20090903/ac-140)

Additionally, the system detects the battery but cannot read the charge status and, as a result, it behaves as if the battery were fully charged. The relevant dmesg lines seem to be the following:

[ 0.957281] ACPI: Battery Slot [BAT1] (battery present)
[ 2.224333] ata2.00: ACPI _SDD failed (AE 0x5)
[ 7.565299] ata2.00: ACPI _SDD failed (AE 0x5)
[ 7.565303] ata2.00: ACPI: failed the second time, disabled

I'm going to attach the full output of dmesg | grep ACPI.

I also tested this under 2.6.34, using the 2.6.34-020634rc7-generic #020634rc7 package from the Kernel Team PPA. With this kernel, the ACPI error is gone, but the AC adapter is always detected as plugged even if unplugged. The battery related behavior is the same: that is, the battery is detected but the battery charge status cannot be read.

I'm going to attach the full output of dmesg | grep ACPI under 2.6.34 as well.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: linux-image-2.6.32-22-generic 2.6.32-22.33 [modified: lib/modules/2.6.32-22-generic/kernel/drivers/net/atl1e/atl1e.ko]
Regression: No
Reproducible: Yes
ProcVersionSignature: Ubuntu 2.6.32-22.33-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-22-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC269 Analog [ALC269 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: tawmas 1617 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xdc500000 irq 22'
   Mixer name : 'Realtek ALC269'
   Components : 'HDA:10ec0269,10250359,00100100'
   Controls : 16
   Simple ctrls : 9
Card1.Amixer.info:
 Card hw:1 'Generic'/'HD-Audio Generic at 0xdc420000 irq 17'
   Mixer name : 'ATI R6xx HDMI'
   Components : 'HDA:1002aa01,00aa0100,00100200'
   Controls : 4
   Simple ctrls : 1
Card1.Amixer.values:
 Simple mixer control 'IEC958',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [off]
Date: Tue May 11 19:04:42 2010
HibernationDevice: RESUME=UUID=74fcdf09-98ca-47e7-b54d-e8ea949388cd
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
MachineType: Acer Aspire 4820TG
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-22-generic root=UUID=f088dc9b-763e-4cec-b26a-c6eef63ad52a ro quiet splash
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.utf8
 SHELL=/bin/bash
RelatedPackageVersions: linux-firmware 1.34
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
SourcePackage: linux
dmi.bios.date: 04/07/2010
dmi.bios.vendor: INSYDE
dmi.bios.version: V1.06
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: ZQ1B
dmi.board.vendor: Acer
dmi.board.version: Base Board Version
dmi.chassis.type: 1
dmi.chassis.vendor: Chassis Manufacturer
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnINSYDE:bvrV1.06:bd04/07/2010:svnAcer:pnAspire4820TG:pvrV1.06:rvnAcer:rnZQ1B:rvrBaseBoardVersion:cvnChassisManufacturer:ct1:cvrChassisVersion:
dmi.product.name: Aspire 4820TG
dmi.product.version: V1.06
dmi.sys.vendor: Acer

Tommaso R. Donnarumma (tawmas) wrote :
Jeremy Foshee (jeremyfoshee) wrote :

Hi Tommaso,

If you could also please test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

    [This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete
Tommaso R. Donnarumma (tawmas) wrote :

Hi Jeremy, as indicated in the bug description, I already did that. I tested against 2.6.34-020634rc7-generic, with the behavior detailed in the description (the bug is still present but some of the symptoms have changed).

tags: removed: needs-upstream-testing
Changed in linux (Ubuntu):
status: Incomplete → New
tags: added: kernel-needs-review kernel-power
Changed in linux (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
Manoj Iyer (manjo) on 2010-06-02
tags: added: kernel-candidate
removed: kernel-needs-review
Andy Whitcroft (apw) on 2010-06-07
tags: removed: kernel-candidate
Sean Colgan (sean-pedorro) wrote :

Also present on AspireOne ZG5

Note that /proc/acpi reports correctly:

cat /proc/acpi/battery/BAT1/state
...
charging state: discharging
...

AceLan Kao (acelankao) wrote :

Tommaso,

Could you try to run the command, acpi_listen, and unplug and plug back the ac power and then report the output here?
Thanks.

Tommaso R. Donnarumma (tawmas) wrote :

Hi. I get no output on unplugging, and the following when plugging back:

processor CPU0 00000081 00000000
processor CPU1 00000081 00000000
processor CPU2 00000081 00000000
processor CPU3 00000081 00000000

Feel free to ask more if you need, and thanks for looking into this bug!

Tommaso R. Donnarumma (tawmas) wrote :

I just found out that the discussion thread at http://ubuntuforums.org/showthread.php?t=1495123 has some discussion, as well as a link to a patch (http://wiki.archlinux.org/index.php/Acer_TimelineX#Issues) and to kernel packages including the mentioned patch.

The patch seems to work here. Would you please consider carrying it until upstream finds a proper fix?

AceLan Kao (acelankao) wrote :

Tommaso,

Cool~~
I applied the patch and build a new kernel, could you help to confirm the patch actually solved the problem?
http://people.canonical.com/~acelan/bugs/lp578894/
Thanks.

Tommaso R. Donnarumma (tawmas) wrote :

@AceLan Kao: I'm running on your patched kernel. I can confirm that the bug is fixed for me, and I see no regressions so far. I will use it for the whole day (it's morning here as I write this) and report back later.

Will you consider the patch for Maverick as well? I would gladly upgrade to help test this.

Thanks again!

Tommaso R. Donnarumma (tawmas) wrote :

After one full day of use, I still see no regressions. The patch does work for me.

AceLan Kao (acelankao) wrote :

Tommaso,

Cool~, I'll contact the patch owner and help to get it upstream and hope this patch will be included in Maverick(and/or in Lucid SRU)

Manoj Iyer (manjo) wrote :

Acelan, assigning the bug to you since you seem to have the fix for this issue. It is on our top 50 bug list.

Changed in linux (Ubuntu):
assignee: nobody → AceLan Kao (acelankao)
status: Triaged → Incomplete

This bug doesn't appear to be Incomplete any longer. Changing the status to In Progress.

Changed in linux (Ubuntu):
status: Incomplete → In Progress
Raven (ravenskrag) wrote :

I can confirm this fix works, but you need to set
GRUB_CMDLINE_LINUX="acpi_osi=Linux"
under GRUB in my case. Same laptop, same model number. I can only assume Donnarumma had it set while trying to fix some other bug.

Still, it takes a while for the battery applet to display that the laptop is on battery. The effect can be seen in the output of acpi -b a little sooner, though.

Tommaso R. Donnarumma (tawmas) wrote :

Raven, please, make no assumptions. I only have the default settings in my /etc/default/grub:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

Detection is immediate for me here.

Laubblatt (laub-blatt) wrote :

@AceLan Kao: Thank you for your compiled Kernel. I have a Acer Travelmate 8472TG. I had the same problems, i.e. that the battery has not been detected by Lucid (using the "normal" Kernel).
Now, the battery is found as well as sensors report a more realistic temperature.

Last 2 general questiona:
What has been changed; what caused the problems?
Will this patch be official and available in the official updates? (sorry for asking but I am a newbie)

AceLan Kao (acelankao) wrote :

Laubblatt,

The patch could be found here - http://wiki.archlinux.org/index.php/Acer_TimelineX#Issues
I have contacted with the patch author and he think the work around is not suitable to be upstreamed, I'm still trying to find an acceptable way to patch this.

Since your machine is different with the origin reporter, could you upload the result of the 'sudo dmidecode' command here, so that I could make some comparisons. Thanks.

Laubblatt (laub-blatt) wrote :

Hi AceLan Kao,

I just updated the kernel again as there has been a official update -- and the battery is not shown anymore :-)

Anyhow, I attach the dmidecode results to this message.
Thank you for your work!

Laubblatt (laub-blatt) wrote :

The precompiled kernels of trevino, to be found in http://download.tuxfamily.org/3v1deb/acer-timelinex/
also work for me. includes a patch for switching gpu

summary: - Cannot detect AC adapter status and battery charge status on Acer Aspire
- 4820TG
+ CIAO!
summary: - CIAO!
+ Cannot detect AC adapter status and battery charge status on Acer Aspire
+ 4820TG
d4rr3ll (darrell-taylor) wrote :

Updated the BIOS to 1.18 on my 4820T and I can confirm that it solves the issue.

AceLan Kao (acelankao) wrote :

darrell, thanks for the quickly response.
I'm going to close this bug, and please feel free to reopen it if updating BIOS to v1.18 is still not working for you.

Changed in linux (Ubuntu):
status: In Progress → Won't Fix
Changed in linux:
status: Unknown → Fix Released
Changed in linux:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related blueprints

Remote bug watches

Bug watches keep track of this bug in other bug trackers.