Boot on battery power ends up with black screen [HP tx1000]

Bug #578119 reported by Lauri Soini on 2010-05-10
56
This bug affects 11 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

When powering up on battery power I always have black screen after the splash screen with no functionality or text of any kind. When powering up with power cord plugged in, the system always starts as it should.

The problem could be related to Bug #480707 or Bug #377773. However, the latter one was fixed in 9.04.

The system was upgraded from Ubuntu 9.10 where booting worked fine.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: linux-image-2.6.32-22-generic 2.6.32-22.33
Regression: Yes
Reproducible: Yes
ProcVersionSignature: Ubuntu 2.6.32-22.33-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-22-generic x86_64
NonfreeKernelModules: nvidia wl
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: soinil 1624 F.... pulseaudio
CRDA: Error: [Errno 2] Tiedostoa tai hakemistoa ei ole
Card0.Amixer.info:
 Card hw:0 'NVidia'/'HDA NVidia at 0x80020000 irq 17'
   Mixer name : 'Realtek ALC861-VD'
   Components : 'HDA:10ec0862,103c30bf,00100001 HDA:10573055,103c30bf,00100700'
   Controls : 23
   Simple ctrls : 13
Date: Mon May 10 10:08:48 2010
HibernationDevice: RESUME=UUID=f42e7f55-84ac-4c62-8219-fa05b4009236
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
MachineType: Hewlett-Packard HP Pavilion tx1000 Notebook PC
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-22-generic root=UUID=0ed1125e-4446-4433-a22e-40e50274b94c ro quiet splash
ProcEnviron:
 LANG=fi_FI.utf8
 SHELL=/bin/bash
RelatedPackageVersions: linux-firmware 1.34
RfKill:
 0: hci0: Bluetooth
  Soft blocked: no
  Hard blocked: no
SourcePackage: linux
dmi.bios.date: 04/18/2008
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: F.20
dmi.board.name: 30BF
dmi.board.vendor: Quanta
dmi.board.version: 69.2E
dmi.chassis.type: 10
dmi.chassis.vendor: Quanta
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnHewlett-Packard:bvrF.20:bd04/18/2008:svnHewlett-Packard:pnHPPaviliontx1000NotebookPC:pvrRev1:rvnQuanta:rn30BF:rvr69.2E:cvnQuanta:ct10:cvrN/A:
dmi.product.name: HP Pavilion tx1000 Notebook PC
dmi.product.version: Rev 1
dmi.sys.vendor: Hewlett-Packard

Lauri Soini (lauri-i-soini) wrote :
description: updated
Lauri Soini (lauri-i-soini) wrote :

Looks like the issue is with graphics card drivers. The login screen is functional only the screen is blank.

Jeremy Foshee (jeremyfoshee) wrote :

Hi Lauri,

If you could also please test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

    [This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete
Toni Rida (brit50483) wrote :

I have the same problem as described above with a HP Pavilion tx2000 laptop. Worked ok in 9.10, black screen on battery boot with a clean install of Ubuntu 10.4. AC power boot is ok.

Joon Hee (juniecho-gmail) wrote :

Like Toni Rida discribed I can confirm the problem as described above happenes on HP Pavilion tx2000, Ubuntu 10.04.

1. After installing more recent packages by adding repository ppa:ubuntu-x-swat/x-updates, I can confirm problem half-solved. 10.04 no longer displays blank screen with default graphic driver.

2. However when using nvidia driver it requires xorg.conf and problem is not solved. If I delete xorg.conf with nvidia driver installed it cannot detect my screen resolution, but it defaults to 1024x768.

Changed in linux (Ubuntu):
status: Incomplete → New
status: New → Incomplete
KishCom (akish-launchpad) wrote :

I've got an HP TX2114CA and am having the same issues.

I can provide any more details required.

lexingtion-cruz (klichtie00) wrote :

I have an hp pavilion tx1308nr and the same bug affects me. Alt+Ctrl+f1 and then Alt+Ctrl+f7 gets me to the login screen after the splash screen when running on battery power. When I run on AC power my computer boots fine. The screen resolution on the ubuntu splash page stinks though.

Michael K, Ham (mkham151) wrote :

HP Pavilion tx1000, Ubuntu 10.04. Initial install with the default graphic drivers worked fine both AC/DC, but when proprietary NVIDIA accelerated graphics driver (version 173) were activated the system experienced blank screen booting from battery and when booting from AC the system would boot to a standard screen resolution with no acceleration. The conflict is simply the Nvidia proprietary drivers. Just do not activate it. I had to re-install Ubuntu to correct the graphics issue to return to default graphic drivers because deactivating the proprietary driver did not fix the problem. The system boots great from either AC/DC now, and the games and applications I have used on this system work very well so far using the default graphic drivers.

Jeremy Foshee (jeremyfoshee) wrote :

This bug report was marked as Incomplete and has not had any updated comments for quite some time. As a result this bug is being closed. Please reopen if this is still an issue in the current Ubuntu development release http://cdimage.ubuntu.com/daily-live/current/ . Also, please be sure to provide any requested information that may have been missing. To reopen the bug, click on the current status under the Status column and change the status back to "New". Thanks.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kj-expired
Changed in linux (Ubuntu):
status: Incomplete → Expired
Celestial (juniecho) wrote :

I can confirm this issue is still around, with 10.10.
With default driver it is fine, but NOT with nvidia driver.

After installing nvidia driver I tried almost everything I could but it didn't help.
People with this issue should stick to nouveau for now until someone fixes this and forget about desktop effects... for now. :)

Changed in linux (Ubuntu):
status: Expired → Incomplete
Michael K, Ham (mkham151) wrote :

HP Pavilion tx1000, - Ubuntu 10.10 - Yes, this is still a problem. Stay away from the proprietary NVIDIA accelerated graphics drivers. These drivers are not developed by the Ubuntu team and they are not guaranteed to work at all. I have attempted to use them under Ubuntu 10.04. and now with 10.10 with the same exact results. Another re-install was done to correct the issue of the driver. Below is my prior post on the matter of the nVidia driver.

"Michael K, Ham wrote on 2010-08-23:

HP Pavilion tx1000, Ubuntu 10.04. Initial install with the default graphic drivers worked fine both AC/DC, but when proprietary NVIDIA accelerated graphics driver (version 173) were activated the system experienced blank screen booting from battery and when booting from AC the system would boot to a standard screen resolution with no acceleration. The conflict is simply the Nvidia proprietary drivers. Just do not activate it. I had to re-install Ubuntu to correct the graphics issue to return to default graphic drivers because deactivating the proprietary driver did not fix the problem. The system boots great from either AC/DC now, and the games and applications I have used on this system work very well so far using the default graphic drivers."

KishCom (akish-launchpad) wrote :

Version 173 of the Nvidia drivers are quite old. Current version on the Nvidia site are 260. Have you tried with them?

This is uniquely an Ubuntu issue. I switched to Mint Debian Edition and my TX2114CA runs flawlessly (Starcraft II even runs OK under wine with the new Nvidia drivers!)

Jan Korpegård (jan-korpegard) wrote :

Having the same problem, using version 260.19.06 of the Nvidia driver. Everything works fine with one exception; blank screen on boot at DC power. My work-around is to go to sleep [fn-f5] for a few seconds when the startup drum sounds.

Toni Rida (brit50483) wrote :

I have some new information on this bug.

First I tested on my HP tx2000 with Maverick and the latest updates and Nvidia version 260.19.12. Same result, black screen after a battery boot, ok on AC power.

Then I tested with an upstream kernel as requested by Jeremy Foshee in post 3 above. I downloaded linux-image-2.6.36-020636-generic_2.6.36-020636.201010210905_i386.deb and sources and installed it. Next I did a manual install of the Nvidia driver version 260.19.12.

The result is that my tx2000 now boots through to a normal X server screen with a battery boot! So I think this shows the problem is related to a regression in the Ubuntu kernel patches, especially as it also works ok in Ubuntu 9.10.

I hope this result can moves things forward a little bit to a solution.

tags: added: maverick
removed: needs-upstream-testing
Toni Rida (brit50483) on 2010-10-28
Changed in linux (Ubuntu):
status: Incomplete → New
elcouz (elcouz) wrote :

Same problem with my HP TX2104CA with NVIDIA 173 and 260 proprietary drivers ... same thing on the linux mint distro. No problem with AC boot or default "lack-of-3D-acceleration" driver.

Charlie Kravetz (charlie-tca) wrote :

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here.

Confirmed working with mainline kernel linux-image-2.6.36-020636-generic_2.6.36-020636.201010210905_i386.deb and hardware nvidia video driver.

Thanks for taking the time to make Ubuntu better!

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
elcouz (elcouz) wrote :

I have the same problem with my HP TX2000 (black screen on gnome login but otherwise boots ok on AC power). Please help us! A laptop without battery support is useless :(

Any progression on this issue ?

elcouz (elcouz) wrote :

Here's a update for this bug.. kinda lame workaround but it work!

when the screen is black switch to tty1 CTRL+ALT+F1 , login then

sudo /etc/init.d/gdm restart

it should restart gnome and everything should be fine until the next battery power boot (repeat each boot).

elcouz (elcouz) wrote :

This bug has been solved with kernel v2.6.37-rc2-maverick

See my post on ubuntuforums how to fix this problem:

http://ubuntuforums.org/showpost.php?p=10292993&postcount=5

regards,
laurent

elcouz (elcouz) wrote :

fixed in kernel 2.6.37-rc2

Changed in linux (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers