Ubuntu

shpchp cannot reserve mmio region

Reported by Chris Eineke on 2010-05-09
194
This bug affects 38 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Low
Unassigned

Bug Description

[ 11.396573] shpchp 0000:00:01.0: HPC vendor_id 1022 device_id 9602 ss_vid 0 ss_did 0
[ 11.396581] shpchp 0000:00:01.0: Cannot reserve MMIO region
[ 11.396993] shpchp: Standard Hot Plug PCI Controller Driver version: 0.4

Shpchp reports this error on boot-up.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: linux-image-2.6.32-22-generic 2.6.32-22.33
Regression: Yes
Reproducible: Yes
ProcVersionSignature: Ubuntu 2.6.32-22.33-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-22-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: SB [HDA ATI SB], device 0: ALC268 Analog [ALC268 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: SB [HDA ATI SB], device 0: ALC268 Analog [ALC268 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ceineke 1569 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'SB'/'HDA ATI SB at 0xd6300000 irq 16'
   Mixer name : 'Realtek ALC268'
   Components : 'HDA:10ec0268,1179ff6a,00100003 HDA:11c11040,11790001,00100200'
   Controls : 12
   Simple ctrls : 7
Date: Sun May 9 09:50:20 2010
HibernationDevice: RESUME=UUID=f1799db9-cfe2-4e42-8dcb-1bce4e94c1cd
MachineType: TOSHIBA Satellite L300D
ProcCmdLine: root=UUID=e7fb9713-5f13-4dea-b461-0fe019929ceb ro quiet splash
ProcEnviron:
 PATH=(custom, user)
 LANG=en_CA.utf8
 SHELL=/bin/bash
RelatedPackageVersions: linux-firmware 1.34
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
SourcePackage: linux
WpaSupplicantLog:

dmi.bios.date: 06/04/2009
dmi.bios.vendor: Insyde Corp.
dmi.bios.version: 1.60
dmi.board.asset.tag: No Asset Tag
dmi.board.name: Portable PC
dmi.board.vendor: TOSHIBA
dmi.board.version: Base Board Version
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: AMD
dmi.chassis.version: None
dmi.modalias: dmi:bvnInsydeCorp.:bvr1.60:bd06/04/2009:svnTOSHIBA:pnSatelliteL300D:pvrPSLC8C-06601R:rvnTOSHIBA:rnPortablePC:rvrBaseBoardVersion:cvnAMD:ct10:cvrNone:
dmi.product.name: Satellite L300D
dmi.product.version: PSLC8C-06601R
dmi.sys.vendor: TOSHIBA

WORKAROUND:
Use tty to update installation:
1. As the system boots, hold right-shift to get the grub menu
   If that fails, try using Ctrl+Alt+F1 to get a login prompt when it freezes.
2. Choose recovery mode
3. At the recovery menu, choose root
4. Type 'sudo apt-get update' and press ENTER
5. Type 'sudo apt-get dist-upgrade' and press ENTER
6. Type 'sudo shutdown -r now' and press ENTER

Chris Eineke (chris.eineke) wrote :
Jeremy Foshee (jeremyfoshee) wrote :

Hi Chris,

If you could also please test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

    [This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete
Avery (docaltmed) wrote :

Continues to happen in kernel 2.6.32-22.

Lawrence Bezeau (lmbezeau) wrote :

I have encountered the same error message and it prevents my computer from booting.
I have a Gateway DX4300-01H with an AMD Phenom IIX4 quad core processor. The
operating system is Ubuntu 10.04 with kernel 2.6.32-24. I have kernel versions going
back to 2.6.32-21 and the computer will not boot in either generic mode or recovery
mode with any of these versions. GRUB works fine and the computer starts to boot
but then freezes after the "Cannot reserve MMIO region" message. I tried booting with
all USB peripherals disconnected and that did not help. The problem seemed to start
with the upgrade to the 2.6.32-24 kernel but I have since been unable to boot with
the earlier kernels.

The computer is in a dual boot configuration with Windows Vista. It will boot with Vista
without error messages and all the internal and external hardware seems to work with
Vista.

Lawrence Bezeau (lmbezeau) wrote :

Since posting the above comments, I managed to get Ubuntu to boot once and,
at that time, I invoked Update Manager to bring everything up to date. Since then
Ubuntu boots fine but I still get this error message at the same stage of the boot
process as before. But the boot process continues and Ubuntu seems to work
okay. This is all very strange.

Ray Harper (raymond-harper1) wrote :

As with Lawrence Bezeau's last comment. I can boot OK, no problems with Ubuntu 10.04 except the "Cannot reserve MMIO region" message at the top of the otherwise blank screen during boot.

fabioamd87 (fabioamd87) wrote :

same issue here on hp 6735b laptop.

Xtian74\ (cchiappa) wrote :

same here with HP 6735s. The message appears at boot but then everything looks ok. Tested with Ubuntu 10.04, 10.04.1 & 10.10 beta 1

mikeu4c (micha-schlittenhardt) wrote :

same problem here on HP 6735s... everything looks good after the boot. BUT it doesnt look well when i'm booting my notebook and needs time, too!

fabioamd87 (fabioamd87) wrote :

maybe is a Catalyst driver bug?

Xtian74\ (cchiappa) wrote :

@fabioamd87
I do not think so cause I tried with ATI proprietary drivers too, but I got the same error.
By the way, is there someone that knows what does this error mean?

gert (gert-cauwenberg) wrote :

I had this bug before on Kubuntu 10.4. Today upgraded to Kubuntu 10.10. Still the same; everything looks ok after boot, but booting takes a long time because of this message.

Kálmán, Ferenc (fkalman) wrote :

Same problem here. I use boot chart. Btrfs and btrfsctl appears on the chart and run (wait) about 15 seconds.
I have attached the boot charts of lucid and maverick.

fig_wright (fig-wright) wrote :

I have this since upgrade to 10.10 today. I get 2 lines in syslog, and it flashes up annoyingly during boot, corrupting the boot splash screen:

shpchp 0000:00:01.0: Cannot reserve MMIO region
shpchp 0000:00:10.0: Cannot reserve MMIO region

Those are PCI device codes:

00:01.0 PCI bridge: Advanced Micro Devices [AMD] AMD-760 MP [IGD4-2P] AGP Bridge (prog-if 00 [Normal decode])
00:10.0 PCI bridge: Advanced Micro Devices [AMD] AMD-768 [Opus] PCI (rev 05) (prog-if 00 [Normal decode])

Perhaps something to do with graphics driver? I have a PCI (yes, PCI!) Nvidia GeForce 6200 card.

isotope (vadim-ryazanov) wrote :

Have same message on HP 6735s running clean install of Ubuntu 10.10 and 2.6.35-22 generic kernel. Ubuntu boots though.

Same here. I have a new install of Ubuntu 10.10 with an AMD Phenom II X4 and an integrated Radeon HD 4290.

edl (eddy-deluca) wrote :

Have same problem. I have hp 380f all in one on network (installed driver hplip 3.10.2 ) and Ati 3200Hd. Update Ubuntu 10.10. Installed the last kernel.

Kevin Channon (kevinchannon) wrote :

I also have this problem. It was fine in Jaunty and then when I upgraded to Lucid I started to get the message. It still occurs in Maverick. I'm using a HP Pavillion DM3. It boots into Ubuntu fine, but it seems like this error might be slowing things down as some signal is waited for from some piece of hardware that might not be there or something. As PCI codes are mentioned above, "lspci" returns this:

00:00.0 Host bridge: Advanced Micro Devices [AMD] RS780 Host Bridge
00:01.0 PCI bridge: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (int gfx)
00:04.0 PCI bridge: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (PCIE port 0)
00:05.0 PCI bridge: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (PCIE port 1)
00:11.0 SATA controller: ATI Technologies Inc SB700/SB800 SATA Controller [AHCI mode]
00:12.0 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI0 Controller
00:12.1 USB Controller: ATI Technologies Inc SB700 USB OHCI1 Controller
00:12.2 USB Controller: ATI Technologies Inc SB700/SB800 USB EHCI Controller
00:13.0 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI0 Controller
00:13.2 USB Controller: ATI Technologies Inc SB700/SB800 USB EHCI Controller
00:14.0 SMBus: ATI Technologies Inc SBx00 SMBus Controller (rev 3c)
00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA)
00:14.3 ISA bridge: ATI Technologies Inc SB700/SB800 LPC host controller
00:14.4 PCI bridge: ATI Technologies Inc SBx00 PCI to PCI Bridge
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:05.0 VGA compatible controller: ATI Technologies Inc RS780M/RS780MN [Radeon HD 3200 Graphics]
01:05.1 Audio device: ATI Technologies Inc RS780 Azalia controller
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 02)
08:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)

My wife runs Lucid on her Sony Vaio (I can't remember the exact model but I think it's a T-series one) but this message is not seen during boot. I think that her laptop boots faster as a result. When I have time, I'll lspci her laptop as well.

This is not a terminal problem, but I really want the fastest boot :o)

Again, although not a major issue, it does really slow my boot times, any help would be appreciated. are there any known temporary workarounds?

Cepher (briankolczynski) wrote :

I have an HP pavillion dv5 laptop, and I didn't have the problem until I went from 10.04 to .10.

DasJott (das-jott) wrote :

Same for me on my Acer Aspire One 521 with Ubuntu 10.10.
It slows down boot time as it waits for some seconds at that point. No further problems with the system though.

iceblueirish (iceblueirish) wrote :

I also have this issue, (Please note, I am running ATI Catalyst. This correlation should not be completely ruled out yet right? This may be an issue, perhaps we could adjust Catalyst settings?

LSL (spesialstyrker) wrote :

I am on an hp-tx2510us tablet pc running on AMD's puma platform, and I get this error.

LSL (spesialstyrker) wrote :

Tested on maverick current kernel image (2.6.37-999-generic) and I get these errors:

shpchp 0000:00:01.0: Cannot reserve MMIO region
shpchp 0000:00:04.0: Cannot reserve MMIO region
shpchp 0000:00:05.0: Cannot reserve MMIO region
shpchp 0000:00:06.0: Cannot reserve MMIO region
ata3: softreset failed (device not ready)
ata4: softreset failed (device not ready)

Whereas on the current stock maverick kernel (2.6.35-22-generic) I only get:
shpchp 000:00:01.0: Cannot reserve MMIO region

tags: added: maverick
removed: needs-upstream-testing
LSL (spesialstyrker) wrote :

These error messages are only printed to TTY1 as well. I don't know what logs they would be under to include them for you.

Westly Ward (sonicrules1234) wrote :

I also have this problem when booting linux mint 10, which is based on Ubuntu 10.10.
I have a Quad-core AMD64 Phenom II processor, and also a realtek ethernet controller. I also have an ATI Mobility Radeon graphics card. It boots for me, showing that message at boot up. My entropy key doesn't show up in /dev like it should, although it does show up in lsusb. This laptop is a HP Pavillion dv6-3050us. Tried the entropy key on a different laptop, and it worked fine. The package manager wanted me to reinstall the kernel. I did but nothing changed.

Fabio Marconi (fabiomarconi) wrote :

Still present with 2.6.37-5 natty's kernel

tags: added: natty
Changed in linux (Ubuntu):
status: Incomplete → Confirmed

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here. Thanks for taking the time to make Ubuntu better!

Changed in linux (Ubuntu):
importance: Undecided → Low
status: Confirmed → Triaged
description: updated
description: updated
fabioamd87 (fabioamd87) wrote :

type sudo when logged as root?

Typing sudo when logged as root does nothing to change the command. However, if, instead, you logged in using a tty, it will allow the command to work. This is easier than writing two separate workarounds when one will actually work for both situations.

Timo Witte (spacefish) wrote :

i just installed the latest kernel package and it seems to work fine for me now, the message is still present, but the graphic driver works!

Xtian74\ (cchiappa) wrote :

It seems to me it could be related to some patches applied to ubuntu's kernel. With other distros (for example PcLinuxOs) this bug is not present. Is it possible to use a "standard" kernel (please, could someone give some tips about how to do it?) and insert it to official repositories?

finndo (finndo77) wrote :

HAD this issue with a custom built rig, has an onboard ATI 3300HD and a PCIe 4890, issue started when I rebooted with a new display configuration, I re-enabled the onboard video and tried plugging one monitor into it and the other into the PICe card. (the onboard has HDMI out and I was planning on hooking it up to my TV, but wanted to use my dual monitors on my onboard too, so I was testing using both cards at the same time. fyi no go, the two are not compatible with each other for such a setup, I'd need a PCIe 3300 or 4300 series to do it, and the 3300 drivers are not longer included in the driver packs, so I'd need to use a 3 year old driver pack or somehow install 2 ATI drivers side by side... the 4890 driver is in the legacy driver pack already anyways).

First thing I did was to mv my xorg.conf file to a new name and reboot
http://ubuntuforums.org/showthread.php?t=1575262

this allowed me to get past the error and login via command line
could not startx (failed with nasty long messages)

reboot again
this time same message, but the GUI launched itself... but only one display powered on (the 4890, but at the time I thought it was the onboard)
I had already downloaded the new ATI driver pack so I went ahead and installed it, ran the aticonfig --initial and rebooted...

everything came back up the same as last time, I tried configuring my 2 monitors, but the ATI driver did not identify the onboard video and would only let me select 640x480, so I disabled it and shut down.

reset my BIOS setup back to single PICe video device and rebooted...

back to square one, error message, and no GUI, but yes to command line...
went back and put my original xorg.conf file in place and rebooted (both monitors back in the 4890 with the onboard 3300 disabled)

system restarted THE ERROR MESSAGE WAS GONE.

this is definitely a graphics based issue and is related to xorg and the display driver/monitor hardware setup.

What I would request is that anyone with this error, please when you post, put if you have an onboard video device and/or an addon card, what monitor configuration you are using, how many, where they are plugged in, if you are doing hydravision/surround display view/crossfire/SLI and any display/hardware changes you have made recently. this should help figure out the cause and get it resolved.

hope this helps someone out.

D. Hartman (daniel-hartman) wrote :

Same symptoms as Lawrence Bezeau (see above). I have a HP Pavilion G4. I can get to GRUB, but the system locks up during the kernel boot, usually some time after the following message (although the specific time is never consistent):

  shpchp 0000:00:01.0: Cannot reserve MMIO region
  SP5100 TCO timer: mmio address 0xb8fe00 already in use
  Bad LUN (0:1)

Afterwhich, a hard reboot is necessary, ctrl+alt+f1 does not work.

This occurred when I upgraded from 10.10 to 11.04. Incidentally, the 11.04 Live CD won't boot either. Going back to 10.10. Very frustrated.

Bjorn Helgaas (bjorn-helgaas) wrote :

This patch should fix the shpchp error message: http://marc.info/?l=linux-pci&m=131411621004431&w=2

The system hangs reported by lmbezeau and daniel-hartman are a separate issue and should be reported as a different bug.

Chris Eineke, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

Also, could you please test the latest upstream kernel available following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Please do not test the daily kernel folder, but the one all the way at the bottom. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-v3.12-rc2

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

Changed in linux (Ubuntu):
status: Triaged → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers