Ubuntu

ACPI errors at boot (HP 8540w Elite Workstation)

Reported by FiX on 2010-05-09
76
This bug affects 12 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
Declined for Maverick by Brian Murray
Declined for Natty by Brian Murray

Bug Description

ACPI error at boot:

[ 1.907252] ------------[ cut here ]------------
[ 1.907258] WARNING: at /build/buildd/linux-2.6.32/arch/x86/kernel/hpet.c:392 hpet_next_event+0x7a/0x90()
[ 1.907261] Hardware name: HP EliteBook 8540w
[ 1.907262] Modules linked in:
[ 1.907266] Pid: 0, comm: swapper Not tainted 2.6.32-22-generic #33-Ubuntu
[ 1.907268] Call Trace:
[ 1.907275] [<ffffffff81066d0b>] warn_slowpath_common+0x7b/0xc0
[ 1.907278] [<ffffffff81066d64>] warn_slowpath_null+0x14/0x20
[ 1.907281] [<ffffffff810375ca>] hpet_next_event+0x7a/0x90
[ 1.907284] [<ffffffff81037610>] hpet_legacy_next_event+0x10/0x20
[ 1.907288] [<ffffffff81092e24>] clockevents_program_event+0x54/0xa0
[ 1.907292] [<ffffffff81094378>] tick_dev_program_event+0x68/0xd0
[ 1.907295] [<ffffffff81093cae>] tick_broadcast_oneshot_control+0x11e/0x120
[ 1.907299] [<ffffffff810934c0>] tick_notify+0x130/0x200
[ 1.907303] [<ffffffff81543b16>] notifier_call_chain+0x56/0x80
[ 1.907307] [<ffffffff8108a366>] raw_notifier_call_chain+0x16/0x20
[ 1.907310] [<ffffffff81092c47>] clockevents_notify+0x37/0x160
[ 1.907314] [<ffffffff8130ccc5>] lapic_timer_state_broadcast+0x46/0x48
[ 1.907317] [<ffffffff8130d234>] acpi_idle_enter_bm+0x187/0x2be
[ 1.907321] [<ffffffff81543ad6>] ? notifier_call_chain+0x16/0x80
[ 1.907325] [<ffffffff81437507>] cpuidle_idle_call+0xa7/0x140
[ 1.907329] [<ffffffff81011e73>] cpu_idle+0xb3/0x110
[ 1.907332] [<ffffffff8153ad4b>] start_secondary+0xa8/0xaa
[ 1.907337] ---[ end trace 487d3471093fd0da ]---

Following: kacpid taking ~100% CPU (fortunately only 1 thread of 1 core):

  PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
   59 root 20 0 0 0 0 R 96 0.0 38:49.67 kacpid

Numerous PCI-Express errors like this one (not sure it is related):

[ 219.136618] pcieport 0000:00:03.0: AER: Corrected error received: id=0018
[ 219.136708] pcieport 0000:00:03.0: PCIE Bus Error: severity=Corrected, type=Physical Layer, id=0018(Receiver ID)
[ 219.136715] pcieport 0000:00:03.0: device [8086:d138] error status/mask=00000001/00002000
[ 219.136721] pcieport 0000:00:03.0: [ 0] Receiver Error (First)

Finally suspend is not working.

Will now try with main-line kernel.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: linux-image (not installed)
Regression: No
Reproducible: Yes
ProcVersionSignature: Ubuntu 2.6.32-22.33-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-22-generic x86_64
NonfreeKernelModules: nvidia
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 2/2
   Subdevice #0: subdevice #0
   Subdevice #1: subdevice #1
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: administrator 1820 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xd7520000 irq 16'
   Mixer name : 'IDT 92HD75B3X5'
   Components : 'HDA:111d7603,103c1521,00100202 HDA:11c11040,103c3066,00100200'
   Controls : 19
   Simple ctrls : 13
Card1.Amixer.info:
 Card hw:1 'NVidia'/'HDA NVidia at 0xd3000000 irq 17'
   Mixer name : 'Nvidia ID d'
   Components : 'HDA:10de000d,10de0101,00100100'
   Controls : 0
   Simple ctrls : 0
Card1.Amixer.values:

Date: Sun May 9 08:21:27 2010
HibernationDevice: RESUME=UUID=1464fe4c-b6eb-48c5-b9b0-45b74f255191
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
MachineType: Hewlett-Packard HP EliteBook 8540w
PccardctlIdent:
 Socket 0:
   product info: "RICOH", "Bay8Controller", "", ""
   manfid: 0x0000, 0x0000
   function: 254 (unknown)
PccardctlStatus:
 Socket 0:
   3.3V 16-bit PC Card
   Subdevice 0 (function 0) bound to driver "pata_pcmcia"
ProcCmdLine: BOOT_IMAGE=/vmlinuz-2.6.32-22-generic root=UUID=95b98a22-b273-4469-aea4-d7962f14e452 ro quiet splash
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
RelatedPackageVersions: linux-firmware 1.34
SourcePackage: linux
dmi.bios.date: 03/26/2010
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: 68CVD Ver. F.07
dmi.board.name: 1521
dmi.board.vendor: Hewlett-Packard
dmi.board.version: KBC Version 32.2E
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.modalias: dmi:bvnHewlett-Packard:bvr68CVDVer.F.07:bd03/26/2010:svnHewlett-Packard:pnHPEliteBook8540w:pvr:rvnHewlett-Packard:rn1521:rvrKBCVersion32.2E:cvnHewlett-Packard:ct10:cvr:
dmi.product.name: HP EliteBook 8540w
dmi.sys.vendor: Hewlett-Packard

FiX (fix-kowalski) wrote :
FiX (fix-kowalski) wrote :

Tested against main-line kernels:

2.6.33-02063303
2.6.34-020634rc6

In both cases, the ACPI error message at boot is no longer here. But:

1) The pcie error messages remain:

[ 179.311138] pcieport 0000:00:03.0: AER: Corrected error received: id=0018
[ 179.311147] pcieport 0000:00:03.0: PCIe Bus Error: severity=Corrected, type=Data Link Layer, id=0018(Receiver ID)
[ 179.311150] pcieport 0000:00:03.0: device [8086:d138] error status/mask=00000040/00002000
[ 179.311227] pcieport 0000:00:03.0: [ 6] Bad TLP

2) The system can still not suspend (USB 3.0):

[ 247.409976] PM: Syncing filesystems ... done.
[ 247.609594] PM: Preparing system for mem sleep
[ 247.609602] Freezing user space processes ... (elapsed 0.01 seconds) done.
[ 247.628911] Freezing remaining freezable tasks ... (elapsed 0.02 seconds) done.
[ 247.648903] PM: Entering mem sleep
[ 247.648944] Suspending console(s) (use no_console_suspend to debug)
[ 247.768895] pm_op(): usb_dev_suspend+0x0/0x20 returns -2
[ 247.768899] PM: Device usb3 failed to suspend: error -2
[ 247.768901] PM: Some devices failed to suspend
[ 247.809176] PM: resume of devices complete after 40.313 msecs
[ 247.809404] PM: resume devices took 0.040 seconds
[ 247.809716] PM: Finishing wakeup.

3) kacpid still at 100% CPU

Will test without the nvidia module.

FiX (fix-kowalski) wrote :

Test without the nvidia proprietary driver (use nouveau):

1) kacpid still at ~100% CPU

2) suspend still does not work (same error message)

3) PCI-Express error message format changed:

[ 19.902815] pcieport 0000:00:03.0: can't find device of ID0018
[ 19.902821] pcieport 0000:00:03.0: AER: Multiple Uncorrected (Non-Fatal) error received: id=0018

FiX (fix-kowalski) wrote :

The system not suspending is another problem (xhci module) already covered by:

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/522263 (specific to HP hardware)
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/522998 (generic)

problem left:

1) kacpid at 100% cpu

2) PCI-Expresse error messages

FiX (fix-kowalski) wrote :

The root cause is a broken ACPI BIOS. I fixed both remaining problems by settings "FAN always on while one AC power" in the BIOS (which is the default value).

NOTE: This is the exact inverse settings compared to the value required to make the "HP 8530w EliteBook Mobile Workstation" work flawlessly.

This behavior is observed using the following BIOS:

BIOS Information
        Vendor: Hewlett-Packard
        Version: 68CVD Ver. F.07
        Release Date: 03/26/2010
[...]

        BIOS Revision: 15.7
        Firmware Revision: 32.41

Eric Baumann (eric-mannbaum) wrote :

Hi

How is this done?
I mean how can I set "FAN always on while on AC power in the BIOS "?

Thanks a lot.

Kind regards.

By the way, didn't you encounter the problem that you couldn't adjust the
display brightness using the fn and f9/f10 buttons?

Well. Press f10 at boot. Go in configuration. Check this fan option. Save.
Reboot.

Le 12 mai 2010 17:05, "Eric Baumann" <email address hidden> a écrit :

Hi

How is this done?
I mean how can I set "FAN always on while on AC power in the BIOS "?

Thanks a lot.

Kind regards.

By the way, didn't you encounter the problem that you couldn't adjust the
display brightness using the fn and f9/f10 buttons?

--
ACPI errors at boot (HP 8540w Elite Workstation)
https://bugs.launchpad.net/bugs/577702
You rec...

Jeremy Foshee (jeremyfoshee) wrote :

Hi FiX,

If you could also please test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

    [This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete
Adamo Ferro (adamo-ferro) wrote :

Hi all,

I've the same kacpid problem on my new HP EliteBook 8540p. Same BIOS as reported by FiX.
When I boot the pc kacpid is not eating my CPU. It seems to start after I suspend or hibernate the pc.

Not sure about the solution of setting to on the "FAN always on while on AC power" in the BIOS.
It was already on ON.

I switched to OFF, the problem remains (kacpid 100% CPU after suspending).

I re-switched to ON, the problem still remains.

Hope this more information helps...

Regards,
Adamo

Pedro Bedolla (pedroobv) wrote :

I have a different experience with the kacpid bug also in a HP 8540w with BIOS ver. F.07. I've tested it in Ubuntu 10.04 with the default kernel and also against the main-line kernels 2.6.33.3-lucid, 2.6.33.4-lucid and 2.6.32-rc7. In all this cases kacpid is taking ~100% CPU (only 1 thread of 1 core). Setting the option "FAN always on while on AC power" in the BIOS didn't work for me.
I've noticed that unloading the xhci module with pm-utils before suspending also fixes the kacpid bug but only after resuming a suspended laptop.
This bug have been reported for the linux kernel version 2.6.34 RC6 (https://bugzilla.kernel.org/show_bug.cgi?id=15924), but here it is mentioned that this bug was not present in the kernel 2.6.33.3 On OSS 11.3 M3.

In Ubuntu 10.04 it is possible to temporary save the problem by disabling GPE01 with
echo disable > /sys/firmware/acpi/interrupts/gpe01

FiX (fix-kowalski) wrote :

I confirm that the problem that was fixed by kernel 2.6.33-02063303-generic does happen again using 2.6.34-020634-generic (downloaded from the link provided above). This is a regression.

FiX (fix-kowalski) wrote :

Aside this regression (kacpid taking ~100% cpu), there is another change in 2.6.34 that null-ifies a previous workaround: the xhci (USB 3.0 module) that does not support suspend/resume was renamed xhci_hcd in 2.6.34. Adapting accordingly the content of the files /etc/pm/config and /etc/pm/config.d/00sleep_module fixes the suspend/resume (but not the kacpid taking 100% cpu)

# https://bugs.launchpad.net/ubuntu/+source/linux/+bug/522263
# https://bugs.launchpad.net/ubuntu/+source/linux/+bug/522998
SUSPEND_MODULES="xhci xhci_hcd"

The above mentioned work-around to disable IRQ's on GPE01 does not work (even run as plain root instead of sudoer).

# echo disable > /sys/firmware/acpi/interrupts/gpe01

# cat /sys/firmware/acpi/interrupts/gpe01
   29441 enabled

tags: removed: needs-upstream-testing
FiX (fix-kowalski) wrote :

2.6.33-02063304-generic (latest 2.6.33 from the Ubuntu kernel team). I observe the same behavior as @pedroobv

- after cold boot: kapcid at ~100% cpu.
- after resume: no pb.

Will try those 2 scenarios with an earlier 2.6.33 & the latest 2.6.34...

FiX (fix-kowalski) wrote :

2.6.34-020634rc7-generic (latest 2.6.34 from the Ubuntu kernel team). I observe:

- after cold boot: kapcid at ~100% cpu.
- after resume: kapcid at ~100% cpu.

Will try those 2 scenarios with an earlier 2.6.33...

FiX (fix-kowalski) wrote :

2.6.33-02063303-generic:

- after cold boot: kapcid at ~100% cpu.
- after resume: no pb

This might be due to the rmmod+insmod sequence forced by the PM configuration described above. I will blacklist this module & test again with the above kernels.

FiX (fix-kowalski) wrote :

black-listing the xhci* modules does not fix the problem => This issue is not the same as https://bugs.launchpad.net/ubuntu/+source/linux/+bug/522998

FiX (fix-kowalski) wrote :

2.6.32-22-preempt:

- after cold boot: kapcid at ~100% cpu.
- after resume: no pb

As expected, this -preempt kernel also has the exact same ACPI/HPET problem as the -generic one.

=> 2.6.33* remain the safest kernel to use on this "HP EliteBook 8540w Mobile Workstation" laptop.

FiX (fix-kowalski) wrote :

Amending #16: as indicated by #10, disabling gpe01 indeed brings kapcid down to a normal CPU usage, even if gpe01 is still reported as enabled. So the work-around from korg works also in my case.

herve (rv-changue) wrote :

Hello everyone many people have the same problem with hp laptop (not only the HP 8540w). i have a hewlet packard bell easynote sb 87 and i have the same problem (kcpid 100% after suspend and only one core). This problem happens in windows seven too (for me)... the newest kernel in ppa didnt fix it. I think this is kinda the same problem as described here but i'm not a kernel programmer.
Can someone help??

Thanks

Frode Haugsgjerd (froh) wrote :

Same here
HP EliteBook 8540p
BIOS 68CVD Ver. F.07.
kacpid 100% cpu after resume.
No problem with kernel 2.6.35-999.201007011005

Michael Toop (michael-toop) wrote :

Same problem: kapcid 100% after resume.
$ uname -a
Linux michaelt-laptop 2.6.32-23-generic #37-Ubuntu SMP Fri Jun 11 08:03:28 UTC 2010 x86_64 GNU/Linux
$ cat /etc/issue
Ubuntu 10.04 LTS \n \l

Michael Zaugg (AOI) (it-oas) wrote :

On a EliteBook 8540w with 2.6.33 I did
echo disable > /sys/firmware/acpi/interrupts/gpe01 in rc.local
but it wasn't executed (80% CPU while and after booting,execution bit set).

Interestingly the CPU stopped after suspending with
SUSPEND_MODULES="xhci xhci_hcd" in /etc/pm/config.d after doing

Finaly I did a
sudo ln -s /etc/rc.local /etc/rcS.d/S99rclocal
and now the CPU is normal after booting (thanks http://maltekueppers.de/wp/?p=1475 for the hint).

jisaac (jisaac) wrote :

Same problem here on my iMac 27" i7 and Ubuntu 10.10.

Charles Majola (chmj) wrote :

Same problem here; Ubuntu 10.10 updated today, EliteBook 8740w

Workaround: echo disable > /sys/firmware/acpi/interrupts/gpe01

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.