ums_cypress missing from lucid server cd

Bug #576066 reported by David Tomaschik on 2010-05-05
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Server papercuts
Undecided
Unassigned
linux (Ubuntu)
Medium
Tim Gardner
Lucid
Low
Tim Gardner
Maverick
Medium
Tim Gardner

Bug Description

The Lucid Server Install CD is missing the ums_cypress.ko driver, but the usb-storage driver has ums-cypress devices blacklisted. Accordingly, I cannot install from a CD for any of my blades located in a Blade Chassis that uses a Cypress chipset for the USB drive. (Specifically, an IBM BladeCenter H, type 8852-HC1.) This is a significant impact to testing Lucid on several blades. (I'll be trying to prep a USB key to see if that works.)

Since this is hardware-specific, I cannot reproduce in a VM to provide specific log information.

David Tomaschik (matir) wrote :

By the way, LP #419231 provides details on why usb-storage does not work, even though it would normally support the device.

Jeremy Foshee (jeremyfoshee) wrote :

Hi David,

Please be sure to confirm this issue exists with the latest development release of Ubuntu. ISO CD images are available from http://cdimage.ubuntu.com/releases/ . If the issue remains, please run the following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux 576066

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

    [This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-kernel-logs
tags: added: needs-upstream-testing
tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete

Jeremy,

I know your automated message is targeted at your average kernel bug,
but obviously, since this is a LiveCD issue, it's much harder to collect
that information.

David

On 05/05/2010 07:57 PM, Jeremy Foshee wrote:
> Hi David,
>
> Please be sure to confirm this issue exists with the latest development release of Ubuntu. ISO CD images are available from http://cdimage.ubuntu.com/releases/ . If the issue remains, please run the following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.
>
> apport-collect -p linux 576066
>
> Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.
>
> Thanks in advance.
>
> [This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]
>
>
> ** Tags added: needs-kernel-logs
>
> ** Tags added: needs-upstream-testing
>
> ** Tags added: kj-triage
>
> ** Changed in: linux (Ubuntu)
> Status: New => Incomplete
>
>

--
David Tomaschik, RHCE
Moderator, LinuxQuestions.org
http://www.tuxteam.com
<email address hidden> [GPG: 0x6D428695]

Jeremy Foshee (jeremyfoshee) wrote :

Indeed, you are correct. Thank you for your understanding.

~JFo

Changed in linux (Ubuntu):
status: Incomplete → Triaged
Jeremy Foshee (jeremyfoshee) wrote :

Changed package to ubuntu-meta. This appears to be a seeds issue but ubuntu-meta is the closest to that.

~JFo

affects: linux (Ubuntu) → ubuntu-meta (Ubuntu)
Changed in ubuntu-meta (Ubuntu):
status: Triaged → New
agklein1 (andyklein) wrote :

I can confirm this bug. Well, actually, a very related bug: the lack of ums_cypress.ko on the ubuntu-10.04-alternate-amd64 CD prevents me from successfully completing the install on a PC with an external CD-ROM drive that has a Cypress Semi chipset. I have posted a workaround here, which might also work around this problem --
http://ubuntuforums.org/showthread.php?p=9365450

Thierry Carrez (ttx) wrote :

This is actually a kernel packaging issue, as confirmed by cjwatson:
<ttx> cjwatson: looking at https://bugs.launchpad.net/ubuntu/+source/ubuntu-meta/+bug/576066 ... I'm not sure it's categorized correctly. Are the kernel modules available to the Server installer really decided by seeds ?
<cjwatson> ttx: no, the kernel packaging decides that

affects: ubuntu-meta (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
status: New → Confirmed
Thierry Carrez (ttx) wrote :

Declined as a server papercut, since this is a kernel issue -- however I'll raise it with the kernel team in todays meeting.

Changed in server-papercuts:
status: New → Invalid
tags: added: kernel-core kernel-needs-review
removed: needs-kernel-logs needs-upstream-testing
Changed in linux (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Medium
Andy Whitcroft (apw) wrote :

Ok. From what I can see this driver is included in the kernel .deb (see below) therefore it should be available on the CD:

    -rw-r--r-- root/root 8736 2010-04-16 13:04 ./lib/modules/2.6.32-21-server/kernel/drivers/usb/storage/ums-cypress.ko

It is however not listed for inclusion in a .udeb in the d-i configuration, so I would expect it to be missing on the alternate CD's.

John Johansen (jjohansen) wrote :

The kernel team is looking for some clarification on this bug.

Is this intended only for the Lucid server install cd or are we looking at Lucid alternate as well?

John Johansen (jjohansen) wrote :

Another point to clarify, is if this is working on Maverick.

Thierry Carrez (ttx) wrote :

I'll let David answer on those questions... IMO this would affect all USB drives with cypress chipset, so alternate should also ship it.

David Tomaschik (matir) wrote :

I can only confirm that it affects the Lucid Server Install CD. I'll try to find an opportunity today to boot one of our test blades with the latest Maverick disk to confirm if this is still present. (Though, even if fixed in Maverick, I would hope it could be fixed for a 10.04.1 release.)

Andy Whitcroft (apw) on 2010-07-12
tags: added: kernel-candidate kernel-reviewed
removed: kernel-needs-review
tags: removed: kernel-candidate
Tim Gardner (timg-tpi) on 2010-07-12
Changed in linux (Ubuntu Lucid):
assignee: nobody → Tim Gardner (timg-tpi)
importance: Undecided → Low
milestone: none → lucid-updates
status: New → In Progress
Changed in linux (Ubuntu Maverick):
assignee: nobody → Tim Gardner (timg-tpi)
milestone: none → maverick-alpha-3
status: Triaged → In Progress
Tim Gardner (timg-tpi) wrote :

SRU Justification

Impact: alternate and server installs won't work on USB Cypress chipsets

Patch Description: Add ums-cypress to d-i scsi-modules

Patch: attached

Changed in linux (Ubuntu Maverick):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.35-8.13

---------------
linux (2.6.35-8.13) maverick; urgency=low

  [ Kees Cook ]

  * SAUCE: Yama: check PTRACE using thread group leader
  * SAUCE: Yama: search for PTRACE exceptions via thread group leader
    - LP: #603716

  [ Leann Ogasawara ]

  * rebase to v2.6.35-rc5
  * [Config] update configs following rebase to v2.6.35-rc5

  [ Nicolas Pitre ]

  * SAUCE: make ndiswrapper available on X86 only

  [ Tim Gardner ]

  * [Config] Added ums-cypress to udeb
    - LP: #576066
  * SAUCE: fix build error with CONFIG_BLK_DEV_INITRD=n
  * [Config] CONFIG_NDISWRAPPER=m across all configs

  [ Upstream Kernel Changes ]

  * HID: magicmouse: report last touch up
  * rebase to 2.6.35-rc5
 -- Leann Ogasawara <email address hidden> Tue, 13 Jul 2010 18:57:59 -0700

Changed in linux (Ubuntu Maverick):
status: Fix Committed → Fix Released
Steve Conklin (sconklin) wrote :

SRU Justification

Impact: The upstream process for stable tree updates is quite similar in scope to the Ubuntu SRU process, e.g., each patch has to demonstrably fix a bug, and each patch is vetted by upstream by originating either directly from Linus' tree or in a minimally backported form of that patch.

The 2.6.32.21 upstream stable patch set is now available and contains fixes for this problem. It should be included in the Ubuntu kernel as well.

Related commits in the Lucid repo are:

a4b2cac UBUNTU: [Config] Added ums-cypress to udeb

Changed in linux (Ubuntu Lucid):
status: In Progress → Fix Committed
Steve Conklin (sconklin) wrote :

whoops, boilerplate fail!

This wasn't a stable update from upstream, but an Ubuntu config change

Accepted linux into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Steve Conklin (sconklin) wrote :

David,

Is it possible for you to test the proposed kernel and see if this is resolved? we're awaiting confirmation of the fix.

Thanks,

Steve

Stefan Bader (smb) wrote :

dpkg --contents scsi-modules-2.6.32-25-generic-di_2.6.32-25.44_i386.udeb |grep cypress
-rw-r--r-- root/root 6428 2010-09-18 03:25 ./lib/modules/2.6.32-25-generic/kernel/drivers/usb/storage/ums-cypress.ko

Colin Watson (cjwatson) wrote :

http://cdimage.ubuntu.com/ubuntu-server/lucid/daily/current/ should have this now; apologies for the delay. (Also apologies for the slightly buggy styling; this is a work in progress at the moment.)

David Tomaschik (matir) wrote :

I'll try to find an opportunity to boot a CD on one of our blades today and let you know if the issue is resolved.

Launchpad Janitor (janitor) wrote :
Download full text (43.7 KiB)

This bug was fixed in the package linux - 2.6.32-25.44

---------------
linux (2.6.32-25.44) lucid-proposed; urgency=low

  [ Brad Figg ]

  * SAUCE: (no-up) Modularize vesafb -- fix initialization
    - LP: #611471

  [ Stefan Bader ]

  * Revert "SAUCE: sync before umount to reduce time taken by ext4 umount"
    - LP: #543617, #585092

  [ Steve Conklin ]

  * Revert "SAUCE: tulip: Let dmfe handle davicom on non-sparc"
    - LP: #607824

  [ Tim Gardner ]

  * [Config] Added ums-cypress to udeb
    - LP: #576066

  [ Upstream Kernel Changes ]

  * Revert "PCI quirk: Disable MSI on VIA K8T890 systems"
    - LP: #607824
  * Revert "PCI quirks: disable msi on AMD rs4xx internal gfx bridges"
    - LP: #607824
  * Revert "(pre-stable) Input: psmouse - reset all types of mice before
    reconnecting"
    - LP: #607824
  * Revert "jbd: jbd-debug and jbd2-debug should be writable"
    - LP: #607824
  * Revert "ext4: Make fsync sync new parent directories in no-journal
    mode"
    - LP: #615548
  * Revert "ext4: Fix compat EXT4_IOC_ADD_GROUP"
    - LP: #615548
  * Revert "ext4: Conditionally define compat ioctl numbers"
    - LP: #615548
  * Revert "ext4: restart ext4_ext_remove_space() after transaction
    restart"
    - LP: #615548
  * Revert "ext4: Clear the EXT4_EOFBLOCKS_FL flag only when warranted"
    - LP: #615548
  * Revert "ext4: Avoid crashing on NULL ptr dereference on a filesystem
    error"
    - LP: #615548
  * Revert "ext4: Use bitops to read/modify i_flags in struct
    ext4_inode_info"
    - LP: #615548
  * Revert "ext4: Show journal_checksum option"
    - LP: #615548
  * Revert "ext4: check for a good block group before loading buddy pages"
    - LP: #615548
  * Revert "ext4: Prevent creation of files larger than RLIMIT_FSIZE using
    fallocate"
    - LP: #615548
  * Revert "ext4: Remove extraneous newlines in ext4_msg() calls"
    - LP: #615548
  * Revert "ext4: init statistics after journal recovery"
    - LP: #615548
  * Revert "ext4: clean up inode bitmaps manipulation in ext4_free_inode"
    - LP: #615548
  * Revert "ext4: Do not zero out uninitialized extents beyond i_size"
    - LP: #615548
  * Revert "ext4: don't scan/accumulate more pages than mballoc will
    allocate"
    - LP: #615548
  * Revert "ext4: stop issuing discards if not supported by device"
    - LP: #615548
  * Revert "ext4: check s_log_groups_per_flex in online resize code"
    - LP: #615548
  * Revert "ext4: fix quota accounting in case of fallocate"
    - LP: #615548
  * Revert "ext4: allow defrag (EXT4_IOC_MOVE_EXT) in 32bit compat mode"
    - LP: #615548
  * Revert "ext4: rename ext4_mb_release_desc() to ext4_mb_unload_buddy()"
    - LP: #615548
  * Revert "ext4: Remove unnecessary call to ext4_get_group_desc() in
    mballoc"
    - LP: #615548
  * Revert "ext4: fix memory leaks in error path handling of
    ext4_ext_zeroout()"
    - LP: #615548
  * Revert "ext4: check missed return value in ext4_sync_file()"
    - LP: #615548
  * Revert "ext4: Issue the discard operation *before* releasing the blocks
    to be reused"
    - LP: #615548
  * Revert "ext4: Fix buffer head leaks after calls to
    ext4_get_inode_loc()"
    - LP: #615548
  * Revert "ex...

Changed in linux (Ubuntu Lucid):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers