On boot keeps trying to mount "UDEVD-WORK..../dev/null"

Bug #575333 reported by tecknomage
312
This bug affects 62 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Invalid
Low
Unassigned
udev (Ubuntu)
Invalid
Undecided
Unassigned

Bug Description

Binary package hint: firefox

After online Upgrade Ubuntu 10 -> 10.04.... On boot keeps trying to mount "UDEVD-WORK..../dev/null" which fails because it does not exist. Forum thread says this is a fstab file problem. Various suggested fixes do not work. System Info:
Ubuntu 10.04 (lucid)
GROME 2.30.0 (Ubuntu 2010-03-31)
Kernal 2.6.32-21-generic
OS Type Linux
GCC 4.4.3 (i486-linux-gnu)

WORKAROUND: Experiment-1: Mounted a data DVD and rebooted. Sure enough at the time, during boot, when the UDEVD-WORK would display, the DVD drive would spin-up (access LED flashed) then the boot continued NORMALLY.

WORKAROUND: Change boot-order to HD then CD, mounted my copy of Ubuntu 10.04 Live CD and booted. Booted NORMALLY, but did read the CD. Rebooted, changed boot-order back to CD then HD, booted WITHOUT CD, mount error again.

WORKAROUND: sudo mdadm --manage /dev/null

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: firefox 3.6.5~hg20100429r34148+nobinonly-0ubuntu1~umd1
ProcVersionSignature: Ubuntu 2.6.32-21.32-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-21-generic i686
Architecture: i386
CrashDB: ubuntu
Date: Tue May 4 11:36:14 2010
FirefoxPackages:
 firefox 3.6.5~hg20100429r34148+nobinonly-0ubuntu1~umd1
 firefox-gnome-support 3.6.5~hg20100429r34148+nobinonly-0ubuntu1~umd1
 firefox-branding 3.6.5~hg20100429r34148+nobinonly-0ubuntu1~umd1
 abroswer N/A
 abrowser-branding N/A
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: firefox
ThirdParty: True

Revision history for this message
tecknomage (tecknode) wrote :
Revision history for this message
Draycen DeCator (ddecator) wrote :

This is not a Firefox bug, so I'm marking that this report needs to be reassigned.

affects: firefox (Ubuntu) → ubuntu
tags: added: needs-reassignment
Changed in ubuntu:
status: New → Confirmed
Revision history for this message
Kristóf Kiszel (ulysses) wrote :

I see this message (or very similar) on boot: "udevd-work[296]: opening directory /dev/null failed: no such file or directory".

ulysses@locris:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 10.04 LTS
Release: 10.04
Codename: lucid

ulysses@locris:~$ uname -a
Linux locris 2.6.32-22-generic #33-Ubuntu SMP Wed Apr 28 13:28:05 UTC 2010 x86_64 GNU/Linux

Revision history for this message
tecknomage (tecknode) wrote :

Ran:
tecknode@LC2000SN:~$ sudo grep null /lib/udev/rules.d/*
[sudo] password for tecknode:
/lib/udev/rules.d/50-udev-default.rules:KERNEL=="null|zero|full|random|urand om", MODE="0666"
tecknode@LC2000SN:~$ sudo grep null /etc/udev/rules.d/*
tecknode@LC2000SN:~$ ls -l /dev/null
crw-rw-rw- 1 root root 1, 3 2010-05-06 07:40 /dev/null
tecknode@LC2000SN:~$

Experiment-1: Mounted a data DVD and rebooted.

Sure enough at the time, during boot, when the UDEVD-WORK would display, the DVD drive would spin-up (access LED flashed) then the boot continued NORMALLY.

So for whatever reason, the bootup tries to access the DVD. Note that I have tried boot sequence HD then DVD and that did not fix the problem. This tells me the attempt to read the DVD drive is coded into the Linux boot sequence.

Experiment-2: Change boot-order to HD then CD, mounted my copy of Ubuntu 10.04 Live CD and booted. Booted NORMALLY, but did read the CD. Rebooted, changed boot-order back to CD then HD, booted WITHOUT CD, mount error again.

I was testing to see if something needed to complete that was not done because of using the online upgrade method. Didn't fix the problem of course.

Revision history for this message
iskarion (markus-goebel-hetos) wrote :

I'm also affected by this bug. This did happen right from the beginning on a fresh Kubuntu 10.04 install.
In order to get some more logging data I have set udev logging level level to debug. Logs are attached. Hope this helps to pinpoint the problem.

Revision history for this message
iskarion (markus-goebel-hetos) wrote :
Revision history for this message
iskarion (markus-goebel-hetos) wrote :
Revision history for this message
iskarion (markus-goebel-hetos) wrote :
Revision history for this message
iskarion (markus-goebel-hetos) wrote :
Revision history for this message
tecknomage (tecknode) wrote :

OK, noticed in "iskarion's" DAEMON.LOG has the "/dev/null" entry. None of the other logs have it.

May 10 18:18:20 meinpc udevadm[1160]: device 0x7f7facfabce0 filled with db symlink data '/dev/null'

Is this and indicator of the problem we are reporting?

Revision history for this message
tecknomage (tecknode) wrote :

OK - I am on my Ubuntu Notebook. Here are my Log Search results.

Search = /dev/null

Log = SYSLOG:

LC2000SN CRON[2184]: (root) CMD (command -v debian-sa1 > /dev/null && debian-sa1 1 1)

Log = UDEV:

UDEV [1273598840.789083] add /devices/virtual/mem/null (mem)
UDEV_LOG=3
ACTION=add
DEVPATH=/devices/virtual/mem/null
SUBSYSTEM=mem
DEVNAME=/dev/null
DEVMODE=0666
SEQNUM=1454
MAJOR=1
MINOR=3
DEVLINKS=/dev/char/1:3

From what I see above, is the SYSLOG "CMD" line entry the culprit?

Revision history for this message
tecknomage (tecknode) wrote :

Another thought.

Since "/dev/null' is listed as a Virtual Memory Device, could the problem be trying to access virtual memory BEFORE it is mounted?

Revision history for this message
tecknomage (tecknode) wrote :

Another thought.

Log = SYSLOG:

LC2000SN CRON[2184]: (root) CMD (command -v debian-sa1 > /dev/null && debian-sa1 1 1)

In the above command, IF "sa1" = swap partition, that is wrong. The swap is SDA5, which means the command should be to "sa5"

Comments?

Revision history for this message
iskarion (markus-goebel-hetos) wrote :

Assuming that this error message is just a cosmetic issue and not a real problem (at least so far I didn't encounter any further side effects related to the udevd-work.. message), I found some workaround, which at least is hiding the error message.
Just add Plymouth to initramfs as described here http://www.ubuntugeek.com/quick-tipplymouth-themes-in-ubuntu-10-04-lucid-lynx.htm
This way Plymouth will come up much earlier in the boot process and the error message will be hidden beneath the nice Plymouth boot screen.

Revision history for this message
Simd (simd) wrote :

I am seeing a similar problem.
Sometimes I get the /dev/null reported, or sometimes I get the problem reported on a partition (like /dev/sdb5) which I have converted to an LVM.
Which message comes up seems fairly random, though the /dev/null is less frequent.
I also have ntfs partitions - could possibly it be to do with LVM/FUSE/other virtual based mounts? Or if these have been added following initial installation of the distribution? The message doesn't show up in any of the logs, including the udev log, which doesn't show anything that seems odd to my untrained eye.
At any rate it only appears to be an annoyance - everything seems to be working on the devices affected.

Revision history for this message
iskarion (markus-goebel-hetos) wrote :

Sorry, wrong url. This is the right one

http://www.ubuntugeek.com/quick-tipplymouth-themes-in-ubuntu-10-04-lucid-lynx.html

I should mention that for me this is adding about 1 second to the whole boot process, but as this did hide the annoying "udevd-work..." message, that's an accetable workaround for me.

Revision history for this message
boatjones (rthomas) wrote :

After upgrading from 9.04 --> 10.04, I receive the same message on bootup though with different line number:
"udevd-work[364]: opening directory /dev/null failed: no such file or directory"
The upgrade and possibly this problem seems to have added 15 seconds to the bootup as it seems to hang at this message instead of displaying the Ubuntu splash screen.

I use NFS and automount to shares on a networked ReadyNAS NV+. Since the upgrade, the automount no longer works and I need to "sudo mount -a" upon login. Still working on that and hope that I can restore functionality soon. I just reinstalled autofs as that seems to have been uninstalled with the upgrade. With references to fstab, possibly this issue is related to the bug.

Revision history for this message
tecknomage (tecknode) wrote :

Question iskarion,

Will the "To fix the delayed loading of the splash" commands work for the normal Ubuntu splash screen?

I don't want the Plymouth boot screen.

I've learned the hard way not to "test" things that change bootup WITHOUT asking. Too many tries have forced me to completely reinstall Ubuntu (which I do NOT want to do this time). Much to much added apps installed, don't want to go through reinstall of all of them.

Revision history for this message
Ulli W.-M. (freeon-f) wrote :

I experience this error after upgrading from ubuntu 8.10 (i386) to 10.4 (amd64).
Ubuntu splash screen is not "delayed" but the boot-process stops right after that message ... leaving a mal-adjusted white rectangle on screen with cursor upper-left corner not blinking.
The only way to "continue" is by 'reset' switch or forced-OFF(powerswitchdepressed >4sec.)
Last to mention: this Error/freeze occurs irregularly, seldom in direct sequence.

Revision history for this message
robbanl (robert-lindberg1978) wrote :

I get this message at every boot up. Is there some good workaround cause it's really annoying.

Revision history for this message
Mario Capurso (m-capurso) wrote :

I have the same experience.
I use Ubuntu 10.4 coming from 8.04 -> 8.10 -> 9.04 -> 9.10 -> 10.4

It started when I inserted and extracted a wifi pcmcia card while the
computer was running.
At the next reboot I had the message.

I found here

http://forum.openvz.org/index.php?t=...untu#msg_39012

something that make me think that the package udev is the culprit.
Udev adds and removes dinamically devices in the /dev directory, when they
are inserted and removed.
These are personal observations.
Now, what to do ?

Revision history for this message
Jordan Bradley (jordan-w-bradley) wrote :

Background: The hard drive in my laptop died so I took the SSD out of my desktop machine and put it in my laptop. Updated fstab, update-grub, grub-install, update-initramfs -c -k all, the whole nine yards.

I'm getting this on an Acer Aspire 5741 using the kernel available in the kernel ppa (for TRIM support). It does not seem to occur with the Maverick Meerkat builds.

Revision history for this message
Mohamed Amine Ilidrissi (ilidrissi.amine) wrote :

jordanwb: If so, marking this as Fix Released.

affects: ubuntu → linux (Ubuntu)
Changed in linux (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
boatjones (rthomas) wrote :

Installed system updates as of 15:00 EDT and the problem persists. Where is the fix?

boatjones (rthomas)
Changed in linux (Ubuntu):
status: Fix Released → In Progress
Revision history for this message
Mohamed Amine Ilidrissi (ilidrissi.amine) wrote :

boatjones: did you try with 10.10? (Since jordanwb reported it was fixed with Maverick)

Changed in linux (Ubuntu):
status: In Progress → Confirmed
Revision history for this message
boatjones (rthomas) wrote :

No. Unless I am mistaken, this bug pertains to 10.04. All previous postings are for those of us experiencing this bug with 10.04. To mark it as resolved for 10.10 is not relevant to those of us wishing to get the LTS version working. If the bug was manifesting itself in 10.10, perhaps it should have a different bug tracking number.

Revision history for this message
Jack O'Molo (jackomolo) wrote :

I don't have the technical knowledge to investigate the bug any further, but I can spend time testing whatever needs to, or provide configuration information if a developer asks for it, etc. This bug is a show stopper for me, and I'd love to see it fixed. Fresh Network (ch.archive.ubuntu.com) install as of last week. LTS 10.04.1.

Revision history for this message
candtalan (aeclist) wrote :

I get this problem Ubuntu LTS 10.04.1

New install.

This is a friends laptop and I regret having to hand it back after work done with an obvious error message showing. It seems to add a few seconds to the boot time, which is otherwise very good.

This is a Long Term Support release.

The user will NOT be upgrading to maverick, the user will be remaining with Lucid for at least two years.
*Please* try to sort this bug in this LTS release, even though it might not show in a future release.

Revision history for this message
boatjones (rthomas) wrote :

@candtalan: Could you plese tell me whether you are using GRUB or GRUB2? Also, could you tell me if you formatted the drives as ext3 or ext4? Does the Ubuntu install share the disk with another OS on other partitions and you get a GRUB menu prior to booting or is the Ubuntu install on the entire disk and you boot directly into it?

I recently setup a new laptop with 10.04 with GRUB2, ext4, bootmenu with Windows on another partition and this laptop does not exhibit the problem. My work laptop has GRUB (legacy), ext3 and boots directly to 10.04 with no other OS partitions and has this problem.

This leads me to suspect that the bug revolves around some change to 10.04 and the continued use of GRUB (legacy) and/or ext3 as I upgraded from 9.04.

I have a spare laptop (although it's an old Toshiba Satellite 1905 currently running 9.10) that I volunteer to the cause for test installs if needed. I plan on upgrading my work laptop to GRUB2 & ext4 within the month that has the problem. I will post a that time whether that eliminates the bug.

It would be great to get this bug dealt with. I don't care a whit about 10.10 and wish to remain with LTS for the foreseeable future as upgrades just break too many things and suck up too much time to then have to fix.

Revision history for this message
Panthera Leo (pleo2012) wrote :

I can confirm this bug still exists in 10.10 RC. I receive the same error message with a clean (but fully patched) install on a core 2 duo Mac Mini. Ubuntu 10.10 is the only operating system installed on the system and I let the installer erase the entire disk and use the default partitioning.

Revision history for this message
tecknomage (tecknode) wrote :

Add me to confirmation on Ubuntu 10.10 after upgrade from 10.04

I CANNOT BELIEVE THIS!

Revision history for this message
tecknomage (tecknode) wrote :

PS: Forgot, I upgraded from Ubuntu 10.04 to 10.10 full-release (NOT RC)

Revision history for this message
Fred (surfavela) wrote : Re: [Bug 575333] Re: On boot keeps trying to mount "UDEVD-WORK..../dev/null"

same for me : my computer HP HDX18

2010/10/15 tecknomage <email address hidden>

> PS: Forgot, I upgraded from Ubuntu 10.04 to 10.10 full-release (NOT RC)
>
> --
> On boot keeps trying to mount "UDEVD-WORK..../dev/null"
> https://bugs.launchpad.net/bugs/575333
> You received this bug notification because you are a direct subscriber
> of the bug.
>

description: updated
Revision history for this message
Steven Liu (liuxiangde-gmail) wrote :

Same for me after online upgrade from Ubuntu 10.04 to 10.10, this is a really annoying error and it makes computer start up slower than before (10.04)

Revision history for this message
tecknomage (tecknode) wrote :

Note, as of this time-date stamp, this CONFIRMED bug is still UNASSIGNED.

Is anyone up at Conical, etc, listening? Or are "they" just ignoring ALL of us. If I were the only one, I would not be complaining.

Revision history for this message
Ivana (ivanafml) wrote :

This was happening to me in 10.04 and still does when I updated to 10.10
(which was really disappointing). And I strongly agree with tecknomage,
we're a already a considerable number of users with the bug.

Revision history for this message
Ibrahim M. Ghazal (imgx64) wrote :

I had this problem in Lucid installed on an ext3 partition. I wiped the installation and installed Maverick on an ext4 partition and the problem disappeared, as #29 suggested. Perhaps this is worth investigating, what filesystem are you people using?

Revision history for this message
uncommon (tom-967) wrote :

I have that problem too on ext4 partitions. Boring.

2010/11/11 Ibrahim M. Ghazal <email address hidden>

> I had this problem in Lucid installed on an ext3 partition. I wiped the
> installation and installed Maverick on an ext4 partition and the problem
> disappeared, as #29 suggested. Perhaps this is worth investigating, what
> filesystem are you people using?
>
> --
> On boot keeps trying to mount "UDEVD-WORK..../dev/null"
> https://bugs.launchpad.net/bugs/575333
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “linux” package in Ubuntu: Confirmed
>
> Bug description:
> Binary package hint: firefox
>
> After online Upgrade Ubuntu 10 -> 10.04....
>
> On boot keeps trying to mount "UDEVD-WORK..../dev/null" which fails because
> it does not exist.
>
> Forum thread says this is a fstab file problem. Various suggested fixes do
> not work.
>
> System Info:
>
> Ubuntu 10.04 (lucid)
>
> GROME 2.30.0 (Ubuntu 2010-03-31)
> Kernal 2.6.32-21-generic
> OS Type Linux
> GCC 4.4.3 (i486-linux-gnu)
>
> ProblemType: Bug
> DistroRelease: Ubuntu 10.04
> Package: firefox 3.6.5~hg20100429r34148+nobinonly-0ubuntu1~umd1
> ProcVersionSignature: Ubuntu 2.6.32-21.32-generic 2.6.32.11+drm33.2
> Uname: Linux 2.6.32-21-generic i686
> Architecture: i386
> CrashDB: ubuntu
> Date: Tue May 4 11:36:14 2010
> FirefoxPackages:
> firefox 3.6.5~hg20100429r34148+nobinonly-0ubuntu1~umd1
> firefox-gnome-support 3.6.5~hg20100429r34148+nobinonly-0ubuntu1~umd1
> firefox-branding 3.6.5~hg20100429r34148+nobinonly-0ubuntu1~umd1
> abroswer N/A
> abrowser-branding N/A
> InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
> ProcEnviron:
> PATH=(custom, no user)
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> SourcePackage: firefox
> ThirdParty: True
>
>
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/575333/+subscribe
>

--
Cordialement,

Thomas Harbonnier

Revision history for this message
Ivana (ivanafml) wrote :
Download full text (3.7 KiB)

Well, here is ext4 either and the problem is still on... so, nope.

2010/11/11 uncommon <email address hidden>

> I have that problem too on ext4 partitions. Boring.
>
> 2010/11/11 Ibrahim M. Ghazal <email address hidden>
>
> > I had this problem in Lucid installed on an ext3 partition. I wiped the
> > installation and installed Maverick on an ext4 partition and the problem
> > disappeared, as #29 suggested. Perhaps this is worth investigating, what
> > filesystem are you people using?
> >
> > --
> > On boot keeps trying to mount "UDEVD-WORK..../dev/null"
> > https://bugs.launchpad.net/bugs/575333
> > You received this bug notification because you are a direct subscriber
> > of the bug.
> >
> > Status in “linux” package in Ubuntu: Confirmed
> >
> > Bug description:
> > Binary package hint: firefox
> >
> > After online Upgrade Ubuntu 10 -> 10.04....
> >
> > On boot keeps trying to mount "UDEVD-WORK..../dev/null" which fails
> because
> > it does not exist.
> >
> > Forum thread says this is a fstab file problem. Various suggested fixes
> do
> > not work.
> >
> > System Info:
> >
> > Ubuntu 10.04 (lucid)
> >
> > GROME 2.30.0 (Ubuntu 2010-03-31)
> > Kernal 2.6.32-21-generic
> > OS Type Linux
> > GCC 4.4.3 (i486-linux-gnu)
> >
> > ProblemType: Bug
> > DistroRelease: Ubuntu 10.04
> > Package: firefox 3.6.5~hg20100429r34148+nobinonly-0ubuntu1~umd1
> > ProcVersionSignature: Ubuntu 2.6.32-21.32-generic 2.6.32.11+drm33.2
> > Uname: Linux 2.6.32-21-generic i686
> > Architecture: i386
> > CrashDB: ubuntu
> > Date: Tue May 4 11:36:14 2010
> > FirefoxPackages:
> > firefox 3.6.5~hg20100429r34148+nobinonly-0ubuntu1~umd1
> > firefox-gnome-support 3.6.5~hg20100429r34148+nobinonly-0ubuntu1~umd1
> > firefox-branding 3.6.5~hg20100429r34148+nobinonly-0ubuntu1~umd1
> > abroswer N/A
> > abrowser-branding N/A
> > InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
> > ProcEnviron:
> > PATH=(custom, no user)
> > LANG=en_US.UTF-8
> > SHELL=/bin/bash
> > SourcePackage: firefox
> > ThirdParty: True
> >
> >
> >
> > To unsubscribe from this bug, go to:
> > https://bugs.launchpad.net/ubuntu/+source/linux/+bug/575333/+subscribe
> >
>
>
> --
> Cordialement,
>
> Thomas Harbonnier
>
> --
> On boot keeps trying to mount "UDEVD-WORK..../dev/null"
> https://bugs.launchpad.net/bugs/575333
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “linux” package in Ubuntu: Confirmed
>
> Bug description:
> Binary package hint: firefox
>
> After online Upgrade Ubuntu 10 -> 10.04....
>
> On boot keeps trying to mount "UDEVD-WORK..../dev/null" which fails because
> it does not exist.
>
> Forum thread says this is a fstab file problem. Various suggested fixes do
> not work.
>
> System Info:
>
> Ubuntu 10.04 (lucid)
>
> GROME 2.30.0 (Ubuntu 2010-03-31)
> Kernal 2.6.32-21-generic
> OS Type Linux
> GCC 4.4.3 (i486-linux-gnu)
>
> ProblemType: Bug
> DistroRelease: Ubuntu 10.04
> Package: firefox 3.6.5~hg20100429r34148+nobinonly-0ubuntu1~umd1
> ProcVersionSignature: Ubuntu 2.6.32-21.32-generic 2.6.32.11+drm33.2
> Uname: Linux 2.6.32-21-generic i686
> Architecture: i386
> CrashDB: ubuntu
> Date: Tue May 4 ...

Read more...

Revision history for this message
Andy Whitcroft (apw) wrote :

It is unclear that this is a kernel bug. I have opened a task on udev _in_addition_ to the kernel task.

24 comments hidden view all 104 comments
Revision history for this message
boatjones (rthomas) wrote :

technomage: To be even more precice, the problem occurs in step #2 in disk drive/DVD drive initialization.

naskoos: While it's interesting that your problems have not returned with 10.10, I maintain that the focus should be to eliminate this problem in 10.04 LTS. Moving to a LTS version for which support would not be dropped is the sole driver for my moving from 9.04. I have not experienced any functional or qualitative gain from upgrading from a perfectly functioning 9.04 version, only the breakage of existing functionality (e.g., NFS) that required time to diagnose & workaround and the introduction of this problem along with the slower bootup time.

Revision history for this message
Thanasis Naskos (naskoos) wrote :

Boatjones,

I agree with all your points!
This is the reason I'm not telling you to upgrade to 10.10 to solve your problem!
I've mentioned the version of my ubuntu and the kernel version, to show you that maybe it's not kernels problem and it's something else that we didn't think about in 10.04.

The fact that mdadm worked for me (so far) and didn't for you, points that a change took place in both ubuntu versions, that temporary solved the problem, but after updating kernel's header files this change was undo in 10.04...

Revision history for this message
David Rossall (mgrisg) wrote :

I was getting this at every boot on an EEE PC 701 with Ubuntu 10.0. Inspired by what tecknomage wrote on 2010-05-07, I looked at my boot devices in the BIOS. I still had the removable device (USB stick) as first from when I installed Ubuntu over the previous Linux version. I have now changed that back to the EEE's internal disc and the /dev/null/ errors at boot are gone.

Revision history for this message
Danjel (danjel) wrote :

Can confim that it dissapears after changing bootorder, so that HD comes first.
Still get errors from grub, and it still waits for something, but the messege about /dev/null is gone.
Running 10.10 on a custombuilt pc.

Revision history for this message
boatjones (rthomas) wrote :

Changed boot order for hdd first. Still have the error.

Revision history for this message
vijay parsi (rockoprem-deactivatedaccount) wrote :

I seem to have got it!! It is the ssh-server which checks /dev/null on start... I disabled it in /etc/init/ssh.conf and problem solved!! :)

Revision history for this message
Danjel (danjel) wrote :

Just updated by automatic updates, error has returned :-(

Revision history for this message
robbanl (robert-lindberg1978) wrote :

In the boot order settings in BIOS i excluded everything (CD and USB-ports) but the HDD and now the problem is gone.

Revision history for this message
tecknomage (tecknode) wrote :

My system does not have a ssh.conf BUT I noticed udev.conf

----- udev.conf text start -----

# udev - device node and kernel event manager
#
# The udev daemon receives events from the kernel about changes in the
# /sys filesystem and manages the /dev filesystem.

description "device node and kernel event manager"

start on virtual-filesystems
stop on runlevel [06]

expect fork
respawn

exec udevd --daemon

----- udev.conf text end -----

Comments?

Revision history for this message
tecknomage (tecknode) wrote :

UPDATE

Ever since I use "sudo mdadm --manage /dev/null" back in 11/2010, I've had the boot problem only ONCE.

So that seemed to fix MY problem.

Revision history for this message
Asmante (asmante) wrote :

In my case:

sudo rm /dev/null
sudo mknod -m 666 /dev/null c 1 3

solved the problem.

Revision history for this message
Giacomo Mirabassi (giacmir) wrote :

The solution suggested by Asmante at #75 didn't worked for me, I've not tried the mdadm solution yet.

Revision history for this message
Pm-saeedi (pm-saeedi-deactivatedaccount) wrote :

Sometimes it happens and sometimes not.It happend at the first boot and is repeated after every 4 or 5 reboots.
The solution that Asmante @ #75 suggested in not working for me either.I'm using Ubuntu 10.10.

Revision history for this message
Pm-saeedi (pm-saeedi-deactivatedaccount) wrote :

Sometimes it happens and sometimes not.It happend at the first boot and is repeated after every 4 or 5 reboots.
The solution that Asmante at #75 suggested in not working for me either.I'm using Ubuntu 10.10.

Revision history for this message
Thanasis Naskos (naskoos) wrote :

Pm-saeedi could you please try the solution suggested in #42 and tell me if it works. I'm using Ubuntu 10.10 too and solved my problem!

Revision history for this message
Pheros (pheros3) wrote :

I'm having the same problem as those above. I'm running 10.04 currently. I haven't had a chance to try the fixes mentioned above, however it seems most are user-specific or temporary.

No RAID arrays or the like, just a dual-boot HP laptop. It happens pretty much every boot now.

Revision history for this message
William (bthomas-akld) wrote :

Todays Maverick kernel update 2.6.35-26-generic has fixed this for me.

Revision history for this message
William (bthomas-akld) wrote :

I have to take that back. Seems that it dissapeared only for one boot. The message is back again.

Revision history for this message
mike.wilmoth (mike-wilmoth-gmail) wrote :

The error message went away after installing mdadm. However, there is still a delay at boot time, during which time the DVD drive is being checked.

10.10

Revision history for this message
glarrain (glarrain) wrote :

I have this problem as well, but in a more painful way: i can't boot at all. After the Ubuntu Splash all goes dark... got to reboot the hard way.

I have a Thinkpad T400, Ubuntu 10.04. I have dual boot with Windows 7 as secondary. Both OS run on the same disk, different partitions. I'm 95% sure I'm using ext3 for my primary partition.

I have to say I'm really disappointed this bug has not been attended by Canonical or someone qualified: it's been almost a year since it was reported!

Revision history for this message
Seth Forshee (sforshee) wrote :

@glm, I suspect your problem booting is a separate issue from this one.

After scanning through the comments here, I think this issue has become quite confused and that some of the comments reflect different issues. Just because an error message starts with "udevd-work" doesn't imply that it's the same issue. This one seems to be specifically related to /dev/null, so if you see an error message relating to another device you are likely seeing a different problem.

@tecknomage, can you explain why you described this as a mount problem? I haven't really seen anything to indicate that anything is trying to mount /dev/null, and doing so doesn't really make any sense as /dev/null cannot be mounted (it isn't even a block device). Can you also clarify exactly what your error message is? Does it look like this?

  udevd-work[xxx]: open /dev/null failed: no such file or directory

Or is it something different? Getting an accurate error message is extremely helpful.

If you are seeing the message above it doesn't indicate any serious problem with your system. Sometimes the udev rules indicate that udev should run a program in response to an event. As part of running the program udev tries to open /dev/null, and it appears in some cases this can happen before the /dev/null device node exists. This isn't a fatal problem though, and execution of the program will proceed even if /dev/null cannot be opened. So really that message is nothing to be concerned about.

Revision history for this message
glarrain (glarrain) wrote :

@Seth Forshee
It might be a separate issue, but it doesn't seem coincidence that I had never seen that message (udevd-work[xxx]: open /dev/null failed: no such file or directory) before, and when it did start appearing, I could not boot Ubuntu at all, for good. I was able to boot Windows 7 in the other partition though.

Just because Ubuntu 11.04 was out yesterday, I downloaded it and upgraded. The problem was pissing me off...

I hope Canonical can fix this problem. Certainly this kind of issues scare windows-like users. I've been with Ubuntu for years, but that isn't necessarily the general case.

Revision history for this message
Nodens (lordnodens) wrote :

Same problem here after upgrading to 11.04. Sometimes it appears, sometimes it doesn't.

udevd-work[XXX] open /dev/null failed: No such file or directory

Revision history for this message
mama21mama (mama21mama2000) wrote :

possible solution, though momentary
replace /dev/null by /dev/zero

Revision history for this message
EricDHH (ericdhh) wrote :

Affects me on 11.04, did not exist up to 11.04 beta-2. With the udevd-work failure on screen the pc waits 1 or 2 minutes and did not boot on.

Revision history for this message
scarey9 (scarey9) wrote :

I am running 11.04. After a cold boot i starting recieving the same error. I cannot boot onto anything but a Live USB Drive. I was running 11.04 for about a month and half b4, this is the first time i have seen this.

Revision history for this message
scarey9 (scarey9) wrote :

So if i leave a CD in my DVD Player @ boot i get a black screen with no errors. It will do nothing from there.

If i press ALT + F1 after the error appears I can login via the terminal(even my Finger Print reader works) and then startx with no issues. Very odd.

Revision history for this message
Darren Conway (darren-conway) wrote :

Hi
I have this bug as well. It appears on a clean slate install on a standard Dell Optilux GX150.
I can't see anything in common with the other reports that point to a root cause.

Dazz

Revision history for this message
Darren Conway (darren-conway) wrote :

I should have mentioned I installed Ubuntu server version 11.04, 32 bit.
Initially this bug didn't show. It appeared after playing around with some grub settings to solve another bug (the white stripes and unreadable text).

I now intend to install server version 10.04.2 LTS

Revision history for this message
Darren Conway (darren-conway) wrote :

I don't see this bug on ver 10.04.2.

Dazz

Changed in udev (Ubuntu):
status: New → Confirmed
Revision history for this message
kveretennicov (kveretennicov) wrote :

Ubuntu 10.04.03, HP 6730s. Have had this error message ("udevd-work[xxx]: open /dev/null failed: no such file or directory") for quite some time.

Changing boot sequence in BIOS did not help.

However, just installing "mdadm" package makes the error message go away.

Revision history for this message
maxstone (rainer-nts) wrote :

Ubuntu 11.04, Lenovo T420s.
Same Error: "open /dev/null failed: ...." Then stops booting up.

Some things I found out:
1) when turning of NVIDIA Optimus in BIOS and enabling discrete graphic I got that error first. (else ubuntu is not able to manage the nvidia card...)
2) Intel VT-d feature (IO virtualisation) is enabled. Ubuntu stops booting after the "/dev/null error" appears.
3) when disabling VT-d feature ubuntu boots up (fast, but no ubuntu splash screen)

maybe that helps

Revision history for this message
BentFX (l-skip) wrote :

There are certainly at least two different issues being discussed here. There are those who get the udev-work - /dev/null error and boot continues without error(possibly with a delay) and there are those who see the error message and boot fails. There are those who see the error on every boot, and those who only see the error part of the time.

Here is my observation regarding my part time, still boots, udev-work error. I recreated my /dev/null as a static node similar to what's described in #75 and it seems to have solved my issue. As for the proposed mdadm fix I don't think it is a direct fix, but rather causes a shift in boot processes that eliminates the race that causes /dev/null to not be ready when requested. Bear with me as I explain...

The udev-work error happens early in the boot process. It is almost surely a udev thread trying to access /dev/null before another udev thread has created the node. Since it only happens sometimes it would indicate that most of the time the threads are timed correctly and the node is ready when requested. mdadm is a RAID array administration tool. /dev/null is not a disk, and it is almost certainly not a RAID array! Though by installing mdadm you have placed another process into the early boot sequence and this can, and probably does affect the timing of other early boot processes, allowing the udev processes to sync correctly.

As for those who have recently upgraded and now cannot boot, it would certainly appear to be a real issue, but though you do see a udev error message, my guess is the issue goes deeper than udev.

1 comments hidden view all 104 comments
Revision history for this message
Stan Williams (stanwmusic) wrote :

I was curious and typed ls -ah *.* /dev/null into the terminal and it returned:
 /dev/null initrd.img initrd.img.old vmlinuz.old

Revision history for this message
Johan Prins (johanprins-free) wrote :

Just saw this error the first time today, (it just displays, while boot goes on), and am surprised to see that it is an old, unsolved bug that is ignored by Canonical (they have too much 'real' trouble to fight, I guess).

I 'vote' for the theory that the error is a timing issue at boot time, like other weird errors I have seen that don't affect the final result of boot-up.

Since the boot process includes executing multiple threads that can run into some "not yet!" sort of problems, I presume
we will see this sort of error messages more often in the future, until some timing management of the boot process is added.

Sadly enough, we will go the same way as the Microsoft world, if ever the top brains lose track of what's actually happening inside Linux.

Revision history for this message
Lutz Andersohn (landersohn-m) wrote :

I didn't have this bug in either form for a long time. Lately I re-profiled ureadahead and I ended up with the version of the bug that ends up in a blank screen with blinking cursor. I disabled ureadahead and my ubuntu (10.04) boots very reliably.
The few seconds extra boot time beats the aggravation of having the system hang at boot 1 out of 10 times.

My experience definitely confirms some posts above that this is a timing issue between various processes at boot time

Revision history for this message
Vilma A (vilma-v-m-a-s) wrote :

I have the same problem in Lucid Lynx 10.04 (dual boot with Win7)
The message is
udevd-work[326]: open/dev/null failed: No such file or directory
at the start-up screen

Sometimes it feezes in the black screen (for half an hour...) and I have to shut down manually and reboot. This does not happen often.
I get this message every single time I open my laptop; it's annoying, it takes time until you get to the login page.
I THINK it appeared one day that I was working on Windows and they crashed. Not sure though, I have it more than 6 months.

I thank in advance the person(s) who will fix it :)

papukaija (papukaija)
tags: added: lucid
tags: removed: needs-reassignment ppa
Revision history for this message
Christopher M. Peñalver (penalvch) wrote :

tecknomage, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu (not upgrade but fresh install)? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

If reproducible, could you also please test the latest upstream kernel available (not the daily folder) following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-v3.13-rc5

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

description: updated
Changed in linux (Ubuntu):
importance: Undecided → Low
status: Confirmed → Incomplete
Revision history for this message
dino99 (9d9) wrote :

This version is now outdated and no more supported

Changed in udev (Ubuntu):
status: Confirmed → Invalid
Changed in linux (Ubuntu):
status: Incomplete → Invalid
Displaying first 40 and last 40 comments. View all 104 comments or add a comment.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Related questions