Ubuntu

Trim support missing from Linux kernel

Reported by phitastic on 2010-04-28
296
This bug affects 51 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned
Nominated for Karmic by John
Nominated for Lucid by phitastic

Bug Description

Would it be possible to backport the 2.6.33 TRIM support into the Ubuntu 2.6.32 kernel? It's a crucial feature for us SSD users.

Jeremy Foshee (jeremyfoshee) wrote :

Hi phitastic,

Please be sure to confirm this issue exists with the latest development release of Ubuntu. ISO CD images are available from http://cdimage.ubuntu.com/releases/ . If the issue remains, please run the following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux 571476

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

    [This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-kernel-logs
tags: added: needs-upstream-testing
tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete

apport information

tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

phitastic (robbel) wrote : Lspci.txt

apport information

phitastic (robbel) wrote : Lsusb.txt

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

tags: removed: needs-upstream-testing

Hi Jeremy,

I executed the tests (+ apport-collect) under 10.04 RC but the kernel has not changed from the RC to the release version. The test i ran to check whether TRIM support is available is from here: http://forums.gentoo.org/viewtopic-t-812509.html ("Where is trim in ext4? How do I know if it's enabled?" entry in the Gentoo Forums). It fails for the 2.6.32 kernel that ships with 10.04.

I tested it with the upstream 2.6.33.2-lucid kernel and the test goes through fine (i.e., TRIM is working when enabled via the "discard" mount option in /etc/fstab).

Thanks,
Philipp

Changed in linux (Ubuntu):
status: Incomplete → New
Jeremy Foshee (jeremyfoshee) wrote :

phitastic,
    Thanks for your testing. :-)

~JFo

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Josh Brown (joshbrown) wrote :

Hasn't this been released in kernel 2.6.33?

Josh Brown (joshbrown) wrote :

Sorry - didn't read the bug properly.

98cwitr (brettm) wrote :

This bug affects me as well. I see @ kernel.org that the stable releases of 2.6.33 and 2.6.34 are available, but I am hesitant to install, I guess I'll wait for 10.10 unless you fine folks can push the kernel update early.

Jeremy Foshee (jeremyfoshee) wrote :

98cwitr,
     We already provide a facility for that. Please see the informaion at https://wiki.ubuntu.com/KernelMainlineBuilds

Thanks!

~JFo

98cwitr (brettm) wrote :

I installed 2.6.34 for Lucid and had video problems...and then had plymouth problems. I'll reinstall tonight and report the bugs (since I didn't do it last time and just rebuilt my machine). Thanks Jeremy.

98cwitr (brettm) wrote :

Mushkin seems to be supportive of the ongoing bug...just fyi http://forums.mushkin.com/phpbb2/viewtopic.php?f=28&t=16389

98cwit: The video/plymouth problems *may* be caused by the lack of a patch that the Ubuntu kernel guys apply that is not in the vanilla kernel.

dcecchin (dcecchin) wrote :

I had installed Ubuntu, but I'm reluctant to use it in anything other than a virtual machine until this has been fixed. I haven't been able to find any information that I consider reliable into setting this up. Guess I'll wait the outcome of this bug before using Ubuntu. I have an OCZ Vertex 120GB

ianaré (ianare) wrote :

This is especially important for netbooks. Bought a Dell preloaded with Ubuntu on an SSD and later upgraded to netbook remix 10.0. Lack of trim support is a major disappointment with the release, given how well the little thing runs, now. Not about to start playing with alternate kernels on it, or even have scripts run ... it is the wife's travel computer, any changes/updates need to be simple to do.

Thank you for your efforts !

wolfen69 (wolfen69) wrote :

Any updates on this situation? I would like to get an ssd, but would like trim support "out of the box" with 10.04.

Any updates will be posted back here, please subscribe and be patient.

On Fri, 2010-07-30 at 17:25 +0000, wolfen69 wrote:
> Any updates on this situation? I would like to get an ssd, but would
> like trim support "out of the box" with 10.04.

Greetings,

I am an Ubuntu supporter and advocate. I just purchased a Mushkin Enhanced Callisto Deluxe MKNSSDCL240GB-DX 2.5" 240GB SATA II MLC Internal Solid State Drive. If there is some test you would like me to run for you "Mushkin-TRIM-Ubuntu 10.04" related please let me know and I will do what I can to assist.

PS: This offer expires once I setup the OS for everyday use.

Thanks for the offer, willdeans, but testing won't be necessary as trim
support has already been added to the kernel - it just isn't scheduled
for release until Ubuntu 10.10.

On Sat, 2010-08-28 at 01:15 +0000, willdeans wrote:
> If there is some test you would like me to
> run for you "Mushkin-TRIM-Ubuntu 10.04" related please let me know and I
> will do what I can to assist.

Has anyone verified if TRIM actually works in 10.10 Beta1?

Josh Brown (joshbrown) wrote :

Ari: Not in this bug, no. However this bug is titled specifically '10.04' (which really needs to be changed).

summary: - Trim support missing from Ubuntu's 10.04 kernel
+ Trim support missing from Linux kernel
tags: removed: needs-kernel-logs
Josh Brown (joshbrown) wrote :

[needs-kernel-logs] tag removed as this has already been marked as triaged.

Josh Brown (joshbrown) on 2010-09-06
tags: added: feature-request
UbuntuFlo (ubuntuflo) wrote :

Josh Brown wrote on 2010-07-30:
> Any updates will be posted back here, please subscribe and be patient.
Hi, sorry to dig out this old report. I'm trying to find out whether 2.6.32 meanwhile received the TRIM-support (→ discard) through updates of the 2.6.32 kernel. I would be happy if someone could shed some light on this.

Josh Brown wrote on 2010-09-06:
> tag removed as this has already been marked as triaged.
Does "triaged" means, this bug in kernel 32 is solved by receiving the necessarry backports of 33?
Thank you for your help!

Josh Brown (joshbrown) wrote :

TRIM support is not implemented in 2.6.32. TRIM support is implemented in 2.6.33, but is not available in the Ubuntu 10.04 repositories. Similar question asked at <http://askubuntu.com/questions/14923/whats-the-story-with-trim-support>.

"Triaged" means that the developers know exactly what they need to do to fix the problem. The TRIM support problem has now been fixed, but a general consensus seems to have been reached that this feature will not be backported. I think a separate bug should be opened for the backporting issue if anyone believes it has not been concluded.

Changed in linux (Ubuntu):
status: Triaged → Fix Released

So, if I understand right, there is general consensus not to add TRIM support to the current Long Time Support version of Ubuntu.
With all due respect, please add some wisdom to that choice, as I (and a lot of other users) have good reasons to run LTS on their systems.

The message Ubuntu is sending is now: if you want to use LTS versions of Ubuntu, you cannot be running on SSD disk.
Possible upgrade path would then be to wait for 2.6.33 to come to LTS 10.04.
Is that happening soon ? Probably not ?

Where's the common sense here ?

And what are the reasons behind this "general consensus" decision?
Some transparency would be nice, I think.

Josh Brown (joshbrown) wrote :

@letstrynl: Yes, the current plan is that Ubuntu 10.04 will never receive TRIM support. Although unstated, I am under the impression that the developers abstain from including new features like TRIM in LTS releases because of possible instability. I trust that the developers are aware of the problem this causes some users and am sure they know what they are doing.

@Josh Brown: thx for your reaction.
I can understand that it would be a lot of work because all filesystem and utility related stuff would have to be updated also, besides the kernel backport patching.

I would very much appreciate if someone from Canonical would comment on this, as I feel when these kind of decisions are made more often, there would not be much sense in LTS desktops anymore (not on recent hardware).
And what about the fastly growing SSD server market ? Doesn't Canonical want to compete on that level ?

Ok, back to a solution: install kernel 2.6.33 from a ubuntu-kernel ppa at http://kernel.ubuntu.com/~kernel-ppa/mainline.
Would that be a wise decision? Any experiences ?

Grmpf, I'm getting annoyed by the non-informing attitude of Canonical.

A while ago heaven and earth was moved for something as insignificant as plymouth.
Which still gives me an ugly startup on my Nvidia card with proprietary drivers, by the way.

But for proper SSD support I have to install a non-supported non-Ubuntu patched kernel, which takes away any advantages of the whole idea behind using a Long Time Support version.
No real options here.

I've seen remarks about not supporting SSD's because not all SSD's are fully ATA compliant.
As far as I know these are supported in higher kernels, so ...

I've seen remarks saying SSD support would make Lucid unstable.
Why support them in higher versions then ?

Bump.

I'm full of questions and am willing to agree if good reasons are given, but for now I haven't seen any good reasons to not backport SSD support. Total silence.

Come on guys, speak up and let your voice be heard !

Josh Brown (joshbrown) wrote :

Removed the ALSA info in the description as it is irrelevant.

description: updated
Josh Brown (joshbrown) wrote :

@letstrynl: In the absence of comments from Canonical, or indeed anyone else, I'll try to answer some of your questions.

The aforementioned kernel PPA <http://kernel.ubuntu.com/~kernel-ppa/mainline> contains fully supported Ubuntu-patched versions of the Linux kernel. In fact, it even seems to have a `2.6.33.5-lucid` kernel which should include desired TRIM support.

TRIM is not supported in 10.04 because long term support releases require more stability than normal releases. For example, Ubuntu LTS may be used in corporate environments where data loss, as is a possibility with new storage device drivers, could have serious consequences.

The decision not to include TRIM support in 10.04 is unlikely to change at this point; `Bump`ing this bug report is unlikely to help the situation. New points and new information are always welcome; your recent comments, however, are better suited elsewhere. I suggest that if you are not satisfied with the answers I have given, you start a new question at <https://answers.launchpad.net/ubuntu/+source/linux/+addquestion>.

@Josh Brown: I really appreciate that you're trying to answer my questions, and thanks for your suggestion.
I'm not sure if a question there would produce any answers, though ;-)

From the the page at https://wiki.ubuntu.com/Kernel/MainlineBuilds?action=show&redirect=KernelMainlineBuilds:
1) "The mainline kernels builds are produced for debugging purposes and therefore come with no support. Use them at your own risk. "
2) "By definition the mainline kernel builds are made from virgin unaltered mainline kernel sources and therefore do not, and should not, include any Ubuntu patches or drivers. There are also no binary drivers for these kernels."
3) The v2.6.32.x/v2.6.33.y combined tree appears to be missing.

So my conclusion from the info on this page: yes, a Ubuntu kernel config, but no support and no Ubuntu specific patches in these custom kernels. And thus also no reason to run them on an LTS system.

I'm also fully aware of the fact that LTS versions are made for environments that require more stability.
That's why I am developing for LTS and not for other versions.
By the way: a lot of business users have SSD enabled laptops by now.
If their company (as it should) requires an LTS version to be installed, Canonical is creating a problem here.

For now I've installed 11.04 on my SSD enabled demo (as in 10.04 demo) laptop to check the 10.04 filesystem once-in-a-while.
I feel this is a crappy solution (as in: install Debian testing to make Debian Stable stable).
I've read that ext4 TRIM is supported from 2.6.33 and xfs TRIM is supported from 2.6.39 (!!!).
So I had to revert from using my favorite filesystem on my demo laptop. Grmpf.

I just would like Canonical to take a stand here (or elsewhere) and be clear and transparent about LTS on SSD.
Right now it's left to developers what is supported and what is not.

I've not found any remarks on stability anywhere, apart from what I've mentioned before.
Maybe you (or anyone) have a link to a developer thread where this is dicussed ?
I spent some time to find one, couldn't find any.

Maybe I'm totally wrong, and there is a simple (and stable) solution out of this situation.
I'm open to suggestions.

Alex Mandel (wildintellect) wrote :

I'd just wanted to add that this doesn't only effect laptop/netbook users. I have a low power server with an SSD (atom 5w) and would love trim support on that. I also recently bought 2 new rack servers each with an SSD drive for scientific computing purposes. I'm not terribly fond of having to use non-LTS server editions (though I'm not sure if they have as many problems as the non-LTS desktop which tend to have experimental GUI changes).

Anyone know how safe is it to use officially backported kernels?
http://sites.google.com/site/lightrush/random-1/howtoinstalllinuxkernel2635onubuntu1004lucidfromubuntu1010mavericktheeasyway

dmt (dmt-shvedov) wrote :

So was TRIM backported to 2.6.32 after all?
I see the following pieces in the description of 2.6.32-39 update:

    sata_mv: fix broken DSM/TRIM support (v2)
        LP: #644694

    ext4: make trim/discard optional (and off by default)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers