8086:3582 blank screen on boot after update to kernel 2.6.32-21

Bug #569702 reported by Richard on 2010-04-25
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: linux-image

After upgrade from 2.6.32-19 to -21 in the 10.04 beta2 release laptop boots to a blank screen. Have, also download and tried the new 10.04 RC and this also boots to blank screen. You are unable to switch to other sessions or to a CAD reboot.

Hadn't reported it for beta2 as appeared from reports problem was fixed.

Laptop is Dell Latitude D400 and was working fine Ubuntu 8 and worked fine on initial install of 10.04 of beta2 (which it's running now) but won't boot after the 2.6.32-21 kernel install.

Due to nature of bug, not been able to get boot log file.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: linux-image (not installed)
Regression: Yes
Reproducible: Yes
ProcVersionSignature: Ubuntu 2.6.32-19.28-generic 2.6.32.10+drm33.1
Uname: Linux 2.6.32-19-generic i686
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: rmcgilli 1343 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'I82801DBICH4'/'Intel 82801DB-ICH4 with STAC9750,51 at irq 5'
   Mixer name : 'SigmaTel STAC9750,51'
   Components : 'AC97a:83847650'
   Controls : 38
   Simple ctrls : 24
Date: Sun Apr 25 10:46:39 2010
EcryptfsInUse: Yes
HibernationDevice: RESUME=UUID=437c2c5c-147a-4270-ba05-f220626a5605
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Beta i386 (20100406.1)
Lsusb:
 Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: Dell Computer Corporation Latitude D400
PccardctlIdent:
 Socket 0:
   no product info available
 Socket 1:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
 Socket 1:
   no card
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-19-generic root=UUID=038dd82b-faa0-4069-811b-5d1eb174e74e ro quiet splash
ProcEnviron:
 LANG=en_GB.utf8
 SHELL=/bin/bash
RelatedPackageVersions: linux-firmware 1.34
RfKill:

SourcePackage: linux
dmi.bios.date: 06/28/2005
dmi.bios.vendor: Dell Computer Corporation
dmi.bios.version: A08
dmi.board.name: 0W0328
dmi.board.vendor: Dell Computer Corporation
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Computer Corporation
dmi.modalias: dmi:bvnDellComputerCorporation:bvrA08:bd06/28/2005:svnDellComputerCorporation:pnLatitudeD400:pvr:rvnDellComputerCorporation:rn0W0328:rvr:cvnDellComputerCorporation:ct8:cvr:
dmi.product.name: Latitude D400
dmi.sys.vendor: Dell Computer Corporation

Just to be clear , system boots to normal ubuntu graphical logo and then screen clears to a blank screen and all activity stops.

Also on 10.04 RC tried text boot ; although still get graphical logo using this option. And tried disabling all options on the boot options but still same effect.

Happy to try other options to get more info.

Tried to pin down where the problem happens; looks like it's the startup of gdm, if I run recover mode and then complete boot and run gdm manually (/etc/init.d/gdm start) ; same thing happens , blank screen and unable to switch to other sessions.

Dave Gilbert (ubuntu-treblig) wrote :

Yep looks like same bug, I'll update my findings in that bug and this one can be closed.

Jeremy Foshee (jeremyfoshee) wrote :

[This is an automated message. Apologies if it has reached you inappropriately.]

This bug was reported against the linux-meta package when it likely should have been reported against the linux package instead. We are automatically transitioning this to the linux kernel package so that the appropriate teams are notified and made aware of this issue.

If this bug really is a bug in the linux-meta package you can move it back to linux-meta and tag it kj-linux-meta, or contact us on the #ubuntu-kernel channel on the FreeNode IRC server. Thanks.

affects: linux-meta (Ubuntu) → linux (Ubuntu)
summary: - blank screen on boot after update to kernel 2.6.32-21
+ 8086:3582 blank screen on boot after update to kernel 2.6.32-21
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers