[Kubuntu 10.04] Compositing works, but cannot choose desktop effects. Fixed in Maverick

Bug #569591 reported by Heimen Stoffels on 2010-04-24
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

In Kubuntu 10.04, compositing works when using Alt+Shift+F12, but when I go to System Settings>>>Desktop, it tells me that the Desktop Effects cannot be activated. Therefore, I cannot choose which effects to use.

I'm using the closed source ATI-driver and I have a ATI Mobility Radeon 4500HD, with 512 MB VRAM in it's own GDDR3 cache.

Heimen Stoffels (vistaus) wrote :

Am I the only one with this bug?

fpe (f-esser) wrote :

Same problem here, with fglrx + Radeon 4870.

Since I upgraded from 9.10, I can not enable Desktop effects anymore.

Heimen Stoffels (vistaus) wrote :

Nobody?

Btw, I didn't do an upgrade, this is a fresh install of Kubuntu 10.04

FisherP (fisherp70) wrote :

I'm having the same sort of issue. I have installed the nvidia-glx-185 after purging all the old nvidia packages. I've tested OpenGL using a game... tremulous (www.tremulous.net) but when ever i try to enable compositing it knotify tells me something like "....open compositing has been locked by another application" and turns it off.

btw I have an nvidia 9 series AGP card 1G ram (sorry that all the details are a little fuzzy, I'm not at that computer at the moment)

FisherP (fisherp70) wrote :

PS (sorry for the double post, thought of something else) Compositing isn't working on my machine at the moment, but it was working a couple of days ago. It's just stopped working for some reason.

Mark_uk (dragothic) wrote :

cant offer much useful advice .. but i have a similar problem,
though my problem is most likely self made.

New install of Kubuntu Lucid 10.04 LTS, Laptop, ATI HD 3200 Graphics,
decided to d/load and install latest (aug 6th 2010) proprietry driver from
AMD. bad idea. failed miserably, i'm not too green either, been using Linux
since 1998 on and off, but just want nice easy distro on laptop.

removed propriety driver, modules, setup dir etc etc,
removed xorg.conf.
fail.

so spent a hour in Bash messing around, installed fglrx, radeon etc.
failed. cleaned up again.

d/loaded again the propriety driver for integrated mobility HD 3200,
fail. tried with jockey-kde, it identified my ATI Radeon integrated mobility HD 3200,
card as a Fire GL. go figure.

cleaned junk again, now propriety driver works very well system-wide.
HW acceleration is much improved on fullbscreen flash.

Only prob is KDE systemsettings reports
" Compositing is not supported on your system."
- but compositing IS running, indeed, its running very well,
i just cant get past this and change eye candy settings.

glxinfo | grep -i direct
direct rendering: Yes
    GL_EXT_copy_buffer, GL_EXT_copy_texture, GL_EXT_direct_state_access,

so i'm leaving it for now, i guess it maybe a disagreement between ATI and Kwin.
very odd.

Hope we get this fixed soon, i may file a bug, but as i say, i think its self-inflicted in my case.

Mark

Mark (mark-localmotive) wrote :

Same problem here.

Desktop effects *are* working. My windows "explode" when they close. Dialog "fold" down when they open and "fold" up when they close.

The Desktop Effects Dialog says "Compositing is not supported on your system."

The "Enable desktop effects" check box is disabled, but it's also CHECKED.

Just below this is the message "Compositing is active"

Common Settings are there and are enabled.

There's nothing at all listed on the "All Effects" tab.

Thins on the "Advanced" Tab are enabled.

But I cannot change any of the non- "Common" settings which should be listed on the "All Effects" tab. I'm stuck with exploding windows...

Mark (mark-localmotive) wrote :

So I downloaded and installed the driver from the ATI (AMD) web site...

Compositing is gone, that's for sure. Dialog says another application disabled it.

RAndR doesn't work, either. Dialog says its not supported.

xcomposite and xdamage are installed.

That would be fine. No eye candy.

But things are worse than that. Far worse. Scrolling and Window movement are jumpy-jerky now. The window repaints and repaints and repaints. It's unbearable when I click the up or down arrow on the scroll bar.

Mark (mark-localmotive) wrote :

Eventually things got so bad that the cursor started to flicker and no input worked. No mouse movement. No clicks. No keyboard input. So I rebooted and logged in from the command prompt.

I ran the following command: sudo apt-get remove fglrx

Then I removed all xorg.conf* from /etc/X11 (The Xorg only uses it if it's there, but the GUI Tools store their settings elsewhere now, right?)

Then I rebooted.

I don't have effects at all anymore, but at least things are working again.

CONCLUSION: DO NOT USE THE CURRENT (8.743.3.3) PROPRIETARY DRIVER FROM THE AMD/ATI WEB SITE!!!

I have a fresh (as of last week,) full install of Lucid AMD64. I am using ATI FirePro v3700.

Heimen Stoffels (vistaus) wrote :

The problem is solved for me by using the Maverick-kernel on Lucid and the newest Ati-driver from the site. So my problem is gone at least :)

But the problem with default 10.04 still remains, but it seems like no one wants to fix it :(

Fabio Marconi (fabiomarconi) wrote :

Hello
Is this problem present with the latest updated Lucid's or Maverick's packages?
Thanks in advance
Fabio

Changed in ubuntu:
status: New → Incomplete
Heimen Stoffels (vistaus) wrote :

Hi Fabio,

the bug still is present in 10.04, but is gone in 10.10
It's not a problem for me anymore, since I use 10.10 But it really should be fixed for people running 10.04 since it's an LTS.

tags: added: lucid
removed: 10.04 but compositing desktop effects no works
affects: ubuntu → linux (Ubuntu)
Changed in linux (Ubuntu):
status: Incomplete → New
summary: - [Kubuntu 10.04] Compositing works, but cannot choose desktop effects
+ [Kubuntu 10.04] Compositing works, but cannot choose desktop effects.
+ Fixed in Maverick

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 569591

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers