Mouse and keyboard become unresponsive on Asus Eee PC 1005HA

Bug #569354 reported by Jonathan Lumb on 2010-04-24
28
This bug affects 4 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

Release: Description: Ubuntu 10.04 LTS
Kernel: 2.6.32-21-generic

I have recently experienced some freezing up of the touchpad, and sometimes also the keyboard of my Asus Eee PC 1005HA with the latest version of Lucid. This tends to happen when the computer is under a bit of strain (opening more than one program at once for example). When the touchpad freezes, I am still able to use the keyboard to type and can restart the computer via keyboard shortcuts. However, when the keyboard also freezes, I can only turn the machine off and on again using the power button.

Interestingly, whilst the keyboard and touchpad may freeze, the system is still completely responsive and will continue to display chat messages, play films, play music etc.

I am not sure what package this bug relates to nor why this bug is occurring and would appreciate any help. Thanks

Shawn O'Connor (oak2278) wrote :

I have the same issue on the same hardware. During the lock, I am able to connect a usb keyboard and mouse and they function correctly and I am able to restart gracefully.

Jonathan Lumb (jonolumb) wrote :

Hi Shawn

I was thinking of trying that but am currently travelling and don't have a mouse or keyboard to try out. Hopefully the problem will go away with some updates or something - it didn't used to happen. Interestingly, it always happens when Google Chrome is open...

Marcin903 (marbella903) wrote :

I've got the same problem, but on HP Pavilion dv5. My touchpad and a keyboard freeze after same time (e.g. 4h 18min). I haven't found any correlation between used aplications and this "freezing" problem. I've always used wi-fi, so I haven't eliminate wi-fi as a "freezing" problem's reason.
I have to mention, that this problem appeared after upgrating Ubuntu for 9.10 to 10.04.
In a file: /var/log/messages I found this:

psmouse.c: TouchPad at isa0060/serio1/input0 lost synchronization, throwing 4 bytes away.

and

psmouse.c: resync failed, issuing reconnect request

Jonathan Lumb (jonolumb) wrote :

i haven't had this since upgrading from the release candidate (RC) version to the full LTS release... make sure you re-enable all third party repositories then update... I still suspect this might have been Google Chrome for me - as soon as I re-enabled the Google repository and updated, the problem went away.

Bill Zimmerly (billzimmerly) wrote :

I have a problem that may be related to this.

I have a HP-dv7 2040 US Quad Core 17" Laptop.

The touchpad has a tiny button just above it that allows touchpad availability to be toggled on or off. When the touchpad is on, the button glows white, and it glows orange when off.

Under the previous version of Ubunutu (9.04) it worked perfectly as it should.

However, since doing a fresh install of Lucid (10.04) the pressing of this button to either turn the touchpad on or off will freeze the keyboard, the cursor becomes a transparent box while in Gnome-Terminal, and the menus will not expand or work when I click them with my Bluetooth mouse. Simply put, that little toggle button freezes the GUI session.

The only way I have found to recover is to press and hold the power switch to turn the unit off. (Very bad!)

Occasionally however, I am able to successfully Ctr-Alt-F1 into a terminal, login as root, and perform a shutdown - but not always.

On the bright side, at least the new version (10.04) can successfully detect my laptop's best video mode, unlike 9.04. :)

KSB (ksb-inbox) wrote :

Same behavior there: Asus eeepc 1000H. After upgrade to Lucid!

antigooner (mel-rep-uk) wrote :

dont know if this is same problem reported by others, but I have eeepc1000 and Keyboard has stopped working. I cant even log in cos I cant get past the 'keyring' cos the keyboard does nowt. I'm fairly new to ubuntu (lucid) please can anyone help. Up to know ubuntu has been brilliant. I have no idea what to do to rectify the problem

I just experienced this problem on my Lenovo ThinkPad X200, using the laptop keyboard and a Logitech M705 USB mouse.
- Menus in the Gnome panel were highlighted, but would not open.
- I could click to change, open or close Chrome tabs, but not click on text fields etc. or switch to other applications.
- Scroll buttons and some keyboard shortcuts (like <Super><Button5> to rotate Compiz cube) still worked and I could switch to a console (<Ctrl><Alt><F1>) and reboot the system.

I have no idea what caused this and no traces in dmesg, /var/log/messages nor /var/log/Xorg.0.log.
It happened as I was using gvim, trying to figure out some builtin keyboard-shortcuts.

Jonathan Lumb (jonolumb) wrote :

Helge, your problem is unrelated and you should file a separate bug for this issue. In my case, mouse and keyboard input was completely frozen - whilst the computer continued to run, a problem that could only be solved by closing the lid of the laptop (to force it to suspend) and then opening it again.

Fabio Marconi (fabiomarconi) wrote :

Hello
Is this problem present with the latest updated Lucid's or Maverick's packages?
Thanks in advance
Fabio

Changed in ubuntu:
status: New → Incomplete
Jonathan Lumb (jonolumb) wrote :

Hi

I haven't been using my netbook as much recently but I certainly haven't experienced this issue recently. I will try and use it more frequently and see if I can get it to freeze up again - and report back here.

Thanks

Changed in ubuntu:
status: Incomplete → New
status: New → Incomplete
Davide Cavestro (d-cavestro) wrote :

I am experiencing the same behavior on my ASUS eeepc 904HA.
If I don't use the touchpad everything works fine (I use an external USB mouse)
If I use the touchpad the cursor starts to skip out of control, showing contextual menus, creating folders on the desktop and so on... sometimes a single keyboard key pressure produces many characters, like thhhhhhhhhis (I'm not sure the two thinngs can be related, since the touchpad issue is nearly systematically reproducible, while the keyboard not)

after that, the external usb mouse still continues to move properly, BUT for instance the cursor remains similar to a pipe (like when it's over a text field) even when I try to click on the window titlle bar, and you can't use the mouse anymore to change focus between windows...
My machine is still in this state while I'm typing here (now I'm using the keyboard to switch between windows)

cat /etc/issue
Ubuntu 10.10

dmesg | grep mouse
[ 0.702868] mice: PS/2 mouse device common for all mice
[ 31.050374] psmouse serio1: ID: 10 00 64
[ 412.957606] psmouse.c: Touchpad at isa0060/serio1/input0 lost synchronization, throwing 4 bytes away.
[ 413.491947] psmouse.c: resync failed, issuing reconnect request
[ 420.528129] psmouse.c: Touchpad at isa0060/serio1/input0 lost synchronization, throwing 5 bytes away.
[ 420.586632] psmouse.c: resync failed, issuing reconnect request
[ 421.768291] psmouse serio1: ID: 10 00 64
[ 2281.396401] psmouse.c: Touchpad at isa0060/serio1/input0 lost synchronization, throwing 4 bytes away.
[ 2281.993380] psmouse.c: resync failed, issuing reconnect request

If needed I can provide info.
Cheers
Davide

Davide Cavestro (d-cavestro) wrote :
Davide Cavestro (d-cavestro) wrote :
Davide Cavestro (d-cavestro) wrote :
Jonathan Lumb (jonolumb) wrote :

David, your issue is a different one, this bug is for complete unresponsiveness of the keyboard and touchpad - please file a separate issue on launchpad. Thanks

Davide Cavestro (d-cavestro) wrote :

Hi Jonathan
many thanks for your fast reply
I'm going to collect more info and file a separate issue as you suggested.

Cheers
Davide

Changed in ubuntu:
status: Incomplete → New
shankao (shankao) wrote :

Could you please run the command "apport-collect -p linux 569354" in your system in order to collect some valuable information about your system that would help with this bug? Thanks in advance!

affects: ubuntu → linux (Ubuntu)
Changed in linux (Ubuntu):
status: New → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired

AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
AplayDevices: aplay: device_list:252: no soundcards found...
ApportVersion: 2.0-0ubuntu4
Architecture: i386
ArecordDevices: arecord: device_list:252: no soundcards found...
AudioDevicesInUse: Error: command ['fuser', '-v', '/dev/snd/by-path', '/dev/snd/controlC0', '/dev/snd/hwC0D0', '/dev/snd/pcmC0D0c', '/dev/snd/pcmC0D0p', '/dev/snd/seq', '/dev/snd/timer'] failed with exit code 1:
DistroRelease: Ubuntu 12.04
HibernationDevice: RESUME=UUID=0e14a174-5cb2-4e13-9a9f-4102d89c05f1
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.2)
MachineType: ASUSTeK Computer INC. 1005HAG
Package: linux (not installed)
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-22-generic root=UUID=e019cf8c-0dd2-41d9-8a34-58bfc8896f64 ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.2.0-22.35-generic 3.2.14
PulseList: Error: command ['pacmd', 'list'] failed with exit code 1: No PulseAudio daemon running, or not running as session daemon.
SourcePackage: linux
Tags: precise precise
Uname: Linux 3.2.0-22-generic i686
UpgradeStatus: Upgraded to precise on 2012-04-04 (3 days ago)
UserGroups: adm admin cdrom dialout lp lpadmin plugdev sambashare
dmi.bios.date: 10/23/2009
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 0202
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: 1005HAG
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: x.xx
dmi.chassis.asset.tag: 0x00000000
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK Computer INC.
dmi.chassis.version: x.x
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr0202:bd10/23/2009:svnASUSTeKComputerINC.:pn1005HAG:pvrx.x:rvnASUSTeKComputerINC.:rn1005HAG:rvrx.xx:cvnASUSTeKComputerINC.:ct10:cvrx.x:
dmi.product.name: 1005HAG
dmi.product.version: x.x
dmi.sys.vendor: ASUSTeK Computer INC.

tags: added: apport-collected precise

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Fabio Marconi (fabiomarconi) wrote :

Hello Andy
This report is Expired.
please open a new one typing in a terminal
ubuntu-bug linux

To post a comment you must log in.